[ROM][11.0] LineageOS 18.1 for Redmi Note 9/Redmi 10X 4G[UNOFFICIAL]

Search This thread


New member
Oct 16, 2021
Hello everyone, i have a redmi note 9 3/64 4G in miui 12.5.1 version and i want to flash lineage os 18.1, i need to downgrade to miui 12.0.3 to flash the rom properly? I am asking because i saw on a video that i need to downgrade to miui 12.0.3 but in the video the guy flashed lineage os 17.something
Thanks :)


New member
Mar 26, 2021
I got a bootloop after flashing this on top of the 12.0.1 indonesian rom, is there a way to get it to work?


New member
Feb 5, 2022
I have severe problems with the installation. Everything works until I want to flash gapps. I am informed that the system partition is not big enough. It has a size of 1.3G and 1.1G are used by lineageos. I have plenty of space on the phone, but I don't know how use some of it to resize the system partition.
In the custom recovery I can enter shell commands, so if there's a way to resize, please let me know how.
Kind regards


Jan 21, 2023
Thanks for this, I successfully installed this ROM, since the original URL for the ROM was not working anymore. For anyone trying to do it, the steps have been the following:
However, I'm having an error: I don't know why the phone keeps rebooting from time to time when the screen is locked. More explicitly, after a minute or so of having the screen locked, sometimes I press the power button and I get no screen response, and then, after some seconds, the phone starts rebooting.

I'm attaching the log file obtained with the command `adb logcat -v threadtime -L` after one of the reboots.

Does anybody have an idea what might be happening? Thanks in advance!

Edit: linking to a public gist in Github since attachments don't seem to work for me.
Last edited:


Jan 21, 2023


Senior Member
Jun 9, 2013


Jan 21, 2023
I'm trying to flash it through Orangefox recovery but it doesn't work :( After flashing without issues i reboot the phone but the OS doesn't boot... it only shows the MI logo and restarts bootlooping :( any idea?
I think you should follow the official guide https://wiki.lineageos.org/devices/merlinx/install, which tells you to:
  • Ensure that the device is currently using Android 11 firmware.
  • Use Lineage Recovery to flash it.
I haven't tried it yet, but as soon as I get to it I will report here as well :)
  • Like
Reactions: riccardosimo

Top Liked Posts

  • There are no posts matching your filters.
  • 27

    LineageOS is a free, community-built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review.

    * Your warranty is now void.
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.

    What's working :
    • Audio
    • Bluetooth
    • Camera
    • EGL
    • GPS
    • RIL (Calls, SMS, Data)
    • Sensors
    • Video Playback
    • Wi-Fi
    • MTP
    • VoLTE
    Everything is Working Except following Bugs

    Known issues/Bugs :
    • VoWiFi
    • You tell me the rest:)

    Reporting Bugs
    DO NOT Report bugs if you're running a custom kernel or you installed any root implementation
    Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless). Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    • Flash MIUI 12.0.1 ID or 12.0.2/12.0.3 Global in fast boot.
    • Install custom recovery.
    • Download the latest LineageOS build.
    • Wipe Data, Dalvik, Internal, Cache
    • Flash the ROM
    • Format data
    • Reboot
    For people who wish to use GApps, use MagiskGApps by @Wacko1805 ,


    Download ROM
    Download MagiskGApps


    LineageOS Team
    @Pulkit Agarwal
    & All People Who helped me in a way or Other !

    Source Code
    Build Author: Communos

    If you liked my work, press thanks on this thread :) !

    Hi guys, Latest LineageOS build for Redmi Note 9 is here.
    All the major bugs listed here have been fixed, Updated security patch and SELinux is now Enforcing!

    Download Link

    If you're on previous build of lineage or any other rom that does not come with OSS Vendor, you will have to reflash MIUI 12.0.1 ID or 12.0.2 Global in fastboot and then proceed with flashing.
    Latest build is up.

    It was reported that Video playback in apps and video recording with camera was broken, it has been fixed.
    Screen recording lag has been fixed.
    Misc Improvements.
    SELinux Enforcing
    I Installed magisk via twrp, and then flashed the gapps in magisk and now it's working fine. But, i really don't want to root my device because of netflix..
    Aha, it's easy to get Netflix working,

    Install Magisk hide props module

    open termux type these

    • su
    • props
    • 1
    • f
    • 7
    • 26
    • y
    • y
    Enable Hide magisk manager in magisk settings, also MagiskHide, After that hide google play services and netflix in magisk hide and wipe data of play store app. After that reboot, Netflix should be working :)

    You might as well get free benefits with the Pixel 5 fingerprint which is installed with the method I mentioned above, Check google one app and see if you get free trial, who knows, good luck ;)
    Is this compatible with any version? I have the Italy, Germany, France, Spain edition. Do you think it could work?

    I bought mine in Germany (so it's probably the same version), and it worked fine with every ROM I've tried so far - within their respective limitations. Currently running Kraken, though.

    Keep in mind that you will need to downgrade to MIUI 12.0.1 (Indonesia) or 12.0.3 (Global) before you flash, otherwise it won't work. Ask me how I know.

    Also, in case something goes wrong, how do I reset the factory image?

    As long as the bootloader is still working, you can flash the stock firmware back onto the device via fastboot (which obviously has to be installed on your PC). There's a website with all versions. Get the fastboot type, extract it, and run the included script (flash_all.sh on Linux, probably flash_all.bat on Windows). There may also be a GUI way to do it, but I can't help you with that.