[ROM][11.0][marlin] PixelExperience [AOSP][OFFICIAL]

Search This thread

spiral777

Senior Member
Oct 21, 2011
630
243
34
Chicago
Nexus 6
Google Pixel
It will not work via TWRP recovery.
1. Kindly go on the downloads page and install the PE recovery.
Code:
fastboot flash boot recovery.img
(It may bootloop once or twice, but then it will show up in PE recovery)

2. Go into Apply update via ADB.
Code:
adb sideload repartition-ogpixel-**gb.zip

3. Factory Reset/Wipe Data.
4. Apply update via ADB and sideload the ROM.
Code:
adb sideload PixelExperience-**.zip

5. Reboot and wait patiently.
Hope this helps.
What does repartition-ogpixel-32gb.zip do exactly? Is there a way to increase the size of the system? Thank you
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Do you know if these marlin builds actually boot?
    These don't boot, if they did, they would have been posted in their own thread. Any build that isn't published won't boot unless PixelBoot says otherwise in their own post/thread.
    1
    Is this the guide that you utilized to repartition?
    Go to the install instructions and download the repartitioning ota. It's listed on the install instructions
    1
    What does repartition-ogpixel-32gb.zip do exactly? Is there a way to increase the size of the system? Thank you
    The basic premise for partitioning
    -- better app management
    -- increasing the internal memory
  • 20
    NFjZzFl.png

    PixelExperience for Google Pixel XL [marlin]

    What is this?

    PixelExperience is an AOSP based ROM, with Google apps included and all Pixel goodies (launcher, wallpapers, icons, fonts, boot animation)

    Our mission is to offer the maximum possible stability and security, along with essential and useful features for the proper functioning of the device

    Based on Android 11.0

    Whats working?
    Wi-Fi
    RIL
    Mobile data
    GPS
    Camera
    Flashlight
    Camcorder
    Bluetooth
    FM radio
    Lights
    Sound/vibration

    Known issues
    Nothing yet
    You tell me


    DON'T FLASH GAPPS, THEY'RE ALREADY INCLUDED
    Download from PixelExperience website

    Donate
    Liked my work? Give me a beer

    Translation
    Help with project translation

    Stay tuned
    Our Telegram channel
    Our blog
    7
    Today's PixelExperience (16/09/2021) brings a lot of the most requested bug fixes for both Google Pixel and Google Pixel XL.
    Here's the changelog, one of which being the highly anticipated APN bug fix:

    • Fixed APN issue
    • Fixed network related issues
    • Fixed SELinux denials
    • Performance improvements
    • Other fixes

    Thanks to however contributed and made me aware about this issue, and sorry for taking so long to resolve such a bug.
    I hope that in the past days, each one of your Google Pixel devices has been performing smoother and more efficiently thanks to all the related bug fixes.
    If you run into any more bugs, kindly do let me know, even though I'm not as active on XDA, I still frequently stay up to date.
    7
    Hello, I have followed the guide until the ROM flashing step and I am stuck with the next error message:

    "Error applying update: 28 (ErrorCode::kDownloadOperationExecutionError)
    E:Error in /sideload/package.zip (status 1)"

    I have tried flashing either the Plus and the normal versions of Android 11 for marlin device.

    Can you help me, please?
    I have the same issue.

    Background: I went through the installation process successfully once. I had problems post-install however, it said no SIM inserted and I suspected a botched restore from Titanium Backup (didn't realize until too late that it's an abandoned app). So I decided to try to re-install the zip, which failed. I looked through the recovery logs and saw "no space left on device", so I perfomed a new factory reset. Still the same. So I repartitioned, then factory reset, then install zip. Still the same. So I go to step 1 and flash boot, reboot recovery, repartition, factory reset, install zip. Still the same.

    So at this point the phone is un-bootable, and I can't see how I can get it back to a working state. Any suggestions?

    EDIT: Sorry, just saw this https://forum.xda-developers.com/t/...xperience-aosp-official.4247199/post-84661869
    Going to try that!

    EDIT2: YES! It worked! So for anyone else experiencing the "kDownloadOperationExecutionError" (like @ogossorio), this is what I did:

    1. Download TWRP (twrp-3.5.1_9-0-marlin.img) from https://dl.twrp.me/marlin/
    2. Boot phone into bootloader mode
    3. Temporarily boot TWRP: fastboot boot twrp-3.5.1_9-0-marlin.img
      1. If you can't reach your phone with adb while in TWRP, try disabling MTP under "Mount"
    4. Start adb shell and perform the steps described for your phone from PixelBoot's post
    5. Power off your phone
    6. Boot into bootloader mode
    7. Flash PE recovery: fastboot flash boot PixelExperience_Plus_marlin-11.0-20210317-1910-OFFICIAL.img
    8. Boot into recovery
    9. Factory reset
    10. Flash PE: adb sideload PixelExperience_Plus_marlin-11.0-20210317-1910-OFFICIAL.zip
    11. Reboot into OS
    6
    PixelExperience - OFFICIAL | Android 11
    PixelExperience (Plus Edition) - OFFICIAL | Android 11
    Updated
    : 15/03/'21

    Links:
    Eleven:
    Eleven (Plus Edition):
    Changelog:
    • Fixed missing VNDK lib.
    6
    No luck. Fails after 2/2.

    Error applying update: 5 (ErrorCode::kPostInstallRunnerError)


    This is exactly what I have been doing. Doing it multiple times does not appear to make it more successful. I was following the install guide on the PIxelExperience website precisely.
    Then your last resort is going to TWRP and using the shell to input the following commands:
    Google Pixel/XL (32GB):

    sgdisk --delete=33 /dev/block/sda
    sgdisk --delete=34 /dev/block/sda
    sgdisk --delete=35 /dev/block/sda

    sgdisk --new=33:227142:1275716 --change-name=33:system_a --typecode=33:EBD0A0A2-B9E5-4433-87C0-68B6B72699C7 /dev/block/sda
    sgdisk --new=34:1275717:2324291 --change-name=34:system_b --typecode=34:77036CD4-03D5-42BB-8ED1-37E5A88BAA34 /dev/block/sda
    sgdisk --new=35:2324292:7785285 --change-name=35:userdata --typecode=35:EBD0A0A2-B9E5-4433-87C0-68B6B72699C7 /dev/block/sda

    Google Pixel/XL (128GB):

    sgdisk --delete=33 /dev/block/sda
    sgdisk --delete=34 /dev/block/sda
    sgdisk --delete=35 /dev/block/sda

    sgdisk --new=33:227142:1537862 --change-name=33:system_a --typecode=33:77036CD4-03D5-42BB-8ED1-37E5A88BAA34 /dev/block/sda
    sgdisk --new=34:1537863:2848582 --change-name=34:system_b --typecode=34:EBD0A0A2-B9E5-4433-87C0-68B6B72699C7 /dev/block/sda
    sgdisk --new=35:2848583:31215429 --change-name=35:userdata --typecode=35:EBD0A0A2-B9E5-4433-87C0-68B6B72699C7 /dev/block/sda