• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM] ► [11.0] ► Nitrogen OS Beta

Search This thread

highdiver_2000

Senior Member
Aug 10, 2012
1,542
341
Any idea on the Google location history not updating? I am using full NikGapps.

FYI, Google Backup is not working too. I think this may be Gapps related/specific.

The backup is working , the minimum package is installed NikGapps-core.
I got the backup working by changing the settings in the Drive app. Turn off 'Transfer only over WiFi'

Edit: This is so weird. According to Google, it seems to be a common problem.
 
Last edited:

highdiver_2000

Senior Member
Aug 10, 2012
1,542
341
Any idea on the Google location history not updating? I am using full NikGapps.

FYI, Google Backup is not working too. I think this may be Gapps related/specific.
I just remembered that my 3T is on Android 11 and the Location History works. One those moments!

Compared the Location permission. Play services on the Poco have "Only while in use". The 3T is 'Allowed all the time'.

The problem now is I can't change the permission on the Poco to Allowed all the time.
 

highdiver_2000

Senior Member
Aug 10, 2012
1,542
341
I just remembered that my 3T is on Android 11 and the Location History works. One those moments!

Compared the Location permission. Play services on the Poco have "Only while in use". The 3T is 'Allowed all the time'.

The problem now is I can't change the permission on the Poco to Allowed all the time.

My Google Location History is working fine..

Nikgapps Omni + Some Addons (Chrome, Calendar, Markup).
I have fixed the permission issue by removing ALL apps permission using this method.

 

Ky0sHiR0

Senior Member
Aug 30, 2013
224
28
Hi all,
Got a strange issue when making calls sometimes mic is stopped working...
It's okay when answering calls. Any ideas?
I tested it on ArrowOS and NitrogenOS. Previously I was on really old NitrogenOS like 6 months old.
 

xyyx

Senior Member
Sep 3, 2013
2,650
8,338
Irkutsk
Hi all,
Got a strange issue when making calls sometimes mic is stopped working...
It's okay when answering calls. Any ideas?
I tested it on ArrowOS and NitrogenOS. Previously I was on really old NitrogenOS like 6 months old.
Maybe you have "Ok, Google" or etc. It uses mic too. I don't have this issue
 

highdiver_2000

Senior Member
Aug 10, 2012
1,542
341
Hi all,
Got a strange issue when making calls sometimes mic is stopped working...
It's okay when answering calls. Any ideas?
I tested it on ArrowOS and NitrogenOS. Previously I was on really old NitrogenOS like 6 months old.
Nope, I have been using lots of voice and data calls, no problem. I use Google Phone app for the call bubble.

Check what app has mic access?

Did you disable Telegram 'Raise to speak'?
 

Ky0sHiR0

Senior Member
Aug 30, 2013
224
28
Nope, I have been using lots of voice and data calls, no problem. I use Google Phone app for the call bubble.

Check what app has mic access?

Did you disable Telegram 'Raise to speak'?
Hi,
Thank You for the answer. I think it's related to the Google Phone App because I can make a calls via Whatsapp etc.
I don't use Telegram.
Apps with mic access like: messenger, google phone app, gboard, camera, brave, messages
 
Dec 20, 2015
24
1
Everything needs to be corrected. The steps you listed are needlessly complicated. Here are the actual steps.
  1. Download the latest recovery ROM from xiaomifirmwareupdater website.
  2. Download the latest Nitrogen OS
  3. Install the latest TWRP by brigudav, which you can download by checking ArrowOS' first post
  4. Flash the recovery ROM and then flash Nitrogen OS
  5. Download and install Gapps (Optional); if you use Gapps, use FlameGapps or NikGapps only.
  6. Format /data and factory reset
I have done all of this. It launches, but Wifi doesn't work.
Follow-up reboot will crash and result in a bootloop.

What am I doing wrong?
 

Noter2017

Senior Member
Dec 10, 2016
1,005
408
Xiaomi Redmi Note 4
Xiaomi Mi Band 4
I have done all of this. It launches, but Wifi doesn't work.
Follow-up reboot will crash and result in a bootloop.

What am I doing wrong?
1) You need to download and flash the fastboot ROM which is about 5 GB and it must be based on Android 11

5) Use the GApps recommended in the first post

6) I only format DATA. Factory reset isn't necessary
 

syscomp

Member
Apr 12, 2017
41
9
Payakumbuh
blog.syaifullah.com
I have done all of this. It launches, but Wifi doesn't work.
Follow-up reboot will crash and result in a bootloop.

What am I doing wrong?

have you already tried flash the requirement firmware + vendor ?

1 - Flash the latest twrp from brigudav
2 - Reboot to TWRP
3 - Wipe Dalvik, Cache and Data
4 - Flash Firmware + Vendor 12.5.0.1 Global
5 - Flash Nitrogen OS ROM 04/08/21
6 - Flash OpenGapps Pico
7 - Formar Data
8 - Disable Encryption (Optional) at Advance menu in TWRP
9 - Reboot your phone (your wifi should work)

Optional Steps (Enable Hello Google)

1 - After finishing Android Setup, restart to TWRP
2 - Flash OpenGapps Nano
3 - Wipe Cache/Dalvik
4 - Reboot (Hello Google will be activated)
 
  • Like
Reactions: EmanueleCiriachi
Dec 20, 2015
24
1
Thank you both for the answers. For now I have settled for OctaviOS, but should I have the time I will consider trying this one too.
 

dramh10

Member
Mar 9, 2015
49
5
Xiaomi Poco X3 NFC
have you already tried flash the requirement firmware + vendor ?

1 - Flash the latest twrp from brigudav
2 - Reboot to TWRP
3 - Wipe Dalvik, Cache and Data
4 - Flash Firmware + Vendor 12.5.0.1 Global
5 - Flash Nitrogen OS ROM 04/08/21
6 - Flash OpenGapps Pico
7 - Formar Data
8 - Disable Encryption (Optional) at Advance menu in TWRP
9 - Reboot your phone (your wifi should work)

Optional Steps (Enable Hello Google)

1 - After finishing Android Setup, restart to TWRP
2 - Flash OpenGapps Nano
3 - Wipe Cache/Dalvik
4 - Reboot (Hello Google will be activated)
Can anyone confirm if GPay still works with this method?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    I know, the guy has a real life and this is just something he does on the side and for free (which I'm really grateful for), but as he hasn't been online in 2 weeks... Does anyone know if @xyyx is maybe more active on telegram, or anywhere else?
    Don't worry) I just had moving to another city) I am waiting my PC for continue working on Nitrogen.
    2
    I tried with and without that option and with swiftkeyboard and the default keyboard. Whenever I press the volume rocker several times while a keyboard is active, it Force closed. Of course it's fine to use as long as you don't use the volume rocker, but this problem makes the "move cursor with volume rocker" option (which is quite handy at times) unusable.
    That being said. the is the problem as it happend in all the latest version. I'm now about to install the latest one. Just wanted to describe the problem in detail, if that helps.

    Btw, thank you so much for the update. was locking forward to it. :)
    Give me logcat. I use this option without any troubles every day
    2
    Yeah, same with SwiftKey here. Thought it was a problem with the app, guess it's not.
    2
    Two more things to put on the list. 😁
    When calling some, not every time, it rings for a split second and then there's silence till the other person pics up, but you can't tell at all that the calling attempt is still going on. (thinking out loud : maybe a problem with volte, because it only happens when calling another mobile phone).
    And when speaker is already activated when starting a call the other person will hear me echoed/double. You either have to start the call without it being on speaker right away, or deactivate it and activate it again.
    Oh and settings/battery/battery manager crashes.
    1
    Same here. Best make a logcat if you have the time, so xyyx can take a look at it. I would, but it's late here and I'm tired. :D
    Sure man.. No problem..
    Here's the logcat for Battery Manager crash issue. @xyyx
  • 14
    nitrogen_accent.png


    SELinux in permissive mode.
    Please, stop posting your wishes. No features requests


    mSx8lRG.png

    Based on AOSP

    ZpXJzKd.png

    xyyx (Max) - main developer

    IxVVRiE.png


    Install firmware from https://sourceforge.net/projects/nitrogen-project/files/surya/10.0/firmware+vendor/surya_firmware_vendor-Global_V12.0.3.0.QJGMIXM_e2c7ace186_10.0.zip/download
    Copy the ROM, Gapps to SD card. (Android 11 Micro-SD, because TWRP doesn't support decrypting)
    • Go to your recovery
    • Format Data
    • Install ROM and Gapps zip.
    • Reboot - 1st boot takes around 5-10 minutes.
    Enjoy

    FAQ

    C8vWqi4.png

    Testing versions Android 11 HERE

    f9K0L2y.png

    If you like my ROM, you can support me.
    xyyx: PayPal

    NnOP1ox.png

    Nitrogen Project

    Known Bugs:
    * Selinux

    XDA:DevDB Information
    [ROM] ► [11.0] ► Nitrogen OS Beta, ROM for the Xiaomi Poco X3 NFC

    Contributors
    xyyx
    ROM OS Version: Android 11
    ROM Kernel: Linux 4.14
    Based On: AOSP, CM, Pure, DU, OmniROM

    Version Information
    Status:
    Testing

    Created 2020-10-06
    Last Updated 2020-10-30
    7
    Uploaded new build. New TAG.
    6
    Oh. I thought Xiaomi's users can flash ROM without spamming. Sorry. I was wrong. If you can't flash something, use MIUI. And you will be happy.
    It's not "spamming" it's updating, pretty common for anyone who regularly uses tech forums. I've got ArrowOS flashed just fine, it's only NitrogenOS I'm having issues with. You could also stop the "spamming" by providing basic instructions, or answering a single question in this thread, or structuring your current instructions in such a way that they work in the order described, or have your links lead to the correct files. Anything like that would help stop what must be such a massive inconvenience when people ask a question. Or you could just continue to leave it as obscure as possible and minimize the amount of users, making all of your extremely hard work completely useless.
    4
    That's what I'm saying for some time. We need step by step instruction on how to safely update to new vendor. So far there is none, people are confused, make installation errors and get frustrated. I'm asking again is there at least one person who managed to upgrade to new vendor without loosing phone data and settings? If no, is there at least one person that managed to upgrade but lost all data. Can that person provide instruction what files, from where, in which order to install?
    4
    Was uploaded alpha build based on A11 vendor. Seems no profit after migrate. You need to format data.