• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Development [ROM][11.0][OFFICIAL][ALIOTH/ALIOTHIN] crDroid v7.10 [19.09.2021]

Search This thread

raystef66

Recognized Developer / Recognized Contributor
Jul 2, 2013
2,238
7,093
ZTE Axon 7
Xiaomi Mi 9
BE3pE0l.png


Code:
*** Disclaimer
I am not responsible for any damage you made to your device
You have been warned


crDroid is designed to increase performance and reliability over stock Android for your device also attempting to bringing many of the best features existent today


Features: https://github.com/crdroidandroid/crdroid_features/blob/11.0/README.mkdn


Flashing Instructions:

Pre-installation: ( aka gather some files )


Always check latest build instructions:

  • base MIUI firmware 12.0.x or 12.5.x
  • unzip crDroid file
  • boot into fastboot (IF ISSUES FLASHING) and run the Install&Format.bat (windows) or Install&Format.sh (LINUX) or Mac&Install&Format.sh (MAC)
  • wait...well, that should be it - it'll boot into the rom
  • ENJOY
  • optional : fastboot the TWRP-3.5.2_10 and flash Magisk or other stuff you want


Sources:

ROM:https://github.com/crdroidandroid
Kernel: kernel Optimus Drunk
Github: raystef66


LATEST crDroidAndroid-11.0-20210919-alioth-v7.10.zip


POCO F3 TELEGRAM GROUP



What's working / what's not:

* most of it is working :
  • ril
  • audio
  • wifi
  • BT
  • camera
  • NFC
  • FP
  • Faceunlock
  • GPS
  • AOD (tile)
  • hotspot
  • DT2W (on doze)
  • DT2S
  • ambient features
  • ok google
  • ...


* bugs : DO SEND LOGS WHEN REPORTING BUGS
  • . . .

Visit official website @ crDroid.net
crDroid Community Telegram
Donate to help our team pay server costs

If you like my work, consider a donation! MY PAYPAL


Contributors
@raystef66
@jomadeto


Source Code: https://github.com/crdroidandroid/android/tree/11.0

ROM OS Version:
11.0
ROM Kernel: Linux 4.x
ROM Firmware Required: Unlocked Bootloader, miu v12.0.x or 12.5.x

Status: stable
Sec. Patches : 2021.09.05

Created : 2021.05.07
Last Updated : 2021.09.19
 

Attachments

  • Screenshot_20210507-145035475.jpg
    Screenshot_20210507-145035475.jpg
    881.8 KB · Views: 6,116
  • Screenshot_20210507-145009306.jpg
    Screenshot_20210507-145009306.jpg
    191.1 KB · Views: 6,079
  • Screenshot_20210507-145105366.jpg
    Screenshot_20210507-145105366.jpg
    180.8 KB · Views: 5,349
  • Screenshot_20210507-145045972.jpg
    Screenshot_20210507-145045972.jpg
    274 KB · Views: 5,029
  • Screenshot_20210507-145804884.jpg
    Screenshot_20210507-145804884.jpg
    218.9 KB · Views: 4,917
  • Screenshot_20210507-145516740.jpg
    Screenshot_20210507-145516740.jpg
    139.5 KB · Views: 4,910
  • Screenshot_20210507-124920902.jpg
    Screenshot_20210507-124920902.jpg
    224.5 KB · Views: 4,743
  • Screenshot_20210507-144836553.jpg
    Screenshot_20210507-144836553.jpg
    204.3 KB · Views: 4,681
  • Screenshot_20210507-154025178 (1).jpg
    Screenshot_20210507-154025178 (1).jpg
    193.5 KB · Views: 4,453
Last edited:

hkfriends

Senior Member
Aug 24, 2007
582
147
Installation is not working on stock (unlocked) alioth_global_images_V12.0.3.0.RKHMIXM rom


H:\crDroidAndroid-11.0-20210507-alioth-v7.5>.\platform-tools-windows\fastboot reboot fastboot
Rebooting into fastboot OKAY [ 0.003s]
< waiting for any device >
fastboot: error: Failed to boot into userspace fastboot; one or more components might be unbootable.


it will boot to a special FASTBOOTD menu and it is stuck with < waiting for any device >
... so i have to select fastboot again..... then it reboot to MI fastboot menu it stuck the same, so i have unplug the usb cable to continue and work..

but in the MI fastboot mode, it cannot flash system.img


H:\crDroidAndroid-11.0-20210507-alioth-v7.5>.\platform-tools-windows\fastboot flash system_a Images/system.img
Sending sparse 'system_a' 1/2 (774900 KB) OKAY [ 17.824s]
Writing 'system_a' FAILED (remote: 'Partition not found')
fastboot: error: Command failed
 
Last edited:

navey

Senior Member
Nov 29, 2012
104
35
OnePlus 6T
Xiaomi Poco F3
Installation is not working on stock (unlocked) alioth_global_images_V12.0.3.0.RKHMIXM rom


H:\crDroidAndroid-11.0-20210507-alioth-v7.5>.\platform-tools-windows\fastboot reboot fastboot
Rebooting into fastboot OKAY [ 0.003s]
< waiting for any device >
fastboot: error: Failed to boot into userspace fastboot; one or more components might be unbootable.


it will boot to a special FASTBOOTD menu and it is stuck with < waiting for any device >
... so i have to select fastboot again..... then it reboot to MI fastboot menu it stuck the same, so i have unplug the usb cable to continue and work..

but in the MI fastboot mode, it cannot flash system.img


H:\crDroidAndroid-11.0-20210507-alioth-v7.5>.\platform-tools-windows\fastboot flash system_a Images/system.img
Sending sparse 'system_a' 1/2 (774900 KB) OKAY [ 17.824s]
Writing 'system_a' FAILED (remote: 'Partition not found')
fastboot: error: Command failed
Having the exact same issue with this ROM and Pixel Experience.... coming from a newly flashed 12.0.2 global fastboot and freshly unlocked bootloader...have no problems with xiaomi.eu though
 

Abaddon

Senior Member
Having the exact same issue with this ROM and Pixel Experience.... coming from a newly flashed 12.0.2 global fastboot and freshly unlocked bootloader...

replug or use a different cable.
use a different platform tools (adb and fastboot exe) I prefer the one's from google but not the latest fastboot as it borks flashing stock roms via fastboot
 

navey

Senior Member
Nov 29, 2012
104
35
OnePlus 6T
Xiaomi Poco F3
replug or use a different cable.
use a different platform tools (adb and fastboot exe) I prefer the one's from google but not the latest fastboot as it borks flashing stock roms via fastboot
tried several cables and like i said I don't have any issues with xiaomi.eu at all. I see my device just fine in adb and fastboot as well.. will do more research
 

Abaddon

Senior Member
tried several cables and like i said I don't have any issues with xiaomi.eu at all. I see my device just fine in adb and fastboot as well.. will do more research

I said those because I had a similar scenario. xiaomi eu fastboot flashes fine but other fastboot roms wont flash properly. its either my port (had to replug), usb drivers and the fastboot exe itself. I fixed it by changing the fastboot.exe to an older one. goodluck with yours hope u get it fixed asap
 
  • Like
Reactions: navey

navey

Senior Member
Nov 29, 2012
104
35
OnePlus 6T
Xiaomi Poco F3
Installation is not working on stock (unlocked) alioth_global_images_V12.0.3.0.RKHMIXM rom


H:\crDroidAndroid-11.0-20210507-alioth-v7.5>.\platform-tools-windows\fastboot reboot fastboot
Rebooting into fastboot OKAY [ 0.003s]
< waiting for any device >
fastboot: error: Failed to boot into userspace fastboot; one or more components might be unbootable.


it will boot to a special FASTBOOTD menu and it is stuck with < waiting for any device >
... so i have to select fastboot again..... then it reboot to MI fastboot menu it stuck the same, so i have unplug the usb cable to continue and work..

but in the MI fastboot mode, it cannot flash system.img


H:\crDroidAndroid-11.0-20210507-alioth-v7.5>.\platform-tools-windows\fastboot flash system_a Images/system.img
Sending sparse 'system_a' 1/2 (774900 KB) OKAY [ 17.824s]
Writing 'system_a' FAILED (remote: 'Partition not found')
fastboot: error: Command failed
Fixed this! Enabled system wide ADB on my machine and now its working smoothly so far with no errors whatsoever. Follow this link

 

navey

Senior Member
Nov 29, 2012
104
35
OnePlus 6T
Xiaomi Poco F3
I said those because I had a similar scenario. xiaomi eu fastboot flashes fine but other fastboot roms wont flash properly. its either my port (had to replug), usb drivers and the fastboot exe itself. I fixed it by changing the fastboot.exe to an older one. goodluck with yours hope u get it fixed asap
Thanks man i actually got it fixed by installing system wide adb but it was your thoughts that lead me there. THANK YOU!!
 

hkfriends

Senior Member
Aug 24, 2007
582
147
Fixed this! Enabled system wide ADB on my machine and now its working smoothly so far with no errors whatsoever. Follow this link


will try this out tonight... strangely it is due to missing system path to execute fastboot?
 

Top Liked Posts