[ROM][11.0][OFFICIAL] MSM-Xtended Project

shadowstep

Forum Moderator
Staff member
Jun 6, 2014
4,642
9,117
263
30
Ambala
THREAD CLEANED

Just a friendly reminder to keep it civil, on-topic and refrain from putting fuel to fire by responding to posts that you think are offensive or hateful. Just report if you feel something isn't right and let us take care of it for you, so that we can make your experience on the forum better. :)

Always remember that the developers are doing this as a hobby, and there are plethora of options to choose from. If something doesn't work for you, report (respectfully, with logs, steps to reproduce, etc.) and wait. If you can't, you can always move on to a different ROM which works for you.

Now let's all take a deep breath, and get back on topic, shall we?

Regards,
shadowstep
Forum Moderator
 

Nothingpersonal19p2

New member
Feb 3, 2021
1
0
11
Hey i have a problem with my device i tried everything but battery problem is in every rom i was charging and İts discharge so quickly İts Like battery stats %10 battery usage but phone's charge is 79 device is redmi note 9 pro joyeuse
 

VladSor

Senior Member
Sep 8, 2017
725
1,586
108
Hello Everyone,

Here is the new Update of MSM Xtended XR-v5.0 with Fixes & more feature addition:-

Device Changelog: Click HERE

ROM Changelog : Click HERE

Download ROM : MSM Xtended XR-v5.0 for davinci

Open GApps Pico - Latest Android 11.0 Build

Clean Flash is highly recommended but Dirty Flash should be fine as well. Remember to flash Gapps & Magisk while both kind of flashing.
Please share your feedback and reviews. Its important for us to understand how we are doing and what all we need to improve.
Best Regards
Team-Xtended
 

Lermite

Senior Member
Dec 29, 2018
565
159
43
Saint Gervais d'Auvergne
I've flashed the XR 5.0 over the XR 4.0 with a dirty flash, without flashing again Magisk and NickGapps which both survived the rom flash.

The only issue so far is that FontFix, my usual app to change the system font, doesn't work anymore.
I've managed to change the font by messing with the system files but only the "Regular" version got replaced by mine.

That's why I'd like the font Roboto Condensed to be included to the system fonts list, to allow me to simply select it instead of messing with the system files to get an approximate result.
 

Lermite

Senior Member
Dec 29, 2018
565
159
43
Saint Gervais d'Auvergne
I'm used to a schema to unlock my phone.

Since the XR 4.0, the lockscreen schema is at the bottom of the screen. It makes it easier to use but it's over the fingerprint sensor.

I've tried to test a fingerprint in more of the schema but despite one fingerprint is registered, the lockscreen doesn't allow to unlock by FP, probably because the icon can't be displayed as the schema takes its place.

The schema at the bottom of the screen is welcomed while no other unlock way is set.
But when a fingerprint is set in more, the schema should be moved higher enough to allow the FOD to be displayed as well.

EDIT / UPDATE:
The FOD icon appears after I lock my phone while an app is running in foreground.
If I lock it without any foreground app, from the launcher, only the schema is displayed as unlock method.

A good point: when it's displayed, the FOD works well, almost a miracle as it never worked on my phone before the XR 5.0 and I've never managed to find out what caused this issue.

EDIT / UPDATE 2:
I've figured out what went wrong.
Locking the phone can be done through two different ways:
- Accessibility: Locks the device like the power button was pressed. Requires Android Pie.
- Device administrator: Locking ompletely the device requires a PIN code. This doesn't allow to unlock by fingerprint.

My mistake was to lock my phone differently depending on the app running in foreground:
- Without any app, only the launcher, I used a Automate widget with only the block "Lock device", which locked obviously as administrator and ended up hiding the FOD.
- With any app in foreground, I used a gesture of Vivid Navigation Gestures, which locked through Accessibility obviously, allowing the FOD to unlock.
I've solved this issue by replacing my Automate widget by a Nova Action widget which locks though accessibility and therefore allows the FOD :cool:
 

Attachments

Last edited:

johnjaffee

Member
Sep 23, 2015
12
0
21
Hi
Is there still space under gboard after the latest update? I can't use this rom because of that, it's annoying. Uninstalling updates of gboard works but it goes to older gboard which is again annoying :)