[ROM][11.0][OFFICIAL][OOSCAM][OnePlus 7 Pro][11.0_r20] Evolution X | Emerald

Search This thread

PriPhaze

Senior Member
Oct 3, 2014
941
359
OnePlus 7 Pro
All working good except.. bank apps can't use the fingerprint at all even using busybox and magisk props fingerprint never shows up, also in PayPal I can't link it
That's pretty much the only issue I have so far.
 

oxadedzn

Member
Aug 25, 2019
7
1
Stuttgart
For real, the performance on this is absolutely thrilling me. I had some wifi issues at first but came to flashing SmurfKernel, which solved my problem and let me use this awesome custom rom. Not sure about the battery life tho but still extreme performance increase in comparison to oxygenos. You guys impressed me!
 
  • Like
Reactions: URIST.LG

Lilobast

Member
Jul 27, 2019
20
3
hi, first thanks for this rom.
I just notice that if i set a static wallpaper, my fingerprint scanner is not working and flicker a bit, but with a live wallpaper it's working fine
 

icy_gt

Senior Member
May 11, 2012
146
21
im on OOS 10.0.3 GM21AA how do I update to the latest OOS and keep my recovery to flash this? can I OTA? i have been out of the seen for a while
 

gyakusetsu1215

Senior Member
Mar 3, 2011
424
278
OnePlus 6T
OnePlus 7 Pro
For real, the performance on this is absolutely thrilling me. I had some wifi issues at first but came to flashing SmurfKernel, which solved my problem and let me use this awesome custom rom. Not sure about the battery life tho but still extreme performance increase in comparison to oxygenos. You guys impressed me!
How are you using Smurf? Did you recompile it without the Android version check script?
 
  • Like
Reactions: URIST.LG

icy_gt

Senior Member
May 11, 2012
146
21
I had a random reboot 2 days ago and a crashdump today .
And it's been 6 days since I installed this rom.
wow so i updated to the latest 5.3 and it was fine but when i went to recovery to install magisk I get qualcomm crashdump mode. How did you fix it ?
 

icy_gt

Senior Member
May 11, 2012
146
21
okay so for what i get now. When i installed the rom it was fine, lte didnt show up until i rebooted it one time. Im on GM1915 i converted to Global. TWRP doesnt automatically install with the rom so i made that mistake and had to ADB really quick. Everything was fine until i went back into twrp to install Magisk 20.4. After I reboot the phone was stuck in Qualcomm CrashDump mode .I then reboot to recovery and re wiped and started over. is there a specified Magisk to install here? magisk 20.4 worked fine on Evolution 4.7
 

PriPhaze

Senior Member
Oct 3, 2014
941
359
OnePlus 7 Pro
okay so for what i get now. When i installed the rom it was fine, lte didnt show up until i rebooted it one time. Im on GM1915 i converted to Global. TWRP doesnt automatically install with the rom so i made that mistake and had to ADB really quick. Everything was fine until i went back into twrp to install Magisk 20.4. After I reboot the phone was stuck in Qualcomm CrashDump mode .I then reboot to recovery and re wiped and started over. is there a specified Magisk to install here? magisk 20.4 worked fine on Evolution 4.7

That magisk version is outdated and not recommended for a11 but answering your question on how I got out of crashdump ... Well I simply hold power and up volume until reboot and then the system started correctly.
Although I been having issues now with the fingerprint even in lockscreen so I might switch rom soon...
 

Top Liked Posts

  • There are no posts matching your filters.
  • 15



    EvoBanner.png


    Evolution X 5.2 for the OnePlus 7 Pro [guacamole]

    Code:
    /*
    * Your warranty is void. Or vaild, probably?
    *
    * I am not responsible for bricked devices, dead SD cards, Ebolation X,
    * thermonuclear war, or the current economic crisis caused by you following
    * these directions. YOU are choosing to make these modificiations, and if
    * you point your finger at me for messing up your device, I will LMAO at you.
    */



    qE4kqsj.png


    Living, Breaking, Keep Evolving.

    Pixel UI, customization and more, we are Evolution X!



    - Team Evolution X -

    @joeyhuab

    @peaktogoo (Now RealAkito)



    Reach us on Twitter! @EvolutionXROM





    RgqrlpK.png




    What are our features?

    - Just flash and check "The Evolver"




    n6b8AXD.png

    single tap gesture doesn't work, WFD doesn't work and No Verizon Network Support

    DO NOT FLASH GAPPS, ALREADY INCLUDED

    u5tIlfT.png


    DO NOT FLASH GAPPS, ALREADY INCLUDED

    gMGb8ee.png


    First Time Install / Clean Flash
    1. Have latest OOS 10.x flashed to both slots!!
    2. Download the proper flashable ZIP for your device
    3. Reboot to Recovery
    4. Wipe Data/Cache/System
    5. Format Data (Required)
    6. Flash the ROM
    7. Reboot to System
    8. Reboot to Recovery (Optional)
    9. Flash Magisk (Optional)
    10. Reboot to System and #KeepEvolving

    Update / Dirty Flash
    1. Reboot to Recovery
    2. Download the proper flashable ZIP for your device
    3. Reboot to Recovery (Optional)
    4. Flash Magisk (Optional)
    5. Flash the ROM
    6. Reboot to System and #KeepEvolving









    Light Screenshots / Dark Screenshots / Download

    Donate to me! / Official Chat / Device Support








    LU9gsrQ.png



    2
    Nice ROM,so smooth,,dualboot with MSM xtended rom,
    Video with OOS Cam crash,,even with shortcut,,
    Screenshot_20210104-202500.pngScreenshot_20210104-202316.pngScreenshot_20210104-202213.pngScreenshot_20210104-202155.pngScreenshot_20210104-202249.png
    1
    Just a heads up, not sure if my phone is just weird, but the first wipe instructions (step 4), resulted in my device only being able to boot to bootloader and resulting in " FAILED (remote: 'Failed to load/authenticate boot image: Load Error')" if i try to flash or do anything on CMD/fastboot now. Not sure if it's bricked or if this will happen to you, and it's obviously not a ROM issue, but just mentioning it just incase anyone is following the exact steps.
    Dont wipe system,,just do format data
    1
    Too late, I already learned the hard way bro. I'm pretty sure it was bricked since I couldn't even get into recovery, just kept booting back to the bootloader. I unbricked it and i'm & running now though. Great rom so far, I noticed the initial UI lag that seems to be common on every A11 roms I tried for the oneplus 7, but it goes away once you refresh the screen, so no big deal. A major issue for me though is that Google FI doesn't seem to activate. When I try to it just tells me "Unfortunately your Google FI service can't be activated because your account currently isn't authorized for service". Which sounds like it's an issue with my account, but when I log into fi via my desktop, nothing seems out of the ordinary, I even randomly used the sim on a t-mobile sim locked iPhone, downloaded FI and it activated without an issue. I'm gonna go back to stock & see if it happens there. Will report back in a few.

    To everyone else, don't let this discourage you from trying this rom out. Like i mentioned before, great rom so far & I appreciate the upload, I loved Evolution on Pixel 3. Just need my service lol
    MSMTool will save your life on this, also I recommend not using Step 4. Skip to Step 5. Wiping will erase OOS off the phone.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone