[ROM][11.0][POTTER] crDroid v7.23 [12.10.2022]

Search This thread

mmortal03

Senior Member
Apr 15, 2014
364
64
so i just installed crDROID on my phone, flashed it, then flashed flash GAPPS, and now its kind of hung up on the boot screen with the eye flashing different colors. i followed the instructions. how long does it usually take to boot the first boot? any ideas what this could be?
Did you format data, or just wipe data when you installed it? You might first try flashing gapps again over what you have. That sometimes seems to work. Which gapps are you using?
 

cjdijk

Senior Member
Apr 25, 2021
99
45
Stuck at bootlogo at first boot after flashing:
I have installed CrDroid on many potters (also for other people). In my case it always stucks at bootlogo, flashing CrDroid the first time. I did think it had to do with a wrong GAPPS, but also flashing the same GAPPS on another potter didn't work at first flash. Just do the flashing procedure a second time and it works fine.

Fingerprint not working for unlocking after (re)boot:
To solve this, just remove simtray, reboot or shutdown and power on phone. After phone has fully booted, put simtray back in, and enter the pincode of your simcard. Now your fingerprint keeps working. As long as you don't (re)boot or shutdown and power on again. Lot's of custom roms have the same issue.
 

Aium

New member
Feb 5, 2020
2
1
stupid problem over here
on crdroid customization menu i want round notifications corners, but when i change it all the corners of the screen becomes rounded too
its suposed to be this way ?
 

mmortal03

Senior Member
Apr 15, 2014
364
64
Speaking of stupid problems, I swapped out the SIM card, restarted the phone a few times, everything was working, powered off and powered back on, and now the Home screen icons/widgets have been reset to their defaults! Fortunately, I did not have too many things customized/arranged.
 

xenomorph150

Senior Member
Feb 16, 2011
193
20
I have been using crDroid now for half a year and love it, however, after about a day of use it becomes unstable. At some point the device will just freeze and be stuck for minutes in that state. Sometimes waiting does recover it, sometimes only a hard reboot. There is also the funny bug that if you leave its screen off and unplug it from charging - and let it sit like that for some minutes without interacting with it, it will hard lockup, meaning it will cease working completly / stuck until hard reset. I attached a logcat showing the first problem of just really getting stuck. Maybe someone can help me? Reinstalling it multiple times did not help.
 

Attachments

  • logcat.zip
    135.6 KB · Views: 2

FailSafeNow

Senior Member
Apr 3, 2020
115
17
Moto G5 Plus
Can you help me getting this ROM to work with Visible Wireless? As I understand it, I need to add some specific APN settings to the phone, but I can't input them because it won't let me. What do I do?
 

LeMaJo

Member
Sep 13, 2017
25
8
Version 7.25 solved the bootfreeze for my Potters.
I also found a file on my disk (I dont remember where i downloaded it) called Oreo_Fingerprint.zip; after installing it via TeamWin my fingerprint sensor worked perfectly.
:)
 

mmortal03

Senior Member
Apr 15, 2014
364
64
i dont remember the origin since the file is 2 or 3 years old., it must have been on a potter forum (maybe even this one) and i hope its okay to post it here. if not any moderator can feel free to remove it.
I found it. It's identical to this:
"From now on, all ROMs need Oreo firmware or else Fingerprint will not work. Flash this if you are still on Nougat firmware:
Fingerprint Firmware (https://www.androidfilehost.com/?fid=1322778262904029635)
If your device is updated to Official Oreo then this is not needed."

 

cjdijk

Senior Member
Apr 25, 2021
99
45
Thanks for letting me know. For some unknown reason my phone didn't get the 7.25 update automatically, it did stay on 7.23. Also didn't know about Oreo_Fingerprint.zip I guess I need to install Oreo_Fingerprint.zip using TWRP (Install zip)? Is it a final fix which you don't have to do again after a re-flash antoher ROM? Does Oreo_Fingerprint.zip actually work, meaning I can reboot anytime, without having to remove my simtray temporary?
 

mmortal03

Senior Member
Apr 15, 2014
364
64
Thanks for letting me know. For some unknown reason my phone didn't get the 7.25 update automatically, it did stay on 7.23.
Not sure why -- I was on 7.23 and it detected 7.25. I wonder if anyone else has experienced this. Maybe the server was down coincidentally?
Also didn't know about Oreo_Fingerprint.zip I guess I need to install Oreo_Fingerprint.zip using TWRP (Install zip)? Is it a final fix which you don't have to do again after a re-flash antoher ROM? Does Oreo_Fingerprint.zip actually work, meaning I can reboot anytime, without having to remove my simtray temporary?
Yeah, you only have to do it once, unless you ever need to go back to Nougat -- then you can always flash the Nougat FP firmware, which is here: https://www.androidfilehost.com/?fid=1322778262904029634
 
  • Like
Reactions: cjdijk

cjdijk

Senior Member
Apr 25, 2021
99
45
i dont remember the origin since the file is 2 or 3 years old., it must have been on a potter forum (maybe even this one) and i hope its okay to post it here. if not any moderator can feel free to remove it.
Unfortunately this doesn't work for me. I have booted in twrp recovery mode an used "install zip" to install your zip. Turned my phone off an on again (leaving simtray in phone). After booting, entering my pincode, let it go to sleep by not touching it for a minute. But pressing my fingerprint sensor doesn't wake it up. Only swiping and entering my pincode does. So I had to remove simtray and reboot my phone and put it back again to make my fingerprint sensor work again for unlocking. Did I do something wrong installing your zip? By the way, I did get the 7.25 update automatically last friday.
 
Last edited:

cjdijk

Senior Member
Apr 25, 2021
99
45
I doubt he knows -- he got it from the Telegram group. I believe @GtrCraft posted it here a few years ago. It's just the Oreo fingerprint scanner firmware. I had a hunch that it would fix your problem, but maybe there's something else wrong with yours?
I do have the same thing on more Moto G5 Plus (XT-1685) phones. Fingerprint sensor works, for e.g. identification on banking app, but not for unlocking. I need to (re)boot it without simtray and put it back in after booting to make it work for unlocking too. When using Pixel Experience I could power off and on again to make it work. Rebooting did give the same problem. No problem when using the original 8.1 Android. It's not a very big problem. It keeps working as long I don't (re)boot it. And if it nessecary to (re)boot, I just need to remove my simtray temporary. But it's a bit annoying having to enter pincode instead or just touching the fingerprint sensor. Thanks anyway.
 

cjdijk

Senior Member
Apr 25, 2021
99
45
For me installing FP_firmware_NP25.137-33.zip does make my fingerprint sensor to not work at all anymore. Not for unlocking and not for banking app. So I am using FP_firmware_OPS28.85-17.zip now. That works as long I don't shutdown or reboot while simtray installed. I guess I am the only one who doesn't want to use a pincode or a pattern to unlock my phone. Or may be It's only an issue on all my XT-1685 potters.
 

mmortal03

Senior Member
Apr 15, 2014
364
64
For me installing FP_firmware_NP25.137-33.zip does make my fingerprint sensor to not work at all anymore. Not for unlocking and not for banking app. So I am using FP_firmware_OPS28.85-17.zip now. That works as long I don't shutdown or reboot while simtray installed. I guess I am the only one who doesn't want to use a pincode or a pattern to unlock my phone. Or may be It's only an issue on all my XT-1685 potters.
Mine has always worked, but it's an XT1687.
 

InfernalAscent

New member
Dec 29, 2022
2
2
First off, thanks for maintaining a quality custom ROM for the Moto G5 Plus!

I've just installed the latest twrp potter recovery image, wiped the cache/data/system partitions (+formatted data) and installed crdroid 7.25, along with flamegapps (full) for Android 11 and the latest Magisk. Everything booted up fine, but it seems internet connection can't be established - via wifi or mobile data.

I can setup the wifi network and sim card without an issue. Wifi reads as "Connected" and doesn't show any issues. But finalising the phone setup, where an internet connection is needed, always fails with "unable to connect" error. Same issue if going to Google Play Store, which asks for sign in, and fails with "unable to communicate with google servers". The same thing happens if wifi is turned off and mobile data is used instead.

Any suggestions on what to try to get the connection working?
 

Top Liked Posts