[ROM][11.0][taimen] PixelExperience [AOSP][OFFICIAL]

Search This thread

Singularity_iOS

Senior Member
May 13, 2014
132
15
NSW
Thanks for this ROM, it is working great and has double the performance of my phone and battery life.

Everything is working well except android auto. It keeps going into a weird state where it can't launch when plugged in. The car screen goes back and the phone says it's in driving mode but AA does not load. I have to then unplug, go into settings and force stop AA. Then it works after that. It seems to happen 2/3 times. 1/3 it works as intended.

I've tested in both my car (using Headunit reloaded AA emulator) and on a real car (Kia Cerato) and the same issue happens on both.

Please advise if there is anything I can try? Didn't have this issue on stock or previous room (PixelDust)
 
  • Like
Reactions: cbasse

MartinN6

Senior Member
Jul 6, 2015
643
365
Kassel
Thanks for this ROM, it is working great and has double the performance of my phone and battery life.

Everything is working well except android auto. It keeps going into a weird state where it can't launch when plugged in. The car screen goes back and the phone says it's in driving mode but AA does not load. I have to then unplug, go into settings and force stop AA. Then it works after that. It seems to happen 2/3 times. 1/3 it works as intended.

I've tested in both my car (using Headunit reloaded AA emulator) and on a real car (Kia Cerato) and the same issue happens on both.

Please advise if there is anything I can try? Didn't have this issue on stock or previous room (PixelDust)
That is very strange. with my device and PE android auto runs fine.
PE: PixelExperience_Plus_taimen-11.0-20210424-1334-OFFICIAL.zip
Root: Magisk 21.4
...nothing else
 

73sydney

Senior Member
Jul 21, 2018
1,547
1,252
Sydney
Google Pixel 2 XL
Hi everyone. When i installing PE Plus edition on status bar showing LTE not 4G. before showed 4G. On previous build. How can fix that? Thank you

Mine shows 4G, because thats what its connected to currently, at least in Australia LTE is between 3G and 4G and apparently your carrier is connecting you currently at LTE speeds


Some ROMs do allow you to toggle the name change from LTE to 4G, but PE isnt one of them
 
Last edited:

palimatix

Senior Member
Jan 18, 2011
1,491
670
Bangalore
hi @73sydney - since you have good knowledge in tweaking stuff, I was wondering if you could help me with something. My carrier (india - Jio , but doesnt matter ) supports Wifi-Calling for Pixel 5. Custom ROMs like fluid 1.2 and PD were posing as Pixel 5 and hence feature was enabled there. But nowadays, ROMs are all with authentic P2XL and hence only cellular is what I get.

So what all places you want me to try changing settings that would make my Taimen appear as Pixel 5 to my carrier in Pixel Experiece/Custom ROMs. Any suggestions would be welcomed.
 

cbasse

Senior Member
Jul 31, 2010
757
87
South of Boston, MA
Thanks for this ROM, it is working great and has double the performance of my phone and battery life.

Everything is working well except android auto. It keeps going into a weird state where it can't launch when plugged in. The car screen goes back and the phone says it's in driving mode but AA does not load. I have to then unplug, go into settings and force stop AA. Then it works after that. It seems to happen 2/3 times. 1/3 it works as intended.

I've tested in both my car (using Headunit reloaded AA emulator) and on a real car (Kia Cerato) and the same issue happens on both.

Please advise if there is anything I can try? Didn't have this issue on stock or previous room (PixelDust)


I've experienced similar issues with Android Auto. Was working fine for a while, then recently (last week or so?) has started exhibiting sporadic issues.
 

Chrislee150

New member
Aug 26, 2018
2
0
Google Pixel 2 XL
there's a little problem
When I wake up the screen, the media will pause for a while
Has anyone figured out this issue? I updated to the latest April 24 version, but audio still stutters when screen on, screen off. Screen off music also pauses and restarts intermittently. My apps also start to quit itself randomly in the middle of songs (Spotify/Strava)
 

73sydney

Senior Member
Jul 21, 2018
1,547
1,252
Sydney
Google Pixel 2 XL
hi @73sydney - since you have good knowledge in tweaking stuff, I was wondering if you could help me with something. My carrier (india - Jio , but doesnt matter ) supports Wifi-Calling for Pixel 5. Custom ROMs like fluid 1.2 and PD were posing as Pixel 5 and hence feature was enabled there. But nowadays, ROMs are all with authentic P2XL and hence only cellular is what I get.

So what all places you want me to try changing settings that would make my Taimen appear as Pixel 5 to my carrier in Pixel Experiece/Custom ROMs. Any suggestions would be welcomed.

You might want to ask the dev's of those ROM's what props they set for it to be viewed as a Pixel 5, i have no idea since i havent ever been able to flash either of those for other reasons...

It would im guessing involve setting certain build.prop entries to change the model, but you would also then need to set valid fingerprints to pass SafetyNet - you could potentially use MagiskHide Props Config, to do both systemlessly (reversibly) via magisk

See these sections of the documentation

Changing fingerprint: https://github.com/Magisk-Modules-R...md#use-vendor-fingerprint-for-treble-gsi-roms

Adding props: https://github.com/Magisk-Modules-R...master/README.md#changeset-custom-prop-values

But youre going to need those props to start with, sorry but im not able to download 1gb just to extract those for you, so i would PM the dev of one of the ROM's you know the feature works on

Changing to Pixel 5 *may* be as simple as adding any/all the following props via MHPC (i grabbed these from online search):

ro.product.product.device=redfin
ro.product.product.model=Pixel 5
ro.product.product.name=redfin

ro.product.vendor.device=redfin
ro.product.vendor.model=Pixel 5
ro.product.vendor.name=redfin

ro.product.device=redfin
ro.product.model=Pixel 5
ro.product.name=redfin

ro.product.system_ext.device=redfin
ro.product.system_ext.model=Pixel 5
ro.product.system_ext.name=redfin

ro.product.odm.device=redfin
ro.product.odm.model=Pixel 5
ro.product.odm.name=redfin

But there may be other props needed to enable the functionality youre looking for...ask the devs

Generally i don't really agree with setting props to a different device because it can have serious side effects, beyond adding what some consider features that your actual device doesnt support...
 
Last edited:
  • Like
Reactions: palimatix

HR-21

New member
Jun 16, 2018
2
6
Udaipur
hi @73sydney - since you have good knowledge in tweaking stuff, I was wondering if you could help me with something. My carrier (india - Jio , but doesnt matter ) supports Wifi-Calling for Pixel 5. Custom ROMs like fluid 1.2 and PD were posing as Pixel 5 and hence feature was enabled there. But nowadays, ROMs are all with authentic P2XL and hence only cellular is what I get.

So what all places you want me to try changing settings that would make my Taimen appear as Pixel 5 to my carrier in Pixel Experiece/Custom ROMs. Any suggestions would be welcomed.
I have 2 mathod but both way your P2XL must be rooted.
1. If you want to change your device fingerprint to pixel 5 then i will suggest you to use this Mod.
It will not just change device fingerprint to pixel 5 but also add more functionality like assistant 2.0 and more...
Alert: this mod is not working or Leg in April security patch, better to try after getting PE May security patch.

2. I am using Airtel cellular and officially P2xl do not support VoLTE but i used 2 magisk module to make it work.
First flash selinux_permissive_v2.0.zip
Then flash VoLTE_enabler_pixel_2_v1_1.zip
Reboot
Open settings app
Select Network & Internet
Select Mobile Network
Turn on Volte & WIFI calling if it is not turned on automatically.
Screenshot_20210514-012148_Settings.png

Open dialer app and press *#*#4636#*#*
Click on Phone information
Click on 3 dot menu and select "IMS Service Status"
Screenshot_20210514-011847_Phone_Services.png
If everything is working it will show status as Available.
Screenshot_20210514-011857_Phone_Services.png
I am not connected to Wifi so it is showing unavailable but it is actually working.
Screenshots added.
I have not created any files so all Credit goes to respective developer.
 

Attachments

  • selinux_permissive_v2.0.zip
    3.7 KB · Views: 8
  • VoLTE_enabler_pixel_2_v1_1.zip
    1.1 MB · Views: 11
Apr 13, 2014
49
9
Jaipur
Has anyone figured out this issue? I updated to the latest April 24 version, but audio still stutters when screen on, screen off. Screen off music also pauses and restarts intermittently. My apps also start to quit itself randomly in the middle of songs (Spotify/Strava)
Yes even i had the similar issue, so I figured out a temporary workaround until dev fixes it. Just turn off now playing - "show songs on lock screen" from settings and you won't notice that annoying pause in your playing media again. 😁
 
  • Like
Reactions: HR-21

Green-Bot

Senior Member
Nov 2, 2012
320
81
On this new PE Plus build(20210514), I am only seeing 1 wallpaper & ability to use 'My Photos', However, earlier there were many wallpapers ranging from Cityscapes, colours, earth, objects etc. All these wallpapers are not available now. Anyone else facing it?
 

palimatix

Senior Member
Jan 18, 2011
1,491
670
Bangalore
Is it just me or is the new build a little bit more aggressive at killing background processes/apps?
You are not alone ! :)
Am facing it too for the first time in PE. Mine happens when its in idle state. That is even more confusing.
The issue of agresssive proc has crept into here as well. Devs really need to iron out such forced efforts related check-ins in GIT.
 
Last edited:

Top Liked Posts