[ROM] [11.0] [UNOFFICIAL] ArrowOS for Redmi Note 9/ Redmi 10X 4G [AOSP] [BETA]

Search This thread
Feb 27, 2021
12
2
New FINAL ArrowOS Update is up!

Great! I simply flashed it over the existing installation (no wiping) and then removed the Magisk GApps. It seems to work fine at first glance. Or have I shot myself in the foot without knowing it? The messages about play services crashing seems to have disappeared, which is nice.


I tried the WeGo app on new build, seems like a source issue, I guess I can't fix it :(

Too bad. Well, it still is the most usable ROM for the Redmi 9 I have found thus far. And that includes the official MIUI. Sure, it's a bit more stable, but it's also really annoying. People had warned me about MIUI, and I thought: "C'mon, how bad can it be?" But it could. And it was.

I'll take having to put the WeGo maps into internal storage and (so far) being unable to encrypt my phone over having to deal with MIUI any day of the week. Please keep up the good work!
 
  • Like
Reactions: Communos
Feb 27, 2021
12
2
Ok, weird little issue because I cannot really reproduce it.

I was at a friend's house and wanted to connect to their wifi. But the phone always said that the connection could not be established (no reason given, who wants meaningful error messages anyway?). I tried both the QR code scan and manually copying&pasting the key. I tried deleting it and connecting again, I tried disabling the entire wifi and re-enabling it. Nothing seemed to work. I could not get into their wifi.

Back home I fiddled around with it, switching back and forth from my normal home wifi to my guest wifi, and it seems to work fine. Finally, I once - just once - managed to get the problem to occur (and I made a log of it, see attachment). But I fixed it by deleting and re-adding the wifi (which didn't work at my friend's house, even though they have the exact same router model I have). And now it works again. And reproducing the steps does not reproduce the problem.

Not sure what this is, but perhaps you can take a look.
 

Attachments

  • log.zip
    138.4 KB · Views: 1

fbachofner

Member
May 30, 2009
34
17
Seaside, CA
Hi @Communos

Thanks for your reply.

This rom build is NOT for Miatoll, Redmi Note 9 with HelioG85 does not come under Miatoll category.

Please reach out to your device maintainer and report the bugs to him/her.


Sorry, I glossed over the missing Pro in the description of the ROM.

You are correct of course, miatoll devices use Qualcomm SM7125 Snapdragon 720G

Ironically, other A11 ROMs (correctly selected for miatoll!) have the same problem with missing mic and/or ear speaker (depending on the ROM). I went through an exhaustive search and acidentally installed Arrow thinking it might help . . .
 
Sep 8, 2019
9
3
Malè
Hello
Can you tell me how to unlock flashing? or unlock bootloader or something? xiaomi phones are complicated i don't know what the hell.. heheh
I want to flash this rom but my phone's bootloader is locked.. help me out? Thanks
 
Feb 3, 2021
34
0
Hey there, I was just wondering, will this ROM work on MIUI 12.0.90? You did say it could work on any devices running 12.0.10 and above right?

And yes I am asking about the Redmi Note 9 (merlinnfc) version.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    logo.png

    ArrowOS

    ABOUT
    ArrowOS
    is an AOSP based project started with the aim of keeping things simple, clean and neat.

    Website: https://arrowos.net
    Github: https://github.com/ArrowOS
    Code Review: review.arrowos.net
    E-mail: arrowos.contact
    Blog: blog.arrowos.net


    WHAT WORKS?
    • Almost everything

    WHAT DOESN'T WORK?
    • Flashing GApps in recovery for vanilla build doesn't work, either use WeebGapps Magisk module or Lite Gapps
    • Hotspot
    Be sure to include a log : check how to

    FLASHING STEPS
    • •Make sure you are on 12.0.1.0 and above firmware to flash ROM.
      •Reboot Recovery (Use the recovery on download section to flash ROM)
      •Flash Rom
      •Format data
      •Reboot System
      •Once you see Bootanimation, Hold the power button to force reboot (To avoid bootloop on first boot)

    DOWNLOADS
    Download Vanilla Build
    Download GApps Build
    Download RECOVERY

    ROM Source: https://github.com/ArrowOS
    Kernel Source: https://github.com/Redmi-MT6768
    Telegram: Channel | Group

    CONTRIBUTORS
    Communos
    Firas
    2
    New FINAL ArrowOS Update is up!

    Download
    : arrow_merlin-gapps.zip

    Changelogs:

    - This build is a followup build of previous ArrowOS build.
    - GApps Included
    - Fixed few minor bugs
    1
    wow pro god sir
    1
    Hmm... all I see is a neverending blue and white arrow symbol.


    is there a gapps to install for this version?

    With the OpenGapps test builds for Android 11, or the NikGapps, the installer always complained about not enough space on the system partition, even though it was already the smallest package (pico/core).

    Only the FlameGapps basic package installed without errors on my device, but since it doesn't boot, I can't tell you if it actually works.

    Here's the log from the OpenGapps pico package:

    Code:
    # Begin Open GApps Install Log
    ------------------------------------------------------------------
                ROM Android version | 11
                       ROM Build ID | RQ1A.210205.004
              ROM Version increment | eng.ebincr.20210225.160609
                    ROM SDK version | 30
            ROM/Recovery modversion | v11.0
                    Device Recovery | TWRP 3.4.2b-1213-c4a6db32
                        Device Name | merlin
                       Device Model | M2003J15SC
                        Device Type | phone
                         Device CPU | arm64-v8a,armeabi-v7a,armeabi
              Device A/B-partitions | false
                 Installer Platform | arm
                       ROM Platform | arm64
               Display Density Used | 440
                       Install Type | Clean[Data Wiped]
    Google Camera already installed | Clean
                  VRMode Compatible | false
           Google Camera Compatible | true
          New Camera API Compatible | false
              Google Pixel Features | false
              Current GApps Version | No GApps Installed
              Google Camera version | Legacy
           Installing GApps Zipfile | /external_sd/Download/open_gapps-arm64-11.0-pico-20210130-TEST.zip
           Installing GApps Version | 20210130
              Installing GApps Type | pico
                        Config Type | 
                 Using gapps-config | Not Used
          Remove Stock/AOSP Browser | false[NO_Chrome]
           Remove Stock/AOSP Camera | false[NO_CameraGoogle]
           Remove Stock/AOSP Dialer | false[NO_DialerGoogle]
            Remove Stock/AOSP Email | false[NO_Gmail]
          Remove Stock/AOSP Gallery | false[NO_Photos]
         Remove Stock/AOSP Launcher | false[NO_GoogleNow/PixelLauncher]
          Remove Stock/AOSP MMS App | false[NO_Messenger]
         Remove Stock/AOSP Pico TTS | false[default]
             Ignore Google Contacts | false
               Ignore Google Dialer | true[NoRemove]
             Ignore Google Keyboard | false
    Ignore Google Package Installer | false
              Ignore Google NFC Tag | true[NoRemove]
              Ignore Google WebView | false
             Total System Size (KB) | 1186384
             Used System Space (KB) | 971236
            Current Free Space (KB) | 198764
     Additional Space Required (KB) | 25676   << See Calculations Below
    ------------------------------------------------------------------
    # End Open GApps Install Log
    
    INSTALLATION FAILURE: Your device does not have sufficient space available in
    the system partition to install this GApps package as currently configured.
    You will need to switch to a smaller GApps package or use gapps-config to
    reduce the installed size.
    
    NOTE: The Stock/AOSP NFC Tag is not available on your
    ROM (anymore), the Google equivalent will not be removed.
    NOTE: The Stock/AOSP Dialer is not available on your
    ROM (anymore), the Google equivalent will not be removed.
    # Begin GApps Size Calculations
    ------------------------------------------------------------------
      TYPE  |         DESCRIPTION        |      SIZE |   TOTAL
            |         Current Free Space |    198764 |  198764
     Remove |             Existing GApps | +       0 |  198764
     Remove |             Obsolete Files | +      56 |  198820
     Remove |           extservicesstock | +       0 |  198820
     Remove |             extsharedstock | +      52 |  198872
     Remove |      packageinstallerstock | +    3284 |  202156
     Remove |                  provision | +       0 |  202156
    Install |                       Core | -  174976 |   27180
    Install |                    calsync | -    2556 |   24624
    Install |            dialerframework | -      32 |   24592
    Install |                  googletts | -   37896 |  -13304
    Install |     packageinstallergoogle | -    3156 |  -16460
            |               Buffer Space | -    9216 |  -25676
    ------------------------------------------------------------------
                          Additional Space Required |   25676
    ------------------------------------------------------------------
    
    # End GApps Size Calculations
    
    # Begin User's gapps-config
    
    # End User's gapps-config
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone