• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][11.0][UNOFFICIAL] Nexus Stock for 2019 Galaxy Tab A 8.0 [SM-T290]

Search This thread

Magendanz

Senior Member
Mar 25, 2008
836
806
Issaquah, WA
www.Vote4Chad.com
Flashed it semi dirty, without the base, sorry no time. This ROM works absolutely flawlessly! No issues whatsoever, everything works perfectly.
Honestly, I'm surprised that it worked without first flashing the T290XXU3CUG4 OEM base first, since that was the transition to the Android 11.0 kernel. In the past, that's been an issue.
Thank you sir for your hard work and dedication. I will let you know how it goes with the sm-t510 shortly. I also have the A7 10.1, s5e, s6, s7 and s7+ among many others.

Cheers, how's the weather in WA? Was born in Seattle, I know how it is.
I've got three Galaxy Tab A7's (SM-T500s) now, and so that's the next big project. I've been putting it off because this is the first release that's been using dynamic partitioning, which is going to be a major hassle. Fortunately, it's going to be raining in Seattle for the entire 4-day holiday weekend, so I'll have lots of time indoors to focus on my hobbies.

Last week I also got an insane deal on a Galaxy Tab S7 FE (SM-T733), so that's been added to my list for TWRP and Nexus Stock supported devices.
 
  • Like
Reactions: gigahurts

gigahurts

Senior Member
Feb 4, 2013
87
56
Well, the rain in a part of life up there, cool you can focus on development whilst indoors.

Awesome news about the s7 fe, unfortunately the soc is a bit different than the s7 and s7+, but I've already got twrp and a of debloated custom ROM installed that I've been working on for them.

I buy broken tabs (frp, broken screens, no charging, etc) and fix them. That's how I've acquired so many, discount in bulk. Lol. Not sure how the dirty flash worked either, - it didn't going from stock a9 to your a10 ROM, I think Odin takes over and pretty much overwrites every partition, and for whatever reason it worked going from a10 to a11 (I'm kinda lazy is the only reason I didn't format data. I'm downloading your t510 new ROM now and will flash shortly, let you know how it goes. I have 4 t290s all with broken screens, but all function perfectly. I ordered replacement screens, just waiting for them to arrive.

Thanks again brother. (Edited to take some ill advised, thanksgiving day, too much alcohol and inebriated based comments out, for the sake of the moderator"s awesome supervision and general protection of this thread, owned by an even more awesome developer - I went into a little bit too much detail about things which should not be discussed here and which google, in their infinite wisdom, probably wouldn't appreciate. - which I blame partially on a combination of ftryptophan and pomegranate cider).
 
Last edited:

gigahurts

Senior Member
Feb 4, 2013
87
56
Just a quick reply. Safetynet attestation passes now, just checked 30 seconds ago. Weird, I'll check the t510 again and update shortly.
 

Gent'

Senior Member
Apr 5, 2016
508
234
22
Mitrovica
New Android 11 release is finally posted. Note that we're now constrained by the system partition size, so I had to trim some of the stock OpenGApps (e.g. Maps, Duo, Messenger, Android Auto) to fit in the available space. Also, you'll need to do a clean flash on top of the OEM T290XXU3CUG4 release because we're moving to an Android 11 kernel. Dirty flashes are not possible (which is why I've disabled the link to the TWRP update). Finally, because we've reached end of life on the Android 10 releases, I've now highjacked this XDA thread for Android 11.

Downloads:
Change Log:
20211121:
  • Updated to Android 11 OEM stock T290XXU3CUG4 kernel (July 2021 Update).
  • Switched underlying GSI from LineageOS 17.1 to CAOS 11.
  • Updated TWRP recovery to v3.5.2_9-1 (20211017).
  • Updated Google apps from latest OpenGapps Stock variant (20211120) w/ rollback for WebView
  • IMPORANT NOTE: Dirty flash is not possible because we're transitioning to Android 11 kernel. Use Oden and do a factory reset from TWRP.
hi there, thanks for the rom. How can i flash the .tar.md5 file, should i use odin or can i flash it through twrp. Btw i'm coming from stock android 11. Thanks in advance.
 

XRaiderV18

Senior Member
May 12, 2019
76
13
so...this is a stock android os experience for the sm-t290? is it still being actively developed?

kind of not thrilled with samsung's take on android 11(the performance just goes down hill the more days elapse since its last reboot)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    qPD09.png

    Here's my first effort at porting the Nexus Stock custom ROM to the 2019 Galaxy Tab A 8.0 [SM-T290] on Android 10. It's very much a work in progress, but it should hopefully help blaze the trail for even better work.

    Notes:
    • The current process may require you to reset to factory defaults to remove file-based encryption. Remember to backup your data!
    • The system is based on eremitein's CAOS GSI project with the latest Stock variant from OpenGApps.
    • Boot animation and default wallpaper is from my Nexus series of custom ROMs for Android TV, and I'm using the Pixel boot animation with black background.
    • This should be installed using my latest TWRP build for the SM-T290.
    • The properties now correctly identify the device as a tablet, and so the Google Dialer and Messenger are no longer installed. I've also disabled the Emergency button, but SetupWizard still insists on reminding you to insert a SIM (sigh!).
    • This is unofficial and unsupported, so the usual caveats apply. Since we don't mess with the bootloader, you should be able recover from any problems...but nothing is guaranteed.

    Not working:
    • Support for file-based encryption
    • MTP support (pending Samsung kernel source update)
    • Offline (cold) charging

    Downloads:
    Build Archives:
    Change Log:
    20211121:
    • Updated to Android 11 OEM stock T290XXU3CUG4 kernel (July 2021 Update).
    • Switched underlying GSI from LineageOS 17.1 to CAOS 11.
    • Updated TWRP recovery to v3.5.2_9-1 (20211017).
    • Updated Google apps from latest OpenGapps Stock variant (20211120) w/ rollback for WebView
    • IMPORANT NOTE: Dirty flash is not possible because we're transitioning to Android 11 kernel. Use Oden and do a factory reset from TWRP.
    20210516:
    • Switched GSI from custom AOSP build to the latest LineageOS 17.1 (20210512).
    • Restored enforced OEM file-based encryption to work around issue with screen lock.
    • Sized boot animation correctly for 720p screen.
    • Worked around issue with OpenGApp's Google Recorder installation.
    • Updated to OEM stock T290XXU3BUC1 kernel (March 2021 Update).
    • Updated TWRP recovery to v3.5.2_9-0.
    • Updated Google apps from latest OpenGapps Stock variant (20210515)
    20210104:
    • Updated to OEM stock T290XXS3BTL6 kernel (December 2020 Update).
    • Updated TWRP recovery to v3.5.0_9-0.
    • Updated Google apps from latest OpenGapps Stock variant (20201223)
    20201223:
    • Initial build based on OEM stock T290XXU3BTI2 kernel (September 2020 Update) and AOSP 10.0 v222.
    • Latest Google apps from Stock variant of OpenGApps (20201205)

    Instructions:
    From OEM stock firmware:
    • Unlock bootloader
    • Ensure matching OEM build (e.g. T290XXU3CUG4) is installed
    • Hold Vol Up & Vol Down buttons during restart to enter Download mode
    • Install custom ROM tarball (.tar.md5 file) to AP with Odin
    • When TWRP launches, factory reset with Wipe->Format Data. (Not necessary for incremental upgrades.)
    • Reboot to system
    From existing TWRP install (for incremental updates):
    • Hold Power & Vol Up during restart to enter TWRP recovery
    • Tap Install, select your update (.zip file), and then swipe to install
    • Reboot to system

    Source:

    Donations:
    • Your support is always appreciated! Just click here.
    • I'm leveraging a ton of work done by @phhusson for Treble GSIs, so please show him some love here!
    3
    Note: If you install Google Recorder from the Google Play Store, it works just fine. The issue is with the pre-installed APK from OpenGApps.
    3
    SafetyNet check failed (but basic is true). SafetyNet on stock firmware failed too, but MagiskHide always help. In your ROM, if i turn on MagiskHide, i got cyclyng reboot, over and over again until i turn "hide" off.
    SafetyNet fails by design on any device with an unlocked bootloader and custom ROM. Magisk has its tricks to try to fool SafetyNet, but it's a bit of Whack-a-Mole game.
    Can you make a custom Kernel with GPU Overclock? Tablet not so bad and run some games pretty well, with overclock they can be runs much better.
    Unfortunately, the Android 10 kernel source that was posted last week is not working. It compiles fine, but builds to a significantly different size and crashes to the bootloader when packaged in either boot or recovery images. Until that's addressed, I can't provide an MTP fix or any overclocking.
    3
    Note: I just posted a v3.4.0-1 update to my TWRP for SM-T290 thread that includes a new custom T290UES3ATC1 kernel fixing MTP support. If you install it over the TWRP build included in this build, it will allow file transfers on this custom ROM by rebooting to recovery.

    Since this is an Android 10 custom ROM, I can't use it in the boot image, but it's a workaround until we get working T290XXU3BTI2 kernel source.
    3
    Hi, there. I've managed to get the image installed, used the compatible version, etc. After rebooting, I got to TWRP, did the wipe, etc. Upon reboot, I get through to the setup process, skip the SIM setup stuff (no cell stuff in this T290) and then when trying to add a wifi connection, it never completes the "Connect to WiFi" step. If I skip, I can get through manual set up of the basics, manual time config, a few other prompts. All that seems okay. But even when I get to the main menu menu, it seems like everything is working (pulls up, etc) but I'm still not connected. The WiFi radio appears to be turned completely off. Each time I try to turn it back on, it flashes on for a split second, then immediately turns off again.

    Any ideas I can try to get this enabled?
    Okay, all weekend I've been trying to figure out why wireless isn't working on my custom kernel, but it appears the OEM kernel isn't working as well...and I didn't even realize it. This is actually a hugely valuable data point that will drive my troubleshooting in an entirely different direction.

    I'm embarrassed that I missed this in my initial smoke testing, but at least I know that my MTP fix is solid. More info to follow...