[ROM][11]Android Open Source illusion Project (27 Feb)[hotdogg][Unofficial]

Search This thread

cyapalmpos

Senior Member
Feb 12, 2011
221
27
58
I figured out the issue. I was flashing from the bootloader and not the fastboot reboot fastboot (blue Chinese letters) screen. This is where it needs to be flashed. Not from the bootloader. Once I did that I was set. Had some help from the telegram forum folks. Mostly SirenOndine and Jamesgryffindor99. They were patient with the new old guy and all my stupid questions. They cleared up a ton for me. I wrote a step by step guide for noobs like me because I plan on doing this for my family and friends. It think, right now, this ROM / lineage is the best de-googled rom and the 7t pro McLaren is the best phone. If I'm wrong show me a de-googled rom (NO GAPPS Option) that supports a better (stats) phone, please. I'll start working on that next.

It needs some cleaning up (the guide), but I have the process saved from literal START to Finish. Including unlocking the boot loader, rooting, and flashing the rom, backing up, flashing persist, all of it. I kept a running log while I was doing it, bricking, unbricking, moving forward. Works like a charm. Thanks for the reply.

My first fall back into the fray was with a Sony XA2 Ultra. What a mistake. No VOLTE = IMEI blocked by all carriers. Yes, I tried them all. All had it blocked and unable to activate (yes the IMEI was clean.) This time everything worked pretty darn flawless.

By the way. To the developers. this ROM is fantastic and stable. Everything works for me. Coming from old cyanogen flashing this was a bit more involved on the One Plus 7T pro McLaren, but when I got help from the group on Telegram I got it done. Network compatibility with the McLaren is fantastic. Eventually I will post my guide from START TO FINISH after I do a phone from start to finish a couple of more times. Thanks again for a such a sexy ROM. The owl is what sold me. The performance is what has kept me so far.
I'd love to see your guide
 

chefcesarpr

Senior Member
Aug 11, 2007
73
7
38
He is right, you need to "fastboot reboot fastboot" from bootloader (green "Start" screen).
This will bring you to fastbootd (looks like OnePlus recovery).
You must flash from here since bootloader doesn't have access to the needed partitions, hence the "Partition not found" errors you got.
Thank you so much for the clarification. Will try again over the weekend.
 

rainland666

Member
Feb 25, 2021
7
1
13
I am getting below error after unlock the bootloader

fastboot update AOSiP-11-Ravioli-hotdogg-20210227-gapp-fastboot.zip
--------------------------------------------
Bootloader Version...:
Baseband Version.....:
Serial Number........: 59f6fba4
--------------------------------------------
extracting android-info.txt (0 MB) to RAM...
Setting current slot to 'a' OKAY [ 0.009s]
extracting boot.img (96 MB) to disk... took 0.227s
archive does not contain 'boot.sig'
Sending 'boot_a' (98304 KB) OKAY [ 2.290s]
Writing 'boot_a' OKAY [ 0.333s]
extracting dtbo.img (24 MB) to disk... took 0.085s
archive does not contain 'dtbo.sig'
Sending 'dtbo' (24576 KB) OKAY [ 0.550s]
Writing 'dtbo' OKAY [ 0.064s]
archive does not contain 'dt.img'
archive does not contain 'pvmfw.img'
archive does not contain 'recovery.img'
extracting vbmeta.img (0 MB) to disk... took 0.001s
archive does not contain 'vbmeta.sig'
Sending 'vbmeta' (8 KB) OKAY [ 0.006s]
Writing 'vbmeta' OKAY [ 0.003s]
extracting vbmeta_system.img (0 MB) to disk... took 0.105s
archive does not contain 'vbmeta_system.sig'
Sending 'vbmeta_system' (4 KB) OKAY [ 0.006s]
Writing 'vbmeta_system' OKAY [ 0.002s]
archive does not contain 'vendor_boot.img'
archive does not contain 'super_empty.img'
archive does not contain 'boot_other.img'
extracting odm.img (2 MB) to disk... took 0.017s
archive does not contain 'odm.sig'
Sending 'odm' (2512 KB) OKAY [ 0.065s]
Writing 'odm' FAILED (remote: 'Partition not found')
fastboot: error: Command failed

Can you please help?
 

rainland666

Member
Feb 25, 2021
7
1
13
HI
All working great anyone having issues with the fastboot reboot command they more than likely out of date. Also its worth mentioning the difference in the bootloader screen and the fastboot one.

The boot loader is the multi-colared one and the correct fast boot screen when doing fastboot reboot fastboot is all black screen with different language selections bottom being english
Hi Buddy

How did you manage to flash this ROM into this 7T pro device?

I am currently facing below error once I flash from the fastboot, can you please shed some lights?
 

factorion

Member
Jan 1, 2014
6
0
21
I am getting below error after unlock the bootloader

fastboot update AOSiP-11-Ravioli-hotdogg-20210227-gapp-fastboot.zip
--------------------------------------------
Bootloader Version...:
Baseband Version.....:
Serial Number........: 59f6fba4
--------------------------------------------
extracting android-info.txt (0 MB) to RAM...
Setting current slot to 'a' OKAY [ 0.009s]
extracting boot.img (96 MB) to disk... took 0.227s
archive does not contain 'boot.sig'
Sending 'boot_a' (98304 KB) OKAY [ 2.290s]
Writing 'boot_a' OKAY [ 0.333s]
extracting dtbo.img (24 MB) to disk... took 0.085s
archive does not contain 'dtbo.sig'
Sending 'dtbo' (24576 KB) OKAY [ 0.550s]
Writing 'dtbo' OKAY [ 0.064s]
archive does not contain 'dt.img'
archive does not contain 'pvmfw.img'
archive does not contain 'recovery.img'
extracting vbmeta.img (0 MB) to disk... took 0.001s
archive does not contain 'vbmeta.sig'
Sending 'vbmeta' (8 KB) OKAY [ 0.006s]
Writing 'vbmeta' OKAY [ 0.003s]
extracting vbmeta_system.img (0 MB) to disk... took 0.105s
archive does not contain 'vbmeta_system.sig'
Sending 'vbmeta_system' (4 KB) OKAY [ 0.006s]
Writing 'vbmeta_system' OKAY [ 0.002s]
archive does not contain 'vendor_boot.img'
archive does not contain 'super_empty.img'
archive does not contain 'boot_other.img'
extracting odm.img (2 MB) to disk... took 0.017s
archive does not contain 'odm.sig'
Sending 'odm' (2512 KB) OKAY [ 0.065s]
Writing 'odm' FAILED (remote: 'Partition not found')
fastboot: error: Command failed

Can you please help?

After you ran fastboot reboot fastboot, did you touch anything on the screen or let it stay at the language menu?
 

rainland666

Member
Feb 25, 2021
7
1
13
After you ran fastboot reboot fastboot, did you touch anything on the screen or let it stay at the language menu?

You are right, I had successfully flashed this ROM and it was a smooth experience

My only issue is that I lost the cellular service from visible network, MSM tool to get back to stock and it is still no phone calls/data, only text message

Not sure what is broken now
 

marcusrab

Senior Member
Sep 28, 2009
219
33
48
chicago, IL
You are right, I had successfully flashed this ROM and it was a smooth experience

My only issue is that I lost the cellular service from visible network, MSM tool to get back to stock and it is still no phone calls/data, only text message

Not sure what is broken now
Try this..

Settings --> network & internet --> mobile network --> preferred network type

mess around with those... try NR/LTE .. if not, try NR only... go down that list of network types and see if it fixes your issue.
 

rainland666

Member
Feb 25, 2021
7
1
13
Try this..

Settings --> network & internet --> mobile network --> preferred network type

mess around with those... try NR/LTE .. if not, try NR only... go down that list of network types and see if it fixes your issue.
Tried all of the options available and it still not picking up signals

2G/3G/LTE/5G (Automatic)
2G/3G/LTE/ (Automatic)
2G/3G (Automatic)
3G/LTE/5G
3G/LTE
2G only
 

Constrabus

Senior Member
Jun 19, 2009
434
282
83
NYC
You are right, I had successfully flashed this ROM and it was a smooth experience

My only issue is that I lost the cellular service from visible network, MSM tool to get back to stock and it is still no phone calls/data, only text message

Not sure what is broken now
If you have a non-tmobile SIM, I've seen people have luck with the Global option
 

yellowredblue132

New member
Jul 20, 2018
2
0
1
Is there any way to modify the lock screen where the pin is typed in? The area where the numbers are located is really high up on the screen and is a bit awkward to type.
 

sabre66

Member
Jun 2, 2012
11
1
23
Hi, just put this ROM on. Real nice, thank you. A few things as I am a bit new to this.

I want to get Google Pay working - right now it does not find my payment methods. Can i relock to the bootloader and it should work, or do i need to root w/ magisk for this to work?

Also, I dont think wifi calling is working. Any extra steps to be sure that works.?
Does face unlock work?

(I tried Telegram but could not post there)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    If you have a non-tmobile SIM, I've seen people have luck with the Global option
    Could you please share a link for global rom working on t mobile mclaren 7t pro.
  • 3
    @jasonziter
    I think that's the same issue I had, had to use the gapps zip file which caused issues with some of the google apps I had installed. Might try copying the needed files into the regular fastboot.zip?

    @gtxaspec
    I have the same issue. My gpay card comes up, but tapping on that or device controls just backs out of the power menu.

    I figured out the issue. I was flashing from the bootloader and not the fastboot reboot fastboot (blue Chinese letters) screen. This is where it needs to be flashed. Not from the bootloader. Once I did that I was set. Had some help from the telegram forum folks. Mostly SirenOndine and Jamesgryffindor99. They were patient with the new old guy and all my stupid questions. They cleared up a ton for me. I wrote a step by step guide for noobs like me because I plan on doing this for my family and friends. It think, right now, this ROM / lineage is the best de-googled rom and the 7t pro McLaren is the best phone. If I'm wrong show me a de-googled rom (NO GAPPS Option) that supports a better (stats) phone, please. I'll start working on that next.

    It needs some cleaning up (the guide), but I have the process saved from literal START to Finish. Including unlocking the boot loader, rooting, and flashing the rom, backing up, flashing persist, all of it. I kept a running log while I was doing it, bricking, unbricking, moving forward. Works like a charm. Thanks for the reply.

    My first fall back into the fray was with a Sony XA2 Ultra. What a mistake. No VOLTE = IMEI blocked by all carriers. Yes, I tried them all. All had it blocked and unable to activate (yes the IMEI was clean.) This time everything worked pretty darn flawless.

    By the way. To the developers. this ROM is fantastic and stable. Everything works for me. Coming from old cyanogen flashing this was a bit more involved on the One Plus 7T pro McLaren, but when I got help from the group on Telegram I got it done. Network compatibility with the McLaren is fantastic. Eventually I will post my guide from START TO FINISH after I do a phone from start to finish a couple of more times. Thanks again for a such a sexy ROM. The owl is what sold me. The performance is what has kept me so far.
    2
    logo.png

    Code:
    **** Disclaimer: I'm not responsible if you destroy your device. Use at your own risk!!! ****[/CENTER]
    Android Open Source illusion Project

    About us:
    AOSIP is a quality custom ROM based purely on AOSP. Twisted with the latest features and blended with stability. We strive for perfection and it shows.

    Team Illusion:

    Josh Fox (xlxfoxxlx)
    Akhil Narang
    Harsh Shandilya
    Anirudh Gupta

    Bug reporting:

    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed​
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)​
    • If it is a random reboot, grab dmesg . (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)​
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log​
    • Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues.​


    Source code:


    Unlock Warning:
    By unlocking a OnePlus phone, you can loose permanent functionality in fingerprint scanner and OTAs for Stock ROMS
    Please see 3rd post for backup instructions BEFORE you unlock your device
    Join our Telegram Chat for added support



    Downloads:
    ROM (MIRROR)
    GAPPS (11)
    GCAM (Wichaya)
    MAGISK
    TWRP (3.4.0-2 by mauronofrio)



    Credit/Thanks:
    Mike Williams (founder and creator of AOSiP)
    Google for Android and AOSP
    LineageOS
    ABC ROM
    AquariOS
    BootleggersROM
    Dirty Unicorns
    PixelExperience
    OmniROM
    CarbonROM
    nathanchance
    ---------
    Other projects whose work helped us to create this
    And last but not the least, all our testers, who have helped us to squash many bugs so that we can try to release builds that as are flawless as possible​
    2
    Just wanted to give you a little something. I appreciate the Rom and the updates. Transaction
    2TV57730XG423470R
    Thank you so much, very appreciated. I've put many many months, days, hours into this project so it means a lot.
    2
    Phone doesn't want to connect to 5g unless forced into me only mode

    Running the latest update as well
    Edit looks like it's an icon bug, speed tests show upwards of 200mbps down so that's clearly a 5g connection
    Everyone else has 5G icon no problem, join Telegram for extra support.


    Also, 18th build had broken in-call earpiece and mic audio, so I just released a small update.
    Non-gapp is up. Gapp build coming within the hour.
    2
    New build is posted
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone