[ROM][11] crDroid 7x for Huawei P8 Lite 2017 and P10 Lite

Search This thread

amonpaike

Member
Aug 21, 2010
41
14
I couldn't get 302 to work yet. bootloop even if I wipe data (tried wipe/format in erecovery, format in twrp, wipe in twrp.) let me know if you get it working... and how. I hate this device is so sensitive... look at it wrong and it bootloops haha
yes I also had bootloops, because I had not read the comments of the Siberia Kernel thread and I had not seen that there were problems and we needed the "stock" version but I saw that you already liked my comment on the other thread, so I know you know already the solution.
 

buteo

Senior Member
Aug 14, 2007
126
16
My phone is a PRA-LX1 with EMUI 8.0.0.402 and the last DarkJoker TWRP (link in my first post). Try the same files as me, the 402 is on androidhost.ru
Hello.
I downloaded and flashed
Huawei P8 Lite 2017 PRA-LX1 PRA-L11 hw eu HLRCF Prague-L31 8.0.0.402(C432) Firmware 8.0.0 r1 EMUI8.0 05014FFV [androidhost.ru]

It was the only v.402 file on the site, for the right area C432

After successful flashing I end with version 8.0.0.046(0OXY) (NOT .402, wrong area code).
In this state ROM boots and stucks at crdroid logo (the same with Lineage) for a long time, then reboots to erecovery.

I tried to reflash EU oeminfo, but it doesn't seem to help. Tried do install
Huawei Honor 8 Lite PRA-LX1 PRA-L31HN hw eu HLRCF Prague-L31HN 8.0.0.375(C432) Firmware 8.0.0 r1 EMUI8.0 05014GNH [androidhost.ru] but it fails.

Any advice?
Some info I can get:

$fastboot oem get-build-number (bootloader) :System 8.0.0.046(0OXY) $ fastboot oem get-product-model (bootloader) PRA-LX1 $ fastboot oem oeminforead-SYSTEM_VERSION (bootloader) :PRA-LX1C432B170
 

buteo

Senior Member
Aug 14, 2007
126
16
There are no sounds or ringtones in the ROM image, right?
So I installed "LineageOS_Sounds.zip" from within TWRP and, even if sound files are in/system/media/audio/* directories ringtones are not selectable from CRdroid UI.
Ringtones appear only if copied in Internal memory Ringtones directory.
What do you think I made wrong?
 

hamedsolo

Senior Member
Dec 24, 2016
70
18
USg Ishimura
I have problems with v314
1-camera has delay
2- screen mirror and hotspot with software like xender not working
3- Qr code scanners not working
4- access to sd card has problems

how can I dirty update this rom from v314 to v315?
I have magisk 22 and gapps.
 

11spqr

Member
Jun 27, 2019
37
25
I have problems with v314
1-camera has delay
2- screen mirror and hotspot with software like xender not working
3- Qr code scanners not working
4- access to sd card has problems

how can I dirty update this rom from v314 to v315?
I have magisk 22 and gapps.
Hi,
Because of SU app change IMHO dirry update is not possible.
I had problems with Mixplorer with root permisions and SU app itself after dirty update(reboot to twrp, clean cache, dalvik/cache, reboot to bootloader, flash system img). I am not usig Magisk on this rom dough.
 
  • Like
Reactions: hamedsolo

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    Non-Official crDroidAndroid 11 v7.x for Huawei (prague)

    cddroid.png


    Changelog :

    Febrary 2022
    • Update to crDrom Febrary version by eremitein (change log) :
      • crDroid 7.15 base
      • February 2022 SPL
      • to the Phh settings > Misc added new options: Restart systemUI and Dump system logs
      • SuperUser app replaced by updated new one (special thanks for contributors ponces and Amy). if you have problems after dirty update you should first remove app from Apps settings then disable/enable Superuser in Phh settings
      • patch for vold timeout applied for real now

    January 2022
    • Update to crDrom January version by eremitein (change log) :
      • January 2022 SPL
      • crDroid 7.14 base
      • implemented Huawei IMS patches from Iceows
      • fixes for for some devices (mainly with Oreo vendor, A-only) access for media files from some apps like WhatsApp or Telegram (based on Iceows's patch)
      • backported changes from v400h device_phh_treble: All devices support unprocessed audio source, Fix audio for Umidigi X and Gome U9, Add Netflix ID for Mi 11 lite 5G
      • patch for vold timeout (by Iceows)
      • opt-out cringe TCP info parsing error (AAAAA....) on legacy kernels (commit)
      • libprocessgroup: Do not remove uid cgroups directory (commit)
      • added patch for Huawei RIL signal indicator (by Iceows)
      • launcher replaced with Trebuchet from LineageOS 18.1
    • Fix sdcard format internal storage

    December 2021
    • Integrate NFC, Miracast/cast , Live Display patches
    • Add media patch (Fix "Error loading media" in social apps like instagram, messenger..)
    • Add support of RNE-L21 (P10 Mate)
    • Update to crDrom December version by eremitein (change log) :
      • crDroid 7.13 base
      • December 2021 SPL
      • phh patches v313 + some stuff backported from v400 device_phh_treble: fixes for Xiaomi Mi 11 Lite 5G, Motorola One Fusion Plus, Huawei P10, Realme GT ME, Blackview BV9500Plus etc
      • trying to fix screen recorder bug on some devices (onemoretime..), thanks Iceows for the points
      • added Phh option for enabling old cutout covering behavior in fullscreen mode
      • Umidigi A7 Pro: put notch value from stock framework-res
      • hide OTA menu, that's the way
    November 2021
    • Initial build based on release crDRom11 October 2021 (thanks to *eremitein)
    • Transform A-Only crDRom11 ROM to Huawei P8 lite 2017 or Huawei P10 lite ROM
    • Fix AGPS, NFC, Cast/MiraCast and Lineage LiveDisplay

    Pre-requisite :

    You must have TWRP installed, use this one (make sure to have the unofficial Android 11 one ! )
    You must be decrypted before installing it otherwise it won't boot

    Installation :

    Download image file of the rom crdrom-v315+220202-iceows-pra.7z


    Not Working :
    • VoLTE


    ROM OS Version: Android 11
    ROM Kernel: Linux 4.4.x (stock 4.4.26 or Siberia_4.4.300.zip)
    ROM Firmware Required: EMUI 8
    Based On: crDroid

    Credits:

    And all the others who tested my patches and helped me improve this ROM

    https://github.com/eremitein/treble-patches/wiki/crDRom11-Project#changes
    1
    The same version that I used for the DarkJoker Lineage 18.1 ROM, ogapps-nano-20210803 which worked fine(?) with that ROM, apart from some other unrelated issues with audio/microphone.
    1
    So far so good, boot time seems a lot faster than LOS 18.1 from DarkJoker360, but camera isn't synchronized with flash lght(same as in LOS 18.1).
    Thank You.
    RNE-L21 Here.
    1
    What are these other problems? I correct the problems that are pointed out to me in the ROM that I maintain and afterwards I distribute my fixes.
    Here is an XDA link on my version of lineage 18 :

    Awesome I'll look into that.
    The problems I've experienced indeed occur on all of the A11-based ROMs as you mentioned, so perhaps this will fix that.

    But just to bring out my problems with the ROM, there seems to be some kind of a conflict with how apps access the camera/microphone:

    Sometimes (most frequently when using something like Snapchat) the camera stops working completely (it says that the camera could not be connected to) and you have to exit the app and reopen it to make the camera work again. This is the only issue that also happens on the stock camera app in addition to all of the third party apps.
    Also on Snapchat, you're not able to record any videos, only take pictures. When you try to record a video the video preview just freezes and essentially all it will be able to do is just capture a picture of the first frame of the "video" you were trying to take. After that if you try to go back the camera crashes and will only display black image until you close the app and open it again.

    When using the camera on Instagram, Twitter, Facebook, you can record videos, but the audio in the captured video is kind of distorted or bad quality.

    However when using the stock camera app or the stock audio recorder app the audio was fine, on all of the A11 ROMs I've tried.
    So far I've tested Darkjoker Lineage 18.1 ROM and AOSP 11 ROM and also latviandudes Descendant XI and the distorted audio issue has been present on each one of them.

    Since nobody has reported these bugs on any of those ROMs, and since it happens for me on all of the ROMs I suspected that maybe it's just my device that is broken but I reverted back and reinstalled original EMUI OS from the Huawei recovery thing, and when testing it on EMUI everything works fine, audio is good, camera works.
    So idk, it must have something to do with A11 ROMs?

    I havent tested other non-A11 ROMs, so idk if there's any difference there but yeah.

    One of the other problems is that applications aren't able to preview photos when you're trying to select photos to send. On FB Messenger for example, it says "Error loading media" for all of the images. On other apps like Discord/Twitter all images appear black/won't load.
    This probably has to do with this what you posted:
    This is a rights issue that prevents applications from reading and writing to the directory that contains the photos.

    But yes, I really don't have a clue what the other issues are related to but let me know and I can send some more proper examples and explanations or something
    1
    So far so good, boot time seems a lot faster than LOS 18.1 from DarkJoker360, but camera isn't synchronized with flash lght(same as in LOS 18.1).
    Thank You.
    RNE-L21 Here.
    Hi,

    I manage to reproduce the problem on my version of lineage 18.1 and on my PRA-LX1 . I will try to fix it.

    Thanks,