• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][11] LineageOS 18.1 [OFFICIAL]

Search This thread

jontis

Member
Jul 1, 2015
12
2
I got a little further on the vowifi part. I realised there was a preference to set to chose if it would go wifi over mobile. When I set it to wifi, the error message change to "connect to a wireless" Problem is that it was connected to wireless and it worked great for other data, so I guess something else in the connection to carrier through ip data did not work. Looking into IMS and APNs now. Has your data ever worked?
 
  • Like
Reactions: RelaxIamOnlyAghost

Amunhateb

Member
Oct 11, 2017
6
0
Sony Xperia XZ2 Compact
Hello guys. I am facing an issue with charger. When I am unplugging my xz2c from 12V QC3 charger the device may become unresponsive. Black screen with no possibility to turn it on. I can see that some processes are working(can receive some alerts soundwise). But bluetooth and other connectivities are dropped down. I can only force reboot by pressing power + volume down(up) to force reboot it. Same issue was on LOS 17.1.

Not sure that logcat is related but the timing is seems really close to when I faced issue the last time.

--------- beginning of crash
09-30 10:32:04.210 5675 5675 F linker : CANNOT LINK EXECUTABLE "/data/data/com.facebook.katana/app_errorreporting/sess__000000040-1632987122651-014c9adb-a0ef-ada1-b75d-2d8b5ea8a80a/nightwatch.txt": library "libclang_rt.xray.so" not found: needed by main executable
09-30 10:33:09.550 14000 14000 E AndroidRuntime: FATAL EXCEPTION: main
09-30 10:33:09.550 14000 14000 E AndroidRuntime: Process: ru.filit.mvideo.b2c, PID: 14000
09-30 10:33:09.550 14000 14000 E AndroidRuntime: java.lang.RuntimeException: Unable to create application ru.filit.mvideo.b2c.app.MvideoApp: com.google.crypto.tink.shaded.protobuf.InvalidProtocolBufferException: Protocol message contained an invalid tag (zero).
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at android.app.ActivityThread.handleBindApplication(ActivityThread.java:6724)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at android.app.ActivityThread.access$1300(ActivityThread.java:237)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1913)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at android.os.Handler.dispatchMessage(Handler.java:106)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at android.os.Looper.loop(Looper.java:223)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at android.app.ActivityThread.main(ActivityThread.java:7664)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at java.lang.reflect.Method.invoke(Native Method)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:592)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:947)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: Caused by: com.google.crypto.tink.shaded.protobuf.InvalidProtocolBufferException: Protocol message contained an invalid tag (zero).
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at com.google.crypto.tink.shaded.protobuf.y.I(GeneratedMessageLite.java:10)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at com.google.crypto.tink.shaded.protobuf.y.F(GeneratedMessageLite.java:2)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at y.g.b.a.y.c0.V(Keyset.java:1)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at y.g.b.a.v.a.d.b(SharedPrefKeysetReader.java:1)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at y.g.b.a.b.a(CleartextKeysetHandle.java:1)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at y.g.b.a.v.a.a$b.e(AndroidKeysetManager.java:4)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at y.g.b.a.v.a.a$b.f(AndroidKeysetManager.java:1)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at y.g.b.a.v.a.a$b.d(AndroidKeysetManager.java:3)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at w.r.a.a.a(EncryptedSharedPreferences.java:7)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at y.k.a.d.d.a.i(BasePreferences.kt:2)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at y.k.a.d.d.a.<init>(BasePreferences.kt:2)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at y.k.a.d.d.b.a.<init>(Preferences.kt:1)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at y.k.a.f.b.g.f(EyezonBusinessSDK.kt:5)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at y.k.a.f.b.g.b(EyezonBusinessSDK.kt:1)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at y.k.a.f.b.g$a.b(EyezonBusinessSDK.kt:2)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at ru.filit.mvideo.b2c.app.MvideoApp.l(MvideoApp.kt:2)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at ru.filit.mvideo.b2c.app.MvideoApp.onCreate(MvideoApp.kt:17)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at android.app.Instrumentation.callApplicationOnCreate(Instrumentation.java:1192)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: at android.app.ActivityThread.handleBindApplication(ActivityThread.java:6719)
09-30 10:33:09.550 14000 14000 E AndroidRuntime: ... 8 more
09-30 10:33:18.742 15842 15842 F linker : CANNOT LINK EXECUTABLE "/data/data/com.facebook.katana/app_errorreporting/sess__000000041-1632987197243-12c81d4e-b794-9729-7ffb-829206a1d892/nightwatch.txt": library "libclang_rt.xray.so" not found: needed by main executable
09-30 10:54:38.560 20500 20500 F linker : CANNOT LINK EXECUTABLE "/data/data/com.facebook.katana/app_errorreporting/sess__000000042-1632988475235-4c1563fe-a4eb-8973-4f3f-e8ee99df26f8/nightwatch.txt": library "libclang_rt.xray.so" not found: needed by main executable
09-30 11:40:37.226 23814 23814 F linker : CANNOT LINK EXECUTABLE "/data/data/com.facebook.katana/app_errorreporting/sess__000000043-1632991236678-f8b49be0-9082-f7a8-0567-08df1b8f9fcc/nightwatch.txt": library "libclang_rt.xray.so" not found: needed by main executable
09-30 11:44:10.349 32406 32406 F linker : CANNOT LINK EXECUTABLE "/data/data/com.facebook.katana/app_errorreporting/sess__000000044-1632991449682-a5f7ed4a-867f-cc66-3f81-cab1fe9109b1/nightwatch.txt": library "libclang_rt.xray.so" not found: needed by main executable
09-30 11:50:22.344 4190 4190 F linker : CANNOT LINK EXECUTABLE "/data/data/com.facebook.katana/app_errorreporting/sess__000000045-1632991821131-cd370fc5-f5d6-1c7f-53c8-3612f02d980e/nightwatch.txt": library "libclang_rt.xray.so" not found: needed by main executable
09-30 11:56:41.170 7392 7392 F linker : CANNOT LINK EXECUTABLE "/data/data/com.facebook.katana/app_errorreporting/sess__000000046-1632992199951-8f9f49e2-263e-2d29-b525-2a4ab2812838/nightwatch.txt": library "libclang_rt.xray.so" not found: needed by main executable
09-30 11:59:39.536 10527 10527 F linker : CANNOT LINK EXECUTABLE "/data/data/com.facebook.katana/app_errorreporting/sess__000000047-1632992378101-fa2e3059-5636-ed36-8993-ae0ea3114eaa/nightwatch.txt": library "libclang_rt.xray.so" not found: needed by main executable
09-30 12:07:35.301 15546 15546 F linker : CANNOT LINK EXECUTABLE "/data/data/com.facebook.katana/app_errorreporting/sess__000000048-1632992854406-3ffa215b-4f26-e674-2d83-da97097095f0/nightwatch.txt": library "libclang_rt.xray.so" not found: needed by main executable
09-30 12:36:14.933 24785 24785 F linker : CANNOT LINK EXECUTABLE "/data/data/com.facebook.katana/app_errorreporting/sess__000000049-1632994572446-1dbe4eef-de1f-58f7-2227-3c04828b3454/nightwatch.txt": library "libclang_rt.xray.so" not found: needed by main executable
09-30 12:53:16.222 27797 27797 F linker : CANNOT LINK EXECUTABLE "/data/data/com.facebook.katana/app_errorreporting/sess__000000050-1632995595205-84e20e0b-a3fa-cf3b-6614-29df39ebdb37/nightwatch.txt": library "libclang_rt.xray.so" not found: needed by main executable
--------- beginning of system
 
Last edited:
has anyone else been having touch issues recently? I've been getting lots of ghost touches since the last week or so, or the screen becoming completely unresponsive at times, and I'm not sure if it's a software or a hardware issue.

edit: I found a video that shows something very similar to what I'm experiencing:

since they're running stock software, I assume it's hardware then :/
 
has anyone else been having touch issues recently? I've been getting lots of ghost touches since the last week or so, or the screen becoming completely unresponsive at times, and I'm not sure if it's a software or a hardware issue.

edit: I found a video that shows something very similar to what I'm experiencing:

since they're running stock software, I assume it's hardware then :/
It's not that uncommon for xz2c users to have touch issues. I'm afraid it's on hardware side.
 

zpunout

Senior Member
Aug 26, 2015
139
23
Samsung Galaxy S5
Moto G5 Plus
I've had ghost touches on my XZ2c H8324. To see better what was happening, I activated the "show touches" setting in Developer Options. I noticed that by cleaning around the edges, especially where the groove is makes it better for a while.
 

zpunout

Senior Member
Aug 26, 2015
139
23
Samsung Galaxy S5
Moto G5 Plus
Q̶u̶e̶s̶t̶i̶o̶n̶ ̶r̶e̶g̶a̶r̶d̶i̶n̶g̶ ̶L̶O̶S̶1̶8̶.̶1̶ ̶a̶b̶i̶l̶i̶t̶y̶ ̶t̶o̶ ̶d̶r̶a̶w̶ ̶g̶r̶a̶p̶h̶i̶c̶s̶ ̶c̶o̶m̶p̶a̶r̶e̶d̶ ̶t̶o̶ ̶S̶o̶n̶y̶ ̶X̶Z̶2̶ ̶C̶o̶m̶p̶a̶c̶t̶ ̶s̶t̶o̶c̶k̶ ̶O̶S̶:̶ ̶ ̶T̶h̶e̶r̶e̶'̶s̶ ̶a̶ ̶m̶a̶r̶i̶n̶e̶ ̶c̶h̶a̶r̶t̶s̶ ̶a̶p̶p̶ ̶i̶n̶ ̶P̶l̶a̶y̶S̶t̶o̶r̶e̶/̶A̶u̶r̶o̶r̶a̶ ̶c̶a̶l̶l̶e̶d̶ ̶N̶a̶v̶i̶o̶n̶i̶c̶s̶ ̶w̶h̶i̶c̶h̶ ̶I̶ ̶t̶h̶i̶n̶k̶ ̶w̶o̶r̶k̶s̶ ̶b̶y̶ ̶d̶r̶a̶w̶i̶n̶g̶ ̶g̶r̶a̶p̶h̶i̶c̶s̶ ̶b̶a̶s̶e̶d̶ ̶o̶n̶ ̶2̶D̶ ̶v̶e̶c̶t̶o̶r̶ ̶d̶r̶a̶w̶i̶n̶g̶.̶ ̶I̶ ̶n̶o̶t̶i̶c̶e̶d̶ ̶a̶ ̶v̶e̶r̶y̶ ̶d̶e̶g̶r̶a̶d̶e̶d̶ ̶p̶e̶r̶f̶o̶r̶m̶a̶n̶c̶e̶ ̶i̶n̶ ̶d̶r̶a̶w̶i̶n̶g̶ ̶t̶h̶e̶ ̶c̶h̶a̶r̶t̶s̶ ̶w̶h̶e̶n̶ ̶z̶o̶o̶m̶i̶n̶g̶/̶s̶c̶r̶o̶l̶l̶i̶n̶g̶ ̶a̶r̶o̶u̶n̶d̶ ̶o̶n̶ ̶L̶O̶S̶ ̶(̶1̶8̶.̶1̶)̶ ̶c̶o̶m̶p̶a̶r̶e̶d̶ ̶t̶o̶ ̶t̶h̶e̶ ̶s̶t̶o̶c̶k̶ ̶O̶S̶ ̶(̶b̶o̶o̶t̶l̶o̶a̶d̶e̶r̶ ̶u̶n̶l̶o̶c̶k̶e̶d̶)̶.̶ ̶I̶ ̶o̶r̶i̶g̶i̶n̶a̶l̶l̶y̶ ̶t̶h̶o̶u̶g̶h̶t̶ ̶t̶h̶i̶s̶ ̶c̶o̶u̶l̶d̶ ̶b̶e̶ ̶a̶ ̶S̶o̶n̶y̶ ̶D̶R̶M̶ ̶i̶s̶s̶u̶e̶,̶ ̶b̶u̶t̶ ̶t̶h̶e̶ ̶p̶e̶r̶f̶o̶r̶m̶a̶n̶c̶e̶ ̶i̶s̶ ̶r̶e̶s̶t̶o̶r̶e̶d̶ ̶w̶h̶e̶n̶ ̶u̶s̶i̶n̶g̶ ̶s̶t̶o̶c̶k̶ ̶O̶S̶ ̶(̶b̶o̶o̶t̶l̶o̶a̶d̶e̶r̶ ̶u̶n̶l̶o̶c̶k̶e̶d̶ ̶a̶n̶d̶ ̶D̶R̶M̶ ̶k̶e̶y̶s̶ ̶l̶o̶s̶t̶)̶.̶ ̶T̶h̶i̶s̶ ̶l̶e̶a̶d̶s̶ ̶m̶e̶ ̶t̶o̶ ̶b̶e̶l̶i̶e̶v̶e̶ ̶t̶h̶e̶r̶e̶ ̶i̶s̶ ̶a̶ ̶d̶i̶f̶f̶e̶r̶e̶n̶t̶ ̶r̶e̶a̶s̶o̶n̶ ̶f̶o̶r̶ ̶t̶h̶e̶ ̶d̶e̶g̶r̶a̶d̶e̶d̶ ̶p̶e̶r̶f̶o̶r̶m̶a̶n̶c̶e̶,̶ ̶p̶o̶s̶s̶i̶b̶l̶y̶ ̶w̶i̶t̶h̶i̶n̶ ̶t̶h̶e̶ ̶N̶a̶v̶i̶o̶n̶i̶c̶s̶ ̶a̶p̶p̶ ̶o̶r̶ ̶a̶n̶ ̶i̶s̶s̶u̶e̶ ̶r̶e̶l̶a̶t̶e̶d̶ ̶t̶o̶ ̶L̶O̶S̶ ̶(̶1̶8̶.̶1̶)̶.̶ ̶ ̶
I̶ ̶h̶a̶v̶e̶n̶'̶t̶ ̶t̶e̶s̶t̶e̶d̶ ̶t̶h̶e̶ ̶a̶p̶p̶ ̶i̶n̶ ̶L̶O̶S̶ ̶1̶7̶.̶1̶ ̶y̶e̶t̶,̶ ̶b̶u̶t̶ ̶I̶'̶l̶l̶ ̶r̶e̶p̶o̶r̶t̶ ̶b̶a̶c̶k̶ ̶h̶e̶r̶e̶ ̶a̶f̶t̶e̶r̶ ̶I̶ ̶d̶o̶.̶ ̶[̶e̶d̶i̶t̶:̶ ̶P̶e̶r̶f̶o̶r̶m̶a̶n̶c̶e̶ ̶i̶s̶s̶u̶e̶ ̶d̶o̶e̶s̶n̶'̶t̶ ̶e̶x̶i̶s̶t̶ ̶f̶o̶r̶ ̶L̶O̶S̶1̶7̶.̶1̶]̶ ̶ ̶J̶u̶s̶t̶ ̶w̶o̶n̶d̶e̶r̶i̶n̶g̶ ̶i̶f̶ ̶a̶n̶y̶o̶n̶e̶ ̶h̶e̶r̶e̶ ̶m̶i̶g̶h̶t̶ ̶k̶n̶o̶w̶ ̶w̶h̶a̶t̶ ̶t̶h̶e̶ ̶t̶e̶c̶h̶n̶i̶c̶a̶l̶ ̶r̶e̶a̶s̶o̶n̶ ̶i̶s̶ ̶f̶o̶r̶ ̶t̶h̶e̶ ̶d̶e̶g̶r̶a̶d̶e̶d̶ ̶p̶e̶r̶f̶o̶r̶m̶a̶n̶c̶e̶.̶
[edit2: Issue found to not be related to LOS but instead app compatibility with Android 11 in general]
 
Last edited:

hxss

Member
Feb 24, 2017
5
0
Is there a way to return stock media volume?
Sound is coming from bottom speaker only.
Vibrations from the speaker are felt during playback.
 

shezy14

Member
Aug 28, 2014
33
2
Redmi Note 10
Pls how can I return to stock firmware from lineage 18.1 I have downloaded firmware from xperifirm but flashing failed with newflasher and flashtool
 

Attachments

  • Screenshot 2021-10-15 080051.png
    Screenshot 2021-10-15 080051.png
    44.5 KB · Views: 27
  • flashtool_2021-10-15_08-16-12.log
    1.8 KB · Views: 6
Last edited:
Which frequency bands are being used by China Unicorn? Maybe the answer can be found by looking at that?
Yesterday I asked China Unicom to replace my SIM card since I suspect it might be faulty, and enabled a service called "visited place access" (translated from Chinese via DeepL), without that my IP is where this card belongs to but apparently I'm far away from that city, and now I can get the IP from the city I'm at right now. And after replacing the card, my LTE connection seems fine now. @jontis maybe you should also try a SIM card replacement.
 
  • Like
Reactions: zpunout

TheeWolf

Senior Member
Oct 8, 2011
894
192
Hi,

I updated the ROM using the updater in the system settings. I then lost my Magisk root.
I was wondering if in order to get root again, I would need to again extract the boot image from the zip, patch it and install it in Magisk, or if I can use the previous boot image (from two weeks ago).

Also, I'm pretty sure it's Android 11 related but I'll ask here anyway - how do I disable that feature that auto plays what I last played when I re-connect my Bluetooth headphones?

Thanks!
 

lba810701

Senior Member
Jul 8, 2010
126
42
Budapest
OnePlus 2
LG G5
Hi,

I updated the ROM using the updater in the system settings. I then lost my Magisk root.
I was wondering if in order to get root again, I would need to again extract the boot image from the zip, patch it and install it in Magisk, or if I can use the previous boot image (from two weeks ago).

Also, I'm pretty sure it's Android 11 related but I'll ask here anyway - how do I disable that feature that auto plays what I last played when I re-connect my Bluetooth headphones?

Thanks!
Hi! Extract the payload file from the los zip, then you could extract the boot.img, system.img, vbmeta...etc from it with payload dumper. After it copy that boot.img file to your phone and patch it with magisk then copy back the patched boot img to your pc then after you updated the system with updater turn phone off ( dont restart the phone ), boot to fastboot mode and flash the newest patched boot.img.

About the bluetooth i don't known what player are you using, because, I'm using poweramp and there you could set it up on the player's headphone/bluethoot settings.
 
Hi
I've been using this ROM in my XZ2c for a while now and only recently experienced a battery charging issue: the charge level will go up to 98% and then the phone gets warm and starts to slowly discharge. If I disconnect and reconnect the cable the battery will eventually get to 100%; Also, if I charge the phone while it's off it charges normally. This didn't happen in builds older than ~2 weeks ago.

Could this be related to LOS? Is there such an issue already identified?

Thank you
 

zpunout

Senior Member
Aug 26, 2015
139
23
Samsung Galaxy S5
Moto G5 Plus
Hi
I've been using this ROM in my XZ2c for a while now and only recently experienced a battery charging issue: the charge level will go up to 98% and then the phone gets warm and starts to slowly discharge. If I disconnect and reconnect the cable the battery will eventually get to 100%; Also, if I charge the phone while it's off it charges normally. This didn't happen in builds older than ~2 weeks ago.

Could this be related to LOS? Is there such an issue already identified?

Thank you
I don't know if this will fix your issue, but I had a charge level issue of the phone switching off after only 8 hours which I think was due to battery calibration. What I did to fix it was to let the phone run out of battery then keep trying to switch it on as the screen flashed an empty battery symbol. I put a rubber band around the phone to keep the power button in and the screen keeps flashing the empty battery symbol. Eventually, after an hour the screen flashing stopped so I plugged in a charger. After about 1 minute I could switch on the phone and let it charge to 100% while the system is running. Since then, the battery charge level appears to be more accurate.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 10
    The first official 18.1 build is up, enjoy: https://download.lineageos.org/xz2c
    10
    A new build is up, please check the OP. Feel free to test and report bugs - we'd like to enable official 18.1 weekly builds soon.
    9
    Hi everyone,
    as some of you may already know, I've decided to step down as device maintainer for the Xperia XZ2 Compact.
    Thankfully, @dtrunk90 has volunteered to take over - he's a skilled dev who has already made valuable contributions in the past few months, and I'm sure he'll continue to do so.

    That being said, I really enjoyed on this device. I want to thank @Sjll who made all of this possible and everyone contributing to the Xperia Open Devices Program -- even though we don't always share the same views (which is what made Sjll and me start this project in the first place), I have nothing but respect for their hard work.
    8
    http%3A%2F%2Fi.imgur.com%2F2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    Code:
    /*
    * Your warranty is now void.
    *
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.
    */

    NOTE
    Should you ever face any issues, capture logs. I also need to know what build you're on (build number or at least a date).
    Hint: "It doesn't work" is not a bug report and posts like this will be ignored.


    KNOWN ISSUEs
    • The Sony stock camera does not work at the moment.

    INFO
    This ROM does not use the device trees/kernel from sonyxperiadev (aka SODP). The device tree was made from scratch, and the stock kernel (based off 52.1.A.x.y) has been used.

    DOWNLOAD
    Official builds

    NOTE: Since the official builds are signed, you can't simply upgrade from my unofficial builds -- you can either migrate to an official build using a script or do a clean install.

    All unofficial builds

    INSTRUCTIONS
    Just flash the builds as usual. Make sure to be on the latest stock firmware.

    SOURCE
    LineageOS
    Kernel
    5
    CHANGELOG
    20210516:
    - fixed WiFi display/screen casting
    - addressed performance issues and lags

    20210515:
    - updated to 18.1
    - fixed remaining most of the bugs
    - set SELinux to enforcing

    20201128:
    - fixed NFC

    20201127:
    - initial public release.