• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM] [11] LineageOS 18.1 [OFFICIAL]

Search This thread

mak6021

Senior Member
Nov 26, 2016
68
21
39
Polotsk
Fails validation safetyNet, magisk 23.0 xz2 H8266
In-app antutu performance test, does not pass the you Vulcan test.
 

dtrunk90

Senior Member
Oct 29, 2021
88
9
31
Sony Xperia XZ2 Compact
Xperia XZ2
Fails validation safetyNet, magisk 23.0 xz2 H8266
In-app antutu performance test, does not pass the you Vulcan test.
You've unlocked the bootloader and installed custom firmware. What do you expect? To pass SafetyNet? Use MagiskHide Props Config or similar to change the fingerprint of your device to pass ctsProfile.

Vulkan driver was imported from latest stock firmware. Tried chewman with and without that driver and that game is working now so vulkan is available. I don't know why AnTuTu doesn't support these tests. Was it possible on stock firmware?
 

dtrunk90

Senior Member
Oct 29, 2021
88
9
31
Sony Xperia XZ2 Compact
Xperia XZ2
Hi, how to enable init.d without root,, i want to do swapon upon boot but i cant use magisk because many game and banking app i use can detect root,,
Create your own flashable zip or use MagiskHide + MagiskHide Props Config

Btw. this is not a question which should be asked here, because it has nothing to do with this rom.
Please create a new thread if you need any help on that.
 
Last edited:

GreeDWaR

Senior Member
@dtrunk, просто чтобы вы знали, на моем устройстве высветилась линия передачи, и оно загрузилось. Но прошились Gapps i, а Magisk не был установлен. У меня тоже больше нет TWRP recovery. Только восстановление LineageOS
NFC is working? My xz2 premium -not working normaly. On stock rom -nfc work-perfectly.
bank cards are not readable and the NFC is turned off and is not active until the restart.(Linage OS)
 

StephRiff

Member
Dec 26, 2019
11
1
Google Nexus 4
ZTE Axon 7
NFC is working? My xz2 premium -not working normaly. On stock rom -nfc work-perfectly.
bank cards are not readable and the NFC is turned off and is not active until the restart.(Linage OS)
Hi I have a same problem and my fingerprint not working after install LineageOs 18.1
I install with this process: https://wiki.lineageos.org/devices/akari/install

Update :
Fingerprint works after deactivating development options
Nfc still not working on my XZ2
 
Last edited:

Trace.Oneil

Senior Member
So after using my XZ2 with LineageOS 18.1 installed. I have found the following. Overall,the rom is smooth and modern looking with lots of new features. But there are also issues.

I cant install Netflix on my device,no matter what i try.

Fonts dont seem to want to change system-wide. I tried a few

Battery drains badly

The screen brightness is down a lot from stock

The overall volumes are also down a lot from stock and installing Viper had no effect in my case of fixing the low sound.

Nearby Share works,but only when you want to share from the XZ2 to another device and not the other way around. You get no notification to say a device wants to share and the other device wont detect the XZ2 if bluetooth is switched off initially. Only after you switch on bluetooth,the other device will see the XZ2 so some work is needed there still.

If these problems can be fixed,i think Lineage will be a really nice Android 11 rom to use as a daily.
 

Katzenstreu

Senior Member
May 28, 2009
63
9
near Hamburg
Hello,

I'm using 18.1 (Android 11) from 3rd November 2021 on my Sony XZ2 (H8216).
How to switch between capacitive display mode and pressure sensitive display mode (while it's raining)?

Best regards
Tim
 

rizgiy

Member
Jan 4, 2021
8
0

Attachments

  • Screenshot_20211208-084006_Google_Play_Store.png
    Screenshot_20211208-084006_Google_Play_Store.png
    133.3 KB · Views: 19
  • Screenshot_20211208-084025_Settings.png
    Screenshot_20211208-084025_Settings.png
    168.1 KB · Views: 18
  • Screenshot_20211208-084045_YASNAC.png
    Screenshot_20211208-084045_YASNAC.png
    124.2 KB · Views: 17
  • Screenshot_20211208-084109_Settings.png
    Screenshot_20211208-084109_Settings.png
    133.4 KB · Views: 17
  • Screenshot_20211208-084137_Settings.png
    Screenshot_20211208-084137_Settings.png
    122.6 KB · Views: 18

dtrunk90

Senior Member
Oct 29, 2021
88
9
31
Sony Xperia XZ2 Compact
Xperia XZ2
hi
not work gpay. sony xz2 8266
device is not sertified
cts profile match - fail
certification site does not help - https://www.google.com/android/uncertified/
what to do?
 

rizgiy

Member
Jan 4, 2021
8
0
my fingerprint tab is gone. on the official one initially, installed different ones via newflasher.
 

Attachments

  • 1.png
    1.png
    47 KB · Views: 15
  • 2.png
    2.png
    111.4 KB · Views: 15

rizgiy

Member
Jan 4, 2021
8
0
You have to pass SafetyNet and Play Services as well as Google Pay itself has to be enabled in MagiskHide. Hint: Use MagiskHide Props Config to pass SafetyNet. After installing the module you simply need to run `props` as root on your device and follow the steps to set the fingerprint for your device.


At the end of the sentence, it says about the fingerprint. But it disappeared in my firmware
 

dtrunk90

Senior Member
Oct 29, 2021
88
9
31
Sony Xperia XZ2 Compact
Xperia XZ2
don't know how to get the fingerprint manager back
You can set the fingerprint in security -> fingerprint, not in security -> screen lock (it's directly beneath that option) because beside of a fingerprint lock you may want to add a fallback screen lock if the hardware can't find a matching fingerprint.

But as I already said: I'm not talking about that fingerprint. I'm talking about the device fingerprint saved as a hash-a-like value in the system and you have to change it using the `props` command from the MagiskHide Props Config module in order to pass SafetyNet/ctsProfile.
 

Attachments

  • Screenshot_20211208-141228_Trebuchet.png
    Screenshot_20211208-141228_Trebuchet.png
    208.6 KB · Views: 15
  • Screenshot_20211208-141240_Trebuchet.png
    Screenshot_20211208-141240_Trebuchet.png
    139.2 KB · Views: 15

AdrY89

New member
Dec 13, 2021
2
0
Hello guys I am using the last version of lineage and i found some problems with the microphone and the speaker

The speaker to max volume it is no very loud and not clear

The microphone it is very low volume on to recorder the messages and in the call.

Can help me? It is a problem of fw. Or my?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Maybe. No matter. I test now magisk v24 but safetynet broken and new magisk do not have hide components.
    with v24 you can use https://github.com/kdrag0n/safetynet-fix and add stuff you want to hide root for (e.g. some google services) to zygisk denylist - but v23 is pretty stable on 18.1 - you have to root it only once. after every OTA update magiskinit will do the rest automatically for you.
  • 18
    Good news, we will go 18.1 official in next week.
    15
    2okPze5.png

    Code:
    #include <std_disclaimer.h>
    /*
    * Your warranty is now void.
    *
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.
    */
    About LineageOS
    LineageOS is a free, community built, aftermarket firmware distribution of Android 11.x (R),
    which is designed to increase performance and reliability over stock Android for your device.

    All the source code for LineageOS is available in the LineageOS GitHub repo.
    And if you would like to contribute to LineageOS, please visit our Gerrit Code Review.

    Official LineageOS website : http://lineageos.org
    About LineageOS Legal : http://lineageos.org/legal/

    Important Information
    1. This ROM has nothing related to ODM images! So you don't need to ask/install anything like that, just follow the instructions.
    2. This ROM will never work with any versions of Google Camera (GCam)!
    3. You need to flash Stock Android 10 before flashing this ROM.
    4. For VoLTE, you need to boot into stock firmware and enable it before flashing this ROM!


    Downloads Links
    LineageOS website

    Google Applications (optional):
    MindTheGapps
    Information: Flash the GApps before the first boot. If not, a clean flash is recommended.

    Flashing and updating
    How to flash

    Make sure you are upgrade to Official Android 10.0 from Sony
    Unlock bootloader is necessary.
    To disable AVB 2.0 using fastboot:
    Code:
    fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img
    For vbmeta.img, you can download it anywhere you found.
    More steps see wiki

    Never flash oem from SODP!!
    If you flashed oem and meet any issues, I could only say you are a hanhan.

    Root access:
    Flash Magisk in recovery.

    Twrp:
    You could download it here: Link
    Code:
    fastboot boot twrp.img

    Issues and reports

    Report issues only if you are using the ROM kernel
    If an additional mod is installed, make sure it's unrelated, and mention it
    Make sure the issue wasn't discussed earlier in the threads
    Share a log of the error with CatLog for example

    Also thanks to:
    Olivier
    Luk1337
    The LineageOS Team
    The CyanogenMod Team
    The SODP Team
    Everyone involved in working and testing

    XDA:DevDB Information
    Lineage 18.1 for Xperia XZ2, ROM for the Xperia XZ2

    Contributors
    Sjll, Olivier
    Source Code: https://github.com/sony-sdm845

    Donation
    https://paypal.me/sjllls

    ROM OS Version: Android 11
    ROM Kernel: Linux 4.9
    ROM Firmware Required: Official Android 10.0 firmware
    Based On: LineageOS

    Version Information
    Status:
    Stable

    Created 2020-11-27
    Last Updated 2021-05-26
    6
    Glad to tell everyone who are waiting for LineageOS 18.1.
    I uploaded the 20210515 build for Akari, but I don't have device to test.
    From the result on XZ3, everything works fine.
    Please test and feedback, if there is no bug, we will get official 18.1 support sson.
    6
    So latest build is 18.0 from November?
    Seems a big pause in development.
    I will try building with the 18.1 sources on Lineage GitHub and see what happens.....

    Edit: Fixed the build errors but it wont boot and devs seem to have moved on.
    Back to 17.1 nightlies
    6
    I don't have battery drain issue to begin with so can't tell the difference sadly, but yeah flashed and everything still works fine as before!
    Uploaded a new lineage-18.1-20210515-unofficial-akari.zip again.
    This removed 2 crashing prebuilt system Apps, enjoy.