[ROM] [11] LineageOS 18.1 [OFFICIAL]

Search This thread

BeastOfTaste

Member
Jan 21, 2022
6
0
Hi, many thanks for your great work!
- I own a Sony Xperia XZ2, model number H8216. After installing lineage-18.1-20220119-nightly-akari-signed.zip and Gapps (MindTheGapps-11.0.0-arm64-20210920_084011.zip) I disabled USB debugging in developer options, disconnected the phone and rebooted.
And there it is: USB debugging is enabled again. When I connect the phone to my computer a message appears, telling me that USB debugging is enabled and in developer options the respective switch is activated.
- No Magisk or anything similar else installed.
Is there any solution, maybe in the next release?

Please see also: https://www.reddit.com/r/LineageOS/comments/s8ff6w Greetings
 

dtrunk90

Senior Member
Oct 29, 2021
289
131
32
Sony Xperia XZ2 Compact
Xperia XZ2
Hi, many thanks for your great work!
- I own a Sony Xperia XZ2, model number H8216. After installing lineage-18.1-20220119-nightly-akari-signed.zip and Gapps (MindTheGapps-11.0.0-arm64-20210920_084011.zip) I disabled USB debugging in developer options, disconnected the phone and rebooted.
And there it is: USB debugging is enabled again. When I connect the phone to my computer a message appears, telling me that USB debugging is enabled and in developer options the respective switch is activated.
- No Magisk or anything similar else installed.
Is there any solution, maybe in the next release?

Please see also: https://www.reddit.com/r/LineageOS/comments/s8ff6w Greetings
Yes, there's a bug report see https://gitlab.com/LineageOS/issues/android/-/issues/308
Afaik this can be fixed by us in a qcom usb script. I'll have a look over the weekend.

EDIT: Weird, I just checked our common device tree and this fix was already present. You did a clean install with wiping data/doing a factory reset before? If not, please run:
Code:
adb shell setprop persist.vendor.usb.config ""

You could also check that persistent property before re-setting it with:

Code:
adb shell getprop persist.vendor.usb.config
 
Last edited:

BeastOfTaste

Member
Jan 21, 2022
6
0
Yes, there's a bug report see https://gitlab.com/LineageOS/issues/android/-/issues/308
Afaik this can be fixed by us in a qcom usb script. I'll have a look over the weekend.

EDIT: Weird, I just checked our common device tree and this fix was already present. You did a clean install with wiping data/doing a factory reset before? If not, please run:
Code:
adb shell setprop persist.vendor.usb.config ""

You could also check that persistent property before re-setting it with:

Code:
adb shell getprop persist.vendor.usb.config
Hello
Sorry to bother you once again.
I did a clean new install after formatting/wiping all data in the recovery.
This time I installed lineage-18.1-20220119-nightly-akari-signed.zip
without Gapps or anything else.
After booting first time USB debugging was activated and consequently after deactivating it via developer options and reboot. So unfortunately there was no improvement.
Using the commands you suggested resulted in mainly empty lines:

>> BT-iMac:~ b_o_t$ adb shell getprop persist.vendor.usb.config

BT-iMac:~ b_o_t$ adb shell setprop persist.vendor.usb.config ""
usage: setprop NAME VALUE

Sets an Android system property.
BT-iMac:~ b_o_t$ <<
 

dtrunk90

Senior Member
Oct 29, 2021
289
131
32
Sony Xperia XZ2 Compact
Xperia XZ2
Hello
Sorry to bother you once again.
I did a clean new install after formatting/wiping all data in the recovery.
This time I installed lineage-18.1-20220119-nightly-akari-signed.zip
without Gapps or anything else.
After booting first time USB debugging was activated and consequently after deactivating it via developer options and reboot. So unfortunately there was no improvement.
Using the commands you suggested resulted in mainly empty lines:

>> BT-iMac:~ b_o_t$ adb shell getprop persist.vendor.usb.config

BT-iMac:~ b_o_t$ adb shell setprop persist.vendor.usb.config ""
usage: setprop NAME VALUE

Sets an Android system property.
BT-iMac:~ b_o_t$ <<
It was worth a try. I'll have a look on the weekend.
 

dtrunk90

Senior Member
Oct 29, 2021
289
131
32
Sony Xperia XZ2 Compact
Xperia XZ2
Hello
Sorry to bother you once again.
I did a clean new install after formatting/wiping all data in the recovery.
This time I installed lineage-18.1-20220119-nightly-akari-signed.zip
without Gapps or anything else.
After booting first time USB debugging was activated and consequently after deactivating it via developer options and reboot. So unfortunately there was no improvement.
Using the commands you suggested resulted in mainly empty lines:

>> BT-iMac:~ b_o_t$ adb shell getprop persist.vendor.usb.config

BT-iMac:~ b_o_t$ adb shell setprop persist.vendor.usb.config ""
usage: setprop NAME VALUE

Sets an Android system property.
BT-iMac:~ b_o_t$ <<
Will be fixed with the next build. Thank you for reporting.
 
Last edited:

BeastOfTaste

Member
Jan 21, 2022
6
0
Hello
Sorry to bother you once again.
I did a clean new install after formatting/wiping all data in the recovery.
This time I installed lineage-18.1-20220119-nightly-akari-signed.zip
without Gapps or anything else.
After booting first time USB debugging was activated and consequently after deactivating it via developer options and reboot. So unfortunately there was no improvement.
Using the commands you suggested resulted in mainly empty lines:

>> BT-iMac:~ b_o_t$ adb shell getprop persist.vendor.usb.config

BT-iMac:~ b_o_t$ adb shell setprop persist.vendor.usb.config ""
usage: setprop NAME VALUE

Sets an Android system property.
BT-iMac:~ b_o_t$ <<


https://review.lineageos.org/c/LineageOS/android_device_sony_tama-common/+/322473
Once this is merged it should be fixed.

Sounds great, thank you very much! So I'm hoping for the best and looking forward to the next build.
All the best
 

dtrunk90

Senior Member
Oct 29, 2021
289
131
32
Sony Xperia XZ2 Compact
Xperia XZ2
Maybe. No matter. I test now magisk v24 but safetynet broken and new magisk do not have hide components.
with v24 you can use https://github.com/kdrag0n/safetynet-fix and add stuff you want to hide root for (e.g. some google services) to zygisk denylist - but v23 is pretty stable on 18.1 - you have to root it only once. after every OTA update magiskinit will do the rest automatically for you.
 
  • Like
Reactions: scaniathe

scaniathe

Senior Member
Jun 12, 2014
428
89
Wadowice
Thanks dtrunk90. Yes, safetynet pass everythimg works. USNF and Props module. I reinstall Magisk last time. Regards
 
Last edited:

Rachsutha

Member
Apr 10, 2015
40
8
problem LiveDisplay.....!
Each time the device restarts, the settings will automatically change. is the value in the picture did not change the way you wanted.
Screenshot_20220127-010357_LineageOS_Settings.png
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    This thread is unwatched by me now since there are no more official 18.1 builds. Pls move over to the 19.1 thread. Thanks.
    1
    i tried twrp and los recovery while following exactly the steps of the official guide (including all the restarts) but just cant get gapps to work. They do install without error but after rebooting they are just not there. I couldn't find any answer online and tried several gapps. Could someone give me a hint?
    Did you rebooted after flashing LOS like it's described in the official install guide? It's an A/B device. I guess it got flashed onto the wrong slot.

    > Optionally): If you want to install any add-ons, click Advanced, then Reboot to Recovery, then when your device reboots, click Apply Update, then Apply from ADB, then adb sideload filename.zip those packages in sequence.

    https://wiki.lineageos.org/devices/akari/install#installing-lineageos-from-recovery Point 6
  • 18
    Good news, we will go 18.1 official in next week.
    16
    2okPze5.png

    Code:
    #include <std_disclaimer.h>
    /*
    * Your warranty is now void.
    *
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.
    */
    About LineageOS
    LineageOS is a free, community built, aftermarket firmware distribution of Android 11.x (R),
    which is designed to increase performance and reliability over stock Android for your device.

    All the source code for LineageOS is available in the LineageOS GitHub repo.
    And if you would like to contribute to LineageOS, please visit our Gerrit Code Review.

    Official LineageOS website : http://lineageos.org
    About LineageOS Legal : http://lineageos.org/legal/

    Important Information
    1. This ROM has nothing related to ODM images! So you don't need to ask/install anything like that, just follow the instructions.
    2. This ROM will never work with any versions of Google Camera (GCam)!
    3. You need to flash Stock Android 10 before flashing this ROM.
    4. For VoLTE, you need to boot into stock firmware and enable it before flashing this ROM!


    Downloads Links
    LineageOS website

    Google Applications (optional):
    MindTheGapps
    Information: Flash the GApps before the first boot. If not, a clean flash is recommended.

    Flashing and updating
    How to flash

    Make sure you are upgrade to Official Android 10.0 from Sony
    Unlock bootloader is necessary.
    To disable AVB 2.0 using fastboot:
    Code:
    fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img
    For vbmeta.img, you can download it anywhere you found.
    More steps see wiki

    Never flash oem from SODP!!
    If you flashed oem and meet any issues, I could only say you are a hanhan.

    Root access:
    Flash Magisk in recovery.

    Twrp:
    You could download it here: Link
    Code:
    fastboot boot twrp.img

    Issues and reports

    Report issues only if you are using the ROM kernel
    If an additional mod is installed, make sure it's unrelated, and mention it
    Make sure the issue wasn't discussed earlier in the threads
    Share a log of the error with CatLog for example

    Also thanks to:
    Olivier
    Luk1337
    The LineageOS Team
    The CyanogenMod Team
    The SODP Team
    Everyone involved in working and testing

    XDA:DevDB Information
    Lineage 18.1 for Xperia XZ2, ROM for the Xperia XZ2

    Contributors
    Sjll, Olivier
    Source Code: https://github.com/sony-sdm845

    Donation
    https://paypal.me/sjllls

    ROM OS Version: Android 11
    ROM Kernel: Linux 4.9
    ROM Firmware Required: Official Android 10.0 firmware
    Based On: LineageOS

    Version Information
    Status:
    Stable

    Created 2020-11-27
    Last Updated 2021-05-26
    6
    Glad to tell everyone who are waiting for LineageOS 18.1.
    I uploaded the 20210515 build for Akari, but I don't have device to test.
    From the result on XZ3, everything works fine.
    Please test and feedback, if there is no bug, we will get official 18.1 support sson.
    6
    So latest build is 18.0 from November?
    Seems a big pause in development.
    I will try building with the 18.1 sources on Lineage GitHub and see what happens.....

    Edit: Fixed the build errors but it wont boot and devs seem to have moved on.
    Back to 17.1 nightlies
    6
    I don't have battery drain issue to begin with so can't tell the difference sadly, but yeah flashed and everything still works fine as before!
    Uploaded a new lineage-18.1-20210515-unofficial-akari.zip again.
    This removed 2 crashing prebuilt system Apps, enjoy.