• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][11][OFFICIAL][BECKHAM] crDroid Android v7.6

Search This thread

pietrotti97

Member
Jun 23, 2019
19
5
BE3pE0l.png

Code:
*** Disclaimer
I am not responsible for any damage you made to your device
You have been warned


crDroid is designed to increase performance and reliability over stock Android for your device also attempting to bringing many of the best features existent today


Features:
https://github.com/crdroidandroid/crdroid_features/blob/11.0/README.mkdn

Flashing Instructions:
Just follow the flashing procedure in the lineageos website and use the official lineageos recovery

Bugs:
- none found so far, tell me, I'll try to fix them

Sources:
- crDroid: https://github.com/crdroidandroid
- Device: https://github.com/LineageOS/android_device_motorola_beckham
- Kernel: https://github.com/LineageOS/android_kernel_motorola_msm8998
- Vendor: https://github.com/TheMuppets/proprietary_vendor_motorola

Download:
- ROM

Gapps:
Use Mindthegapps

Supported Devices: the ones supported by lineageos, BTW I'm using it on an unsupported XT1929-8 and it seems to be working fine.

Credits:
- crDroid
- LineageOS

Visit official website @ crDroid.net
crDroid <device> Telegram
crDroid Community Telegram
crDroid Updates Channel
Donate to help our team pay server costs
 
Last edited:

mikeshutte

Member
Feb 21, 2015
25
9
I just installed this on my 1929-8 as well. Everything seems good except I have no speakerphone. Other than that, great job! I'll let you know if I run into anything else.
 

mikeshutte

Member
Feb 21, 2015
25
9
Ok was able to get speakerphone working. I had google dialer installed and switched back to android dialer and working good now.
 

pietrotti97

Member
Jun 23, 2019
19
5
BE3pE0l.png

Code:
*** Disclaimer
I am not responsible for any damage you made to your device
You have been warned


crDroid is designed to increase performance and reliability over stock Android for your device also attempting to bringing many of the best features existent today


Features:
https://github.com/crdroidandroid/crdroid_features/blob/11.0/README.mkdn

Flashing Instructions:
Just follow the flashing procedure in the lineageos website and use the official lineageos recovery

Bugs:
- none found so far, tell me, I'll try to fix them

Sources:
- crDroid: https://github.com/crdroidandroid
- Device: https://github.com/LineageOS/android_device_motorola_beckham
- Kernel: https://github.com/LineageOS/android_kernel_motorola_msm8998
- Vendor: https://github.com/TheMuppets/proprietary_vendor_motorola

Download: ( for now uploaded on MEGA )
- ROM

Gapps:
Use Mindthegapps

Supported Devices: the ones supported by lineageos, BTW I'm using it on an unsupported XT1929-8 and it seems to be working fine.

Credits:
- crDroid
- LineageOS


New version uploaded, changelog available in the download directoy. I was unable to boot just dirty flashing this, So clean flash is needed.
 
Last edited:
  • Like
Reactions: mosta00

mikeshutte

Member
Feb 21, 2015
25
9
I'm not sure if this would be considered a bug or not, but it happens on all android 11 ROMs I've tried and haven't gotten any way to possibly fix the issue yet. Bluetooth when connected to my car stereo, I can't hear anything when I try to answer calls by either the stereo or the phone. It works fine for outgoing calls however. Now I noticed with this ROM I was able to get it to answer twice but that's it. I'm sure it's something simple I'm missing just not sure where to start. Any help would be greatly appreciated. And again great job on the ROM. Glad to see someone got this going for the moto Z3 play.
 

pietrotti97

Member
Jun 23, 2019
19
5
I'm not sure if this would be considered a bug or not, but it happens on all android 11 ROMs I've tried and haven't gotten any way to possibly fix the issue yet. Bluetooth when connected to my car stereo, I can't hear anything when I try to answer calls by either the stereo or the phone. It works fine for outgoing calls however. Now I noticed with this ROM I was able to get it to answer twice but that's it. I'm sure it's something simple I'm missing just not sure where to start. Any help would be greatly appreciated. And again great job on the ROM. Glad to see someone got this going for the moto Z3 play.

Hi, I've never encountered this issue. I know for a fact ( as I use it every day ) that android auto works perfectly fine with calls. Could you try that?
 

mikeshutte

Member
Feb 21, 2015
25
9
BTW I tried on my car with just bluetooth and no android auto and it worked fine, so maybe it's a car problem. I have no idea.
Are you using the latest crdroid version?
Tried to re-pair with the car?
Yep I'm using the latest version. I haven't tried to repair yet. It worked when I was running android 10 ROMs, and I think if I remember correctly it worked when I first installed lineage 18.1 I'll try to re-pair the device and see what happens. I'm gonna try my ear buds too and see what they do. Haven't tried them yet.
 

Agnanzo

Member
May 27, 2019
5
2
M8, what about SafetyNet, does it work?

Edit: I tried it already, everything seems fluid enough, awesome job!
Buuut, here´s the catch, I´m using the recommended Gapps, clean wipe, and everything, but SafetyNet fails, any idea how to workaround this?
 

Andreas1138

New member
Jun 14, 2021
2
1
Have you tried LineageOS? I have XT1929-8 too and I am using it in Europe. Unfortunately it's quite slow, I am sure with Lineage or your distribution it can work fine.

I use the Battery Moto Mods (turbo power and the one included in the package). Have you had the chance to try them?

Thank you so much for your work and your time!
 

pietrotti97

Member
Jun 23, 2019
19
5
M8, what about SafetyNet, does it work?

Edit: I tried it already, everything seems fluid enough, awesome job!
Buuut, here´s the catch, I´m using the recommended Gapps, clean wipe, and everything, but SafetyNet fails, any idea how to workaround this?
No idea on why safetynet is not working tbh, never been able to pass that f*****g test in any custom rom. BTW I haven't found yet an app complaining so for me it's a tie for now.
 

pietrotti97

Member
Jun 23, 2019
19
5
Have you tried LineageOS? I have XT1929-8 too and I am using it in Europe. Unfortunately it's quite slow, I am sure with Lineage or your distribution it can work fine.

I use the Battery Moto Mods (turbo power and the one included in the package). Have you had the chance to try them?

Thank you so much for your work and your time!
This rom is based on LineageOS btw.

For the mods, I tried the incipio offgrid and the moto power pack included when I bought the phone and they seemed to be working fine. Funny thing is that I completely forgot of having them for something like a year and a half, so when I connected both I got something like 5 seconds of charge before they went flat. SOOO I'll test them in the future, but I think they'll work fine. They worked fine in the past on LineageOS.
 

Top Liked Posts