• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][11][OFFICIAL] Havoc-OS 4.9 for Redmi 5 Plus/Note 5 [vince]

Search This thread


Dec 21, 2017
Installed on Redmi 5 plus.
Installed Magisk 23.0 and Adaway.
Very fluid and smooth.

Great work, thanks a lot.

Only request: How can I encrypt the phone?
I tried to encrypt the usual way but unfortunately ended up in a bootloop.
Any suggestions?


New member
Jul 7, 2021
please help me.
my phone is dead because the battery is 0%. then i charged it and i tried to turn it on again.
but it always stuck in Havoc OS animation.
i already try to reflash the ROM but it always stuck on Havoc OS animation.

please help me. i don't know what to do.


Dec 21, 2017
Adaway from magisk? teach me senpai. I wanna block my ads too.
Just download magisk.apk, rename it to magisk.zip. Boot to your recovery twrp , or Orangefox recovery and install magisk.zip.
Reboot your system, download Adaway app from fdroid and install it.
Starting Adaway you will be asked to give root permission, give the permission and that's it.
Anyway you will find a lot of extensive info on XDA on that arguments.
  • Like
Reactions: TeeTipu
Oct 16, 2016

I clean flashed this ROM, wipe system data dalvic cache internal, then flash ROM and reboot

Now after setting it up, fingerprint is not working for me now, I took time to set it up now don't want to re-flash again
What could be the fix??

I have added 3 fingerprints, but still it doesn't recognize them

Even the apps like payment apps which support fingerprint authentication doesn't detect my fingerprint
Had this problem in this rom only!

WhatsApp Image 2021-07-09 at 4.07.32 PM (1).jpeg
WhatsApp Image 2021-07-09 at 4.07.32 PM.jpeg

System version: Havoc-OS v4.6 (18 June 2021)
Security Patch: Jun 5, 2021


New member
Hi, im new to this forum. i've just installed this rom into my phone and i noticed that there is no messaging app that usually came by default from the phone, any suggestion for the app or it was a bug perhaps? i need the messaging app for verification some stuff.. :(


  • WhatsApp Image 2021-08-02 at 3.48.05 PM.jpeg
    WhatsApp Image 2021-08-02 at 3.48.05 PM.jpeg
    56.8 KB · Views: 39


Senior Member
Dec 23, 2010
Redmi K20 Pro
Working well here. Came from the Android 10 HavocOS and this has completely fixed the lags I was having; I'm actually really impressed with how smooth my old 5 Plus is now.

Can't comment on cellular use as I'm actually using the 5 Plus as a sort of MP3 player and for leisurely browsing/reddit on workouts (I don't mind it taking a beating). I'll probably stay on this version for a long while since it works fine and I haven't found any bugs (although I think Shady Launcher settings can be a bit temperamental but that's Shady Launcher not the ROM).

Btw - any possibility you could make some experimental patches for this ROM's Bluetooth stack? Been looking at the the matlog and want my Samsung Buds to negotiate higher SBC, AAC rates (esp. AAC which is 256). The max bitpool seems to be 37 on my Buds, 53 on some Anker Soundbuds so the latter (cheaper) earphones get better connection fidelity on both codecs. If there's a way to override it'd be cool. Think this and this is it. A2DP_AAC_MIN_BITRATE 320000 might budge it past 256. Or maybe you could add SBC XQ?

Update: tried the edits myself but knowing nothing my Ubuntu terminal did the equivalent of "what do you want from me? 👁️👄👁️". Not sure the stack and it's libraries can be compiled on its own 😅.
Last edited:


Aug 14, 2015
After upgrading to 4.8 WhatsApp mic problem is here again. Last time (on android 10) I fixed it by stripping Google Assistant of Mic privileges, I cant deny Mic To Assistant anymore. any fixes?

Edit: I updated through OTA Update, And guessing that's where the bugs came from, I later noticed the Camera wasn't working either. Both problems were fixed with Factory Reset.
Last edited:

Top Liked Posts