• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][11][OFFICIAL] lineage-18.1 for Pixel 3/XL (blueline/crosshatch)

Search This thread

appye

Senior Member
Jun 20, 2006
280
28
I have not seen any answers to this. Does anyone know if the build.prop fix for camera night mode either breaks or is broken (overwritten?) by OTA? I don't mind doing the fix whenever I upgrade my own phone, but I manage phones for my wife, my daughter and my mom. None of them are going to do that.

Also, do we know if Lineage is going to fix this or are they digging their heels in waiting for Google to make the change to their app?
 

StarLord21

Senior Member
Jan 20, 2015
60
49
Lagos
I have not seen any answers to this. Does anyone know if the build.prop fix for camera night mode either breaks or is broken (overwritten?) by OTA? I don't mind doing the fix whenever I upgrade my own phone, but I manage phones for my wife, my daughter and my mom. None of them are going to do that.

Also, do we know if Lineage is going to fix this or are they digging their heels in waiting for Google to make the change to their app?
I've been seeing the Google Camera version numbers change weirdly in APK Mirror, I'd like to think that Google working on this 🤞
For now, v8.2.300 is still our best bet.
 

StarLord21

Senior Member
Jan 20, 2015
60
49
Lagos
I was able to flash MindTheGapps finally. To do that, I flashed stock (force flashing all partitions) and installed Lineage.


I had the same issue just now. I rebooted back to recovery (WITHOUT actually going into the ROM) and it let me flash the nano package.
Yeahh same here, apparently System couldn't mount after flashing Lineage. A reboot to recovery solved that issue as you said.
 
  • Like
Reactions: justDave

agraceful

Senior Member
Mar 29, 2011
902
363
I have not seen any answers to this. Does anyone know if the build.prop fix for camera night mode either breaks or is broken (overwritten?) by OTA? I don't mind doing the fix whenever I upgrade my own phone, but I manage phones for my wife, my daughter and my mom. None of them are going to do that.

Also, do we know if Lineage is going to fix this or are they digging their heels in waiting for Google to make the change to their app?
Yeah, OTA breaks it so you'll need to do the fix again. Spezi (Pixeldust dev for p3/xl) has fixed this issue. I'm sure razor knows and just needs to merge it
 

appye

Senior Member
Jun 20, 2006
280
28
Yeah, OTA breaks it so you'll need to do the fix again. Spezi (Pixeldust dev for p3/xl) has fixed this issue. I'm sure razor knows and just needs to merge it
I saw that! Hopefully it gets fixed soon.

The other phones are all currently Pixeldust, but this one (my Mom's) is LineageOS because it has OTA. I wonder why Pixeldust can't use Lineage recovery for OTA. Its partly why I am likely to switch all of them over.
 

faheyd

Senior Member
Dec 29, 2011
152
33
Reno NV
Silly question upcoming: How do I get my home/main pages to continuously scroll left or right with a swipe?. I remember doing it on other phones, just can't remember where the setting is.
 

agraceful

Senior Member
Mar 29, 2011
902
363
Went with the July 27 OTA and the night mode camera issue is still there ... Do we know if Lineage devs are aware of this?
Razor absolutely knows about it, he posted the workaround. I saw two references to the camera on the builds a week ago but I don't think they were related to the issue. The pixeldust dev spezi I believe fixed the issue, so it's just a matter of grabbing that and adding it in (hopefully). Razor is a busy man these days but I can guarantee it's on his list to address
 

leaveNOW

Member
Jan 24, 2021
35
4
Google Pixel 3 XL
Google Pixel 5
Razor absolutely knows about it, he posted the workaround. I saw two references to the camera on the builds a week ago but I don't think they were related to the issue. The pixeldust dev spezi I believe fixed the issue, so it's just a matter of grabbing that and adding it in (hopefully). Razor is a busy man these days but I can guarantee it's on his list to address

Google made a screwed up change in the newest version of google camera (8.2.400) that came out about a week ago.
It reads a value from the build.prop and only accepts numbers, but lineage uses numbers and letters. This causes google camera to crash when using night sight and possibly other features.

you can revert to the older version of google camera (8.2.300).
or do the following commands:


Code:
adb root

Code:
adb remount

Code:
adb shell sed -i 's/ro.build.version.incremental.*/ro.build.version.incremental=123456789/' system/build.prop
then reboot, and google camera should work fine.

EDIT: if you have magisk it breaks the adb root command, so you can do these commands instead.
adb shell
su
remount
sed -i 's/ro.build.version.incremental.*/ro.build.version.incremental=123456789/' system/build.prop

*its from Zaor...

so its no big problem... any other issue for big update on this month
 
  • Like
Reactions: Elyey

agraceful

Senior Member
Mar 29, 2011
902
363
Google made a screwed up change in the newest version of google camera (8.2.400) that came out about a week ago.
It reads a value from the build.prop and only accepts numbers, but lineage uses numbers and letters. This causes google camera to crash when using night sight and possibly other features.

you can revert to the older version of google camera (8.2.300).
or do the following commands:


Code:
adb root

Code:
adb remount

Code:
adb shell sed -i 's/ro.build.version.incremental.*/ro.build.version.incremental=123456789/' system/build.prop
then reboot, and google camera should work fine.

EDIT: if you have magisk it breaks the adb root command, so you can do these commands instead.
adb shell
su
remount
sed -i 's/ro.build.version.incremental.*/ro.build.version.incremental=123456789/' system/build.prop

*its from Zaor...

so its no big problem... any other issue for big update on this month
Why are you quoting me? I already stated Razor posted that.
 

allindaze

Senior Member
Nov 24, 2012
58
2
I've suddenly had problems with Google Fi not activating. I'm getting no phone signal and unable to Erase my digital sim.

I've tried clearing the cache of my Google Fi app and restarting my phone but it still immediately fails to activate
 

linuxpauling

Member
Mar 10, 2021
36
4
Having problems booting to recovery. I took a new Pixel 3 xl and following the instructions from Lineageos.org to install lineage 18.1. I got to the point where I flashed the lineage 18.1 recovery file. However, on the next step I was not able to reboot into recover. My bootloader screen says error booting boot.img at the bottom. I realized that I did not check to ensure the phone was at Android 11 before I started the process - would this be the problem? If it is, at this point can or should I try to flash the most recent Android 11 factory image for the phone (and then redo the Lineage flashing)? Or is there something else I should be doing
 

appye

Senior Member
Jun 20, 2006
280
28
Just a heads up...
Google made a screwed up change in the newest version of google camera (8.2.400) that came out about a week ago.
It reads a value from the build.prop and only accepts numbers, but lineage uses numbers and letters. This causes google camera to crash when using night sight and possibly other features.

you can revert to the older version of google camera (8.2.300).
or do the following commands:

Code:
adb root
Code:
adb remount
Code:
adb shell sed -i 's/ro.build.version.incremental.*/ro.build.version.incremental=123456789/' system/build.prop
then reboot, and google camera should work fine.

EDIT: if you have magisk it breaks the adb root command, so you can do these commands instead.
adb shell
su
remount
sed -i 's/ro.build.version.incremental.*/ro.build.version.incremental=123456789/' system/build.prop
Hello, is this fix going to be included in the ROM at some point? I wonder, does including it violate some LineageOS policy or something? I can see that the fix is integrated into Pixeldust, but I like lineage and having the ability to OTA ...

Aug 3 still has the same issue ...
 

Texas_Ace

Senior Member
Apr 1, 2012
199
13
Ok, having a bit of a battle with a pixel 3. I purchased 2 of them and one flashed easy peasy. The other gave me the run around. Finally got it done though after flashing back to stock and then flashing lineage.

I am now trying to install gappas on it. I have re-flashed lineage a few times now trying different methods of flashing gapps but keep getting a not enough space in system error.

Attempting to flash the gapps 11 nano package which others said they have gotten to work. I followed what I saw above but still get the error.

Any ideas?

I did see someone say they put it in /tmp/install but no idea how to do that?
 

dcarvil

Senior Member
Apr 20, 2016
464
246
Ok, having a bit of a battle with a pixel 3. I purchased 2 of them and one flashed easy peasy. The other gave me the run around. Finally got it done though after flashing back to stock and then flashing lineage.

I am now trying to install gappas on it. I have re-flashed lineage a few times now trying different methods of flashing gapps but keep getting a not enough space in system error.

Attempting to flash the gapps 11 nano package which others said they have gotten to work. I followed what I saw above but still get the error.

Any ideas?

I did see someone say they put it in /tmp/install but no idea how to do that?

Did you flash stock to both slots? I had to do a wipe (fastboot -w) when I flashed stock as well as the wipe installing Lineage before mine worked.

Did you wipe and reformat the data partition during the Lineage install?

After flashing Lineage, you should reboot to recovery, then flash gapps before you boot to system. You could try the pico package, which should be smaller. You can install any apps not in pico from the app store.

Don't know what putting it in /tmp/install means, or how it would apply.
 

Top Liked Posts