[ROM][11][OFFICIAL] lineage-18.1 for Pixel 3/XL (blueline/crosshatch)

Search This thread

smileguy91

Member
Oct 20, 2018
38
8
Google Pixel 3 XL
Okay, I don't think this problem is with a debloat. Audio from the speakers seems to be distorted and muffled. Is there something with the stock vs Lineage drivers?

Edit: I think my phone's trying to play audio like it would call audio through speakerphone. Everything sounds like it would through speakerphone - is there a way to direct the audio "normally"?
 
Last edited:

thachdangss

New member
Apr 5, 2018
2
0
I don't see the boot.img in the zip, also adb root (su inaccessible or not found), is there another way to root ?
solved: Turn out the recovery.img is the boot.img, never mind guys ! @@
 
Last edited:

jkl7878

Member
Nov 1, 2016
11
2
I'm also having problems with GPS. Seems to work sporadically in Google Maps. Not at all in some other apps.

Not sure if it's a GApps issue - I'm using the version linked in the first post (MindTheGapps).

Thanks for any help
 

jkl7878

Member
Nov 1, 2016
11
2
I'm also having problems with GPS. Seems to work sporadically in Google Maps. Not at all in some other apps.

Not sure if it's a GApps issue - I'm using the version linked in the first post (MindTheGapps).

Thanks for any help
Actually, I'm not sure if GPS is working at all. I might have just had Wifi location those few times I got it working in Google Maps
 

namlas

Senior Member
Apr 16, 2009
78
51
Is anyone getting random UI unresponsiveness? I thought maybe it was just an issue with the UnOfficial release, but even with the official release I'm still having the same issue.

Completely randomly, the phone will stop responding to most touch events. Can't pull up app drawer, can't pull down notification bar, can't reboot through the UI, etc. The screen turns on/off at the usual timeouts, and I can use the power button to turn the screen on/off as well. But, most other things don't work.

adb shell and adb logcat still work fine, so the OS hasn't crashed and burned. I have to hold the power button down to force a restart. But, even after that, sometimes the phone goes back into the exact same state and I have to reboot multiple times to get it back into a working state.

I also keep getting "Setting Service has crashed" messages at startup -- though, I was also getting these on lineage 17, so I'm not sure if this is related. I'm not able to spot any specific crashes in logcat that would point me towards something specific being the cause of this behavior.
 

Tech180

Senior Member
I'm also having an issue with the GPS... I don't know if this is a common problem or not but when using pixel dust it worked just fine.

Also as a side note... When using mindthegapps I had horrible google play store issues so I ended up switching to open gapps and pretty much every problem I had was fixed (except the GPS issue)
 

FcukBloat

Senior Member
  • Jun 18, 2012
    6,281
    3,012
    Is anyone getting random UI unresponsiveness? I thought maybe it was just an issue with the UnOfficial release, but even with the official release I'm still having the same issue.

    Completely randomly, the phone will stop responding to most touch events. Can't pull up app drawer, can't pull down notification bar, can't reboot through the UI, etc. The screen turns on/off at the usual timeouts, and I can use the power button to turn the screen on/off as well. But, most other things don't work.

    adb shell and adb logcat still work fine, so the OS hasn't crashed and burned. I have to hold the power button down to force a restart. But, even after that, sometimes the phone goes back into the exact same state and I have to reboot multiple times to get it back into a working state.

    I also keep getting "Setting Service has crashed" messages at startup -- though, I was also getting these on lineage 17, so I'm not sure if this is related. I'm not able to spot any specific crashes in logcat that would point me towards something specific being the cause of this behavior.
    no problems of this kind at all
     

    FcukBloat

    Senior Member
  • Jun 18, 2012
    6,281
    3,012
    I'm also having an issue with the GPS... I don't know if this is a common problem or not but when using pixel dust it worked just fine.

    Also as a side note... When using mindthegapps I had horrible google play store issues so I ended up switching to open gapps and pretty much every problem I had was fixed (except the GPS issue)
    no problems of any sort with mindthegapps either. about gps it works here in maps but it may be thanks to network location i dunno..
     

    razorloves

    Senior Member
    Sep 19, 2007
    3,094
    14,701
    Miami
    not sure how some of you are ending up with messed up gps.
    gps has been working fine for me in multiple apps.
    using mindthegapps.
    according to a log someone sent me with gps not working, the permissions on the Google Play Services app is broken. this can happen from not installing gapps properly.

    if your gps isn't working do these adb commands. should fix it.
    adb root
    adb shell pm grant com.google.android.gms android.permission.ACCESS_COARSE_LOCATION
    if that doesn't fix it, try reboot.
    if it still doesn't work, send me a pm with logcat showing the problem.
     

    jkl7878

    Member
    Nov 1, 2016
    11
    2
    not sure how some of you are ending up with messed up gps.
    gps has been working fine for me in multiple apps.
    using mindthegapps.
    according to a log someone sent me with gps not working, the permissions on the Google Play Services app is broken. this can happen from not installing gapps properly.

    if your gps isn't working do these adb commands. should fix it.
    adb root
    adb shell pm grant com.google.android.gms android.permission.ACCESS_COARSE_LOCATION
    if that doesn't fix it, try reboot.
    if it still doesn't work, send me a pm with logcat showing the problem.
    You're right, it's because I didn't follow your initial GApps installation procedures exactly. I factory reset it and followed your directions and it's working now. Thank you!
     
    yeah cool i didn't know we could update ota without twrp available! great it worked here too :)
    haha commercial phone manufactorers dream about that full featured updater since early ages of android. I switched from TWRP to LOS recovery as i started using 18.1 on my Pixel2 and my Galaxy S5. OTA updates running very smooth with LOS recovery. I still use a 3rd phone a Pixel 3 for business usage. As soon as it will run out of support this winter, i will flash LOS to extend its life and to support this wonderful project.
     

    razorloves

    Senior Member
    Sep 19, 2007
    3,094
    14,701
    Miami
    yeah cool i didn't know we could update ota without twrp available! great it worked here too :)
    ota updating doesn't involve the recovery at all, on devices with a/b slot partitions. never has.
    the update is installed while in android (to the other slot). same as on stock rom.
    this is not a new thing. lineage has been doing it for a few years. since google implemented it in aosp. started with first gen pixel.
    so it doesn't matter what recovery is installed.
     

    zeppelin03

    New member
    Mar 16, 2020
    1
    0
    Thanks for putting this together. I'm excited to have a phone updated beyond Google's arbitrary cutoff.

    The one issue I've encountered is that bedtime mode in digital wellness will not cause the screen to go into greyscale. It does trigger do not disturb overnight though. Could a reinstall of mindthegapps fix this?
     

    dethzord

    Member
    Nov 17, 2009
    26
    3
    Just got an 3xl, fresh out of the box. Upgraded to stock android 11 immediately, then installed Lineage. Installed mindthegapps. Installed magisk. Everything looked good until I discovered my phone won't rotate, no GPS. Testing app says no gyro, no accelerometer, no compass.

    Is this a mistake with how I installed gapps, or do I have a bad device? Pretty sure I installed correctly, didn't boot prior to gapps install. If the former, can I do a wipe, and reinstall mindthegapps? Or would I need to re-flash Lineage?
     

    Top Liked Posts