[ROM][11][OFFICIAL] LineageOS 18.1 for Lenovo P2

Search This thread

RAVINTER

Member
Mar 12, 2021
16
7
I installed latest LOS on my friend's Lenovo P2. No root, stock LOS only. Google Pay, and banking apps work. SafetyNet passed (basic integrity, and CTS passed). But there is that one app, which doesn't want to start, because it's saying that system is modified or rooted. I think device fingerprint could be the problem. I was also considering rooting it and trying to use MagiskHideProps module, however there is no Lenovo's fingerprint in there. Does anyone have stock fingerprint, or have any idea how to make it work?
The app itself is local app for paying for highway (Autopay), we are from Poland.

Below are screenshot from Momo app.
I checked it for you, installed this Autopay application, launched it and it said I have root. I added version 23.0 to magiskhide and it works fine. It's strange that you have no root and it shows that it is, but apparently some apps treat custom roms this way.
 
Last edited:
  • Love
Reactions: Klusio19

Zdeslav

Member
Nov 24, 2017
17
3
Split
Regards folks,
thanks to great 18.1 ROM my Lenovo P2 is reborn. I didn't seen any mayor flaws in ROM.

P2a42 / My ROM Build / Latest update : RQ3A.211001.001 086569df20
Rooted, Magisk 25.2, Safety Net, All works well with banking apps

Just question for Camera if somebody knows.
Camera APP ver: 2 02.072 (086569df20-00)
org.lineage.snap

For Camera default app and flash, they are not in sync when I take photos in dark places, can focus very well but flash fires to early or to late.

Aldo there is same flaw in OpenCamera APP, same thing

How can it be synced ?
Need some edit correction files or something else to do?
Please help about that. I had also problems in LOS 16.

Regards
 
Last edited:

en666

Senior Member
Apr 23, 2011
85
40
Lenovo p2c72, twrp 3.6.2, magisk 23.0, ext4 partitions, updated to 2022-10-02 with the updater app. Everything smooth. Thanks to your work Mike. Looking forward for los19!

I also experience the problem with the flash, in both camera and opencamera apps - the second application suffers a little less delay? - but couldn't find a way to fix it.

Also, on every update it doesn't put back the SMS default preference to what it was but it forces it to 'ask every time', which it doesn't properly work: when you try to send a text, if you're on 'ask every time' it won't actually ask.
 

Klusio19

Senior Member
Nov 13, 2018
179
41
Tarnobrzeg
OnePlus 8T
I checked it for you, installed this Autopay application, launched it and it said I have root. I added version 23.0 to magiskhide to magiskhide and it works fine. It's strange that you have no root and it shows that it is, but apparently some apps treat custom roms this way.
Spróbuję jutro go zrootować, a następnie ukryć Autopaya i zobaczymy co z tego wyjdzie. A mam jedno jeszcze pytanie, czy jak zwykle jest to standardowa procedura sflashowania TWRP i potem sideload zipa z Magiskiem? Pytam, bo obecnie posiadam OnePlusa 8T, które jest urządzeniem A/B i tam, osobiście rootuję poprzez wyciągnięcie obrazu boot, spatchowanie go w aplikacji Magisk, i zbootowaniu go przed fastboot.
Chodzi mi o to, czy jest coś charakterystycznego dla tego Lenovo w przypadku rootowania, czy flashowania TWRP.


Mod edit: English please!
Google translation:


I'll try to root it tomorrow and then hide Autopay and we'll see what comes out of it. And I have one more question, is it the usual procedure for flashing TWRP and then sideload zip with Magisk? I'm asking because I currently own a OnePlus 8T which is an A / B device and there, I personally root by pulling the boot image, patching it in the Magisk app, and booting it before fastboot.

I mean is there anything specific to this Lenovo when rooting or flashing TWRP.
 
Last edited by a moderator:

RAVINTER

Member
Mar 12, 2021
16
7
I'll try to root it tomorrow and then hide Autopay and we'll see what comes out of it. And I have one more question, is it the usual procedure for flashing TWRP and then sideload zip with Magisk? I'm asking because I currently own a OnePlus 8T which is an A / B device and there, I personally root by pulling the boot image, patching it in the Magisk app, and booting it before fastboot.

I mean is there anything specific to this Lenovo when rooting or flashing TWRP.
I installed normally TWRP, for this I choose NikGApps, of course, you can choose the recommended one from this thread, then the magisk installation via twrp (I did not do sideload) and everything runs. Finally, I had to install the safetynet fix module in magisk, the first time im install it via twrp and had a bootloop, but man learns from mistakes.
 
Last edited:
  • Like
Reactions: Klusio19

Zdeslav

Member
Nov 24, 2017
17
3
Split
Lenovo p2c72, twrp 3.6.2, magisk 23.0, ext4 partitions, updated to 2022-10-02 with the updater app. Everything smooth. Thanks to your work Mike. Looking forward for los19!

I also experience the problem with the flash, in both camera and opencamera apps - the second application suffers a little less delay? - but couldn't find a way to fix it.

Also, on every update it doesn't put back the SMS default preference to what it was but it forces it to 'ask every time', which it doesn't properly work: when you try to send a text, if you're on 'ask every time' it won't actually ask.

I didn't solve camera flesh fire problem, for sms and calls I've installed a google messages app and phone app, dint have any problems.
Reg
 

sebcel

New member
Jul 30, 2016
2
0
Hi there,
I have a problem with LineageOS 18.1, on my Kuntao P2a42. I am French, and it is impossible for me to connect my phone to the "Bouygues" network.
Impossible to activate 4G (LTE), yet I have an antenna right next to my house. I also tested my sim on another phone, and no problem!
Do you have an idea please?
Thank you for your help !
 

Ryus25099

Member
Oct 18, 2022
5
0
Chrome tidak berjalan di Rom ini dengan baik..apakah penyebabnya?selalu error'

Mod edit: English please!
Google translation:


Chrome doesn't run on this Rom properly.. what is the cause? always error'
 
Last edited by a moderator:

Zdeslav

Member
Nov 24, 2017
17
3
Split
Guys I am unable to register fingerprints. It says enrollment failed. Any solution?
If you are root !!!!
Well, after deleting pin and fingerprint I always need to delete those files. From Lineage OS 16 to 18.1 for Lenovo P2 with Root option, maybe for non root isn't problem, don't know.

  1. Boot into TWRP
  2. Go to advanced>filemanager to acces the files in your phone.
  3. Enter the folder /data/system/user/0
  4. Delete following files: ./fpdata/user.db, settings_fingerprint.xml
  5. Reboot to system and set up new fingerprints with the fingerprint wizard
Everything should work normal

and or...

Delete your Android PIN – TWRP Method
  1. Boot your phone into TWRP recovery.
  2. Go to Advanced > File Manager and navigate to /data/system.
  3. Find the files that end in the .key extension and any files that have “locksettings” in the filename. They will typically be (but vary by manufacturer):

    Code:
    Gatekeeper.password.key
    gatekeeper.pattern.key
    locksettings.db
    locksettings.db-shm
    locksettings.db-wal
some phones have this files or don't

Link
 
Last edited:
  • Like
Reactions: abhishekjain.ims

Zdeslav

Member
Nov 24, 2017
17
3
Split
Maybe to report BUG about fingerpint system on
Lineage os 18.1 / Lenovo P2 a42
RQ3A.211001. a177e63d45
Rooted, Magisk 25.2, Universal Safety fix, working

I can register only one correct fingerprint, second, third ... is non recognized.
Even if I delete those files in data/system/user, stil I can use only one registered.

Regards
 
  • Like
Reactions: abhishekjain.ims

abhishekjain.ims

Senior Member
If you are root !!!!
Well, after deleting pin and fingerprint I always need to delete those files. From Lineage OS 16 to 18.1 for Lenovo P2 with Root option, maybe for non root isn't problem, don't know.

  1. Boot into TWRP
  2. Go to advanced>filemanager to acces the files in your phone.
  3. Enter the folder /data/system/user/0
  4. Delete following files: ./fpdata/user.db, settings_fingerprint.xml
  5. Reboot to system and set up new fingerprints with the fingerprint wizard
Everything should work normal

and or...

Delete your Android PIN – TWRP Method
  1. Boot your phone into TWRP recovery.
  2. Go to Advanced > File Manager and navigate to /data/system.
  3. Find the files that end in the .key extension and any files that have “locksettings” in the filename. They will typically be (but vary by manufacturer):

    Code:
    Gatekeeper.password.key
    gatekeeper.pattern.key
    locksettings.db
    locksettings.db-shm
    locksettings.db-wal
some phones have this files or don't

Link
Thank you very much for the solution. I tried another ROM but that didnt work either then I read about another solution to downgrade it to Lineage OS 16 & voila it worked. Now I am using Lineage OS 16 with this issue (y) The only thing which bothers me in LOS 16 is its weak network strength. Can we increase it with root?

Thank you very much again.

Regards,
Abhishek J
 

en666

Senior Member
Apr 23, 2011
85
40
Hi there,
I have a problem with LineageOS 18.1, on my Kuntao P2a42. I am French, and it is impossible for me to connect my phone to the "Bouygues" network.
Impossible to activate 4G (LTE), yet I have an antenna right next to my house. I also tested my sim on another phone, and no problem!
Do you have an idea please?
Thank you for your help !
I lived for a while in Perpignan and I had your same problems with Free. I eventually managed to make it working with LTE, playing around with the 'Network and Internet' > Free section > 'preferred network type'. The configuration that eventually worked for me was LTE/WCDMA, but with a little patience you can try if there is another one and if you find, please tell us!
 

eried1

Senior Member
May 27, 2016
346
41
Stockholm
giskhide and it work

At the current state, no. 3.18 kernel is missing essential functionality for android 12. I have started some experiments with 4.9 kernel here: https://github.com/mikeNG/android_kernel_lenovo_msm8953/commits/lineage-18.1-4.9

It's in very early state so I can't promise that will ever become fully functional. At the moment I have only tested recovery booting and display/volume button navigation work, however usb and touch aren't working so I can't debug much further yet.
Thank you for your great contribution! Much appreciated by everyone on the forum. Hoping that you (or someone else) manage to get 4.9 properly working.
 

MagicMedlar

New member
Oct 27, 2022
3
0
Last edited:

hypomaniak

New member
Nov 18, 2022
1
1
I am getting communication error 17 while setting up the Android Auto, I am using Mindthegapps. Any fixes for the same?
Hello

I had that problem when I installed LOS, and if I remember correctly, the solution I found was to manually set the authorizations for Android Auto in the System/apps settings and give access to the microphone.
Strangely enough, Android Auto wanted to access that before getting to the Wizard screen where it says which authorizations are needed.
 
  • Like
Reactions: abhishekjain.ims

Top Liked Posts