[ROM][11][OFFICIAL] LineageOS 18.1 for Mi A2

Search This thread

misterbirra

Member
Mar 17, 2021
35
5
Majority of banking apps will not work if you keep the phone non-rooted.
Does it happen when using Lineage, or any custom ROM?
Because I have another phone (Xperia XZ1) flashed with Havoc OS, not rooted, and I have 2 banking apps that still run without any problem. May I assume that these apps will still work on the Mi A2 with Lineage?
 

rackstar41

Member
Nov 2, 2011
26
10
Xiaomi Mi A2
Xiaomi Mi A3
Does it happen when using Lineage, or any custom ROM?
Because I have another phone (Xperia XZ1) flashed with Havoc OS, not rooted, and I have 2 banking apps that still run without any problem. May I assume that these apps will still work on the Mi A2 with Lineage?
Honestly, I don't know ! It depends if HavocOS is SafetyNet OK or not.

If I look in this thread (https://forum.xda-developers.com/t/rom-havoc-os-v3-11-official-stock-based.4113345/#post-82800513), it's seems that Havoc is SafetyNet compliant, so your banking app will probably NOT work with Lineage (without Magisk)
 

Raskaipika

Member
May 12, 2016
34
2
Hi community, I need your help urgently:

I'm unable to boot my phone and my phone is continuously booting to the recovery, the process that I did was the next:

- The last Saturday, I updated the phone via OTA (09042022), reboot the phone and wait to the system, once time that I was at the system, I rebooted the phone to the bootloader, from there, with fastboot, I booted the twrp.img to be able to flash the recovery using the option "Install Recovery RamDisk" and everything worked ok.

- Once the phone boots to the system, I rebooted again to the bootloader and with the proper command, I rebooted to the recovery, from the recovery with the adb shell, I extracted the boot_b partition (active at that moment) to patch it with magisk, again, reboot to the system.

- Using magisk app (lastest stable version) I patched the boot_b.img extracted with TWRP, renamed it (the magisk .img file generated) to boot_b.img and rebooted to the bootloader again, and form there, I flash the boot_b like ever, with the command "fastboot flash boot_b ./boot_b.img".

Once time the phone rebooted, the phone boots to the recovery ever and I have to shutdown it from the recovery.

Is there anything that I can make to fix this???, I'm ****ed right now without my phone.

Thanks in advance guys, for your time and help.

P.S.: This time, I did all the process from my linux TabPC (2-1 convertible) instead of my Windows PC like ever, I don't know if the last command (fastboot flash boot_b ./boot_b.img) is the problem here, I comment it because I don't know if the command from a linux terminal is the same than in a PowerShell terminal.
 
Last edited:

Raskaipika

Member
May 12, 2016
34
2
Answering to myself:

I've been able to make the phone boots again, the only thing that I've done is flash the LineageOS recovery with the right command "fastboot flash boot ./lineage-18.1-20220409-recovery-jasmine_sprout.img" instead of use the "fastboot flash boot_b....", and when the flash process have finished, command to reboot and everything works again like a charm and ever, then download the lastest OTA (from yesterday), install it and repeat the process that I make every weekend to update the phone.

I can confirm too, that the problem was caused by me, let me explain, like I've said at my first post requesting help from the gurus of this forum, the last week, I did the process for first time from my Linux PC, and everything was related with the permissions of the boot.img patched by magisk when I copied it from the phone to my PC using the GUI of the PC. For a reason that I don't know, the file has the wrong permissions, and when I've checked them comparing against with the recovery downloaded from Internet, they were different, doing a "chmod 664" to the twrp patched by masgisk BEFORE to flash it, was the trick.
 

mikedeaster

Member
May 26, 2016
14
1
Moto X4
Sometimes screen not power off when i make call, on stock the same, but it have hiden menu in dialer for calibrate sensor. How to make it on los?
 

DarkDany

New member
Apr 26, 2022
1
0
In my Device the banking app does not recognize the biometrics suggesting that the device is not supported to use biometrics, it could use it on stock which is unfortunately outdated.

Also CTS Profile fails to pass safetynet checks, in other custom roms that I tested it seems to be working.
I could only temporarily fix it by getting magisk and getting props to change the device fingerprint as well as hiding root from the app but I do not wish to use root.
Any Help?
 

eginugraham

Senior Member
May 6, 2017
61
3
Smoothest ROM I've tried so far.
Camera2 api enabled out of the box, and banking apps just works.
Although i have to use built in lineage recovery, which makes me unable to flash without a pc, not really a big deal though
*edit* also, type c headset works which is nice

10/10
 
Last edited:

albysprx

Senior Member
Nov 10, 2012
449
147
I'm getting safetynet basic and CTS fail even with the MI A2 Android 10 fingerprint from props config, what am I doing wrong?
 

mikeioannina

Recognized Developer
Mar 22, 2011
1,949
26,986
Ioannina
Lenovo P2
Xiaomi Mi Mix 2
Hi @mikeioannina,

The Mi A1 device (which is 1 year older than the Mi A2) already has official LOS 19.1. Could you tell us, more or less, when we will have LOS 19.1 for the Mi A2?
There is some progress but still a bit of work left to be done, since we will be switching to 4.19 kernel. I am simply too busy with work and other devices and didn't find time to continue.
 

Top Liked Posts