• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][11][OnePlus 7 Pro] PixelExperience [AOSP]

Search This thread

slgooding

Senior Member
Oct 6, 2011
713
236
West Lafayette
OnePlus 7 Pro
I'm seeing a 3.5 amps. Oddly though sometimes it gets stuck around 1.5. Replugging seems to fix. I'm running dora kernel though
Hi, haven't flashed this ROM as of yet, however I was wondering if there are screen calibration options available, like in Oxygen, see screenshot attached, so that I could pick DCI-P3 for my colour profile?
If so, is that available on both regular and plus editions of the ROM?
Also, I've noticed some discussion above regarding warp charging, however can't help but notice "charging rapidly" can also imply PD charging, which is inferior to warp (18W vs 30W).
Has anyone done software measurements of the charge current using apps like Ampere or Accubattery?
Thanks!
 

mobilityguy

Senior Member
Aug 18, 2010
114
26
Boston, MA
I've looked through recent posts for news about encryption. It's not listed in the "what's working" or "known issues" sections of the introduction. Does it work on the PE rom for the 7 Pro?
 

mobilityguy

Senior Member
Aug 18, 2010
114
26
Boston, MA
I've looked through recent posts for news about encryption. It's not listed in the "what's working" or "known issues" sections of the introduction. Does it work on the PE rom for the 7 Pro?
For the record, I installed the latest Pixel Experience ROM on a spare OP7Pro. The "Encryption & credentials" panel shows the phone is encrypted. So encryption appears to work, in case anyone else was wondering.
 

mobilityguy

Senior Member
Aug 18, 2010
114
26
Boston, MA
When I installed the Pixel Experience ROM on my OP7Pro, the installation replaced my TWRP recovery with the PE recovery. Mostly I can get around any differences, but I can no longer do Nand backups of the phone, which is kind of important as I go through setups on the new OS. Is there an alternate way to do full phone backups without reinstalling TWRP, which is problematic on this phone?
 

SPRec

New member
Nov 20, 2021
2
0
Try install ota update from 20210518, get loop on recovery. Device is rooted. How to update without data loss?
 

SPRec

New member
Nov 20, 2021
2
0
yes. Install on magisk manager, after intall OTA update - not worked.
After reboot try "adb sideload magisk" in recovery
 

espositodnl86

Member
Aug 28, 2021
13
2
Hey guys, I have flashed PE on my OnePlus 7 Pro and everything runs smoothly, kudos to the developers! I just have a few questions:
  • What's the difference between GCam and the Google Camera that I can download from the Play Store?
  • I didn't lock the bootloader after flashing the ROM, is this the reason why I'm stuck on Widevine L3?
  • If I flash TWRP and make a complete backup, would I be able to lock the bootloader and then restore the backup?
Thanks for helping out!
 

archer100

Senior Member
Mar 24, 2011
109
59
OnePlus One
OnePlus 7 Pro
The Nov update still does not detect my sim card (July version does, but Oct update does not). I have the t-mobile version of 7pro flashed to international. Can someone help me to find a solution? Logcat attached. Thanks!

Edit: I tried a few times already, but I cannot see the logcat I attached. Trying once more.
 
Last edited:

mobilityguy

Senior Member
Aug 18, 2010
114
26
Boston, MA
Hi all. Just installed Pixel Experience on my OP7Pro last week, and updated to the November update last night. Everything seems to be working OK except the Starbucks app, which will not let me log in. My login works fine on another OP7Pro running OxygenOS 10 and on a OP3t that I use as a test platform, but on the 7Pro running PE I get "A system error has occurred. Please try again later." I thought the fingerprint sensor might be to blame, since the app allows biometric login, but that all works fine on the 3t. I can't make the app fail on any other phone or computer.

I've tried uninstalling and reinstalling the app and restoring data from a previously logged in session using Titanium Backup, but this is annoyingly the only app that seems to have trouble, and only on this phone running Pixel Experience. I've eliminated any other possibility, I think. I have auto-reload and the barcode on my Pebble so I don't absolutely need the app to work right now, but I will at some point.

Ideas? Any help would be appreciated.
 

GamerX2010

Member
Sep 16, 2020
9
0
OnePlus 7 Pro

GtwTyCR.png

PixelExperience for OnePlus 7 Pro [Guacamole]

What is this?
Pixel Experience is an AOSP based ROM, with Google apps included and all Pixel goodies (launcher, wallpapers, icons, fonts, boot animation)

Our mission is to offer the maximum possible stability and security, along with essential and useful features for the proper functioning of the device

Based on Android 11.0



What's working?
Wifi
RIL
Mobile data
GPS
Camera
Flashlight
Camcorder
Bluetooth
Fingerprint reader
NFC
Lights
Sound/vibration


Known issues
Nothing yet
You tell me

DON'T FLASH GAPPS, THEY'RE ALREADY INCLUDED
Download from PixelExperience website


Donate
Liked my work? Give me a beer

Translation
Help with project translation

Stay tuned
Our Telegram channel
Device Specified Telegram Group
Our blog



I recently installed pixel experience on my OnePlus 7 Pro Which was running OOS11.



I installed the latest plus edition with root. When the phone finally started I continued on with the setup but no wifi networks were shown. I thought it was just a bug and skipped the wifi step to do it later, but I later figured out I couldn't even turn on wifi it would just automatically turn itself off. And also the fingerprint sensor wasn't working. I reverted back to oos but is something wrong in my phone or the custom rom cause I saw videos with pe+ running on op7pros and nothing was wrong.



Thanks
Help would we appreciated.
 

mobilityguy

Senior Member
Aug 18, 2010
114
26
Boston, MA
I recently installed pixel experience on my OnePlus 7 Pro Which was running OOS11.



I installed the latest plus edition with root. When the phone finally started I continued on with the setup but no wifi networks were shown. I thought it was just a bug and skipped the wifi step to do it later, but I later figured out I couldn't even turn on wifi it would just automatically turn itself off. And also the fingerprint sensor wasn't working. I reverted back to oos but is something wrong in my phone or the custom rom cause I saw videos with pe+ running on op7pros and nothing was wrong.



Thanks
Help would we appreciated.
I installed Pixel Experience about a week and a half ago on my OP7 Pro. My WiFi access points showed up during the setup process and have been working fine ever since, through the November update. The fingerprint sensor has been a little more finicky than under OOS but things improved when I double-registered the fingers I use to wake the phone. Now it's almost up to the level of performance I'm used to, with one exception - it doesn't always respond when the AOD is on, and makes me press the power button to display the lock screen. The fingerprint sensor almost always works from there. I also find I have to hold my finger on the sensor a little longer than I did with OOS, but now that I've adapted to the slightly different behavior it works well enough for me.

Did you follow the installation instructions exactly, including the factory data reset? I've put lots of custom ROMs on lots of phones and sometimes artifacts of the old software and cache can screw things up.
 

GamerX2010

Member
Sep 16, 2020
9
0
OnePlus 7 Pro
I installed Pixel Experience about a week and a half ago on my OP7 Pro. My WiFi access points showed up during the setup process and have been working fine ever since, through the November update. The fingerprint sensor has been a little more finicky than under OOS but things improved when I double-registered the fingers I use to wake the phone. Now it's almost up to the level of performance I'm used to, with one exception - it doesn't always respond when the AOD is on, and makes me press the power button to display the lock screen. The fingerprint sensor almost always works from there. I also find I have to hold my finger on the sensor a little longer than I did with OOS, but now that I've adapted to the slightly different behavior it works well enough for me.

Did you follow the installation instructions exactly, including the factory data reset? I've put lots of custom ROMs on lots of phones and sometimes artifacts of the old software and cache can screw things up.
i reflashed pixel experience but this time sideloaded it through adb without flashing it in twrp. The wifi is working and the fingerprint sensor works just in the way you said.
 

GamerX2010

Member
Sep 16, 2020
9
0
OnePlus 7 Pro
USB File Transfer dosent work, the device dosent show up in my pc nor adb works. but when i go into recovery mode (TWRP) the usb file transfer works just fine, any ideas why this is happening.
 

mobilityguy

Senior Member
Aug 18, 2010
114
26
Boston, MA
i reflashed pixel experience but this time sideloaded it through adb without flashing it in twrp. The wifi is working and the fingerprint sensor works just in the way you said.
Interesting. A side effect of installing PE is that it replaced TWRP with the PE recovery, which is much more limited. I suspect it's best to leave that in place. I haven't tried booting TWRP from the computer yet, but I hope I can do that to create nand backups.
 

abhi0502

Senior Member
Dec 3, 2013
912
486
Mumbai
OnePlus 7 Pro
USB File Transfer dosent work, the device dosent show up in my pc nor adb works. but when i go into recovery mode (TWRP) the usb file transfer works just fine, any ideas why this is happening.
Try this method it will work

Only the first step is different - select kedacom USB Devic

 
  • Like
Reactions: GamerX2010

Top Liked Posts