• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][11.x]Havoc-OS-4.8[UNOFFICIAL][Suzuran]

Search This thread

DevelLevel

Senior Member
Report: Awesome ROM! Thank you, passes SafetyNet now! The only thing left to fix is fingerprint sensor, still not working on 4.3
Nice to hear,
But the fingerprint sensor is working, the problem is that the fingerprint wakelock or something does not get enabled at boot time, the times I were able to start the service, it worked without any issues until I rebooted the phone, of course...
I have successfully started the fingerprint sensor by: waking the phone up after deep sleep with double tap on the screen. And when trying to create a fingerprint in settings... but it does not work every time, it is unreliable. In the same way as Arrow-OS messages and calls works unreliable, it works sometimes :(
 

udaemon

Member
Aug 11, 2020
13
7
Hello DevelLevel

When listening to music with bluetooth earphones
It's much lower in volume than Lineage-OS 18.1.
I tried it on the same phone. 
this may have to do with the fact that Berni changed some audio settings in his LOS18.1 rom, have a look at the 1st post. also the topic has been taken up several times throughout LOS14, 17 and 18 threads. you could search these for "mixer_paths.xml" for example to find further info.
 
  • Like
Reactions: DevelLevel

udaemon

Member
Aug 11, 2020
13
7
thanks again, @DevelLevel for your work on this rom!
still find it odd that gapps are required for basic actions like setting up style but, of course, that's not in your sphere.
does anybody know if and how one can set/adjust the way the notification-led works? in LOS18.1 there's a particular entry in the settings but in havoc I can't find it and I would like to adjust it.
thanks!
 
  • Like
Reactions: DevelLevel

VBBoston

Senior Member
Nov 9, 2015
156
29
Nice to hear,
But the fingerprint sensor is working, the problem is that the fingerprint wakelock or something does not get enabled at boot time, the times I were able to start the service, it worked without any issues until I rebooted the phone, of course...
I have successfully started the fingerprint sensor by: waking the phone up after deep sleep with double tap on the screen. And when trying to create a fingerprint in settings... but it does not work every time, it is unreliable. In the same way as Arrow-OS messages and calls works unreliable, it works sometimes :(
Hopefully it can be resolved.
In addition to fingerprint sensor I noticed there are no LED indicators when charging (red, yellow, green)
 
Last edited:
  • Like
Reactions: DevelLevel

DevelLevel

Senior Member

DevelLevel

Senior Member
Hopefully it can be resolved.
In addition to fingerprint sensor I noticed there are no LED indicators when charging (red, yellow, green)
Strange, when I charge my phone with OS on, I get red charging indicator when under 40%. Then yellow but not green. It stays red when charging without OS booted. But this should be a kernel issue. I'll see what I can find...
 

DevelLevel

Senior Member
thanks again, @DevelLevel for your work on this rom!
still find it odd that gapps are required for basic actions like setting up style but, of course, that's not in your sphere.
does anybody know if and how one can set/adjust the way the notification-led works? in LOS18.1 there's a particular entry in the settings but in havoc I can't find it and I would like to adjust it.
thanks!
Then it probably isn't a feature in this ROM :(
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    hmm maybe it's because I used a third party home app. I did some testing and rebooted several times but there was no clear button, or I missed something maybe, not sure.
    1
    thanks for confirming android auto works!!! Going to give it a shot now........ hopefully the camera is better than the berni build at this point (re: auto focus); stoked to try out some of the goodness baked into the feature sets.

    love seeing devs continuing to work on this device - huge thanks for the recent update.
    1
    24hrs running Havoc ROM and it runs beautifully with android 11.. really awesome to see on such an older device - thanks again for the great work.

    Confirming I flashed the relevant gapps after ROM flash, went through the first boot steps flawlessly, allowed Google and Android Auto to update from the play store before first reboot, and the car Android Auto setup completed equally flawlessly - great stuff!

    All that said, still at a loss how we have gone from best-in-class camera for this device (half the reason I chose a SOny device) to a completely broken camera that won't auto focus and produces barely acceptable photo images given today's standards. What's the blocker here with fixing the camera and why is nobody working on this?
    1
    thanks for confirming android auto works!!! Going to give it a shot now........ hopefully the camera is better than the berni build at this point (re: auto focus); stoked to try out some of the goodness baked into the feature sets.

    love seeing devs continuing to work on this device - huge thanks for the recent update.

    24hrs running Havoc ROM and it runs beautifully with android 11.. really awesome to see on such an older device - thanks again for the great work.

    Confirming I flashed the relevant gapps after ROM flash, went through the first boot steps flawlessly, allowed Google and Android Auto to update from the play store before first reboot, and the car Android Auto setup completed equally flawlessly - great stuff!

    All that said, still at a loss how we have gone from best-in-class camera for this device (half the reason I chose a SOny device) to a completely broken camera that won't auto focus and produces barely acceptable photo images given today's standards. What's the blocker here with fixing the camera and why is nobody working on this?
    First of all I have stated many times that I'm using the same camera blobs as berni (because they are the only ones which work on android versions higher than 7.x) which should reproduce the same experience as bernis ROMs. And there are lots of people working on this issue, it isn't like we don't care!
    The blocker is the proprietary camera blobs provided by SONY, they are not open source so it is almost impossible to adapt code for newer android versions.
    We are lucky that berni and some other developers were able to even get the camera to work. You'll need to remember that we do this on our free time, and we are not working for SONY...
    1
    First of all I have stated many times that I'm using the same camera blobs as berni (because they are the only ones which work on android versions higher than 7.x) which should reproduce the same experience as bernis ROMs. And there are lots of people working on this issue, it isn't like we don't care!
    The blocker is the proprietary camera blobs provided by SONY, they are not open source so it is almost impossible to adapt code for newer android versions.
    We are lucky that berni and some other developers were able to even get the camera to work. You'll need to remember that we do this on our free time, and we are not working for SONY...

    Please check post histories before prompting reminders on context - the first words out of my mouth are always "THANK YOU FOR THE WORK!" - hyper aware this is a side project for the folks who do dev work here. I'm not a junior member and have been posting here for about a decade, thanks.

    I guess my surprise at the camera remaining unfixed over such an extended time is that all of the dev work that I see here is quite good, and what one person lacks as an individual, I've seen teamwork compensate for in sharing and tackling blockers together. So when months (years) go by and an issue as substantial as broken camera remains, it does encourage the presumption that it's been given up on, vs being "un-blockable".

    Thanks for the longer reply; the context and info are helpful.
  • 8
    havoc.png

    Disclaimer:
    I am building this ROM in my spare time,
    feel free to report bugs and things that do not work but I may not be able to fix does.
    I just wanted to share my project.
    I am not responsible for any bricked or faulty devices!

    Description:
    "Havoc-OS 3.x is based on AOSP, inspired by Google Pixel.
    Has a refined Material Design 2 UI crafted by @SKULSHADY.
    So many features that you probably won't find in any ROM.
    All you can dream of and all you'll ever need.
    Just flash and enjoy..."
    Team Havoc

    Key Features:
    Android version: 11.x
    Kernel version: 3.10.108
    Security patch: 2021-08-05
    Selinux: Enforcing

    Working:
    WIFI, Bluetooth, Location, Camera, Calls, SMS, etc

    Not Working:
    The fingerprint sensor is unreliable, you tell me

    Flashing:
    Flash TWRP
    Reboot to recovery
    Wipe
    Flash Havoc-OS
    (Optionally flash Magisk/Gapps)
    Reboot

    Downloads:
    Gcloud
    Mega

    Sources:
    Kernel
    Suzuran
    Kitakami-common

    Credits:
    Everybody who is involved in the Havoc-OS and LOS development.
    @Berni-0815 and other msm8994 kitakami developers who made this possible for our phone.
    (If you feel that you should be listed here too, just tell me.)​
    3
    New release!

    2021-04-08
    -Upstreamed Havoc-OS sources to version 4.3
    -Security patches updated to 2021-03-05
    -Safetynet passing
    -Implemented Kcal display driver, Thanks to @savoca
    -Implemented Adreno idler, Thanks to @arter97
    -Implemented "zen" and "fifo" i/o schedulers, Thanks to @GreyLeshy
    -Implemented "Chill" and "BioShock" governors, Thanks to @GreyLeshy
    -Implemented Boeffla-wakelock-blocker, Thanks to andip71 @ github.com
    3
    Hello
    Thank you for your tireless efforts.
    Your rom is fine and I really like it.
    However, it fails to SafetyNet authentication.
    Please tell me how to succeed.
    Best regards.
    I don't know how to succeed yet, but I am working on it. Sadly it does not help by changing the fingerprint...
    3
    New release!

    2021-06-10
    -Security patches updated to 2021-05-05
    -Upstreamed Havoc-OS sources to version 4.5
    -Upstreamed Device trees and kernel from @Berni-0815 (Thanks!)
    3
    anyone successfully using android auto with this? Would love to try the build, but hate breaking a perfect setup to experience new bugs and ultimately revert.

    Any qualitative feedback on the camera performance?? Is it "like stock" as an AOSP rom, or "exactly stock" ?

    Thanks to devs for the work!!!

    I have not tried android auto with this ROM, but I can maybe test it during this week if I got time. Camera performance is the same as if you would use @Berni-0815's lineage 18.1, because i'm using his blobs (thx!). I would describe it as a little bit worse (due to proprietary stuff) than the stock Sony ROM, but not much worse:)

    np
    I can now confim that Android Auto is working fine on this ROM :cool: