• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM][11.x][UNOFFICIAL][GApps][OTA] LineageOS 18.1 for Xperia Z1 (C6903) [2021-07-13]

Search This thread

daviiid99

Senior Member
Apr 1, 2021
71
52
WhatsApp was successfully installed and working on 2021-05-11 version. Then I installed 2021-05-28 and got an issue with boot logo - instead of one word SONY got a string of NY SONY SONY SO and desided to make a factory reset with 2021-06-12 version. WhatsApp says the support doesn't work with custom ROM but it was the first time too and was working good. Not sure the cause, just googled it could be not appropriate device fingerprint.
And still have an issue with boot logo but it's not a big problem.
The Sony logo thing will be fixed in the next release,

The fingerprint used in this rom looks okay to me, I didn't touch it Sony/C6903/C6903:5.1.1/14.6.A.1.236/2031203603:user/release-keys

I'm the next update I'll update some vendor files you can try it and check If it fixes the Whatsapp issue
 
Last edited:

Zigvard

Member
Jun 12, 2021
9
6
The Sony logo thing will be fixed in the next release,

The fingerprint used in this rom looks okay to me, I didn't touch it Sony/C6903/C6903:5.1.1/14.6.A.1.236/2031203603:user/release-keys

Maybe you're not using a C6903?
Thanks for that!
It's for sure C6903. Now think that the problem could be in on of Magisk module I've installed before login to WhatsApp like WebView manager.
 
  • Like
Reactions: daviiid99

daviiid99

Senior Member
Apr 1, 2021
71
52
Check OP for instructions to get Play Certified license with Z1
Screenshot_20210615-135744_Google_Play_Store.png
 
WhatsApp was successfully installed and working on 2021-05-11 version. Then I installed 2021-05-28 and got an issue with boot logo - instead of one word SONY got a string of NY SONY SONY SO and desided to make a factory reset with 2021-06-12 version. WhatsApp says the support doesn't work with custom ROM but it was the first time too and was working good. Not sure the cause, just googled it could be not appropriate device fingerprint.
And still have an issue with boot logo but it's not a big problem.
I never got banned by whatsapp. But yes, i got alert for using custom ROM. But, until now its fine.

Do you rooted ur phone? Or do you often reinstalling whatsapp?
 

daviiid99

Senior Member
Apr 1, 2021
71
52
I never got banned by whatsapp. But yes, i got alert for using custom ROM. But, until now its fine.

Do you rooted ur phone? Or do you often reinstalling whatsapp?
Magisk is no longer maintained so I'll not recommend it anymore.

I'm also using the ROM for testing purposes and I didn't face any problem with whatsapp too
 

daviiid99

Senior Member
Apr 1, 2021
71
52
How to remove gapps?
Remove the gapps will bring back some issues like missing sounds

You can build yourself with manifest
I can't download the rom, I get an error when reaching 70% and then it seems forbidden
Maybe there's a problem with your network
Try to keep the screen on downloading the OTA file or you can download the latest file from Here and flash it manually with LineageOS recovery
 

8000cilindros

Member
Oct 30, 2014
21
5
I have already been able to install the rom, I only found 2 problems in it
1. in games the touch screen fails, it does not detect well when you touch the screen (it only happened to me while I was playing).
2. the stereo speaker.
I have not had any problems in everything else.
 
  • Like
Reactions: daviiid99

bingoSexy

Member
Nov 20, 2008
19
2
Thanks for the updates David! The phone now works great! I am however trying to get the phone certified in play store using the link on XDA you've provided. I believe I am able to register the phone via Google Services Framework (I don't get an actual confirmation, it only says the phone has been registered.) but even after a reboot of the phone it still says uncertified device in play store.

Would it have anything to do with how I applied the update? I downloaded the new version from 15/6 and moved it to internal storage. I then used Lineage recovery to install the update. After that I rebooted the device.
I am used to TWRP and the prodecure of clearing cache, dalvik etc. for my non-xperia devices but I fail how to do this in Lineage recovery? Do I need to factory reset the device?

Thanks!
 
  • Like
Reactions: daviiid99

daviiid99

Senior Member
Apr 1, 2021
71
52
Thanks for the updates David! The phone now works great! I am however trying to get the phone certified in play store using the link on XDA you've provided. I believe I am able to register the phone via Google Services Framework (I don't get an actual confirmation, it only says the phone has been registered.) but even after a reboot of the phone it still says uncertified device in play store.

Would it have anything to do with how I applied the update? I downloaded the new version from 15/6 and moved it to internal storage. I then used Lineage recovery to install the update. After that I rebooted the device.
I am used to TWRP and the prodecure of clearing cache, dalvik etc. for my non-xperia devices but I fail how to do this in Lineage recovery? Do I need to factory reset the device?

Thanks!
You need to wait
You'll know that your device is certified when Play Store is unable to update apps and then you just need to wipe Play Store app data and voilá, your device is certified now :)
 
Last edited:

8000cilindros

Member
Oct 30, 2014
21
5
Remove the gapps will bring back some issues like missing sounds

You can build yourself with manifest

Maybe there's a problem with your network
Try to keep the screen on downloading the OTA file or you can download the latest file from Here and flash it manually with LineageOS recovery
at last I was able to install the rom, just one question will you have the file for stereo speaker?
Thanks
 

Top Liked Posts