[ROM] [12.0.0_r2] ArrowOS Poco X3 [BETA/EARLY RELEASE]

Search This thread

pnin

Senior Member
Well it looks like I've bricked the phone. I downloaded the latest miui fastboot version, 8.4gb extracted,12.5.4.0, extracted it to a folder on my PC. I then booted the phone ito fastboot, connected it, got the windows jingle, found the device in miflash (latest version), loaded the rom, set miui to clean all, then started the flash. It was green, ran for a few seconds and then failed. I tried several times and nothing but failures. Changed usb cables, different usb ports, nothing worked. Since it failed I tried to reboot (mistake), nothing happened and the screen is black. I get the windows jingle when I plug the phone into a USB, but no device shows in This PC. Plugging it in and out in device manager does give a windows prompt, but no phone shown and can't find the device. Adb devices shows nothing.
Is there anything I can do with this phone to recover?

As I haven't tested any of this, best I can do is point you to my saved related resources:




 
Last edited:

idiarik1234

Member
Jan 8, 2015
32
2
I can't seem to enter recovery after flashing the latest build, it keeps flashing the twrp splashscreen then the screen goes off.
 

Areck83

Member
Apr 1, 2016
23
2
HTC One (M9)
Xiaomi Poco X3 NFC

m0han

Senior Member
Apr 30, 2012
4,798
1,890

jjcdennis

Senior Member
Jun 20, 2015
502
102
Toronto
As I haven't tested any of this, best I can do is point you to my saved related resources:




Thanks for the help pnin. After a long day of messing around, I've given up. In trying to enter EDL again, the battery strap came down on a chip...puff of smoke...the usb connection is baked. When the phone is connected via usb it disconnects the device in the next port. I will look for an X3 Pro or GT down south.
 
Last edited:
  • Wow
  • Sad
Reactions: qu38mm and pnin

Undogmatic

Member
Jul 4, 2021
16
12
Those who need twrp-3.6.0_10-0-surya.img or twrp-3.5.2_10-12-surya-a12.img can find them reuploaded here by @paradøx , just click the desired version:

Note: both are compatible with Android 12, but you MUST first disable the screen lock password/PIN/pattern before booting into recovery, otherwise these TWRP won't be able to decrypt the data.
I uploaded latest brigudav's TWRP 3.6.0_10-0 and 3.5.2_10-12.
 
Last edited:
  • Like
Reactions: temporarium

m0han

Senior Member
Apr 30, 2012
4,798
1,890

Attachments

  • Screenshot_20211203-222544_Chrome.png
    Screenshot_20211203-222544_Chrome.png
    189.8 KB · Views: 30

wCk32d7

Senior Member
Jun 22, 2021
58
11
Hi

Is there already any TWRP for Android 12 that can decrypt data when I have set a password ?

I wanted to update today to the latest version of Arrow OS 2021-11-30

Since the current build of Arrow OS doesn't have OTA update feature so I have to update manually via TWRP

But if I want to get into TWRP I have to remove the PIN / Password to decrypt the data.

But if I remove the PIN / Password it also deletes the fingerprint that I have stored in several apps.

( Then I would have to set the fingerprint again for all apps )

Thank you.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    Points of view man, I understand your opinion but I prefer to stay completely decrypted :)
    Couldn't stand the risk. I have never lost my phone so far, but with all the 2FA, banking and wallets on my phone, having it unencrypted would be unthinkable.
    3
    To anyone complaining about TWRP decryption for OTAs

    Once the ROM is installed for the first time, flash ArrowOS Recovery.

    OTA updates will now work flawlessly and automatically, without needing to be decrypted.
    No entering passcodes, nothing, it just reboots, installs the OTA then boots up again.
    TWRP 3.6.1-11 by brigudav installs Arrow 12 OTAs without any problems for me
    2
    If I already have arrow os installed with a newer twrp can I simply flash this img in twrp to downgrade or should I use the adb method? And will a wipe be necessary to decrypt my phone?
    Yes, you can downgrade TWRP by flashing an older version.

    For example, if you are currently running the latest version of TWRP (twrp-3.6.1_11-1-surya_20.04.img). You can flash downgrade older version TWRP (twrp-3.6.0_10-1-surya-15.12.img).

    Be aware the older version TWRP (twrp-3.6.0_10-1-surya-15.12.img) decrypts ArrowOS 11 Only! It does not decrpyt ArrowOS 12 or ArrowOS 12.1

    There is currently no version of TWRP that decrypts Android 12/12.1 as far as I know!
    2
    Thanks to the programmers who are always on the move and who feed their passions. I write all my impressions and everything I noticed in the first 5 days of use
    I have recently installed Arrow 12 latest version sil little x3 nfc version with gapps.
    In daily use and in personal settings I noticed some bugs:
    -in the emergency information I can not add emergency contacts.
    -there is an app for crypto that I use often that should be unlocked even with the fingerprint sensor but it does not work.
    -unlocking with face is not present or I can't find it
    -I must emphasize, that the battery has a long life
    -I would have preferred a more complete gcam type gcam 8.4 latest

    Thanks again
    To help everyone, you can report bugs to this ROM better.

    2
    I am about to do the same process as yours. Likely with cherish os [from android 11 to 12L]. These are my steps:

    1) collect and backup stuff for restore and in case something goes completely wrong:

    - system: your current ROM zip file, double check that this zip file is not corrupt!!! If you don't have, take the MIUI fastboot ROM that is arond the date as your Arrow OS custom ROM [ https://xiaomifirmwareupdater.com/archive/miui/surya/ ] and find out how to flash. Double check this with the info you find in 'About phone' details. This is important, as your phone can have MIUI vendor [as in my case] or OSS vendor firmware.

    - data:
    Remove pin/pattern and fingerprint from your phone.
    'Fastboot flash recovery' the latest twrp and check you can boot and decrypt after reboot to recovery. See video in step 2 which twrp is latest
    Backup data/boot partition in twrp, incl internal storage. check that google one backup has been done. As an extra resort, install magisk and swift backup and backup your apps with data. Move all this stuff to external storage e.g. usb, sd or pc.

    2) preps for flashing:
    - watch this video on process how to flash with what [
    ]
    - collect stuff what to flash [see video]: latest firmware [check https://xiaomifirmwareupdater.com/archive/firmware/surya/ ] depending on your phone], arrow os

    3) flash the stuff according to video, but at end don't reboot to system

    4) in twrp: Restore data partition incl internal storage from usb otg or sd card. rename data/mediaxxx. Check in file manager that internal storage files and directories are readable. Reboot to system

    5) fingers crossed and check that your phone has started correctly and running as before. Add fingerprint and pin and check if your banking apps and google pay are running as before. It may be that you have to configure these apps manually, depending on the app.

    Good luck!
    Beware: cherish os doesn’t have phone encrypted by default. I think some of the performance is coming fo due to that
  • 36
    logo.png

    ArrowOS

    Code:
    /*
    * We are not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at us for messing up your device, We will laugh at you.
    * It is your fault because you chose to do all the modifications on your device.
    * Remember projects like these and the work done on them is a hobby to the
    * contributors and the team members, no one is working for you nor is getting paid for it
    * have some respect for the work done by them since it is done purely on interest or a hobby
    */

    ABOUT
    ArrowOS
    is an Android Open Source Project based Android mobile operating system started with the aim of keeping things simple, clean and neat.

    Website: https://arrowos.net
    Telegram: Channel | TG Portal/Links
    Github: https://github.com/ArrowOS
    Code Review: review.arrowos.net
    E-mail: arrowos.contact
    PayPal: Donate to us
    Blog: blog.arrowos.net

    Checkout more documentation at (maintainership/contributing): Check this out

    WHAT WORKS?
    • Almost everything

    WHAT DOESN'T WORK?
    • You tell me
    Be sure to include a log : check how to

    DOWNLOADS
    Click here to Download
    Tip: Select OEM -> Device,choose Arrow version, choose build type: "GAPPS" or "VANILLA" to download.

    Read our blog article/post about:
    * HOW-TO report a bug
    * GAPPS and VANILLA variants
    * Checking build integrity

    GPL compliance:
    ROM Source
    - https://github.com/ArrowOS
    Kernel Source- https://github.com/ArrowOS-Devices/android_kernel_xiaomi_surya.git
    15
    Note:

    - Clean flash is required to avoid any issues.
    8
    ygb7 said:
    My Clean flash of Arrow-v12.0-surya-OFFICIAL-20220123-GAPPS.zip still shows only Screenshot at the bottom of the recents window.

    Where in the launcher settings? I do not see any recents setting at all in the default Lawnchair launcher settings
    It's in the launcher settings.

    Zzenyoo,

    Thank you very much for showing me how to enable the Clear All Button At the Bottom of the Recents screen for ArrowOS 12 - Arrow-v12.0-surya-OFFICIAL-20220123-GAPPS.zip

    I feel really stupid & highly embarrassed that I was not able to figure this out for myself. The answer was right in my face & I did not see it. I am truly humbled. Thank you again for your patience & your reply.

    I included procedures & screenshots below to help anyone else that may want to turn on or off the Clear All Button At the Bottom of the Recents screen for ArrowOS 12.

    Procedure
    1. Long press any blank space on the Lawnchair Launcher screen
    2. Select Home Settings from the menu
    3. Select Recents from the Settings menu
    4. Select Clear All Button at Bottom button
    5. Verify by selecting recents buttons at very bottom of screen. Clear all will now show at the bottom of the screen instead of the extreme left of the recents screen.
    Screenshots

    ss1.jpg


    ss2.jpg


    ss3.jpg
    8
    Moderator Announcement

    Thread has been cleaned. I'd appreciate if "unsuitable" posts are only reported but not replied to.

    And allow me a personal remark: I've recognised some impatience in the reports. Please be aware that ALL moderators are volunteers who are doing this "job" absolutely for free besides our real life, real family and friends, real business and occupation. This means we aren't always able to immediately react to a report but I promise and can assure you, we do our very best that every report is handled as soon as possible. Thanks for your understanding.

    Regards
    Oswald Boelcke
    Senior Moderator
    8
    Everything is working fine so far. The only issue is that the fingerprint scanner acts as some sort of "enter" key. Does anyone know how to make it ignore accidental touches?

    I managed to fix the annoying fingerprint issue (the one reported above by me, and by other users on the first few pages of this thread). The fingerprint sensor was acting like an "enter key" whenever I touched it, which was quite annyoing).

    It was fixed after completely restarting the whole process, by reflashing the latest MIUI rom (12.5.3 Global) and then repeating all the steps to install ArrowOS. Here's a list of steps, if you're having the same issue or any other issues that might pop up for just some users:

    1 - Use MiFlash20210226 to flash the ROM downloaded from xiaomifirmwareupdater website:

    "MIUI V12.5.3.0.RJGMIXM Stable Official Update for POCO X3 NFC Global (surya)"

    The archive name is: surya_global_images_V12.5.3.0.RJGMIXM_20211013.0000.00_11.0_global_9eca9fae68.tgz
    Size: 5.2 GB (it's the fastboot type, not the recovery type).

    Note 1: if you don't know how to do this, look for "[GUIDE]⚙ USE XIAOMI FLASH TOOL" here on XDA, by user @NOSS8

    Note 2: It's normal to receive an error at the end when using the "clean all" option, right when the smartphone automatically reboots while flashing. As long as it's taking a while to flash all the necessary data, it should be fine.

    2 - Don't know if this is necessary, but I booted into the MIUI 12.5.3 system, skipped most configs, then I let it finish the initial configuration. Made sure it's the last update avaliable through OTA.

    3 - Reboot into fastboot (hold power +volume down).

    4 - I used the "Minimal ADB and Fastboot" tool in order to use the fastboot command to flash the latest TWRP compatible with Android 12 by @brigudav
    Currently, the file is called: twrp-3.5.2_10-12-surya-a12.img and you can find it here on XDA.

    Note: Boot into TWRP right away after flashing it, don't let your smartphone boot into the MIUI or it'll be overwritten.

    5 - While in TWRP, go to WIPE > Advanced wipe > Select "Dalvik / ART cache" + "Cache" + "Data" and confirm the action.
    Press the home button to return to TWRP main menu.

    6 - While in TWRP, use "install" to flash the zip archive of the latest firmware package for MIUI V12.5.3.0 (Global).
    Currently, it's: fw_surya_miui_SURYAGlobal_V12.5.3.0.RJGMIXM_624ada8a33_11.0.zip also available through the xiaomifirmwareupdater website.
    Press the home button to return to TWRP main menu.

    Note: you can use your PC to send these zips into your smartphone's "Download" folder while in TWRP.

    7 - Also while in TWRP, use "install" to flash the zip archive of the latest official ArrowOS (Gapps version) with android 12.

    Note: Don't forget to go into WIPE > "format data", and typing "yes" to confirm, after flashing the ArrowOS Zip archive.

    8 - Reboot system and you're done.