[ROM][12.0][Alpha] DerpFest S for Mi A2 [OFFICIAL][Jasmine_Sprout]

Search This thread

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    BuIx4Um.jpg


    This is a small project based on AOSP. We try to be a platform for beginners and support the Custom ROM community with our own unique contributions as well. This ROM exists thanks to inspiration of AOSiP, Thank you! #StayDerped

    Code:
    /* Your warranty is now void.
    *
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.
    */

    Notes :

    GApps included,
    TWRP not included for now,
    Use Magisk Canary, &
    CLEAN FLASH IS ALWAYS RECOMMEND !!!



    Device-specific features
    - Initial build

    What's broken?
    You tell me!


    DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    If it is a random reboot, grab dmesg . (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues.



    IYoyzLd.png



    ROM: Gdrive
    Mirror: Sourceforge

    Magisk: Canary


    Follow us on Telegram for more support !!


    Credit/Thanks:



    Google for Android and AOSP

    LineageOS

    AOSiP

    AICP

    ABC ROM

    AquariOS

    BootleggersROM

    PixelExperience

    OmniROM

    Cory Collins

    ---------

    Any others we may have forgotten to credit

    And last but not the least, all our testers, who have helped us to squash many bugs so that we can try to release builds that as are flawless as possible




    Contributors @NurKeinNeid, @OdSazib, @kenny3fcb, @rcstar6696, @Clarencelol

    ROM source: https://github.com/DerpFest-12/
    Device sources: https://github.com/DerpFest-Devices/
    Kernel source: https://github.com/PradyX/unified_kernel_sdm660/tree/4.19
    4
    Hello! I'm here after 2 days of usage. Pretty stable ROM and for it's initial stage seems very good.
    It's usable as daily driver, but can be better. Battery is good (for Mi A2 standards). No major problems, sometimes a little bit too slow. No problems with Bluetooth, GPS or 4G/WiFi.

    With this post I'm trying to tell you about two "minor-major" problems I found in this build.

    Some details about phone and build I'm having:
    Model: Mi A2 (jasmine_sprout). Not converted 6X. Never replaced, never opened.​
    ROM: DerpFest, clean flashed (formatted everything). 26th Nov Build (SD1A.210814.036.A8)​
    ROOT: Yes, Magisk (with Zygisk)
    Bootloader: unlocked​
    Recovery: TWRP 3.3.1-0​
    Mods & others: Nova Launcher (I hate google bottom bar not being removable). For the rest I have a clean "Derp Android 12 UX". I just flashed the ROM, TWRP, Magisk and DISABLE_DM_VERITY.​
    Main Language: Italian​

    But now for the problems.

    1. Nuclear Power Plant Syndrome
    Named like this because of the insane reported amount of mA and W on the lock screen when charging. Don't know what is causing it. I attach also a logcat (logcat_nuclear_power_plant.txt) before putting in charge and when charging, maybe it will help. When rebooted it shows correct values for like 10 seconds, switching again to Nucler Power Plant immediatly after.
    nuclear_power_plant_small_1.png


    2. Big cores "not working" (?) [see also EDIT on 10th DEC]
    My big cores are all always at 1113Mhz and at 0% of use. They jump only for 1-5 seconds to 2208Mhz when opening an app, but then immediatly stops. This is very noticeable when opening SmartPack Kernel Manager. The cores are "sleeping" or they are not reported correctly. But doing things like recording screen and having SmartPack open caused a big slowdown of entire system. Also, when using heavier apps, like Coinbase that were very slow to open (even with my previous LOS 18.1) now are even slower (sometimes 40-50 seconds to load everything).

    EDIT 10th Dec
    I partially solved the problem restoring all settings on SmartPack Kernel Manager, uninstalling it and then rebooting the phone. I'm not telling this is the solution, but maybe is correlated. Is not "as before", but much better.

    Then, there are some problems that appeared in this two days, but was not able to reproduce them again. Just marking them out.
    1. Clock not being set on CENTER or RIGHT: it just disappeared when set to things others than "left". It happened just when I installed the ROM and immediatly went to settings. When I wanted to customize clock position it won't change. I tried to do this again and again but after a reboot it seems to working properly.
    2. Something crashed at first start. It was called "System Audio Synthetizer" or "Android Audio System" something like that. Never appeared again
    3. One time when turning on GPS, the UI crashed and all screen turn black. After 5 seconds the phone restarted the UI and everything worked. No reboot, just UI restart. I was not logcat-ing in that time, so I have no proof for this, other than my experience.
    4. The phone sometimes takes time to load emojis, like on Telegram. Maybe related to "Big Cores not Working"?

    I'll continue to monitor the situation. If you need details or wanna teach me how to catch more info about problems, let me know: this is the first time I'm doing something like this and I have no experience on doing this.