[ROM][12.1][OFFICIAL] ArrowOS 12.1 for OnePlus 7 Pro

Search This thread

bokchoi2020

Senior Member
Jul 24, 2013
379
242
Ottawa
OnePlus 3
OnePlus 7 Pro
Looks very good but my sensors aren't working either Accelerometer or light or compass. How can I fix this? I installed according to the instructions.
Sounds like maybe your persist.img is corrupted... Not sure if you have oneplus 7 pro or 7, but search for persist.img fix on xda, may be able to find the solution for it. I haven't had it happen to me, but saw it mentioned before.
 

Samo671

Member
Dec 7, 2020
19
6
OnePlus 7 Pro
Moto Edge 30 Pro
Sounds like maybe your persist.img is corrupted... Not sure if you have oneplus 7 pro or 7, but search for persist.img fix on xda, may be able to find the solution for it. I haven't had it happen to me, but saw it mentioned before.
Thanks for the information. Unfortunately I didn't manage it, so I'm back on OOS.
Tried to flash persist.img but it didn't work and you can lose your Widevine L1 if you flash it.
 

97hugo777

Member
May 28, 2018
47
4
I noticed a really tiny thing about the lockscreen, Should the date above the clock bebslightly higher? because seems like there are a lot of spare space above the main clock
 

TheJeff_08

Member
Jun 17, 2021
11
3
Hey everyone - I followed the directions in the OP but found that this ROM isn't recognizing Verizon SIM cards, there's no mobile data, and the phone wants to "finish setting up" and asks me to insert a sim. So I went to wipe and move to another ROM. Unfortunately I seem stuck with the Arrow recovery/boot. Every time I try to flash another boot.img or update to another ROM in recovery I get errors. I'll give an example.

Pulled boot.img from another ROM
fastboot flash boot boot.img
target reported max download sized of xxxxbytes (there's a # there...not relevant)
sending 'boot_b' (98304 KB)...
FAILED (remote: Download is not allowed on locked devices)
finished. total time: 0.006s

Long story short, for some reason my phone is unlocked, but thinks it's locked? Tried re-locking and unlocking, this temp bricked my device ("your device is corrupt and will not boot") but then I figured out the vol + and - combo to get back into fastboot to re-unlock, but am still having these issues.

Is there a way around this? Need my phone for work and unfortunately am in a bit of a bind!

Thanks for your help!

EDIT: should have pointed out that it won't let me switch between a/b either. When I got to try and switch it does the same thing where it thinks that I have a locked device and won't switch the partition over.

Double EDIT:
I had done "adb reboot fastboot" and instead what I should've done was use the recovery to reboot/enter bootloader. Everything is good to go =)
 
Last edited:

bokchoi2020

Senior Member
Jul 24, 2013
379
242
Ottawa
OnePlus 3
OnePlus 7 Pro
Hi alk3p or other rom builders, I tried to build arrow 12 guacamole (op7pro) but I get build error:
FAILED: Copy init script: /home/bokchoi/arrow_os/out/target/product/guacamole/obj/ETC/com.android.os.statsd.init.rc.com.android.os.statsd_intermediates/init.rc

host_init_verifier: Unable to serialize property contexts: Duplicate prefix match detected for 'vendor.camera.aux.packagelist'

These are the steps I did:
repo init --depth=1 -u https://github.com/ArrowOS/android_manifest.git -b arrow-12.0
repo sync -c
lunch arrow_guacamole-eng
m otapackage

Did I use wrong device for lunch?
Also if I want to build with gapps, do I use:
export TARGET_BUILD_GAPPS=true?

Thanks
 

alk3p

Senior Member
Sep 5, 2020
58
176
OnePlus 7 Pro
host_init_verifier: Unable to serialize property contexts: Duplicate prefix match detected for 'vendor.camera.aux.packagelist'
I've triggered builds on official jenkins & my server and didn't see this.
Please consider re-syncing your local repos.

export TARGET_BUILD_GAPPS=true?
export ARROW_GAPPS=true

Does this rom have the little button to quickly hide the navigation bar? I just upgraded to A11 and i all ready miss that feature the most. Why did 1+ or google remove that?
Arrow hasn't added this back yet. Literally, we perform complete tests on each change to ensure that builds pushed to users are clean and stable.

I saw that the December 5th build is reported as experimental, is there anything specific to our device to test?
Nope.
 
  • Like
Reactions: bokchoi2020

o0xalucardx0o

New member
Nov 27, 2021
2
0
I caught an interesting bug. On Microsoft Teams calls, I hear everyone like the chipmunks from the movie (squeaky voices). It is solved by rebooting, but temporarily, that is, I’m rebooting - I hear everything is fine, but the next day, again such nonsense
 

immppa

Senior Member
Dec 5, 2012
327
163
Joensuu
Thank you! i could install it but i can't load any config files, any suggestions?
Since Android 11, apps need permission to access all files (the config files in this case).

Go to your Android settings → Apps → Google Camera → Permissions → Files and Media access and select "Allow management of all files".
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    @alk3p Offline charging not working.... Merge has been made for paranoid android for this. It would be great if you look into this. Thank you.
    1
    alarm doesn't work when phone is switched off.
    Power-off alarm won't work with DeskClockGoogle.

    is ambient display option hidden in latest 12.1 build?
    Because i personally do not like double tap to show clock but i cant find a way to disable it
    Disable dt2w in Settings > Display > Tap to wake or st2w in OnePlus Settings > Touchscreen gestures > Single tap.

    Did this ever get fixed? I tried Arrow in January and wasn't working. Looks like your comment is the last one I can find in the thread referring to Verizon. Let me know if you've tried.
    Verizon is reported not working since Day 1. I've tried fixing apns and carrierconfig but users didn't see any difference. I'm quite sorry for that.

    Offline charging not working.... Merge has been made for paranoid android for this. It would be great if you look into this. Thank you.
    Offline charging works here and I'm sure it works on ArrowOS as well. Have you installed any mods or custom kernel?

    I can't find the options to change the resolution
    Not supported.

    and the refresh rate
    Disable "Smooth Display" in Settings > Display and make sure you haven't enabled "Force peak refresh rate" in dev options.

    and I think is very important because with 60 Hz and 1080 Full HD It's possible to improve battery duration.
    I don't think so.
    1
    Does everyone who have flashed this ROM actually go through the process of extracting the boot.img via Python???

    I heavily dislike working with code not because it's tedious, but because something always goes wrong, and today is no exception.

    I followed the instructions to a tee and did everything it told me, but yet still I get this error: SyntaxError: invalid character '·' (U+00B7)

    There is literally no '·' in the filename so I have no idea what it wants from me..... I give up.

    I do, I have jumped back and forth from this ROM (now I'm back on it).

    Always thought extracting the boot.img was tedious as well, why can't we just have a separate download link or something? I'm sure it would encourage more users to use this ROM.

    Nonetheless, I set up a python environment for the sake of extracting boot.img in case I need it for the future.

    Unfortunately I can't help diagnose errors (not proficient with python myself), but I found success by installing Anaconda, then installing the required libraries through there.
  • 30

    logo.png


    ArrowOS for OnePlus 7 Pro (guacamole)

    ABOUT

    ArrowOS is an AOSP/CAF based project started with the aim of keeping things simple, clean and neat.

    Website: https://arrowos.net
    Telegram: Channel | TG Portal/Links
    Github: https://github.com/ArrowOS
    Code Review: review.arrowos.net
    E-mail: arrowos.contact
    PayPal: Donate to us
    Blog: blog.arrowos.net

    Checkout more documentation at (maintainership/contributing): Check this out

    WHAT WORKS?

    Almost everything.

    Note: If you run into extremely laggy UX, launching the camera app might help.

    DOWNLOADS

    Click here to Download
    Tip: Select OEM -> Device, choose Arrow version, choose the build type: "GAPPS" or "VANILLA" to download.

    INSTRUCTIONS

    Read our blog article/post about:
    * HOW-TO report a bug
    * GAPPS and VANILLA variants
    * Checking build integrity

    ROM Source: https://github.com/ArrowOS
    Kernel Source: https://github.com/ArrowOS-Devices/android_kernel_oneplus_sm8150
    12
    Reserved.

    I didn't plan to write any Q&As but it seems necessary to drop some notes here. (Last updated: 2021-11-29)

    Q: How to flash?
    A: Extract the boot.img using payload dumper, flash it into your device via fastboot then reboot into recovery. ADB sideload the firmware, reboot to recovery and sideload again to ensure that both slots have been updated. Lastly, wipe the userdata partition and reboot to system.

    Q: Root solution?
    A: The canary variant of Magisk is recommended. Download and rename this file to .zip, then sideload it in recovery. Reboot to system and install the original app-debug.apk file.

    Q: How to preserve Magisk after an OTA?
    A: Install the OTA but do not reboot immediately. Open the Magisk app and tap the `Install to inactive slot` option.

    Q: Custom kernel?
    A: Play at your own risk. The only supported alternative is NeptuneKernel.

    Q: Ah! It's extremely laggy after a reboot, halp!
    A: Open the camera app and tell me if it's resolved.

    Q: Soft reboots on Netflix? (#325)
    A: Choose a color mode other than `Saturated` to activate HDR normally.

    Q: Why can't I find this feature...balabala...I saw it on Arrow 11.0
    A: Please, wait for ArrowOS team to bring them back.

    Q: Bug! Here's a bug!
    A: Upload the log or, describe the steps to reproduce, in detail.

    Q: Any support group?
    A: Here.
    10
    Since ArrowOS infra is temporarily available now, I'll drop an unofficial release here as a gift for you guys.

    Changelogs?
    - Latest SPL (aosp, kernel, vendor)
    - Switched to QTI bt (better latency & stability, aptX should be supported now)

    Download
    Global / CN Mirror

    md5sum: b67174492f85a6d0e2bc4ac737c92054

    Merry Christmas!
    8
    Can please somebody provide me a noob friendly flash instruction manual (exact steps to be followed)? I just bought a used OP7 Pro and it's the first time to flash a custom ROM on it. Thanks!
    The first Q&A here already gives all the necessary hints but let's go a bit more into detail. First of all, you need to download and successfully install (along with all its needed dependencies) Payload Dumper. I'll explain how to do it directly on your smartphone under Termux. It's just an adaptation of the guide that you can find here which didn't work out of the box for me, probably because of the different Termux version, this leading also to different versions for the packages, especially Python and its modules. I exclude mistakes by the original writer instead.
    Just a couple of hints before beginning... When you would update the sources for the packages it would ask you for just one confirmation (I couldn't avoid it, at least to my knowledge): just press enter (which means choosing the default selection) and it would go on with the process. For what concerns the commands which would follow in my guide, you can just copy and paste them from here or complete them with the TAB key you find just above the keyboard under Termux (if you've ever used a terminal, you know what I mean).
    1. Download the latest ArrowOS 12 rom here (please don't forget to select the right version because the defualt selection is ArrowOS 11, at least for now)
    2. Extract payload.bin from the downloaded archive (the built-in file manager app is just enough) and leave it in the "Downloads" folder
    3. Download Termux here and install it
    4. Load Termux and issue these commands:
    5. Code:
      termux-setup-storage
      apt update && apt upgrade -y
      pkg install python2 -y
      pip2 install --upgrade pip
      cd storage/downloads
      pkg install wget -y
      wget https://github.com/vm03/payload_dumper/archive/refs/heads/master.zip
      unzip master.zip
      cd payload_dumper-master
      pip install -r requirements.txt
      pip install backports.lzma
      python2 ./payload_dumper.py ../payload.bin
    6. As we need only boot.img, don't let the whole process to complete. Just press CTRL (above the keyboard under Termux) then the c key
    7. Assuming you're on Windows, download and install this
    8. Transfer the so extracted boot.img (you find it in the "output" folder inside the parent folder "payload_dumper-master" which, in its turn, is inside the "Downloads" folder on your smartphone) to your pc putting it inside the folder where Minimal ADB and Fastboot has just been installed (Windows UAC will ask you for confirmation, just say yes)
    9. Press WIN+R then write cmd and confirm with enter. After that, put your OP 7 Pro in fastboot mode and issue these commands:
    10. Code:
      cd "%ProgramFiles(x86)%\Minimal ADB and Fastboot"
      fastboot flash boot boot.img
    11. Reboot your OP 7 Pro into the now installed ArrowOS recovery and follow the instructions of post #2 from this thread which I've linked at the very beginning
    If you don't know how to put your OP 7 Pro into fastboot and recovery modes, just make a Google search and you'll find tons of tutorials.
    It has taken a lot for me to write this step by step guide and I can confirm it is perfectly fine so, should something go not as expected, please read it again because there aren't mistakes in it. Have a nice day! :)
    8
    Adaptive brightness and other sensor-related issues have been resolved in 20211102 build.
    SELinux is enforcing now, and Safetynet check passes out of the box.