[ROM][12][gauguin][OFFICIAL] LineageOS 19.1 | Mi 10T Lite / Mi 10i / Redmi Note 9 Pro 5G

Search This thread

samhhmobil

Senior Member
May 25, 2017
467
234
Hamburg
Probably a bug: I think "Disable Animations" option doesn't work.

Setting: > Accessibility > enabling "Remove animations" does nothing.
Sorry, I cannot confirm that.

For me it does exactly what it should do: it switches off exactly the (small) animations of the system for different events.

So, this switch (enable on/off) is working.

samhhmobil
 

drebin54

Member
May 16, 2022
40
14
hi everyone, i've a question. Have you too this problems of message. The notification is present but the message are not present?
 

alexrsj

Member
Jan 11, 2011
21
9
Madrid
hi everyone, i've a question. Have you too this problems of message. The notification is present but the message are not present?
No, I don't.

Do you have a lock screen enabled? I think there's a setting to avoid showing the messages if you have enabled the lock screen. Maybe it's because of that.

I've another issue: the screen lights ON whenever I get a notification (even from email, SMS, whatsapp, telegram...). I don't want that (i.e: I want to receive messages and notifications on time, but not have the screen to turn on every time). Is it possible to turn that feature OFF?
 

drebin54

Member
May 16, 2022
40
14
No, I don't.

Do you have a lock screen enabled? I think there's a setting to avoid showing the messages if you have enabled the lock screen. Maybe it's because of that.

I've another issue: the screen lights ON whenever I get a notification (even from email, SMS, whatsapp, telegram...). I don't want that (i.e: I want to receive messages and notifications on time, but not have the screen to turn on every time). Is it possible to turn that feature OFF?
I don't know if this is possible. Have you tried the launcher notification settings and lock screen notifications?
 

j-t-z

New member
Dec 22, 2022
2
0
Warsaw
Sometimes system ui(?), will freeze for a couple of seconds (touch doesn't work and the clock stops), any advice?
I don't see anything in the logs
 
Last edited:

Tbronl

New member
Jan 18, 2013
1
2
Sometimes system ui(?), will frizz for a couple of seconds (touch doesn't work and the clock stops), any advice?
I don't see anything in the logs
Yes from time to time it happens, including when using the browser. I haven't found any solutions yet.
I've also experienced these freezes when using web-browsers. For me, disabling 'Smooth Display' in the display options fixed this (at the expense of using a lower refresh rate).
 

j-t-z

New member
Dec 22, 2022
2
0
Warsaw
I've also experienced these freezes when using web-browsers. For me, disabling 'Smooth Display' in the display options fixed this (at the expense of using a lower refresh rate).
Yes from time to time it happens, including when using the browser. I haven't found any solutions yet.
I disabled "Smooth Display" and enabled "Force peak refresh rate" in the developer
options (forced 120hz), we will see how it goes
 

Burgeruking

Senior Member
Sep 22, 2017
143
35
Sorry, but not all banking apps working. Most of them say "sorry, device is rooted or error about security problems". Safetynet test fails with "cts profile match problem". Maybe thats because of NikGapps, but I doubt it.
 
  • Like
Reactions: ntelas

datmir

Member
Mar 8, 2018
40
14
if you use root+magisk and banking apps:

 
  • Like
Reactions: Burgeruking

Burgeruking

Senior Member
Sep 22, 2017
143
35
if you use root+magisk and banking apps:

No, device is not rooted. Only clean install of LineageOS+Nikgapps omni latest version. I dont see a point for myself of rooting my phones.
 

Falar85

Member
Jan 5, 2015
46
17
In order to banking apps don't detect root:
I use the microG version of this ROM to make apps that require it think there are Google services on the phone. I then do a root with the help of Magisk. I use the option to hide Magisk app and I use the Shamiko module. Then after installing the apps (e.g. banking apps) I mark them on the DenyList, select Enforce DenyList and restart the phone. I test many banking apps and so far they all work. It's important not to run the app before setting the Denylist and restarting the phone (or if you have done so, clear the app data and log back in).
 
  • Like
Reactions: Burgeruking

samhhmobil

Senior Member
May 25, 2017
467
234
Hamburg
No, device is not rooted. Only clean install of LineageOS+Nikgapps omni latest version. I dont see a point for myself of rooting my phones.
Some Apps detect the unlocked Bootloader (and the custom ROM) and for them this is enough to stop working and saying: your phone is rooted (even if it is not).

So you need mechanisms to hide that (AFAIK you need!! root to establish such hide mechanisms).

samhhmobil
 
  • Like
Reactions: Burgeruking

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Sorry, but not all banking apps working. Most of them say "sorry, device is rooted or error about security problems". Safetynet test fails with "cts profile match problem". Maybe thats because of NikGapps, but I doubt it.
    1
    if you use root+magisk and banking apps:

    1
    In order to banking apps don't detect root:
    I use the microG version of this ROM to make apps that require it think there are Google services on the phone. I then do a root with the help of Magisk. I use the option to hide Magisk app and I use the Shamiko module. Then after installing the apps (e.g. banking apps) I mark them on the DenyList, select Enforce DenyList and restart the phone. I test many banking apps and so far they all work. It's important not to run the app before setting the Denylist and restarting the phone (or if you have done so, clear the app data and log back in).
    1
    No, device is not rooted. Only clean install of LineageOS+Nikgapps omni latest version. I dont see a point for myself of rooting my phones.
    Some Apps detect the unlocked Bootloader (and the custom ROM) and for them this is enough to stop working and saying: your phone is rooted (even if it is not).

    So you need mechanisms to hide that (AFAIK you need!! root to establish such hide mechanisms).

    samhhmobil
    1
    I mean what's your setup cause I'm on lineage too but I'm not getting it and i don't want to go back to stock.
    It worked from the start, right after flashing the LOS. You just set the preferred network type to 5G (NR). Make sure that the operator in your service variant provides 5G, as this is not the rule. Sometimes an additional paid plan is needed.
  • 15
    Lineage brand guidelines.jpg

    Code:
    * Your warranty is now void.
    *
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.

    LineageOS 19.1 for Mi 10T Lite / Mi 10i / Redmi Note 9 Pro 5G [gauguin]

    What is this?


    LineageOS, an open-source Android distribution, is available for several devices,
    with more being continuously added thanks to the biggest, yet ever growing, Android open-source community.
    Join us and breathe new life in your device, be it old or new.

    What's working?
    Wifi
    RIL
    Mobile data (5G NSA/SA, LTE+/LTE, 3G, 2G)
    GPS
    Camera
    Flashlight
    Bluetooth
    Fingerprint
    Lights
    Sound/vibration
    NFC
    DRM L1
    SELinux Enforcing
    OK Google

    Known issues
    You tell me

    How to Install?
    https://wiki.lineageos.org/devices/gauguin/install

    Download Link
    LiineageOS Website

    Big Thanks
    LineageOS Team
    TH779
    And Of Course To All The Supporters, Testers And Users

    Redmi Note 9 Pro 5G | Mi 10i | Mi 10T Lite Telegram Community

    Updates Channel

    https://t.me/Gauguin_Updates
    https://t.me/Mi10i5GOfficialUpdates
    https://t.me/Lynnrin_channel

    Donate

    2
    Yeah so far on my device everything's running ok, apps are working fine, the only thing I have noticed is that my screen get stuck sometime while browsing, I'm using bromite. Rest all is working as it should.
    2
    Hi,
    the switch for automatically select network doesn't work in the Rom.
    It can't be disabled...

    Anybody else with this problem?
    Thanks to the maintainer @Lynnrin :)
    I confirm, the switch does not work.
    2
    Yeah so far on my device everything's running ok, apps are working fine, the only thing I have noticed is that my screen get stuck sometime while browsing, I'm using bromite. Rest all is working as it should.
    Indeed, the screen also freezes with fennec
    2
    Hi! Ok Google seems doesn't work. I ve tried with mindthegapps and nikgapps
    I cannot confirm that.

    LOS 19.1, MindtheGapps 12.1, Magisk 24.3 (with Busybox, Shamiko, PropsConfig)... everything works well as it should, and PlayStore says "Device is certified".

    Just only... LAN via USB does not work, sigh

    samhhmobil