[ROM][12][OFFICIAL][ginkgo/willow] PixelExperience 12

Search This thread


Dec 18, 2021
Hello. First of all, thanks for this rom. I want to install this rom but I have a question. Is there any bug in this rom? I will install accordingly. I will be glad if you answer.


Senior Member
May 19, 2011
Milan, London & Zürich
Hi everyone! Do you have any mirror of the rom? It's been two days that I'm trying to download it from the PE website, but the connection is super slow (like 10/20 kb/s and hangs down before it can complete the download :(). Thanks
  • Like
Reactions: M1gu3lGnR


Senior Member
Jan 28, 2014
How do I dirty flash the latest build?

The last time I tried it with TWRP, it factory resetted and I don't think I selected any option for it to do that. Please advise, I'm a bit of a noob.


Senior Member
Feb 22, 2015
Build 21/12/2021: Nobody can call me in spite of phone signal icon is full
Last edited:
Use Gcam 8.2.204 it works great ..
I use Gcam 8.2 on MIUI 12.5 and it works very well, but when I install that same version on pixel experience 12 it doesn't work, can you give me the apk you use?
ps: download the apkm from the link but it doesn't work on MIUI 12.5


Jan 11, 2021
How does the Google one trial work? When I click check membership in Google one app, it closes after short loading.

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hello, I unlocked the bootloader and now I can't seem to flash the recovery image successfully...

    I run the fastboot command and it says that it's successful but if I try to get into recovery (power button + volume up) I get the message saying "the system has been destroyed", after restarting it boots to MIUI normally...

    I'd appreciate if someone could tell me what to do.

    I followed installation guide and downloaded recovery image file from here.
    Gday. I was having the very same an hour ago. Tooth ache and an unsuccessful new ROM install, poor me!

    The first thing I did was installing good old TWRP. Just to see that the system was still encrypted after wiping. A few tries later (I killed the sdcard0 partition in the process; Rom installation atemp through TWRP gave me a beautiful bootloop) I finally gave up and installed the pixel recovery (using TWRP) through OTG (exFat pendrive), then pixelRom through otg, and no bootloop. Now I am free from MIUI's petty tyranny. Xiaomi is worse than the CCP officials mandating lockdown.

    TL;DR: flash TWRP through Fastboot, put the recovery and the Rom on an exFat USB stick, flash the recovery from TWRP and the Rom from the recovery.
    Thanks for the reply. I however managed to solve it on my own in the meantime.
    I also used TWRP but I had no trouble flashing the ROM with it so everything worked out in the end.

    Now I am free from MIUI's petty tyranny.

    You and me both, hooray 🎉

    And so far PE is pretty solid, it feels smoother and faster. I haven't found any serious bugs yet (hopefully never).
    BTW, if you install this ROM you will get unlimited photo storage, without compression. I didn't check the props but I'm guessing it is a OG Pixel.

    A huge thanks to the developers for this work and this perk! We love you, guys!
    Haptic feedback is very weak and there is no option to increase the intensity. Any solution plz...
    I've noticed that the built in recorder application doesn't work, in that despite having microphone access it fails to detect any audio when recording.
    Click on the Mic, use Phone instead of Pixel 5.

    In Android 11 builds. This works. But it doesn't on Android 12.

    Captioning won't work either if you downloaded offline speech regonition pack. You will need to clear Speech Services by Google app data.
  • 18


    PixelExperience for Redmi Note 8/8T[ginkgo]

    What is this?
    PixelExperience is an AOSP based ROM, with Google apps included and all Pixel goodies (launcher, wallpapers, icons, fonts, boot animation)

    Our mission is to offer the maximum possible stability and security, along with essential and useful features for the proper functioning of the device

    Based on Android 12

    Whats working?
    Mobile data
    FM radio
    Fingerprint reader
    Enforcing Selinux
    NFC (willow)

    Known issues
    You tell me


    Liked my work? Give me a beer

    Help with project translation

    Stay tuned
    Our Telegram channel
    Our blog

    New PixelExperience 12 update

    Fixed NFC (willow)
    - Fixed audio issues with media playback
    - Fixed RIL crashing while using 2 Sim Cards
    - Fixed lost fingerprints after switching users
    - Enabled Iorap
    - Improved performances

    From now on pixel experience 12 will receive monthly updates (unless some hotfix updates), our device if fully brought up for Android 12.0 and ready for official. When PixelExperience will be officially launched ginkgo will be officially supported.
    I have flashed this rom on my 8T willow, the process was simple and quick. So far everything seems to work well. I was able to install MAGISK for the few root apps I use like adaway. My banking apps work, as does netflix and government apps that usually complain on rooted devices. Safety net passes even after root. The phone is more responsive, the battery life is much better. NFC works.

    The only small issues seems to be the camera, the one that comes in the rom is ok, it works well, but lacks features. I tried to install several versions of the MIUI camera, all crash, as does the google camera from play store. I tried open camera and picai camera, both work but the banding is terrible which which appears on the photos making them no good.

    I will use this from now as my daily phone, it is fantastic! I hope the camera can be improved or a version of the MIUI camera can be used. You have given life to my old phone, I was so sick of it and ready to buy a new one.

    Thanks so much for your effort!
    Ok, so an update, I am obsessed with getting a decent camera, I tried many from the app store and wasn't happy with them so I ended up flashing ANXCamera. The version I am using is for Android 11 but it works on 12 After some trial and error everything works with the exception of the portrait option. I had issue with the 48mp option to but it is working now. The files I flashed in order from camera.aeonax-dot-com are: MiuiCore-D-MagiskModule-20211105024254.zip, ANXCameraUnity.Light.190R.BountifulDistantHapuka.zip, 48MPFixQ_181.GlossyIntelligentCock.zip. I did try newer versions of the 48MPFix, but non of the others allowed me to use the 48mp camera.

    I hope that helps someone.
    New PixelExperience 12 update


    * Synced with latest Pixel Experience 12 source code
    * Merged November 2021 security patches
    * Updated blobs from MIUI V12.0.2.0
    * Updated kernel
    * Improved performance
    * Reduced lags and junks
    * Fixed some selinux denials
    * Fixed Wifi Display

    NOTES: Official builds of twelve will come out as soon as PE merges S caf nfc stack.
    New PixelExperience 12 update


    * Fixed flickers
    * Fixed charging not being reported
    * Switched to oss libcameraservice
    * Fixed front camera videorecording
    * Audio offload updates
    * Removed conflicting atrace hal
    * Updated some overlays to 12