[ROM][12L][XZ2C][OFFICIAL] LineageOS 19.1

Search This thread

dtrunk90

Senior Member
Oct 29, 2021
320
147
32
Sony Xperia XZ2 Compact
Xperia XZ2
I saw reports of VoLTE on T-Mobile working on xz2c (AKA xz2 compact) with official lineageos 18.1 builds. So using the instructions on the LineageOS website, I flashed the more recent and presumably also working lineage-19.1-20220617-nightly-xz2c build on my Sony XZ2 Compact model H8314 over the stock 52.1.A.3.49 build. Everything seems to work fine except Voice over LTE (VoLTE) at least on T-Mobile in the US (Wi-Fi calling does not work either but I did not expect Wi-Fi Calling to work).

Calls go through but best I can tell it is not VoLTE as the mobile network switches back to 3G and there is not HD voice indicator. I attempted to set my preferred network type to LTE but then calls do not go through but instead immediately says "Call Ended." I've toggled VoLTE on and off in setting trying calls each way along with changing the network type as mentioned before. All to no avail.

Per this message, I did try taking the SIM out and putting in a known work VoLTE device (a stock Samsung S10 in this case) and indeed VolTE worked fine in that device but it still didn't

Is there something else I should try or do?
There's something which needs to be merged so the apk could load: https://github.com/sonyxperiadev/SonyOpenTelephony/pull/10

Might be the reason for the broken VoLTE. I'll investigate.
 

dtrunk90

Senior Member
Oct 29, 2021
320
147
32
Sony Xperia XZ2 Compact
Xperia XZ2
I saw reports of VoLTE on T-Mobile working on xz2c (AKA xz2 compact) with official lineageos 18.1 builds. So using the instructions on the LineageOS website, I flashed the more recent and presumably also working lineage-19.1-20220617-nightly-xz2c build on my Sony XZ2 Compact model H8314 over the stock 52.1.A.3.49 build. Everything seems to work fine except Voice over LTE (VoLTE) at least on T-Mobile in the US (Wi-Fi calling does not work either but I did not expect Wi-Fi Calling to work).

Calls go through but best I can tell it is not VoLTE as the mobile network switches back to 3G and there is not HD voice indicator. I attempted to set my preferred network type to LTE but then calls do not go through but instead immediately says "Call Ended." I've toggled VoLTE on and off in setting trying calls each way along with changing the network type as mentioned before. All to no avail.

Per this message, I did try taking the SIM out and putting in a known work VoLTE device (a stock Samsung S10 in this case) and indeed VolTE worked fine in that device but it still didn't

Is there something else I should try or do?
Should be fixed with next build. If not, let me know the modem config of your notification and I'll have a look.
 

kufuska23

Member
Jun 17, 2022
9
1
Sony Xperia XZ2 Compact
in this link only for NFC they are talking but here for SO-05K, we need complete custom rom. not even a single supported rom for that deviCe so far in thr internet. since the device update stops at android 10, an Custom rom based on android 10 will be good, sufficient and enough. here i have started digging youtube for tutorials for building custom rom and before that i almost forgot to order apiggy bank to save some money for buying a decent PC to build that custom rom based on andriod 10😎.. so definetly on that fine day with complete generousity you will be developing the custom and we expect that you will provide that rom for us.. so please do something for on screen button community. atleast a patch for gesture based navigation would be HUGE!!🙆
 

dtrunk90

Senior Member
Oct 29, 2021
320
147
32
Sony Xperia XZ2 Compact
Xperia XZ2
in this link only for NFC they are talking but here for SO-05K, we need complete custom rom. not even a single supported rom for that deviCe so far in thr internet. since the device update stops at android 10, an Custom rom based on android 10 will be good, sufficient and enough. here i have started digging youtube for tutorials for building custom rom and before that i almost forgot to order apiggy bank to save some money for buying a decent PC to build that custom rom based on andriod 10😎.. so definetly on that fine day with complete generousity you will be developing the custom and we expect that you will provide that rom for us.. so please do something for on screen button community. atleast a patch for gesture based navigation would be HUGE!!🙆
I will not support/maintain something I cannot test. You're free to build it for jp models yourself.
 
  • Like
Reactions: kufuska23

dtrunk90

Senior Member
Oct 29, 2021
320
147
32
Sony Xperia XZ2 Compact
Xperia XZ2

jcummings2

Member
Jun 20, 2022
6
2
Does it support VoLTE and/or VoWiFi for Europe carriers ? For example T-Mobile PL ?
Or I have to add IMS configs by myself ?

Yes, orange, play, telekom and many others got added here: https://review.lineageos.org/c/LineageOS/android_device_sony_tama-common/+/327624
But better wait for the build of tomorrow since SonyOpenTelephony isn't working on latest build right now.

With today's update (lineage-19.1-20220624-nightly-xz2c-signed.zip) applied via the Updater, I can confirm that VoLTE (Voice over LTE) is working on T-Mobile in the US on my XZ2 Compact model H8314. As expected, Voice over Wifi doesn't work.

Thank you @dtrunk90.
 
With today's update (lineage-19.1-20220624-nightly-xz2c-signed.zip) applied via the Updater, I can confirm that VoLTE (Voice over LTE) is working on T-Mobile in the US on my XZ2 Compact model H8314. As expected, Voice over Wifi doesn't work.

Thank you @dtrunk90.
For me in T-mobile PL not.
Modem configuration used: S8657.1
No VoLTE, no VoWiFi.

On stock + simple hack (oem partitions from branded software) both worked well.

/edit:
VoLTE works only in SIM1. When i put card to SIM2 then not.
 
Last edited:

dtrunk90

Senior Member
Oct 29, 2021
320
147
32
Sony Xperia XZ2 Compact
Xperia XZ2
With today's update (lineage-19.1-20220624-nightly-xz2c-signed.zip) applied via the Updater, I can confirm that VoLTE (Voice over LTE) is working on T-Mobile in the US on my XZ2 Compact model H8314. As expected, Voice over Wifi doesn't work.

Thank you @dtrunk90.
Did you selected to prefer calls over wifi in sim settings? it should work if your provider allows voice over wifi.
 

dtrunk90

Senior Member
Oct 29, 2021
320
147
32
Sony Xperia XZ2 Compact
Xperia XZ2
For me in T-mobile PL not.
Modem configuration used: S8657.1
No VoLTE, no VoWiFi.

On stock + simple hack (oem partitions from branded software) both worked well.

/edit:
VoLTE works only in SIM1. When i put card to SIM2 then not.
did you activated volte on sim slot2? and also check the preferred network types so LTE is in use.
nevertheless, i'll put it onto my todo list and have a look once i have time. thanks for reporting.
 
did you activated volte on sim slot2? and also check the preferred network types so LTE is in use.
nevertheless, i'll put it onto my todo list and have a look once i have time. thanks for reporting.

Just tested 2x TmoPL SIMs in Zenfone 8: 2xVoLTE works, 2xVoWiFi works (in normal and airplane mode)

Then I put them to ZX2c

SIM1 (slot 0), IMS status: VoLTE only or VoWiFi only.
No VoLTE and VoWiFi at same time.
VoLTE randomly disapears.
VoWiFi not working at all (even if IMS says it's available)

SIM2 (slot 1) - no IMS, no VoLTE, no VoWiFi

No IMS in airplane mode at all.

If you need more info, logs, etc... pm me what and how I can send it to you.
 

dtrunk90

Senior Member
Oct 29, 2021
320
147
32
Sony Xperia XZ2 Compact
Xperia XZ2
Just tested 2x TmoPL SIMs in Zenfone 8: 2xVoLTE works, 2xVoWiFi works (in normal and airplane mode)

Then I put them to ZX2c

SIM1 (slot 0), IMS status: VoLTE only or VoWiFi only.
No VoLTE and VoWiFi at same time.
VoLTE randomly disapears.
VoWiFi not working at all (even if IMS says it's available)

SIM2 (slot 1) - no IMS, no VoLTE, no VoWiFi

No IMS in airplane mode at all.

If you need more info, logs, etc... pm me what and how I can send it to you.
And both slots are using modem config S8657.1? Thanks I'll take a look.
 

dtrunk90

Senior Member
Oct 29, 2021
320
147
32
Sony Xperia XZ2 Compact
Xperia XZ2
Yes, both use same config (S8657.1)

Is there option to turn on VoLTE and/or VoWiFi indicator?

Thanks!
Yes see attached screencast


EDIT: oh sorry, you're talking about an indicator. I don't think there's an indicator other than doing a call and check the on screen icons.

EDIT2: Btw: You can't use both at the same time. Either VoWiFi or VoLTE.
 
Last edited:

jcummings2

Member
Jun 20, 2022
6
2
Did you selected to prefer calls over wifi in sim settings? it should work if your provider allows voice over wifi.

Yes - using the two options that allow mobile appear to just use the mobile network - is there a way to know for sure? With the Wi-Fi only option selected calling fails with the message: "Connect to a wireless network to make a call" even though the device (N8314) is connected to the internet via wifi. Provider (T-Mobile in US) does allow voice over wifi calling.

On possibly related note, I have been getting notifications today from Open Device ModemConfig. It typically says "Slot 0" for the title with the message itself saying "Modem configuration: S264.8 Firmware file: mcfg_sw/generic/row/tmobile/vl/us/mcfg_sw.bin". When toggling out of Airplane mode the message itself is "No modem configuration found" until it switches back to the message above (presumably after it has restarted the modem). Other than blocking all notifications from Open Device ModemConfig, is there a way to silence this notification?
 
Last edited:

dtrunk90

Senior Member
Oct 29, 2021
320
147
32
Sony Xperia XZ2 Compact
Xperia XZ2
Yes - using the two options that allow mobile appear to just use the mobile network - is there a way to know for sure? With the Wi-Fi only option selected calling fails with the message: "Connect to a wireless network to make a call" even though the device is connected to the internet via wifi.

On possibly related note, I have been getting notifications today from Open Device ModemConfig. It typically says "Slot 0" for the title with the message itself saying "Modem configuration: S264.8 Firmware file: mcfg_sw/generic/row/tmobile/vl/us/mcfg_sw.bin". When toggling out of Airplane mode the message itself is "No modem configuration found" until it switches back to the message above (presumably after it has restarted the modem). Other than blocking all notifications from Open Device ModemConfig, is there a way to silence this notification?
There's only one notification channel you can block. So you could also block whole notifications for that app. I'm doing that myself. It's just for debugging purposes if some modem configs are missing i can ask which S1234.1 and i can check if the config exists or if i have to add it. But it's also not my app. It's from https://github.com/sonyxperiadev/SonyOpenTelephony
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    It seems to me that split screen functionality does not work. (no complains, just want to report.)
    ?
    Screenshot_20220717-015613_Yandex Music.png
    1
    Thanks for your respond. Hmm, interesting... Than it's just my device. Maybe this is my reward for not making a clean flash...?
    I tried activating split screen by setting "System", "Buttons" "Recents long press action" to "Splti Screen" and than... pressed long. but nothing happend. Using other buttons has the same result, while the action "Last App" works this way just fine.
    Is there an other way to activate split screen?
    Open recents and hold the app icon, then press "split top"
    1
    Open recents and hold the app icon, then press "split top"
    Oh yeah, thank you very much! That's very good to know. This way it works with my device, too.
    1
    After a long time of testing, it turns out, that the setting "SCREEN_OFF_POWER_STATE=0" in libnfc-nci.conf (/vendor/lib) seems nevertheless to be the key to get NFC working in my case (except for the Mirafare-bug mentioned above). However, after each LOS update, the file is overwritten again (SCREEN_OFF_POWER_STATE=1). The consequence: NFC crashes again after some minutes. Is there any chance that the default setting could be set to 0 (also in the file itselft, it is stated that 0 is the default setting)?
    Yeah, a magisk module would be the only solution since you seem to be the only one affected by this and i don't want the controller to be in sleep-state while screen is off. That would mean we all couldn't use NFC anymore when screen is turned off.
    1
    Hello,
    I'm still on an old H8314 unlocked Android 9 52.0.A.11.3
    working quite ok but some bug are there.
    I'm looking for a daily driver, seems this one is ok ?

    What's the best update option now ?
    Using sony EMMA tool in flash mode is ok? Do I need to go to Android 10, then 11, then 12 ?

    or just taking the xperiafirm 52.1.A.3.49 and flash it with newflasher ?

    thanks for your help
    Please read the install instructions in the official wiki
  • 8
    2okPze5.png

    Code:
    #include <std_disclaimer.h>
    /*
    * Your warranty is now void.
    *
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.
    */
    About LineageOS
    LineageOS is a free, community built, aftermarket firmware distribution of Android 12.x (S),
    which is designed to increase performance and reliability over stock Android for your device.

    All the source code for LineageOS is available in the LineageOS GitHub repo.
    And if you would like to contribute to LineageOS, please visit our Gerrit Code Review.

    Official LineageOS website : https://lineageos.org/
    About LineageOS Legal : https://lineageos.org/legal/

    Important Information
    1. This ROM will never work with any versions of Google Camera (GCam)!
    2. You need to flash Stock Android 10 before flashing this ROM.

    Downloads Links
    LineageOS 19.1:
    Official builds:
    Link

    Google Applications (optional):
    MindTheGapps:
    https://wiki.lineageos.org/gapps
    Information: Flash the GApps before the first boot. If not, a clean flash is recommended.

    Flashing and updating
    Please refer to the official installation guide at https://wiki.lineageos.org/devices/xz2c

    Issues and reports
    Report issues only if you are using the ROM kernel
    If an additional mod is installed, make sure it's unrelated, and mention it
    Make sure the issue wasn't discussed earlier in the threads
    Share a log of the error with Logcat for example

    Also thanks to:
    Olivier
    Sjll
    The LineageOS Team
    The CyanogenMod Team
    Everyone involved in working and testing

    XDA:DevDB Information
    Lineage 19.1 for Xperia XZ2 Compact, ROM for the Xperia XZ2 Compact

    Contributors

    dtrunk90, Sjll
    Source Code: https://github.com/LineageOS

    Donation
    https://paypal.me/dtrunk90

    ROM OS Version: Android 12L
    ROM Kernel: Linux 4.9
    ROM Firmware Required: Official Android 10.0 firmware
    Based On: LineageOS

    Version Information
    Status:
    Stable

    Created 2022-05-05
    Last Updated 2022-06-17
    4
    Official builds are now available!

    In order to switch from unofficial to official builds a clean flash is required. Please refer to the official installation guide on how to clean flash properly.
    3
    Thanks Dtrunk90 and Lineageos for support our XZ2C device! :)

    I know that in principle I would have to do a clean install to switch from 18.1 to 19.1 rom, but since I have a lot of applications ( 96 piece ) and gmail accounts ( 3 piece ) and email address settings ( 6 ) on my phone, I tried to make it dirty for the first time. A refresh from 18.1 to 19.1, saying if I fail I will do it from the ground up.
    BUT, it worked without any serious error at first try. The process if someone is interested in:

    - Downloaded everything, and put they to my adb folder. The los.zip, the los.recovery.img, and gapps.12.1-arm64.zip ;
    - Booted phone to fastboot mode ;
    - In fastboot " fastboot flash boot lineage-19.1-20220617-recovery-xz2c.img " ;
    - Plug uff USB, then rebooted into recovery with key combo ;
    - In recovery if I choosed the upgrade from adb ( sideloads ) I've got error message, something like: " los recovery error package is for product xz2c but excepted 8324... "
    - after that, In the recovery I enabled adb ;
    - then from pc " adb reboot sideload " ;
    - after it " adb sideload lineage-19.1-20220617-nightly-xz2c-signed.zip " ; <- it went perfectly now
    - rebooted to recovery from recovery ;
    - then " adb sideload MindTheGapps-12.1.0-arm64-20220605.zip " ;
    - rebooted phone once ;
    - made patched magisk boot img file with magisk app
    - rebooted to fastboot, then flash patched magisk boot img ;

    All of my programs, settings, passwords, mail accounts, are remained as they was. What I've looked at so far is all working. The rooting process still good. My Telekom and Bank applications could still hided from they root detection. And what surprised me was, that the poweramp equalizer also works properly, although on my other " gaming " phone on an xperia x compact ( kugo ) also under lineage os 19.1 i can't work it at all. And here is perfect. ( At least in addition to spotify ).

    Thanks again!

    Edit: My phone is a H8324 ( DualSim , EU version )
    3
    Hi

    I'm looking to flash my phone as I've run into the Stock issue where the secondary mic stops working (annoying.. happened after a factory reset).

    Anyhoo..

    I'm weighing up between Official 18 and Unofficial 19. I saw the Sony camera doesn't work with Unofficial 18. Doe it work with 19?

    Thanks!
    Only as a magisk module but it's not the stock version camera but an updated apk. Check xperiance at gitlab.

    I would suggest waiting for the official 19.1 builds. Everything is in place, just some stuff needs to be merged from someone with write privileges to those repositories.
    3
    Does it support VoLTE and/or VoWiFi for Europe carriers ? For example T-Mobile PL ?
    Or I have to add IMS configs by myself ?
    Yes, orange, play, telekom and many others got added here: https://review.lineageos.org/c/LineageOS/android_device_sony_tama-common/+/327624
    But better wait for the build of tomorrow since SonyOpenTelephony isn't working on latest build right now.