Development [ROM][13.0][UNOFFICIAL] LineageOS 20.0 for Xiaomi MIX 4

Search This thread

SpicyM

Member
Apr 17, 2019
7
5
On LOS 20, I have firefox and the Google Family Link app crashing sometimes.
Netflix makes an error (5.10) if I press +10s too often.

This did not happen on LOS 19.

Thank for the builds @Inkypen
 

xtacb4

Senior Member
Oct 11, 2010
132
30
Hi!

I just flashed TWRP odin-twrp-3.7.0_12-1.img then rebooted, installed lineage-20.0-20221116-UNOFFICIAL-gapps-odin.zip, flashed TWRP again using TWRP itself, and them installed Magisk-24.2.zip. No errors.

But when I boot into LOS there is no root, and there is no option to enable root in the developer settings.

For context, I had LOS19 lineage-19.1-20220910-UNOFFICIAL-gapps-odin.zip installed and rooted, including TWRP odin-twrp-3.6.2_12-1.img, all without issues.

Is anyone familiar with this kind of issue? perhaps I'm doing something out of order? What can I try/check, provide feedback/logs? (which kind? logcat? other/s?)

Thanks!


edit: Nevermind! I used Magisk app to patch odin-twrp-3.7.0_12-1.img and then flashed that in TWRP and it worked!(? i don't understand why it worked though, since I was installing TWRP after flashing LOS20 and then installing magisk.zip to patch the boot image, in that order).
 
Last edited:

SpicyM

Member
Apr 17, 2019
7
5
I add to the list a bug probably on google services that affects the playstore. It is disconnected with an empty icon in the top right corner instead of the menu. A restart solves the problem.
This is probably the reason why Family Link is not working. It's totally random.
I tried to reinstall gapps without success
 

SpicyM

Member
Apr 17, 2019
7
5
... and the round light on the fingerprint scanner that sometimes stays on and starts to annoy me.
If anyone knows how to disable it
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Found another bug - in Camera app, the video stabilization (Steady video) doesn't work for me. When I hit record, the app freezes and then crashes.
    1
    That is probably the same issue as with slow-mo - it is a known bug with this rom.

    @Inkypen I have noticed something wrong with Media API (my educated guess) in LOS13 releases - this has NOT happened in LOS12. Sometimes (this seem random, but frequent) when I have media app like VLC opened with video - then switch to another app - I can't play any videos in the browser, or open the Camera app (can;t connect to camera). If I then close all the apps in the overview - it starts working again.
    In the latest November build i tried to recreate this. I installed VLC, played a video and switched between camera, YouTube app and YouTube in a browser. It all seems to be working fine, perhaps it was a bug in LOS source as no one has brought this up on any of the other ROMs. I'm uploading the new builds now, should be available a bit later today.
  • 13
    2okPze5.png

    LineageOS is a free, community built, aftermarket firmware distribution of Android 12 (S), which is designed to increase performance and reliability over stock Android for your device.

    Code:
    #include <std_disclaimer.h>
    
    /*
    * Your warranty is now void.
    *
    * We are not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at us for messing up your device, we will laugh at you.
    *
    */

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (gapps). LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

    GPL compliance:
    yG18r6g.png


    Working:
    Almost everything

    Broken:
    You tell me :)

    Downloads:
    https://sourceforge.net/projects/xiaomi-odin/files/13/LineageOS
    https://sourceforge.net/projects/xiaomi-odin/files/12/LineageOS
    https://sourceforge.net/projects/xiaomi-odin/files/11/LineageOS

    Installation:
    Reboot to recovery
    Copy LineageOS zip to internal storage
    Install LineageOS zip package
    Install [optional] a Google Apps package of your choice
    Format data (wiping is not sufficient, formatting requires you to type "yes")
    Reboot

    Important notes:
    GApps can only be flashed on clean installs.
    Formatting data (all user data is wiped, including internal storage) is a must if MIUI was previously installed and device was encrypted.

    Contributors
    Inkypen
    ROM OS Version: Android 12
    ROM Kernel: Linux 5.4
    Based On: AOSP
    6
    New builds are up:
    • June security patch
    • Kernel upstreamed to 5.4.197 and latest lahaina CAF tag
    • LHDC Bluetooth codec added (untested as I don't have a BT device that supports this)
    • Some ANX tweaks (should start a little bit faster)
    Regarding the conversation about the visible camera hole at maximum brightness, that's a hardware limitation. You must have seen Xiaomi's promotional image of the pixel array above the front facing camera showing the smaller pixels allowing light to pass through to the image sensor. A smaller pixel will not be able to shine as brightly as a larger one hence the slightly darker view on max brightness. MIUI gets around this flaw by displaying a sun symbol over the camera hole at max brightness. On a couple of builds I tried limiting the max brightness by about 15% so this wasn't noticeable but I had a few people in sunny areas complain about the change, so I reverted back. If it bothers you just turn the brightness down a little bit.

    Are there any plans to fix the widevine level from l3 to l1? I know that the China/eu Rom habe l1,so it should not be impossible to fix
    I've had L1 support since before I even released any builds. Download any media codec info app from play store and check for yourself.
    5
    New build is out, fixes seedvault among other things. Check changelog here: https://github.com/Inkypen79/OTA/commit/15f3c51b1ca99eaea2c026a47a6d0a02d3f5f583

    Turns out seedvault is a bug in Lineage, I used the main seedvault repo instead of the Lineage one and it's all working. This was fairly straight forward to fix but for future reference please, please, please provide build version and logs when giving a bug report.

    @subject4 Thanks for your suggestion. Nikgapps is actually what I would personally recommend if someone needed a gapps package, but unfortunately it can only be flashed on top of an installed ROM and is not suitable to integrate into a build from source.
    5
    New test build is up. It has a new version of minimal gapps installed and it also passes safetynet from clean flash without the need of root or any additional patches or modules. OK Google detection is now working with the screen switched off. Biggest change is a much improved ANX camera experience. There are no more crashes when using certain camera modes, the only thing not working is slow motion. I'm considering making ANX the default camera for all future builds (gapps and non gapps) and I would appreciate any feedback about this change.

    Build is here: https://sourceforge.net/projects/xi...220426-UNOFFICIAL-gapps-anx-odin.zip/download
    4
    @Inkypen Thank you so much... you're the best. So, if ANX is (sadly) not included, there might be a chance, it will go "official"-status eventually, right?
    Sorry to say that the chances of Lineage becoming official are exactly zero. The requirements to go official are unbelievably strict and very restrictive. For example, I wouldn't be allowed to patch the source code to make the ROM pass safetynet or I wouldn't be allowed to extract drivers/firmware from a Qualcomm dump if I needed to. I just don't have the time/energy to jump through their hoops. Besides, the only upside to official builds are OTA updates which I've added to my builds :)

    I am currently working on getting stock MIUI Camera to function correctly on AOSP based ROMS as I have discovered that ANX depends on a framework called Frida that is not currently compatible with A13.