Development [ROM][13][OOS Cam][OP9Pro] crDroid v9.1 [03.02.2023]

Search This thread

TheSayaMan

Senior Member
Sep 12, 2016
905
380
OnePlus 9 Pro
Hi. My OnePlus 9 pro is already on Android 13. Will that work with crdroid or will I need to roll back? Also, are there plans for crdroid to support being on OnePlus' version of 13?
Yes it will work. Just use either the c63 flasher to flash firmware and recovery and then you can flash rom. In your case, you can also just flash the dtbo.img, boot.img and vendor_boot.img located in kit and recovery folders.
 
  • Like
Reactions: texasaggie1

Strike-F8

New member
Dec 7, 2022
3
1
OnePlus 2
Samsung Galaxy S9+
Hey everyone, I just updated to the December 3rd build and now all my notifications and system sounds are extremely loud. Changing the notification and ringer sound levels in settings or the volume flyout doesn't affect them. I've been enjoying crDroid with minimal problems before this. I wonder if there is a bug in this latest version?
 

foxyfado

Member
Jan 23, 2014
47
8
Hey everyone, I just updated to the December 3rd build and now all my notifications and system sounds are extremely loud. Changing the notification and ringer sound levels in settings or the volume flyout doesn't affect them. I've been enjoying crDroid with minimal problems before this. I wonder if there is a bug in this latest version?
I had the same problem and posted the same question, didn't get any answer.
After two days of use the problem gone. i didn't do anything. just couple of restart.
 

Reznor7

Senior Member
Apr 27, 2013
378
84
Sorry for posting this question again, but is do not disturb broken for anyone else? I've had apps sound notifications when it's turned on (and configured for no sound), and if I reboot while DND is activated, it does not re-activate upon boot.
 

Hahatulk

Senior Member
Feb 6, 2018
86
13
Sorry for posting this question again, but is do not disturb broken for anyone else? I've had apps sound notifications when it's turned on (and configured for no sound), and if I reboot while DND is activated, it does not re-activate upon boot.
checked in bedtime mode (digital wellbeing), working good
firmware c.48 GL
 

Strike-F8

New member
Dec 7, 2022
3
1
OnePlus 2
Samsung Galaxy S9+
I had the same problem and posted the same question, didn't get any answer.
After two days of use the problem gone. i didn't do anything. just couple of restart.
I think I figured out the problem. I tried rebooting but it did not work. After a few days, I realized that media sounds were increasing and decreasing in volume rapidly. So, I tried looking around for some EQ settings. It was difficult to find, but I was able to access the Dolby application through Spotify settings. It was set to automatically adjust sounds. I disabled it and everything is back to normal.
 
  • Like
Reactions: foxyfado

Enismirdal

Senior Member
Feb 23, 2011
90
46
Just installed this late last week, so far mostly-so-good. It does have some issues:

-Lift to wake seems either broken or very unreliable
-"Long press on fingerprint sensor to unlock" can't be turned on, the setting reverts to off
-UDFPS custom animation is off-center
-With 3-button nav, navbar turned off, the floating rotate button never appears - is there a way around this? I'd prefer to use third-party gestures without the stock ones interfering, while still having the rotate button.

Is there a way to blacklist an app from access notifications? SystemUI gets location every few minutes, which makes that notification pretty useless.
 

Hahatulk

Senior Member
Feb 6, 2018
86
13
Everything is good (except the post above) and I want to continue:
- Clock is buggy sometimes and shift to left a bit, looks readble only with date appended from left so time is not shifted

edit: found out that it can be fixed with reboot and happened when I was watching youtube for long time

1670781311155.jpeg
 

Enismirdal

Senior Member
Feb 23, 2011
90
46
Just noticed - no AptX Adaptive support? I see HD and standard, but no Adaptive. That'd be very much a nice-to-have.

I just assume stock probably supports this, as my old OP phone did.

Edit: An option to change the limit of four statusbar icons would be nice, as well.
 
No update this week?

Looking at the Github repositories, it looks like they're having to rework and re-add a lot of stuff after LineageOS merged the Android 13 QPR1 changes, which broke and changed a lot of stuff. I found myself in the same boat with the Android 13 version of my LOS-based custom ROM, which I haven't officially started using yet for this very reason. I'm sure a new release will be coming soon; patience, young padawan. 😉
 
  • Like
Reactions: foxyfado

dion_starfire

Member
Oct 21, 2009
16
7
Just wanted to give an update. I did another clean flash install. Hulu and Netflix are working.

However, within a 24hr time period, Google services get stuck. Play store won't load my profile and subsequently won't allow me to update my apps unless I restart the system. Is anyone else experiencing this? I understand that this could be a Gapps issue and not necessarily a ROM issue.

I'm also experiencing this issue. I installed from a clean c.63 flash.

Judging from the way the system acts, it's almost like the system call to open files/streams just occasionally fails. Audible will occasionally fail to open the book I'm listening to when I first open the app until I swipe it away and re-open it. Firefox will hang loading random web pages on first app load. Anything dependent on Google services (Maps, for example) will fail to load the account (blank profile image), and any activity that relies on accessing the account (like updating search history) will subsequently cause the app to hang. Fixing the account load failure requires a reboot. The biggest failure is Google Meet (original), which even if it's not having account loading issues will drop calls mid-stream every few minutes unless the system has been freshly rebooted in the last hour or so.

All of these issues go away with a reboot and don't occur for the first few minutes that the system is running. This makes me strongly suspect some sort of file descriptor leak that eventually exhausts some important process (zygote?)'s fd supply.

I've also noticed that my data usage has spiked ridiculously. From prior experience limiting Play Store with XPrivacy, I know that it does not handle error states well and will happily retry downloading Play Protect updates (even if PP is off) repeatedly forever if something fails during the download or scan process. So, I suspect something similar is happening during the times when accounts are broken.
 

Enismirdal

Senior Member
Feb 23, 2011
90
46
I'm also experiencing this issue. I installed from a clean c.63 flash.

Judging from the way the system acts, it's almost like the system call to open files/streams just occasionally fails. Audible will occasionally fail to open the book I'm listening to when I first open the app until I swipe it away and re-open it. Firefox will hang loading random web pages on first app load. Anything dependent on Google services (Maps, for example) will fail to load the account (blank profile image), and any activity that relies on accessing the account (like updating search history) will subsequently cause the app to hang.

I've also started to notice this same set of problems - albeit without the data use spike, yet, and I don't use Meet. App hangs and play services failing, which seems to cause the blank profile image in Google apps, are definitely an issue. I've found that I can force stop play services and things will work again for a time. I've also noticed that sometimes Gboard won't type until the app calling it is closed, removed from recents, and reopened. Not sure what triggers this or if it's related.
 

Top Liked Posts