[ROM][13][PHOENIX][OFFICIAL] Evolution X | tiramisu 7.3 [16/11/22]

Search This thread


Senior Member
Jul 19, 2009
my step is format date -> wipe date cache-> adb push evolution*.zip ->install evolution -> error
I don't know why it doesn't work.

Try flashing A12 evo rom first and dirty flash over it with new A13 evo rom. If it still doesn't work, usually I will restart the whole process by flashing stock rom using miflash, install twrp, format data and flash the custom rom again.


New member
Sep 10, 2022
There may be a bug
rom version is evolution_phoenix-ota-tp1a.220905.004-09070950
Bug description: sign in to a network which requires login will cause the CaptivePortalLogin keeps stopping message.

How to reproduce:sign in to a network which requires login

I think the Admin ComponentInfo{com.google.android.captiveportallogin/com.android.captiveportallogin.CaptivePortalLoginActivity} does not exist or is not owned by uid xxx log is the key.

I've reported it in telegram.What should I do?
Recovery (twrp- -> Install A13 evo from sd card (evolution_phoenix-ota-tp1a.220624.021.a1-08271216.zip) by dirty flash over A12 evo (evolution_phoenix-ota-sq3a.220705.004-08090558.zip) -> reboot (data encrypt)

I have not tried install from new. I think you should format data before flashing A13 evo.
I tried a lot of stuffs... Finally i was able to Install A11 ROM of evolution and flashed evolution recovery. From there I did OTA update to A13. My phone had issues with fastboot being detected, so sent it off for exchange to vili (Xiaomi 11T PRO)
  • Like
Reactions: jngiag


Apr 17, 2019
Cant flash rom with able to mount /data and root with magisk causes bootloop.
Have tried to disable encryption but it doesn't work
weird bug - able to mount system in TWRP but not in orange fox
tried flashable.zip
If anyone has been able to root with data partition mountable please list detailed steps as I have use china and eu build but no results
Try to share links , google tags or backup file from TWRP (if possible i can directly go to recovery and use it)

Top Liked Posts

  • There are no posts matching your filters.
  • 14


    Evolution X 7.3 for the POCO X2/Redmi K30 [phoenix]

    * Your warranty is void. Or vaild, probably?
    * I am not responsible for bricked devices, dead SD cards, Ebolation X,
    * thermonuclear war, or the current economic crisis caused by you following
    * these directions. YOU are choosing to make these modificiations, and if
    * you point your finger at me for messing up your device, I will LMAO at you.


    Living, Breaking, Keep Evolving.

    Pixel UI, customization and more, we are Evolution X!

    - Team Evolution X -


    @peaktogoo (Now RealAkito)

    Reach us on Twitter! @EvolutionXROM


    What are our features?

    - Just flash and check "The Evolver"







    First Time Install / Clean Flash
    1. Download the proper flashable ZIP for your device
    2. Reboot to Recovery
    3. Flash the ROM
    4. Format Data
    5. Reboot to System
    6. Reboot to Recovery (Optional)
    7. Flash Magisk (Optional)
    8. Reboot to System and #KeepEvolving

    Update / Dirty Flash
    1. Reboot to Recovery
    2. Download the proper flashable ZIP for your device
    3. Reboot to Recovery (Optional)
    4. Flash Magisk (Optional)
    5. Flash the ROM
    6. Reboot to System and #KeepEvolving

    Light Screenshots / Dark Screenshots / Download

    Donate to me! / Official Chat / Device Support


    Hey i cant access android/Data folder!
    Data folder shows empty!
    Hey guys...
    New update is pushed. don't update rom via updater flash manually from recovery. Because new build signed with custom keys. So we can be prepared for future incremental builds. so guys do clean flash the new build. just for this build clean flash is must.
    Thank you.
    For anyone having issues with booting, coming from MIUI 12, there is a specific combination of rom as well as vendor to install before the Evolution-x rom, then it boots first time correctly. I tried literally all combinations.

    My device - K30 4G CN - Updated to MIUI EU 12 Latest Weekly

    1. Installed -xiaomi.eu_multi_HMK30_V11.0.15.0.QGHCNXM_v11-10- Stable EU Android 10
    2. Reboot, make sure MIUI 11 Loads, power off and go back to recovery.
    3. Clear Data
    4. Install Vendor PHOENIX-V12.0.4.0.QGHCNXM-10.0-vendor-firmware.zip - Android 10 one
    5. Install EVOX
    6. Clear Data and Reboot

    I tried the latest MIUI and latest vendor, and many other combinations, but that is the only one that worked.
    Thanks to @Pras_92