[ROM][4.2.2][OFFICIAL] PAC-man (NIGHTLIES)

Status
Not open for further replies.

Ravikirancg

Senior Member
May 3, 2012
778
1,112
0
Bangalore
Paranoid + AOKP + CyanogenMod = PACman



!!NOTE2: THESE ROMS ARE BMM ONLY




BROUGHT TO YOU BY RAVIKIRANCG
THIS IS BUILT STRAIGHT FROM PACMAN SOURCE AND STS-DEV-TEAM SOURCE. I WILL KEEP THIS UPDATED AS MUCH AS I CAN SO WHEN THERE ARE NEW THINGS ADDED ILL MAKE A BUILD






Features
  • based off of AOSP Jellybean 4.2.2
  • latest CM10.1
  • latest AOKP MR1
  • latest AOSPA (ParanoidAndroid 3.60)
  • all settings from CyanogenMod 10.1, Android Open Kang Project MR1, and AOSPA 3.60
  • PIE navigation controls
  • Hybrid Settings
  • Per-App Layout
  • Per-App Color
  • much more...flash and find out!

SCREENSHOTS





Flashing Instructions
  1. Wipe Dalvik Cache
  2. Flash Rom
  3. Flash Gapps
  4. Reboot
  5. Enjoy :)
    (NOTE: If you are coming from other roms or from PAC prior to 10-may build, you MUST WIPE DATA)


Downloads

NIGHTLIES: VISIT

ROM:DOWNLOAD

GAPPS:DOWNLOAD

ALL:VISIT

CHANGELOG

Code:
24 July, 2013
-Synced to latest sources
-You know it (Kexec based. Huge thanks to Hashcode)

17 July, 2013
-Synced to latest sources
-Add ROM-Share
-Update all CM Commits

04 July, 2013
-Synced to latest sources
-Fixed Torch (missed it last time :p)

27 June 2013
-Updated to latest sources
-Based on CM-10.1.1-RC0
-Updated AOKP Rom Control

21 June 2013
-Synced to latest sources
-Fixed Tethering

12 June 2013
-Synced to latest source
-Added HALO
-Updated PA to 3.60
-Updated to CM-10.1-RC5
-TRDS 2.0
-Add ROMstats to PAC-Man ROM

4 June 2013
-synced to latest source.
-Updated all CM commits to RC4.
-Updated PA commits.
-Update AOKP Ribbons.
-Fix 3-dot Menu Button.

17 May 2013
-synced to latest source.
-status bar collapse is back.
-front cam recording fixed. (Thanks again altered)
-torch fixed (Thanks again altered and sts-dev-team)
-should now be installable through bootstrapper. (Had missed the bootmenu binary last time)


10 May 2013
-synced and rebuilt on 10th
-fixed camera
-can be installed by bootstrapper
-installs bmm
-incuded recovery switch (thanks alteredlikeness)


04 May 2013
-rebuilt with updated sources
-other bugs still present


Thank You
  • STS-Dev-Team (Hashcode and DHacker)
  • whirleyes
  • wanggjghost
  • jimbridgman
  • Google
  • CyanogenMOD Team
  • AOKP Team
  • PA Team
And Special Thanks to alteredlikeness for guiding me


PAC ISSUES
-No 1080p recording. (common to all kexec roms)
Thats it.​
 
Last edited:

Ayush Jain

Senior Member
Oct 22, 2012
438
107
0
Awesome ROM!!
Pretty fast and smooth
I guess alter did make a patch for pa which wud remove ui tearing resulting in s/s and rotation bug
Would that patch on this ROM sir?
 

deveshmanish

Senior Member
Sep 22, 2012
1,450
1,498
0
New Delhi
Okay so far so good :thumbup:
Some bugs which are not in OP:
1.Gallery isn't able to play HD videos.

Also it doesn't even shows thumbnails for these.

I've tried clearing data of gallery but no good.
2.The per app color settings can't be applied even if the color panel shows up.There are no buttons.
Yes I've set the permissions.

However there seem to be predefined(not mine) custom color settings for the apps.

Also no camera at all??:eek:

May the -Mass times Acceleration-be with You...
 

A2Trip

Senior Member
Mar 2, 2012
1,584
404
0
Silver Lake, WI.
Running as system number three! Thanks man, great work! :thumbup: Hopefully we'll get a camera fix soon. Until then I'll still play around with it and switch systems if I need a cam.

Sent from my MB865 using xda premium
 
  • Like
Reactions: elafanto

Ravikirancg

Senior Member
May 3, 2012
778
1,112
0
Bangalore
Okay so far so good :thumbup:
Some bugs which are not in OP:
1.Gallery isn't able to play HD videos.

Also it doesn't even shows thumbnails for these.

I've tried clearing data of gallery but no good.
2.The per app color settings can't be applied even if the color panel shows up.There are no buttons.
Yes I've set the permissions.

However there seem to be predefined(not mine) custom color settings for the apps.

Also no camera at all??:eek:

May the -Mass times Acceleration-be with You...
1. the HD videos might be because of the hwcomposer. try out 3rd party app like MXplayer.. I never use the stock player.. and all the videos I played with es player work fine for me..

2. thats odd.. gallery shows thumbnails just fine for me

just give it some time to load I guess.. will put some hd videos on my phone and check..

3.no idea what you are talking about regarding the per-app colour settings..

If I were to take a guess about what you didnt do, try these..
after selecting the colour, tap on new colour, the colour now changes near the written part. tap on the tick mark..

4. and sorry, no camera at all.. tried what I could for a week..
 

alteredlikeness

Senior Member
Mar 2, 2012
2,454
5,472
0
reflecting on Indra's net
3.no idea what you are talking about regarding the per-app colour settings..
If I were to take a guess about what you didnt do, try these..
after selecting the colour, tap on new colour, the colour now changes near the written part. tap on the tick mark..
The new ParanoidPreferences.apk (v5.3) doesn't display well on hdpi devices.. It's a known issue, and hopefully the PA Team is still working on it: https://github.com/ParanoidAndroid/android_vendor_pa/commit/e99a9b192386ca186dfe5a52126ce6fbe7da79a5. My solution was to revert back to v5.1 in AOSPA.
 

deveshmanish

Senior Member
Sep 22, 2012
1,450
1,498
0
New Delhi
The new ParanoidPreferences.apk (v5.3) doesn't display well on hdpi devices.. It's a known issue, and hopefully the PA Team is still working on it: https://github.com/ParanoidAndroid/android_vendor_pa/commit/e99a9b192386ca186dfe5a52126ce6fbe7da79a5. My solution was to revert back to v5.1 in AOSPA.
Oh dang yeah I remember now.Thanks for the clarification.
1. the HD videos might be because of the hwcomposer. try out 3rd party app like MXplayer.. I never use the stock player.. and all the videos I played with es player work fine for me..
Yeah vlc works just fine for me,was just pointing out the bug.
2. thats odd.. gallery shows thumbnails just fine for me

just give it some time to load I guess.. will put some hd videos on my phone and check..
Actually the thumbnails which are not showing are those of the HD videos only.Others show up just fine.
3.no idea what you are talking about regarding the per-app colour settings..

If I were to take a guess about what you didnt do, try these..
after selecting the colour, tap on new colour, the colour now changes near the written part. tap on the tick mark..
Lol.There are no "written parts" or the "tick Mark".
4. and sorry, no camera at all.. tried what I could for a week..
Don't sweat it bro, great work allover.
BTW one more bug there ain't no clear button in the recent apps window.


May the -Mass times Acceleration-be with You...
 

Ayush Jain

Senior Member
Oct 22, 2012
438
107
0
U got to find the clear button for recent apps in setting...
I'll check and let u know where it is exactly
edit : under rom control>general ui
 
Last edited:
  • Like
Reactions: deveshmanish
Status
Not open for further replies.