• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][4.4.x] AOKP :: kitkat :: nightlies | test builds :: odin {ZL}

Search This thread

championswimmer

Inactive Recognized Developer
Oct 22, 2011
5,018
8,446
New Delhi
android.championswimmer.tk
DISCLAIMER
You need to have an unlocked bootloader to use this ROM & kernel. Also I or any contributor in the software DOES NOT take responsibility of damages caused to your phone due to this ROM.


83.png

81.png

1. Copy ROM zip and gapps zip to sdcard
2. Flash any kernel which has recovery or use TWRP (if you do not have any recovery yet).
3. Reboot device and go to recovery by pressing Vol-UP when LED is pink
4. If coming from 4.3, or 4.2 ROM wipedata/factory reset your phone
5. Flash ROM zip
6. Flash Gapps zip
7. Reboot and enjoy.

80.png


Official NIghtlies (automatically built every 4-5 days) :
http://goo.im/devs/aokp/yuga

Unofficial Test Builds (will contain experimental changes for testing) :
http://goo.im/devs/kxp/kk/odin

Gapps :
http://goo.im/devs/kxp


79.png

We spend countless of hours doing this for next to nothing. Posts, views, and donations encourage me, and everyone else who helps out.

Donate to AOKP

Every donation is cherished and loved.

If you'd like to help contribute by writing code, feel free to stop by IRC and talk to us!
78.png

Latest merges on Gerrit

http://gerrit.aokp.co/#/q/sony+status:merged,n,z
82.png

Check out the ROM source on github. Open source, in the spirit of community kangage.



CREDITS


Thanks to all device maintainers of Sony devices on CM/AOKP/Omni/PA/PAC as everyone working on the device helps each other into making better ROMs.
Also thanks to Sony Mobile for being so helpful to developers.



XDA:DevDB Information
[ROM][4.4.x] AOKP :: kitkat :: nightlies | test builds :: odin {ZL}, a ROM for the Sony Xperia ZL

Contributors
championswimmer, @FXP, @Bin4ry, @Kali-, @Entropy512, @cdesai, @codeworkx
ROM OS Version: 4.4.x KitKat
ROM Kernel: Linux 3.4.x
Based On: AOSP

Version Information
Status: Beta

Created 2014-01-11
Last Updated 2014-01-10
 

JinJK's

Senior Member
Mar 7, 2012
190
139
All working gr8 Thnx, from recovery to 2g-3g data, camera video rec, Xposed module, also try to play MC4 game, its working smooth. Still not try BT.

Sent from my Xperia ZL using Tapatalk now Free
 

melquisedec

Senior Member
Feb 14, 2010
254
18
I found some bugs in this Rom. First in a call the screen turned off but then turned on and in an second turned off again. The other bug is in expand the screen, I mean in immersive mode. Some times the screen blink.

Enviado desde mi Xperia ZL mediante Tapatalk
 

gella1992

Senior Member
Mar 14, 2011
57
12
I´m on 2014-01-14 Nigthly an found a bug, too!

Bluetooth music streaming isn´t working well. If the screen turns off the music is stuttering, but when I turn on the screen, everthing is okay.
So I think this is a Kernel related issue. Maybe the Screen Off Frequency is set to low
 

ej_424

Senior Member
Apr 17, 2009
566
63
Minneapolis, MN
So I flashed a Kernel without a recovery included. What can I do to get another customer recovery installed now that I'm on this rom?

Great work, just got my ZL and ready to rock! I love this phone, last sonys I had where the Xperia Arc and Xperia S, where I followed this Dev and loved his AOKP roms! Keep up the great work glad to see you here!

Thanks
ej_424
 

ATRIXXIRTA

Senior Member
Mar 17, 2012
2,434
766
The Shangri-La Motel
So I flashed a Kernel without a recovery included. What can I do to get another customer recovery installed now that I'm on this rom?

Great work, just got my ZL and ready to rock! I love this phone, last sonys I had where the Xperia Arc and Xperia S, where I followed this Dev and loved his AOKP roms! Keep up the great work glad to see you here!

Thanks
ej_424

Download one of the latest cm11 builds to your comp. Extract the boot.IMG. Then hook up your phone to your computer in fastboot and "fastboot flash boot boot.IMG" from the location of the boot.IMG and fastboot on your computer.

Sent from my C6503 using Tapatalk
 

ej_424

Senior Member
Apr 17, 2009
566
63
Minneapolis, MN
Does this ROM not show the LTE icon? I'm on a C6506 model and LTE icon showed up perfrectly on stock based ROMs. Now I only get the "4G" logo however based on Download speeds it appears to be using the LTE bands as I'm getting 40Mbps down.

Anyone able to confirm this? Is there a fix/workaround? My network settings are set to ATT .pta which is correct for LTE.
 

ATRIXXIRTA

Senior Member
Mar 17, 2012
2,434
766
The Shangri-La Motel
Does this ROM not show the LTE icon? I'm on a C6506 model and LTE icon showed up perfrectly on stock based ROMs. Now I only get the "4G" logo however based on Download speeds it appears to be using the LTE bands as I'm getting 40Mbps down.

Anyone able to confirm this? Is there a fix/workaround? My network settings are set to ATT .pta which is correct for LTE.

Im not too sure? I am using the latest CM11 nightlie and it shows the LTE logo as apposed to the 4G one...

If im not mistaken, I think OMNI rom also shows a 4G symbol instead of LTE.

Either way, 4G and LTE are supposed to be the same thing anyway, lol
 

championswimmer

Inactive Recognized Developer
Oct 22, 2011
5,018
8,446
New Delhi
android.championswimmer.tk
If you would like to use TWRP Recovery with this ROM, you can use this app to install it
https://play.google.com/store/apps/d...mer.twrpxperia

Also, this app allows you to come back to CWM if you don't like it. This app works on all custom ROMs (that have FXP-based kernel) and allows installation of TWRP to FOTAKernel partition.
 

Kohelet

Member
Sep 15, 2013
35
21
Los Angeles
I've been running 4.4.x nightlies since late December and haven't had any problems thus far. Good work!

Does this ROM not show the LTE icon? I'm on a C6506 model and LTE icon showed up perfrectly on stock based ROMs. Now I only get the "4G" logo however based on Download speeds it appears to be using the LTE bands as I'm getting 40Mbps down.

Anyone able to confirm this? Is there a fix/workaround? My network settings are set to ATT .pta which is correct for LTE.



I get LTE icon on my C6506 when I'm in an area with LTE. If you're using t-mobile make sure you have the right APN settings for LTE.
 

Top Liked Posts