[ROM][5.0.0][The unnamed Android L SDK port][for MultiROM][06/07/14][v5]

Search This thread

frederic98

Member
Jul 5, 2014
38
15
I'm on 4.4.2 and having the same problem. GApps from the OP install fine but setup crashes on the step after connecting to wifi. Did you get it working after downloading and reflashing GApps again?

Did you boot before flashing GApps? If yes, try clearing your /data in TWRP under advanced - multirom - select rom *select repacked4* - clear /data
 

Carlyle_f

Senior Member
Jan 22, 2014
611
382
Cape Town
This is the error message I get when I start chrome "Critical functionality required to run chrome is missing; either your chrome installation is incomplete, or not compatible with this version of android."

Sent from my GT-I8190 using Tapatalk
 

frederic98

Member
Jul 5, 2014
38
15
This is the error message I get when I start chrome "Critical functionality required to run chrome is missing; either your chrome installation is incomplete, or not compatible with this version of android."

Sent from my GT-I8190 using Tapatalk

How did you install chrome?
 

ironmaskusa

Senior Member
Jul 25, 2011
525
118
USA
Personally, I just installed aptoide and then installed chrome like that.. A lot of my apps seem OK.. But some are kinda quirky.. They work sometimes then force close occasionally, like gmail. But there is always a work around. Overall, I haven't set my expectations high on this experimental build. It is what is!

Can't wait to see more devs getting involved with this build to get it going.. But all this takes time and patience from these guys.. Most of them have their hands in other devices, school, family, life in general. We know this is a dying tab and we just need to except that and not set our expectations too high. I still love my grouper and plan on keeping it for years to come. I will be upgrading to the next Nexus tablet when it gets released. I usually skip generation just because I can't afford the upgrade every time one gets released.

That being said, great work so far for what we have on Android L builds. My hat goes off to you that have taken the time so far to give us something. Look forward to more. ?
 

ichigo_kurosaki

Senior Member
Feb 24, 2013
963
229
34
Butuan City
Waiting...Waiting...Searching for stable version...:D

This is an awesome piece of work! But i'm not so experienced with nexus 7 yet. I'll just have to wait for a more stable version of this which doesn't require multiROM..:D haven't tried flashing ROMs yet on my grouper but all data have backups now if ever i try to b more of a daredevil like i did with my HTC Sensation XE.:D

Anyway, thanks again to the one who made it. Appreciate your efforts.:) :good:
 
Jun 29, 2014
38
310
Version 5: the "oh no, we have to catch up to the Nexus 4" edition ;)

https://drive.google.com/file/d/0B9YZBHL7jnUDeVA5TmNyMGVGaEU/edit?usp=sharing

- Added etc/permissions from stock ROM; Play Store and the Wi-Fi settings now work - thanks to everyone who suggested this
- Switched the build type to userdebug from eng in the build.prop: no more flashing red borders - again, thanks to everyone
- Added Bluetooth libraries and APKs from Cyanogenmod

The Bluetooth is interesting: the Nexus 4 port can use the bluetooth stuff from the Nexus 5 because their processors both support hardware divide, unlike the Nexus 7. Therefore, I can't use the bluetooth apk from the preview images. I chose to use Cyanogenmod's bluetooth stuff because their APK is deodexed, and has a few more features. Unfortunately, audio support in Cyanogenmod's bluetooth framework didn't work on L: first, the Java code force-closes Bluetooth because of a missing method, but thankfully that doesn't get triggered often, unlike the native C++ code. The native code refused to load because libmedia was changed between 4.4.4 and 5.0, so I made a fake libmedia, and the native code managed to load.
 

pknall

Senior Member
Aug 27, 2012
51
16
Why would that cause emojis not loading? Almost every windows pc doesn't hava a native keyboard...

Probably a phone with a third party keyboard? For example the japanese emoji on docomo/softbank/au were incompatible with each other for ages, and I do believe that's how they came out if you sent them to the wrong carrier.
 
  • Like
Reactions: frederic98

frederic98

Member
Jul 5, 2014
38
15
Probably a phone with a third party keyboard? For example the japanese emoji on docomo/softbank/au were incompatible with each other for ages, and I do believe that's how they came out if you sent them to the wrong carrier.

You're not the only one, probably a third party keyboard.

Sent from my DROID RAZR M using XDA Free mobile app

Thanks:good: I understand it now :)

*Hits
:good:THANKS
button*

HTML:
</offTopic>
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 69
    Yes, I know this thread is in the wrong section. I tried to get this thread moved into development, only to be locked out of my own thread. So it's here for now.

    This is an SDK port of Android L preview to the Nexus 7 2012 (Grouper).

    First of all, this ROM is not up to the quality of other ports, as Bluetooth, NFC, many sounds, light sensor, and other features are not working.

    What works:
    - the boot animation ;)
    - Touchscreen
    - Sound (partially)
    - Screen rotation
    - The Settings app
    - The camera
    - Installing apps
    - Wi-Fi - thanks, gnustomp!
    What doesn't work:
    - Playing some sounds, such as the Ding noise played by Google Search after recognizing OK Google
    - Bluetooth
    - NFC
    - Google Text to Speech
    - Everything else

    The port is based on the system image of the 32-bit ARM Android L emulator, with proprietary binaries pulled from the stock 4.4.2 image.
    The kernel used is the LegoKernel from http://forum.xda-developers.com/showthread.php?t=2664392
    The kernel used in v3 and earlier is the stock 4.4.2 kernel from MultiROM http://forum.xda-developers.com/showpost.php?p=34577851&postcount=2.
    The .zip packaging (and the boot animation) is based on the MultiROM repack of the Nexus 5 image from http://forum.xda-developers.com/showpost.php?p=53707461&postcount=1213
    The Superuser shipped with this ROM is made by Koush: http://koush.com/post/superuser
    The non-PIE fix is based on the patch by cernekee.
    This ROM uses the Bluetooth and NFC apks from Cyanogenmod. Thanks!

    To reiterate, this ROM is rather useless. Therefore, I have made this ROM for MultiROM (the ROM won't run without it, currently) so you can dual-boot into this and experiment. To setup MultiROM, follow the instruction on its thread: http://forum.xda-developers.com/showthread.php?t=2011403

    Note that F2FS is not supported.

    I have only tested this on my own device, so if you're getting bootloops, please send me a LogCat of the boot so I can diagnose the problem.

    Installing:
    - Back up your device. This ROM is highly experimental and may screw up stuff.
    - Install MultiROM first
    - Put the downloaded .zip onto the /sdcard partition
    - Boot into the MultiROM recovery
    - Select "Advanced"
    - Select "MultiROM"
    - Select "Add ROM"
    - For "Choose ROM type", select "Android"
    - For "Share kernel with Internal ROM?", Choose "Don't share"
    - Select "Next"
    - Select "Zip file"
    - Choose the downloaded .zip
    - Slide to flash
    - To flash Gapps: Return to home menu -> Advanced -> Multirom -> List ROMs
    - Select the flashed ROM, and then choose Flash Zip; choose the Gapps package
    - After reboot, choose the new ROM in MultiROM's startup menu

    Download: Download latest version (v5)

    Mirrors: (thanks to Frederic98 and alwaysadeel)

    V5
    Mediafire: http://www.mediafire.com/download/q4e6axr73qnslh5/repacked5.zip

    Google Drive: https://docs.google.com/file/d/0BwU6LFnoV_gEMmJ3TWNVSTNOeHM/edit?pli=1

    4Shared: http://www.4shared.com/zip/k9gVsGF7ba/repacked5.html

    Gapps
    Mediafire: http://www.mediafire.com/download/8p81sbwkm876tif/gapps-repacked.zip
    GApps for Android L: here - based on the 4.4.3 Gapps from https://itvends.com/gapps/ with apps pulled from the Nexus 5 image. (I'll remove this download if anyone complains)

    Changelog:
    v5: (July 6th): download v5
    - Added etc/permissions from stock ROM; Play Store and the Wi-Fi settings now work - thanks to everyone who suggested this
    - Switched the build type to userdebug from eng in the build.prop: no more flashing red borders - again, thanks to everyone
    - Added Bluetooth libraries and APKs from Cyanogenmod

    v4: (July 1st): download v4
    - Added gnustomp's Wi-Fi fix
    - Switched to the Lego Kernel

    v3 (June 30th): download v3
    - Added Koush's Superuser to the ROM
    - Added cernekee's non-PIE fix so that Superuser would run

    v2 (June 29th): download v2
    - Fixed stupid mistake that caused app installation to fail
    - Fixed another stupid mistake that prevented Wi-Fi from turning on

    v1 (June 29th): download v1
    - Initial release

    Tools for building this ROM are available at https://github.com/zhuowei/unnamedL - contributions welcome.

    Screenshots:

    VR45vRT.png

    DQl2DuV.png

    oVUKTb8.png

    trIv7DQ.png
    19
    Hi guys, I got Wi-Fi working.
    The problem is that @500 Internal Server Error forgot to copy a couple of libraries.
    The libs needed for WiFi are:
    Code:
    /system/lib/libiprouteutil.so
    /system/lib/libnetlink.so
    Copy them from the stock ROM.

    There are probably a lot more other files that are missing in this ROM, so check if you get an error like
    Code:
    CANNOT LINK EXECUTABLE: could not load library "libiprouteutil.so" needed by "ip"; caused by library "libiprouteutil.so" not found
    That tells you what library is missing.

    UPDATE: proof (just in case)
    Code:
    [email protected]:/ $ ping google.com
    PING google.com (74.125.237.166) 56(84) bytes of data.
    64 bytes from syd01s18-in-f6.1e100.net (74.125.237.166): icmp_seq=1 ttl=56 time=38.5 ms
    Screenshot_2014-07-01-21-29-57.png
    18
    Version 5: the "oh no, we have to catch up to the Nexus 4" edition ;)

    https://drive.google.com/file/d/0B9YZBHL7jnUDeVA5TmNyMGVGaEU/edit?usp=sharing

    - Added etc/permissions from stock ROM; Play Store and the Wi-Fi settings now work - thanks to everyone who suggested this
    - Switched the build type to userdebug from eng in the build.prop: no more flashing red borders - again, thanks to everyone
    - Added Bluetooth libraries and APKs from Cyanogenmod

    The Bluetooth is interesting: the Nexus 4 port can use the bluetooth stuff from the Nexus 5 because their processors both support hardware divide, unlike the Nexus 7. Therefore, I can't use the bluetooth apk from the preview images. I chose to use Cyanogenmod's bluetooth stuff because their APK is deodexed, and has a few more features. Unfortunately, audio support in Cyanogenmod's bluetooth framework didn't work on L: first, the Java code force-closes Bluetooth because of a missing method, but thankfully that doesn't get triggered often, unlike the native C++ code. The native code refused to load because libmedia was changed between 4.4.4 and 5.0, so I made a fake libmedia, and the native code managed to load.
    14
    WIFI FIX

    Here you go guyz just flash this zip from recovery(Recover-->Advanced--->Multirom--->List roms--->[select the build]--->flash zip! ) and internet will be all good to go!! :good::good:

    All thanks to @gnustomp for pointing it!!




    @500 Internal Server Error
    Update-*Rom does not have the NFC.apk neither it has the option to toggle!
    *Upon flashing of gapps the TTS gives force close
    *Lags


    Still small yet significant progress so far!:D
    9
    https://drive.google.com/file/d/0B9YZBHL7jnUDQTk5dWJaTmJ4QUk/edit?usp=sharing

    v4:
    - Added @gnustomp's Wifi fix - thanks!
    - Switched to the Lego Kernel: http://forum.xda-developers.com/showthread.php?t=2664392 this might help F2FS users, since that kernel's commonly used on F2FS ROMs.

    I also looked into making this flashable without MultiROM: unfortunately, with the changes, it always tries to flash to the real system partition, even when I want it to flash as a secondary ROM. So I had to Nandroid restore to get my old ROM back. Sigh. I reverted that change.

    The remaining serious issues:
    - Sound corruption for certain sounds (perhaps with different sample rate?) e.g. the "ding" noise Google Search plays after OK Google is recognized - I already copied over audio_policy.conf, so I dunno what else I need to copy.
    - A lot of Play Store applications are marked as incompatiable with device - probably needs a build.prop or a /system/etc/permissions edit
    - No Bluetooth and NFC support - I don't have a deodexed Bluetooth.apk and Nfc.apk right now; I might download another ROM and pull them from there.

    I would really appreciate if anyone with more porting knowledge can offer advice - this is my first ROM porting project.

    I get neverending boot after flashing..but I have to mention I'm on data-f2fs. (Other roms work fine)

    Sent using my nexus⁴ running Mahdi 2.7 with Xposed and hells-Core B47 KK

    By the way, can someone with a f2fs data partition try to run this? Since the LegoKernel is used for most f2fs ROMs, and MultiROM's trampoline tries to mount /data as f2fs if mounting as ext4 fails, it should boot...

    Edit #2: Oh, wow. http://www.androidpolice.com/2014/0...ve-aosp-includes-support-nexus-4-5-7-2013-10/ says Android L source is released? Then I guess this ROM is now obsolete. :( Ah, well, I'll keep maintaining it until we get a proper Android L port.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone