[ROM][5.0.2] Unofficial CyanogenMOD 12 for MK808B-Plus - WeTek Gift

Search This thread


New member
Jul 29, 2016
Many users have same problem, it is due to different WiFi modules used.

Solution is very easy - just replace drivers in your firmware system/lib with correct one.
I have same problem with many custom and original ROM's using on my MXQ S805, in my situation WiFi works fine when drivers replaced to RTL8188EVT.
That's it.
well, first sorry for my English, can you upload the rom file with the driver already modified for mxq S805 ?
tried to put this one and was no wifi and ethernet


Nov 9, 2009
The CWM install gives me the error that stats "this is only for wetek devices and this device is m201" and I can't install.
Already install Finless ROM 1.1 but I would really like to try this one is it possible. I've used the recovery img provided here but still no success.
Is there something I'm missing.


Hey guys - I'm having the same problem here - can anyone help?


Oct 8, 2014
This is really old but I need help. I use this stick in one of my caffe. I need to upgrade it to 5 to use one app. It had finless 1.1 until now. I installed this but ethernet dosent work :( i use the same usb ethernet adapter which works with finless
Last edited:


New member
May 19, 2015
Thanks for this, I only seem to have found it now as 109k4 seems to work quite well for me :) (but I want kodi 17 and that's android 5 only)

I try and update it and its says:

this package is for device m201c;wetekgift, this device is m201

Then it says update complete but nothing has really changed. I used the recovery image as per instructions.

Any suggestions?



Senior Member
Mar 12, 2011
I'm running finless 1.1 on my mk808b plus and am trying to upgrade to this Rom. Have tried to get the unit to boot to cwm recovery but it only goes to twrp and it fails flashing in that. Have tried making a flashable zip of cwm and flashing that and it doesn't take? Any ideas how to go from finless to cm?


New member
Apr 9, 2018
Problems with Video-Signal

'im asking myself, would my MK808bplus work with my 22" DVI Monitor ?
Now i have probs to get a propper video signal to my Monitor (Acer V223W ) It is 1/3 black on the left side and flickering stripes all over now, with a Finless rom 1.1
Any idea about that ?


Dec 4, 2010
Root is working!

At all - thanx for 5.0.2 but for MXQ S805 it works slowly with some lags, also don't have root. Any way thanx!

Just for reference if anyone else is still using it or plans to: ROOT is there and working!

You just need to enable it through developer settings (tapping a few times on the build number in "About the phone").
There is also a root manager included, but not visible as an app. I did not try to flash SuperSU or Magisk.
If you start any root-app you are being asked for permission, however I did not find any manager to change previous permissions.

I am still using the device with Spotify, Kodi/Spmc and a decent Usb-DAC for Hifi listening and I am pretty much satisfied with it ;)

Btw: I can recommend "Spotify Music - for Android TV (Android TV) 1.6.3". Almost no configuration, automatically HQ and always there to connect while the normal app has to be in the foreground to be available via connect.
Last edited:


New member
May 7, 2018
Awesome, Have you got the source?

Man this is awesome, have you got the device tree used for building this?, I would like to try something with it please.

Top Liked Posts

  • There are no posts matching your filters.
  • 19

    Release notes

    Hello guys, I guess most of you have noticed that, right now, I'm just working on WeTek products (and couldn't be anything different since I really like doing this kind of stuff for them).
    To prove you that WeTek Electronics cares about community and since we don't have any AMLogic S805 product, we decided to make users of MK808B-Plus happy by releasing a CyanogenMOD 12 build for them.

    Userspace and kernel code has been upgraded to Amlogic's Lollipop SDK dated 2015-01-31 (they removed Widevine DRM support in Lollipop so apps like Play Movies won't be able to stream, I'm sorry).

    First install instructions

    * As really first thing I suggest you to flash stock "109k4" rom using "AMLogic Burning Tools" in case you're not already using that ROM or Finless' 1.1.
    * Grab CWM from here, unzip it and copy "recovery.img" file to a MicroSD.
    * Power off your device and unplug the AC power cord.
    * Get the latest available ROM and GAPPS version from the links below and copy them to a MicroSD card.
    * Now insert the MicroSD card in your HDMI stick.
    * Plug the AC power cord while you keep pressed the little reset pinhole (located on the top left of the device) until you see the "Google TV" logo.
    * Once the device has booted to recovery perform a factory reset and flash the ROM's zip for first followed by the GAPPS zip.
    * Reboot and enjoy CyanogenMOD brought to you by WeTek.

    Update instructions

    * Get the latest available ROM and GAPPS version from the links below and copy them to a MicroSD card.
    * Now insert the MicroSD card in your HDMI stick.
    * Enable "Developer options" following this tutorial and from it enable the "Reboot to recovery" option.
    * Bring up power menu by keeping F5 (if you have a keyboard plugged in) and select "Reboot -> recovery", otherwise use the pinhole method adove.
    * Once the device has booted to recovery flash the ROM's zip for first followed by the GAPPS zip.
    * Reboot and enjoy your updated CyanogenMOD.


    * ROM 2015-04-19
    * GAPPS 2015-01-07 (LITE)
    It's a problem of the amlogic kernel, in the previous build I had applied a patch from them (amlogic) to make it work (but the same patch should be used by Rikomagic in their latest 109k4 rom, in fact it was working on my FullHD DVI pc monitor), the same patch doesn't apply with the newer kernel though, I will give it a look and manually merge it
    +1 Would love an update with the CM upstream features/fixes.
    Reserved for later use