• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][5.1.1][condor] Official CyanogenMod 12.1

Search This thread

JimDandy68

Senior Member
Feb 6, 2012
115
10
T-Mobile Samsung Galaxy S5
Moto X4
I'm not sure from reading various posts here whether flashing latest pico open_gapps (20161201) over an older pico pa_gapps (20150418) will cause any problems on my Moto E. I'm running the CM12.1 20160401 snapshot, and I've been getting play services errors recently. I thought I might try installing the latest open gapps for the phone, but want to avoid any unwanted issues. Any advice is appreciated. Thanks.
 
Last edited:

Papdya

Senior Member
Jun 28, 2014
232
63
PUNE
I'm not sure from reading various posts here whether flashing latest pico open_gapps (20161201) over an older pico pa_gapps (20150418) will cause any problems on my Moto E. I'm running the CM12.1 20160401 snapshot, and I've been getting play services errors recently. I thought I might try installing the latest open gapps for the phone, but want to avoid any unwanted issues. Any advice is appreciated. Thanks.
Update your google play services app.
 
  • Like
Reactions: JimDandy68

JimDandy68

Senior Member
Feb 6, 2012
115
10
T-Mobile Samsung Galaxy S5
Moto X4
Lol. I dont know then. I usually used to get that error when my play services would be outdated. Why dont you try the marshmallow roms they are quite stable. Do read the comments though. Cause some CM13 builds are not booting.

I've read none are as stable as this one, and this one has generally been stable, minus this hiccup. I'll search around, but also might try out stock rooted. Thanks.
 
  • Like
Reactions: Papdya

TigerKing

Senior Member
Jul 15, 2015
630
546
Mumbai
OnePlus X
Xiaomi Redmi Note 4
I've read none are as stable as this one, and this one has generally been stable, minus this hiccup. I'll search around, but also might try out stock rooted. Thanks.
Not like that.. try wiping cache and dalvik cache.
Or try wiping above and again installing gapps
Or try factory reset then gapps.

Try cm13 Nov 8 build, is most stable with no issues as known. Other updates build have bootloop problems from Nov 13 build to latest Dec 4 build.
Cm14 is still in fast working.
 
  • Like
Reactions: nOne4u

JimDandy68

Senior Member
Feb 6, 2012
115
10
T-Mobile Samsung Galaxy S5
Moto X4
Not like that.. try wiping cache and dalvik cache.
Or try wiping above and again installing gapps
Or try factory reset then gapps.

Try cm13 Nov 8 build, is most stable with no issues as known. Other updates build have bootloop problems from Nov 13 build to latest Dec 4 build.
Cm14 is still in fast working.

Thanks for this follow-up. I missed it. I actually moved to that build of CM13 and switched to a different Moto E (had two, one with a broken screen and evidently one maybe with a bad mobo, so I franken-swapped). The phone is actually running quite well now with the 11/8 CM13.
 

Akshay_92

Senior Member
Oct 11, 2015
76
9
hey, i was using the 20160110 cm12.1 nightly on my motorola xt1022 and the recovery is twrp 2.8.7.0 by ashwin007 and it was working really well ,barring the music fc every time ,but i learned to live with it, it didn't bother me that much,to point out this nightly was working flawlessly for 20 odd days ,but today things got a little troublesome ,a couple of my apps started force closing,and they force closed every time i opened them,so i decided to wipe the dalvik cache ,after that it normally booted and started doing the usual '' optimizing apps'' thing but after it finished that the issue wasn't resolved and while i was in the lock screen i normally pushed the volume button to unlock it (as my power button is damaged so i use the volume buttons to control it ) the screen froze and the device rebooted ,and after that it kept stuck in a bootloop ,i decided to re-flash the same nightly with the same pico gapps from open gapps i had ,i wiped everything from the wipe option in recovery except micro-sd and flashed both the zip files in the same flashing session ,the installation went normal but after it booted to the ''welcome screen'' and as soon as i selected the language it rebooted!! on its own! and after rebooting when i was again on the welcome screen but i noticed that i was unable to turn the '' WIFI'' ON but i finished the setup thinking that i would do so manually ,but i was not able to turn the wifi on ,it wouldn't turn on from the quick panel and also didn't from the settings menu :( ,but as soon as i also decided to check bluetooth boom!!, it was also busted and after that the device keeps rebooting endlessly ...i have no clue whats gone wrong ,i clean flashed the rom again but the issue persists...please help me right now i have to hang around with this device and i can't afford a new one :(
 
Last edited:

Ujwal Agrawal

Senior Member
Aug 2, 2015
410
195
Mumbai
hey, i was using the 20160110 cm12.1 nightly on my motorola xt1022 and the recovery is twrp 2.8.7.0 by ashwin007 and it was working really well ,barring the music fc every time ,but i learned to live with it, it didn't bother me that much,to point out this nightly was working flawlessly for 20 odd days ,but today things got a little troublesome ,a couple of my apps started force closing,and they force closed every time i opened them,so i decided to wipe the dalvik cache ,after that it normally booted and started doing the usual '' optimizing apps'' thing but after it finished that the issue wasn't resolved and while i was in the lock screen i normally pushed the volume button to unlock it (as my power button is damaged so i use the volume buttons to control it ) the screen froze and the device rebooted ,and after that it kept stuck in a bootloop ,i decided to re-flash the same nightly with the same pico gapps from open gapps i had ,i wiped everything from the wipe option in recovery except micro-sd and flashed both the zip files in the same flashing session ,the installation went normal but after it booted to the ''welcome screen'' and as soon as i selected the language it rebooted!! on its own! and after rebooting when i was again on the welcome screen but i noticed that i was unable to turn the '' WIFI'' ON but i finished the setup thinking that i would do so manually ,but i was not able to turn the wifi on ,it wouldn't turn on from the quick panel and also didn't from the settings menu :( ,but as soon as i also decided to check bluetooth boom!!, it was also busted and after that the device keeps rebooting endlessly ...i have no clue whats gone wrong ,i clean flashed the rom again but the issue persists...please help me right now i have to hang around with this device and i can't afford a new one :(
Update the TWRP as well as the ROM . CM 14.1 is very good have a try.
 

ABSathe

Senior Member
Aug 4, 2016
437
458
Pune
hey, i was using the 20160110 cm12.1 nightly on my motorola xt1022 and the recovery is twrp 2.8.7.0 by ashwin007 and it was working really well ,barring the music fc every time ,but i learned to live with it, it didn't bother me that much,to point out this nightly was working flawlessly for 20 odd days ,but today things got a little troublesome ,a couple of my apps started force closing,and they force closed every time i opened them,so i decided to wipe the dalvik cache ,after that it normally booted and started doing the usual '' optimizing apps'' thing but after it finished that the issue wasn't resolved and while i was in the lock screen i normally pushed the volume button to unlock it (as my power button is damaged so i use the volume buttons to control it ) the screen froze and the device rebooted ,and after that it kept stuck in a bootloop ,i decided to re-flash the same nightly with the same pico gapps from open gapps i had ,i wiped everything from the wipe option in recovery except micro-sd and flashed both the zip files in the same flashing session ,the installation went normal but after it booted to the ''welcome screen'' and as soon as i selected the language it rebooted!! on its own! and after rebooting when i was again on the welcome screen but i noticed that i was unable to turn the '' WIFI'' ON but i finished the setup thinking that i would do so manually ,but i was not able to turn the wifi on ,it wouldn't turn on from the quick panel and also didn't from the settings menu :( ,but as soon as i also decided to check bluetooth boom!!, it was also busted and after that the device keeps rebooting endlessly ...i have no clue whats gone wrong ,i clean flashed the rom again but the issue persists...please help me right now i have to hang around with this device and i can't afford a new one :(
The issue may be causing because of google play services ..(my device too had similar issues when I tried LP ROM with latest open Gapps) You may try older Gapps (banks Gapps or something like that ) . My another device having stock lollipop also had issues with updated play service .If you really want to use lollipop . But it's pretty outdated (from my point of view).. so I'd suggest you to upgrade to marshmallow or nougat :good
Good luck !!
 

Akshay_92

Senior Member
Oct 11, 2015
76
9
Update the TWRP as well as the ROM . CM 14.1 is very good have a try.

i greatly appreciate your advice but i would rather stick with cm 12.1, isn't there a way to fix this ? ..thank you for your advice .

---------- Post added at 05:42 PM ---------- Previous post was at 05:01 PM ----------

The issue may be causing because of google play services ..(my device too had similar issues when I tried LP ROM with latest open Gapps) You may try older Gapps (banks Gapps or something like that ) . My another device having stock lollipop also had issues with updated play service .If you really want to use lollipop . But it's pretty outdated (from my point of view).. so I'd suggest you to upgrade to marshmallow or nougat :good
Good luck !!

I am really grateful and acknowledge the fast response ,but is their any way to fix this issue? , i'd really appreciate if i got this working,as i have an exam coming and i"m without my pc to do any tweaking... I hope you understand :)
 

ABSathe

Senior Member
Aug 4, 2016
437
458
Pune
i greatly appreciate your advice but i would rather stick with cm 12.1, isn't there a way to fix this ? ..thank you for your advice .

---------- Post added at 05:42 PM ---------- Previous post was at 05:01 PM ----------



I am really grateful and acknowledge the fast response ,but is their any way to fix this issue? , i'd really appreciate if i got this working,as i have an exam coming and i"m without my pc to do any tweaking... I hope you understand :)
As a first step of debugging .. try clean flashing ROM only .. don't flash Gapps
If this works fine .. you can obviously conclude that Gapps are faulty .. if Gapps are faulty .. try some other Gapps

If your ROM is faulty .. try stock optimized ROM (by @lost101) it's available in android development section :good:

Hope this helps
 
  • Like
Reactions: Akshay_92

Top Liked Posts

  • There are no posts matching your filters.
  • 177
    cyanogenmod-12-1-rom.jpg


    CyanogenMod is a free, community built, aftermarket firmware distribution of Android 5.1 (Lollipop), which is designed to increase performance and reliability over stock Android for your device.


    Code:
    #include 
    /*
    * Your warranty is now void.
    *
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.
    */

    CyanogenMod is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (gapps). CyanogenMod does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    Instructions For Flashing First time

    1. Reboot to recovery.
    2. Factory Reset. (wipe data,cache and dalvik cache)
    3. Flash the zip and reboot.

    Instructions For Upgrading from Previous Nightly/RC/Stable/Milestone

    • Reboot to recovery.
    • wipe cache and dalvik cache only .
    • Flash the zip and reboot.

    Working List

    1. RIL
    2. Wifi
    3. Gallery Video OK
    4. GPS

    Not Working /Issues
    • PM me if you find any issues with logcat only.

    LINKS

    ROM:-
    official Nightly Builds

    GAPPS:-


    New gapps

    CyanogenMod 12.1 Sources changelog:
    CM-12.1 Change log's

    Credits
    Google
    CyanogenMod Team
    Motorola
    Dhacker29
    JackpotClavin
    cybojenix

    About feedback:
    We always welcome any kind of feedback, but if you report a bug, please, do it in a proper way, make a full detailed description about how to reproduce that bug, explain which add-ons you installed, tell us if you wiped cache and dalvik-cache or if you made a clean install, also, is very helpful to attach a logcat reproducing that bug, here you have a great guide about how to report a bug and take a logcat


    XDA:DevDB Information
    Lollipop 5.1.1 for moto E, ROM for the Moto E

    Contributors
    scritch007, percy_g2, ashwin007
    Source Code: https://github.com/CyanogenMod

    ROM OS Version: 5.1.x Lollipop
    ROM Kernel: Linux 3.4.x
    ROM Firmware Required: TWRP Recovery
    Based On: CyanogenMod

    Version Information
    Status: Nightly

    Created 2015-03-27
    Last Updated 2015-08-23
    36
    Changelog

    07/04/2015
    + CM12.1 updates

    06/04/2015
    + CM12.1 updates

    02/04/2015
    + CM12.1 updates
    + No need to apply previous patches they are in the CM official repositories
    + Video Fix

    30/03/2015
    + CM12.1 updates
    + http://review.cyanogenmod.org/#/c/92582/ (which should fix the package installer but can't test it for now)

    29/03/2015

    CM 12.1 updates
    + http://review.cyanogenmod.org/#/c/92526/
    + http://review.cyanogenmod.org/#/c/92529/
    + The fix for the MediaProvider
    + A fix of mine which now makes it possible to have some playlist that persists after reboot for files that are on the external SDCard. The files will only be removed from the playlist if you eject the SDcard explicitly. This should also increase the speed of accessing media that are on the external sdcard after a reboot.
    26
    I don't know why you guys come to weird conclusions.I'm working on CM 13...
    26
    Its booting....But no display.....Once I get it working I'll post preview builds.....