• XDA Forums have been migrated to XenForo. We are aware of several issues including missing threads, logins not working, and more. To discuss, use this thread.

[ROM][5.1.1_r1][UNOFFICIAL] CyanogenMod 12.1 Lollipop - Amami [LMY47V][2015/04/24]

someone8

New member
Aug 18, 2010
25
10
0
Those commits were pushed directly to github, not over gerrit, so they won't show up in cmxlog ;)
Currently just sitting at a PC in university, waiting for wifi to break :p
let's see if I'm successful :D

EDIT: no wifi breakage here, with about 15 minutes of testing. I'd say the problem is solved, but maybe I was just lucky in those 15 minutes...
Ahhh, thanks! I will flash the recent nightly and do the same like you: waiting until the wifi connection to eduroam snaps (or the phone reboots) :rolleyes: I hope I will wait forever :fingers-crossed:

EDIT: I would argument that the WiFi issues are still fully not solved. After walking around in the university, the WiFi settings crashed, and it took a while until it reconnected to eduroam :crying:
 
Last edited:

NRG-R9T

New member
Sep 10, 2012
66
17
0
is the latest nighlty from 2015 09 22 useable as daily driver ?
is the battery life better now ? the latest nightly i tested was in begin of september, but the battery life was to bad
I use the CM12.1 nightlies as a daily driver since july, but I'm comfortable on the bleeding edge of technology. It's like it is, not stable, but mostly. I dirty flash every other day the latest version and that seems to help also with random reboots. I'm not a developer.

as for the battery life I've found a solution I'd like to recommend to everybody on any 5.1.1 ROM. install this and you'll enjoy much less battery drain. turned off without Wifi I got a flat out battery life ( not more that 2% drain over night). install xposed and this fine little fix module: http://forum.xda-developers.com/xposed/modules/xposed-mobileradioactivefix-t3189393
 
Last edited:
  • Like
Reactions: someone8

someone8

New member
Aug 18, 2010
25
10
0
as for the battery life I've found a solution I'd like to recommend to everybody on any 5.1.1 ROM. install this and you'll enjoy much less battery drain. turned off without Wifi I got a flat out battery life ( not more that 2% drain over night). install xposed and this fine little fix module: http://forum.xda-developers.com/xposed/modules/xposed-mobileradioactivefix-t3189393
Cool, thanks. I will try that out (currently activated). And since you have xposed already installed now, you can also try out Amplify to block/limit the wakelocks, alarms, and services of Google Play Services, etc. (blocking NlpWakeLock and NlpCollectorWakelLock is free). FYI: I came across this issue/potential fix here: https://www.reddit.com/r/Android/comments/27lf82/fix_for_nlpcollectorwakelock_that_does_not/
I have the feeling that my battery drain improved by doing this. But as always: subjective feeling... But even a placebo effect can make one feel better :victory:
 

mcastagnaa

New member
Mar 23, 2008
285
64
0
Dublin
Cool, thanks. I will try that out (currently activated). And since you have xposed already installed now, you can also try out Amplify to block/limit the wakelocks, alarms, and services of Google Play Services, etc. (blocking NlpWakeLock and NlpCollectorWakelLock is free). FYI: I came across this issue/potential fix here: https://www.reddit.com/r/Android/comments/27lf82/fix_for_nlpcollectorwakelock_that_does_not/
I have the feeling that my battery drain improved by doing this. But as always: subjective feeling... But even a placebo effect can make one feel better :victory:
Didn't notice any benefit I am afraid.
Amplify on the other end makes a difference.

On a different note, the worst issue I still have is on bluetooth devices not being recognised upon reboot. Which means you always have to pair them.

Sent from my Xperia Z1 Compact using Tapatalk
 

too.stoopid

Active member
Jul 8, 2014
164
33
28
Didn't notice any benefit I am afraid.
Amplify on the other end makes a difference.

On a different note, the worst issue I still have is on bluetooth devices not being recognised upon reboot. Which means you always have to pair them.

Sent from my Xperia Z1 Compact using Tapatalk
Simple workaround for the BT bug:
Use an app like root browser and create a file (not a folder) in /data/etc/ and name it bluetooth_bdaddr
Set the permissions of the file to rw-r-r
Open the file as a text file and write an existing bluetooth address in there. To get one, just turn on bluetooth and take the one that gets created automatically.
Now reboot your phone and you have a fixed bt address that will no longer change.
 

mcastagnaa

New member
Mar 23, 2008
285
64
0
Dublin
Simple workaround for the BT bug:
Use an app like root browser and create a file (not a folder) in /data/etc/ and name it bluetooth_bdaddr
Set the permissions of the file to rw-r-r
Open the file as a text file and write an existing bluetooth address in there. To get one, just turn on bluetooth and take the one that gets created automatically.
Now reboot your phone and you have a fixed bt address that will no longer change.
It works!
You made my day [emoji1]

Sent from my Xperia Z1 Compact using Tapatalk
 

someone8

New member
Aug 18, 2010
25
10
0
Only get Wifi issues when using M5 Kernel. Kernel hasnt been updated with the latest cm commits hence the Wifi issues at least for me that is.
Well observed, @lemon567! I was flashing the M5 kernel by default after every CM update, but I forgot that he (or she?) depends on CM as well.
Without M5, the WiFi works indeed as a charm now! The phone can connect to different EAP WiFis without crashes. Awesome! Feels so gooood :victory: (almost like I would have a new phone :D)
 

l.ca

New member
Oct 6, 2015
15
8
0
Palermo
BT/WiFi problems workarounds until proper fixes.

I worked around BT and WiFi problems like this:
On your phone, after installing and booting the latest nightly (I'm on 20151006 as of this writing. Hope soon this will not be needed anymore):
Launch File Manager. You will need either Prompt or Root access mode on * => General settings;
change directory to /system/etc/firmware/wlan/prima, open WCNSS_qcom_cfg.ini
scroll down to gChannelBondingMode24GHz=1 (on line 306, towards the end) and change it to gChannelBondingMode24GHz=0
save and exit the editor

Switch on Bluetooth;
Settings => About phone => Status:
write down or copy to the clipboard your Bluetooth address (better yet, write it down when still stock);
Back to File Manager (with root access enabled).
in /data/etc/ create a file named bluetooth_bdaddr , in Properties>Permissions change owner/group to bluetooth and permissions to -RW--R---R--
open the newly created bluetooth_bdaddr with Editor, type or paste the Bluetooth address you wrote down or copied before
save and exit the editor;

if your are plagued by the "identical WiFi MAC address for all Xperia Z1C" (that is, you have collisions from more than one device with the same MAC on the same network segment)
In File Manager (with root access enabled).
in /data/etc/ create a file named wlan_macaddr0 , in Properties>Permissions change owner/group to wifi and permissions to -RW--R---R--
open the newly created wlan_macaddr0 with Editor, type or paste a new MAC address (e.g. 20:54:76:BA:DA:55 - see below)
save and exit the editor;
You will want to use your original hardware MAC if you took note of it while still stock, or make some yourself using a prefix from Sony Mobile Communications (look for some on http://standards-oui.ieee.org/oui.txt) and six random {0-9, A-F} characters

Of course you can perform all this using adb shell or local terminal and su, vi, chown, chmod.

Reboot your phone (will also update your WiFi MAC if you specified one) or enter/exit airplane mode;

WiFi should work as it used to until 20150927 (that is, no drops every few seconds). Bluetooth address will not change and screw pairings up all the time

In Settings => About phone => Status you should see the WiFi MAC and Bluetooth addresses you specified. They should both survive CM updates. You will need to put gChannelBondingMode24GHz back to 0 in WCNSS_qcom_cfg.ini until either channel bonding is fixed in the driver or the change is reverted upstream.
Also keep an eye on:
https://jira.cyanogenmod.org/browse/NIGHTLIES-1877
http://review.cyanogenmod.org/#/c/111158/
 
Last edited:

prinz.z

New member
Sep 20, 2008
75
12
0
I worked around BT and WiFi problems like this:
On your phone, after installing and booting the latest nightly (I'm on 20151006 as of this writing. Hope soon this will not be needed anymore):
Launch File Manager. You will need either Prompt or Root access mode on * => General settings;
change directory to /system/etc/firmware/wlan/prima, open WCNSS_qcom_cfg.ini
scroll down to gChannelBondingMode24GHz=1 (on line 306, towards the end) and change it to gChannelBondingMode24GHz=0
save and exit the editor

Switch on Bluetooth;
Settings => About phone => Status:
write down or copy to the clipboard your Bluetooth address (better yet, write it down when still stock);
Back to File Manager (with root access enabled).
in /data/etc/ create a file named bluetooth_bdaddr , in Properties>Permissions change owner/group to bluetooth and permissions to -RW--R---R--
open the newly created bluetooth_bdaddr with Editor, type or paste the Bluetooth address you wrote down or copied before
save and exit the editor;

if your are plagued by the "identical WiFi MAC address for all Xperia Z1C" (that is, you have collisions from more than one device with the same MAC on the same network segment)
In File Manager (with root access enabled).
in /data/etc/ create a file named wlan_macaddr0 , in Properties>Permissions change owner/group to wifi and permissions to -RW--R---R--
open the newly created wlan_macaddr0 with Editor, type or paste a new MAC address (e.g. 20:54:76:BA:DA:55 - see below)
save and exit the editor;
You will want to use your original hardware MAC if you took note of it while still stock, or make some yourself using a prefix from Sony Mobile Communications (look for some on http://standards-oui.ieee.org/oui.txt) and six random {0-9, A-F} characters

Of course you can perform all this using adb shell or local terminal and su, vi, chown, chmod.

Reboot your phone (will also update your WiFi MAC if you specified one) or enter/exit airplane mode;

WiFi should work as it used to until 20150927 (that is, no drops every few seconds). Bluetooth address will not change and screw pairings up all the time

In Settings => About phone => Status you should see the WiFi MAC and Bluetooth addresses you specified. They should both survive CM updates. You will need to put gChannelBondingMode24GHz back to 0 in WCNSS_qcom_cfg.ini until either channel bonding is fixed in the driver or the change is reverted upstream.
Cool thanks a lot.. sounds promising. The ChannelBondingMode could fix the problem for Wifi here. However my bluetooth problem was something different to the MAC thing, with the latest nightlies, I was not able to turn bluetooth on at all (or recently I could but not after it crashed once, with the problem even surviving a reboot).
 
  • Like
Reactions: Talkrabb
Our Apps
Get our official app! (coming soon)
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone