• XDA Forums have been migrated to XenForo. We are aware of several issues including missing threads, logins not working, and more. To discuss, use this thread.

[ROM] [5.1.x] [PRE-NIGHTLY] OmniROM for the ME301T

Status
Not open for further replies.

lj50036

Senior Member
Feb 14, 2013
3,321
3,293
0
39
FUXDA
OmniROM for ME301t

About OmniROM
See what OmniROM is all about: http://omnirom.org/about/

What do you need
OmniROM is a custom ROM and to be able to install a custom ROM, you will need to unlock your bootloader. You can unlock your bootloader from the Asus website. Please be advised that you will loose your warranty.

  • You need to be on the latest 4.2 bootloader. If not please update to the lastest Asus stock ROM first, otherwise you might brick your ME301T!!!
  • To be able to install OmniROM you will need at least TWRP 2.8.5.0 or higher
  • You need to have TWRP or CWM installed
  • You will need a flashable GApps package
  • You need SuperSU if you want to have root access

See the Downloads part of this message for the needed packages

How to install
To install OmniROM please follow these instructions:
  • Flash the TWRP 2.8.5.0 (or higher)
  • Reboot into recovery
  • Do a factory reset / full wipe
  • Flash the OmniROM zip file, the GApps ZIP file and SuperSU ZIP file
  • Reboot the tablet and enjoy OmniROM

Downloads
Below are the files you need for flashing OmniROM:

To see the changes in the nightly builds download https://play.google.com/store/apps/details?id=com.bytehamster.changelog

Enjoy OmniROM

XDA:DevDB Information
OmniROM for Asus Transformer ME301T

Contributors
lj50036, hardslog, scanno
Source Code: https://gerrit.omnirom.org

ROM OS Version: 5.1.x Lollipop
ROM Kernel: Linux 3.1.x
Based On: OmniROM

Version Information
Status: Beta

Created 2015-05-19
Last Updated 2015-05-27
 
Last edited:

lj50036

Senior Member
Feb 14, 2013
3,321
3,293
0
39
FUXDA
ALL

The ROM is still in pre-nightly and by flashing it you are helping the pre-nightly Testing process ;)

It may still have some bugs, spontaneously reboot, drain the battery faster or heat up a bit. The aim is to make it better and fix them.

If you find a bug and want to report it here please post a logcat (after it occurred) with a description of what you were doing at the time and the rough timing in the logcat to look at (these things get huge!).

You can also post a dmesg which is the kernel boot logs and can indicate issues with data corruption or hardware.

If you get a reboot then please post a last_kmsg from the /proc folder.

How to get a logcat

How to get useful logs


Thank you!!

Join us on IRC for a chat or if you have questions:

Freenode
#omnirom

There is no Q&A section for this rom as it is still in dev so you are ok to post your questions here!
 
Last edited:

Okiera29

Active member
Apr 18, 2014
224
57
28
Oklahoma City
First, I said it before, but I will say it again, @lj50036. @hardslog and @scanno, thanks for all the hard work. The ROM is running great, no SOD either...YAY!!!
Now, stupid question that I most likely already know the answer for... I am on the 20150516 version already. I can just flash the -enforced version over it right? I don't need to do a clean install again do I? Thanks
 

lupuradu

New member
Aug 24, 2014
70
28
0
30
Sulmona
Twrp will format your old ROM anyway so no, you can't flash the enforced ROM over the existing one. Just do a dalvick / cache wipe and flash. It will be a clean install but you will still have all of your files in the Tab's internal memory. Gapps should restore all of your previously installed apps and settings.
 

acebeace

New member
Aug 10, 2013
5
0
0
Hi guys,
I have a stupid question: I have TWRP 2.8.1 and i have already 5.1.1 (it was flashed with out any issue).
The question is - is it OK to stay on this TWRP or i will have a problems and better to update?
And the second: is it ok to flash from 2.8.1 to 2.8.6 via fastboot? (on the original site it is info that i have to update through 2.8.4, but where to obtain 2.8.4 for me301?)
 

lj50036

Senior Member
Feb 14, 2013
3,321
3,293
0
39
FUXDA
all my apps and such are backed up with Titanium anyway so will just install that app and go from there
I would test the water. never restore /system apps, and if you have issue after a restore...

Then you will have to download new from the play store .....

Thx Josh


Hi guys,
I have a stupid question: I have TWRP 2.8.1 and i have already 5.1.1 (it was flashed with out any issue).
The question is - is it OK to stay on this TWRP or i will have a problems and better to update?
And the second: is it ok to flash from 2.8.1 to 2.8.6 via fastboot? (on the original site it is info that i have to update through 2.8.4, but where to obtain 2.8.4 for me301?)
Anything above 2.8.x.x will work.....

If you want to upgrade to the newest, yes fastboot will work .....

If you hold of I am going to be releasing a KANG version of my TWRP....

Thx Josh
 
Last edited:

lupuradu

New member
Aug 24, 2014
70
28
0
30
Sulmona
For those people that are looking for GApps and like the aroma installer, take a look at http://forum.xda-developers.com/showthread.php?t=3010798

[GAPPS][5.0/5.1][AROMA] LP-GAPPS [May, 15 2015]

I am using these on the tf300t. Sometimes the aroma installer hangs a bit, but presentatie the screen helps.
Right now i'm using bANKS gapps but i will try these too eventually.
Today i tried 5.1 minimal and i got errors right at the startup.
Thanks for the heads-up!
 
  • Like
Reactions: the.perfect.man

lupuradu

New member
Aug 24, 2014
70
28
0
30
Sulmona
Very odd...I could not add a Google account with BaNkS or Aroma-LP, but 5.1 minimal worked.
Well in my case with banks it felt like i bought the tablet with lollipop pre-installed by asus, everything went smooth just like when i first turned on the tablet. With minimal on the other hand i couldn't get past language selection screen. Some ".com process stopped working" pop-up kept showing on the screen. Tried to wipe cache and stuff but it proved to be a no-go.
 

Olinbit

New member
May 6, 2015
8
0
0
valcea
what works in this rom?

OmniROM for ME301t

About OmniROM
See what OmniROM is all about: http://omnirom.org/about/

What do you need
OmniROM is a custom ROM and to be able to install a custom ROM, you will need to unlock your bootloader. You can unlock your bootloader from the Asus website. Please be advised that you will loose your warranty.

  • You need to be on the latest 4.2 bootloader. If not please update to the lastest Asus stock ROM first, otherwise you might brick your ME301T!!!
  • To be able to install OmniROM you will need at least TWRP 2.8.5.0 or higher
  • You need to have TWRP or CWM installed
  • You will need a flashable GApps package
  • You need SuperSU if you want to have root access

See the Downloads part of this message for the needed packages

How to install
To install OmniROM please follow these instructions:
  • Flash the TWRP 2.8.5.0 (or higher)
  • Reboot into recovery
  • Do a factory reset / full wipe
  • Flash the OmniROM zip file, the GApps ZIP file and SuperSU ZIP file
  • Reboot the tablet and enjoy OmniROM

Downloads
Below are the files you need for flashing OmniROM:

To see the changes in the nightly builds visit https://changelog.omnirom.org/#/me301/next

Enjoy OmniROM

XDA:DevDB Information
OmniROM for Asus Transformer ME301T, ROM for the Asus Transformer TF300T

Contributors
lj50036, hardslog, scanno
Source Code: https://gerrit.omnirom.org

ROM OS Version: 5.1.x Lollipop
ROM Kernel: Linux 3.1.x
Based On: OmniROM

Version Information
Status: Beta

Created 2015-05-19
Last Updated 2015-05-19


i can't see the change in https://changelog.omnirom.org/#/me301/next
He has any bug? What workly?
 

lj50036

Senior Member
Feb 14, 2013
3,321
3,293
0
39
FUXDA
i can't see the change in https://changelog.omnirom.org/#/me301/next
He has any bug? What workly?
Well I dont want to be rude, but did you have to reply to the op ?

It is a pre-nightly but most everything is working as it should .....

This is a dev thread for devs to test and report back what is not working ......

So feel free to flash and test ....

Thx Josh
 
  • Like
Reactions: the.perfect.man

CanuckinPA

New member
Nov 28, 2010
281
19
0
State College, PA
For those people that are looking for GApps and like the aroma installer, take a look at http://forum.xda-developers.com/showthread.php?t=3010798

[GAPPS][5.0/5.1][AROMA] LP-GAPPS [May, 15 2015]

I am using these on the tf300t. Sometimes the aroma installer hangs a bit, but presentatie the screen helps.
Flashed the ROM on my ME301T but the aroma GAPPS installer hung up, so I went with PA GAPPS. So far, no SOD like I got with KatKiss. :good:
 

csjjpm

New member
Jan 6, 2012
109
13
0
Manchester
Fantastic thank you

Wow, this is great. I've applied it to my ME301T which has CWM recovery and it works great.

My camera didn't work with OmniROM 4.4.4 it crashed my tablet but EVERYTHING is working brilliantly with this ROM.

Great work. Well done.
 
Status
Not open for further replies.