[ROM][5.x] CyanogenMod (CM12 / CM 12.1)

Search This thread

Android-Andi

Inactive Recognized Contributor
Mar 3, 2013
10,847
29,253
andi34.github.io
Tho there are mm roms now available for tab2 7" but I'd still get lollipop.. So I flashed the rom, got gapps from opengapss
The issue is whenever I start it the CM boot logo is in landscape mode, when the device is booted everything is seen in landscape mode but the bigger problem is tho everything is in landscape, the touch responds to portrait, confusing? It's like this the lock screen is in landscape mode but to open it I have to drag it from the bottom to top like we would do on the portrait mode..... Anyone? Who got this issue?
Please get a logcat and dmesg. The commit i though missing is applied already.

Edit:
Checked on my p3110 and all is fine.
Must be an issue on your end. Custom kernel?
 
Last edited:
Tho there are mm roms now available for tab2 7" but I'd still get lollipop.. So I flashed the rom, got gapps from opengapss
The issue is whenever I start it the CM boot logo is in landscape mode, when the device is booted everything is seen in landscape mode but the bigger problem is tho everything is in landscape, the touch responds to portrait, confusing? It's like this the lock screen is in landscape mode but to open it I have to drag it from the bottom to top like we would do on the portrait mode..... Anyone? Who got this issue?
Same issue was with me I don't know how I fixed I think it fixed by do some reboots or I don't know
But u can try reboot until it fix
Try to reboot it from recovery
Or try wipe cache /dalvik cache or dirty flash ROM again
Or provide logs if u want it to fix
 
Last edited:
Please get a logcat and dmesg. The commit i though missing is applied already.

Edit:
Checked on my p3110 and all is fine.
Must be an issue on your end. Custom kernel?
No I guess it's the gapps? Many in the thread said try slim gapps.. And I didn't flash a custom kernel

---------- Post added at 04:25 AM ---------- Previous post was at 04:04 AM ----------

Same issue was with me I don't know how I fixed I think it fixed by do some reboots or I don't know
But u can try reboot until it fix
Try to reboot it from recovery
Or try wipe cache /dalvik cache or dirty flash ROM again
Or provide logs if u want it to fix
Oh hey this worked...
 

walkjivefly

New member
Sep 27, 2015
4
1
First off, thanks to Android-Andi for providing contemporary ROMs for an "old" but still functional device.

Today I installed CM 12.1 and OpenGapps on a Tab2 10.1 5110. I did a full wipe (cache, Dalvik, system, data) first using TWRP 3.0.0.0. The actual files used were

GT-P5110_TWRP_3.0.0-0.tar.md5 installed by heimdall
cm-12.1-20160209-2255-UNOFFICIAL-p5110.zip installed by TWRP
open_gapps-arm-5.1-pico-20161208.zip installed by TWRP

Upon reboot the initial setup rebooted at the end of every single stage. After about 5 or 6 reboots I got fed up, assumed Gapps was the culprit, went back to recovery, wiped everything again, reflashed CM12 and tried again.
It was better this time, initial setup ran to completion, most things seem to work. I reinstalled the apps I want most. One problem is contacts only works in landscape mode. Auto-rotation is switched on but ignored. Except in contacts/settings where it is respected. Oh, and the device doesn't show up on my PC in adb. Developer options are enabled and USB debugging is switched on. But I've also had about 3 or 4 random restarts which is 3 or 4 too many.

So, finally, the question: can I (upgrade TWRP first) dirty flash cm-12.1-20161108-1918-UNOFFICIAL-espressowifi.zip over what I've got or do I need to wipe it all again and then re-install all the apps again after reflashing?
 
Last edited:
  • Like
Reactions: ashkineeeeee

Lightracer

Senior Member
May 28, 2016
379
110
First off, thanks to Android-Andi for providing contemporary ROMs for an "old" but still functional device.

Today I installed CM 12.1 and OpenGapps on a Tab2 10.1 5110. I did a full wipe (cache, Dalvik, system, data) first using TWRP 3.0.0.0. The actual files used were

GT-P5110_TWRP_3.0.0-0.tar.md5 installed by heimdall
cm-12.1-20160209-2255-UNOFFICIAL-p5110.zip installed by TWRP
open_gapps-arm-5.1-pico-20161208.zip installed by TWRP

Upon reboot the initial setup rebooted at the end of every single stage. After about 5 or 6 reboots I got fed up, assumed Gapps was the culprit, went back to recovery, wiped everything again, reflashed CM12 and tried again.
It was better this time, initial setup ran to completion, most things seem to work. I reinstalled the apps I want most. One problem is contacts only works in landscape mode. Auto-rotation is switched on but ignored. Except in contacts/settings where it is respected. Oh, and the device doesn't show up on my PC in adb. Developer options are enabled and USB debugging is switched on. But I've also had about 3 or 4 random restarts which is 3 or 4 too many.

So, finally, the question: can I (upgrade TWRP first) dirty flash cm-12.1-20161108-1918-UNOFFICIAL-espressowifi.zip over what I've got or do I need to wipe it all again and then re-install all the apps again after reflashing?
Always use Andi's common TWRP for flashing his roms. The latest TWRP can be found here under recoveries andi34.github.io. And you can try to dirty flash but make a backup first just in case something goes wrong!

Sent from my espresso3g using XDA Labs
 

walkjivefly

New member
Sep 27, 2015
4
1
Always use Andi's common TWRP for flashing his roms. The latest TWRP can be found here under recoveries andi34.github.io. And you can try to dirty flash but make a backup first just in case something goes wrong!

Sent from my espresso3g using XDA Labs

OK, thanks. I was hoping for something a little more definitive than "suck it and see" but I'll suck it and see.

I flashed espresso-common_TWRP_3.0.2-8.tar.md5 recovery as a starting point and the tablet refused to boot, either normally or into recovery.

Reflashed GT-P5110_TWRP_3.0.0-0.tar.md5 and was able to boot recovery and normally. Will try espresso-common_TWRP_3.0.2-6.tar.md5 recovery next...
 

Lightracer

Senior Member
May 28, 2016
379
110
OK, thanks. I was hoping for something a little more definitive than "suck it and see" but I'll suck it and see.

I flashed espresso-common_TWRP_3.0.2-8.tar.md5 recovery as a starting point and the tablet refused to boot, either normally or into recovery.

Reflashed GT-P5110_TWRP_3.0.0-0.tar.md5 and was able to boot recovery and normally. Will try espresso-common_TWRP_3.0.2-6.tar.md5 recovery next...
You can just flash the zip while in your current recovery

Sent from my espresso3g using XDA Labs
 

walkjivefly

New member
Sep 27, 2015
4
1
You can just flash the zip while in your current recovery

Sent from my espresso3g using XDA Labs

Ah, that'll be good to know once I get a ROM installed where ADB works again. I didn't know if TWRP could flash a recovery itself or if that would break things, perhaps in an interesting/nasty way. For now I'm downloading a bunch of alternative P5110 and espressowifi ROMS to copy to sdcard using a card reader. At least heimdall still works so I don't need to do that for the recoveries but if I have room left I might chuck a couple of alternative TWRPs on, just in case.
 

Lightracer

Senior Member
May 28, 2016
379
110
Ah, that'll be good to know once I get a ROM installed where ADB works again. I didn't know if TWRP could flash a recovery itself or if that would break things, perhaps in an interesting/nasty way. For now I'm downloading a bunch of alternative P5110 and espressowifi ROMS to copy to sdcard using a card reader. At least heimdall still works so I don't need to do that for the recoveries but if I have room left I might chuck a couple of alternative TWRPs on, just in case.
As far as I know, you can update twrp just buy flashing the zip. It won't break things :) If it did, I wouldn't be typing on this tablet! :D

Sent from my espresso3g using XDA Labs
 

walkjivefly

New member
Sep 27, 2015
4
1
I upgraded TWRP to 3.0.2.6 (using heimdall and espresso-common_TWRP_3.0.2-6.tar.md5), rebooted recovery, wiped cache and Dalvik, rebooted recovery, installed CM12 (cm-12.1-20161108-1918-UNOFFICIAL-espressowifi.zip), rebooted.

It started OK.
No random reboots so far.
ADB is working.
Contacts still only in landscape mode but contacts/settings does respect rotation and appears in portrait mode if appropriate.

So dirty install over cm-12.1-20160209-2255-UNOFFICIAL-p5110.zip appears not to be a problem.

I'm not running gapps and plan not to ever again after the 11 November update trashed all my devices. Investigating alternative repositories and apps for the things which require Google Play Services the biggest virus in the Android universe. Had to kiss a few games and a couple of apps goodbye. It's worth it for not having constant hangs, apps crashing everywhere and unreasonable battery drain.
 

tavoc

Senior Member
Jun 22, 2012
190
73
My parents are using an P5110 with a year old Version of CM12.1 and where quite happy. Everything was working as expected, but this week they said, that the device keep crashing once a day and shows only the blue CM guy/skull on a black screen.
I am not near this device and my parents are lacking the skill to get me more infos.
As I have no longer any Android devices with cm on my hands, what is this thing? Do I need a reflash, is the memory broken, why did it keep crahsing suddenly?

Regards

tavoc
 

Android-Andi

Inactive Recognized Contributor
Mar 3, 2013
10,847
29,253
andi34.github.io
My parents are using an P5110 with a year old Version of CM12.1 and where quite happy. Everything was working as expected, but this week they said, that the device keep crashing once a day and shows only the blue CM guy/skull on a black screen.
I am not near this device and my parents are lacking the skill to get me more infos.
As I have no longer any Android devices with cm on my hands, what is this thing? Do I need a reflash, is the memory broken, why did it keep crahsing suddenly?

Regards

tavoc
Tell them to boot into recovery and wipe cache and dalvic/art cache.

See if it helps.
 

djlman

Senior Member
Sep 16, 2007
56
2
I realize that this is an old thread (and old devices) but I am interested if this ROM would work on the AT&T SGH-I497 or T-Mobile SGH-T779 both of which are the Galaxy Tab 2 10.1 4G versions. They have a slightly different SOC,'s the P5100 has a TI OMAP 4 4430 and the SGH models have a Qualcomm Snapdragon S4 Plus MSM8960. The CPU in the P5100 is the ARM Cortex A9 while SGH models have a Krait. They are otherwise the same except for level 0 and level 1 cache memory.

If anyone knows the answer, I d sure appreciate it. Here's the comparison link I used for the technical specs...


Thanks!
 

Top Liked Posts