• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][7.1.2][UNOFFICIAL] LineageOS 14.1 - SM-T800

Search This thread
Currently using this ROM on my SM-T705Y, with klimtlte version. I use this tablet to only read epub books, you can say I am using it as an ebook reader. I have turned off the adaptive display brightness and generally set the brightness to low, have not installed Gapps, and only using clean LineageOS and apps are minimal and limited to only ebook reader apps, Tachiyomi, Fdroid, DuckDuck Go Browser. Also, I am using the deathly version and have set the CPU frequency to a minimum of 100 MHz and max 400 MHz, and have increased the charging current rate. I have to say, the battery life now is outstanding. With a full charge and causal 1-2 hours reading, I get around 2-3 days of battery life. The screen on time is around 10-11 hours with only causal readings. This is probably one of the best tablets made by Samsung. 6-7 years and it is still going strong to date.

Thats great battery life!!
 

TheWinner2810

New member
Sep 22, 2021
2
0
Hello, I have managed to flash the ROM, and it works flawlessly, it's given a new life to this tablet, BUT, I've tried to get Deathly Adiutor working but I can't, can someone help me, please? (I've already flashed AddonSU 14.1 twice)
 

runekock

Senior Member
Apr 24, 2012
874
501
Samsung Galaxy Tab S
Nexus 6
did you try this step?

17: Optional ROOT
Go to Settings > About Tablet > tap the build number seven times to enable developer options
Then go back and go to > Developer Options > Root Access. and choose what you want - I selected Apps Only.

Also - assuming you are on the T800 and you flashed the ARM version from here?

Maybe, never done this - try using the removal tool and try again?
 
Last edited:

Ceshy

New member
Sep 28, 2021
3
0
Hello,
I have installed Lineageos 14.1 with the latest gapps but unfortunately a few things are not working.
I can't download any apps from the Google Playstore. The download does not start.
Also, the home button does not work (only to wake the device but not to return to the home screen). Fingerprint sensor setup also no longer works (it did in a previous version).
Also, I cannot access developer options (error message: Developer options are not available for this user). However, I can not change the user or create a new one?

Does anyone have any solutions for this? Thanks a lot.
 
Hello,
I have installed Lineageos 14.1 with the latest gapps but unfortunately a few things are not working.
I can't download any apps from the Google Playstore. The download does not start.
Also, the home button does not work (only to wake the device but not to return to the home screen). Fingerprint sensor setup also no longer works (it did in a previous version).
Also, I cannot access developer options (error message: Developer options are not available for this user). However, I can not change the user or create a new one?

Does anyone have any solutions for this? Thanks a lot.
Try this for developer Options - but before make sure you looked correctly as it is in a different place to stock:
select system (It's above about phone) > Tap Advanced and it's the second last option, if not:
use TWRP to wipe Dalvik Cache, System, Data and Cache and then re-installed the ROM.

info from here: https://forum.xda-developers.com/t/lineage-os-developer-mode-missing.3561945/

for apps found this - maybe see if the same problem:
https://www.lineageosrom.com/2017/02/how-to-fix-google-play-services-error.html

Also found this:
  1. Use TWRP as your recovery loader
  2. Backup your image using TWRP
  3. Install the latest GApps - I use the Nano version
  4. Wipe the Cache after the install is complete
  5. Reboot (do not install Lineage) and wait for the system to settle
  6. Reboot into recovery (TWRP)
  7. Install the latest Lineage (I use nighties)
  8. Wipe the Cache after the install is complete
  9. Reboot and wait until everything loads
  10. Problem solved.
Basically... install the GApps over the existing install, reboot in Lineage and wait, then reboot into recovery again and install the latest Lineage update. It's worked for me three times so far.

Hope this will guide you where you need - I google a lot :)
 
  • Like
Reactions: Ceshy

Ceshy

New member
Sep 28, 2021
3
0
I had done a full wipe before the last install, but another full wipe and reinstall of the ROM and gapps fixed all the problems.

Thanks for the answers.
 
Yes - you need to update it from TWRP
Reboot in recovery - find the LinegeOS folder where the download is and update from there - remember to clear cache/dev after

Go to install
IMG_20211012_181543-min.jpg


find the downloaded install here:

IMG_20211012_181730-min.jpg


After installed wipe cache and reboot

IMG_20211012_181909-min.jpg
 
Last edited:
  • Like
Reactions: jaqferreira

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Does anyone have any solutions for this? Thanks a lot.
    Did you do a full wipe? You can even try format data (will delete your files in internal storage as well). Try without an sd-card at first.
    1
    Hello,
    I have installed Lineageos 14.1 with the latest gapps but unfortunately a few things are not working.
    I can't download any apps from the Google Playstore. The download does not start.
    Also, the home button does not work (only to wake the device but not to return to the home screen). Fingerprint sensor setup also no longer works (it did in a previous version).
    Also, I cannot access developer options (error message: Developer options are not available for this user). However, I can not change the user or create a new one?

    Does anyone have any solutions for this? Thanks a lot.
    Try this for developer Options - but before make sure you looked correctly as it is in a different place to stock:
    select system (It's above about phone) > Tap Advanced and it's the second last option, if not:
    use TWRP to wipe Dalvik Cache, System, Data and Cache and then re-installed the ROM.

    info from here: https://forum.xda-developers.com/t/lineage-os-developer-mode-missing.3561945/

    for apps found this - maybe see if the same problem:
    https://www.lineageosrom.com/2017/02/how-to-fix-google-play-services-error.html

    Also found this:
    1. Use TWRP as your recovery loader
    2. Backup your image using TWRP
    3. Install the latest GApps - I use the Nano version
    4. Wipe the Cache after the install is complete
    5. Reboot (do not install Lineage) and wait for the system to settle
    6. Reboot into recovery (TWRP)
    7. Install the latest Lineage (I use nighties)
    8. Wipe the Cache after the install is complete
    9. Reboot and wait until everything loads
    10. Problem solved.
    Basically... install the GApps over the existing install, reboot in Lineage and wait, then reboot into recovery again and install the latest Lineage update. It's worked for me three times so far.

    Hope this will guide you where you need - I google a lot :)
    1
    Yes - you need to update it from TWRP
    Reboot in recovery - find the LinegeOS folder where the download is and update from there - remember to clear cache/dev after

    Go to install
    IMG_20211012_181543-min.jpg


    find the downloaded install here:

    IMG_20211012_181730-min.jpg


    After installed wipe cache and reboot

    IMG_20211012_181909-min.jpg
  • 65
    LineageOS is a free, community built, aftermarket firmware distribution of Android 7.1.2 (Nougat), which is designed to increase performance and reliability over stock Android for your device.​

    http%3A%2F%2Fimg.imgland.net%2FBINawli.png


    Code:
    #include <std_disclaimer.h>
    
    /*
     * Your warranty is now void.
     *
     * We are not responsible for bricked devices, dead SD cards,
     * thermonuclear war, or you getting fired because the alarm app failed. Please
     * do some research if you have any concerns about features included in this ROM
     * before flashing it! YOU are choosing to make these modifications, and if
     * you point the finger at us for messing up your device, we will laugh at you.
     *
     */

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (gapps). LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    http%3A%2F%2Fi.imgur.com%2Fv3ogd3K.png

    This thread is for Official LineageOS 14.1 builds for chagallwifi (SM-T800) The following will not be supported here:
    Custom kernels
    Mods
    Xposed

    I don't support Xposed and any logcat which includes a Xposed module will be ignored. You're kindly invited to not report bugs if you:
    Flashed a custom kernel
    Installed or did mods from untrusted sources
    Modified system files
    Have not attempted a clean flash

    http%3A%2F%2Fimg.imgland.net%2F_4JAwRZ.png

    First time flashing LineageOS 14.1 on your device, or coming from another ROM?
    Download the zip(s)
    Install a compatible Recovery
    Perform a nandroid backup of your current ROM (Optional)
    Wipe data/factory reset
    Flash LineageOS
    Install the Google Apps addon package (Optional)
    Reboot

    Make sure you have the Marshmallow bootloader. Guide is in the comments below.

    http%3A%2F%2Fimg04.imgland.net%2FAg8dlGr.png

    There will be a new build every week, every Monday.
    The builds will no longer be personally tested by me before being uploaded (but everything will probably be fine)
    Change logs will no longer be posted within every new build, but instead when the changes are uploaded to GitHub. I will try though to post changes for major bugs or fixes as they are released.
    Some builds might feature only minor changes, ie. only updating the LineageOS source

    Chagallwifi Download

    Google Apps:
    Beans GAPPS 7.1.2

    Kernel
    https://github.com/LineageOS/android_kernel_samsung_exynos5420
    Device Tree
    https://github.com/LineageOS/android_device_samsung_chagallwifi

    http%3A%2F%2Fimg04.imgland.net%2F2uCBhNw.png

    Aytex, who made all of the banners on this post.
    @Barracuda77777 (For helping along the way)
    @UpInTheAir for his kernel magic and misc fixes
    @crpalmer (for picassowifi device and kernel gits - the base @Barracuda77777 and @nvertigo67 started of from)
    @eousphoros (for his device git)
    @nvertigo67 (for his work on chagallwifi)
    @Nexorrr (for his work on chagalllte)​
    24
    For OTA updates to flash correctly:
    Update your TWRP to 3.1.0-1 (USE THE 2017-05-04 BUILD OR LATER. DO NOT USE A BUILD FROM BEFORE THIS DATE)
    You can get Official TWRP 3.1.0-1 for chagallwifi from this link!
    TWRP for CHAGALLWIFI
    This updated TWRP recovery image contains a fix that will allow it to flash OTA updates properly!
    23
    http%3A%2F%2Fimg03.imgland.net%2FGdaEH5d.png

    Fingerprint is disabled

    Other issues?
    Before posting in this thread, make sure of a few things:


    You used the search function of the forums.
    If you are the only one having a problem. Boot into recovery, wipe data/factory reset, reflash the rom/gapps and nothing else. Boot up and see if the problem persists.
    Make sure your post is relevant to this thread.
    Logs! You can use this: https://play.google.com/store/apps/details?id=com.tortel.syslog
    23
    How to update to Marshmallow bootloader (required for 20170324 and later builds)
    Updating the bootloader is very quick and doesn't wipe data or repartition the device.
    If the last Samsung ROM you had was 6.0.1 Touchwiz, you already have Marshmallow bootloader and don't need to follow these steps. (If you were on MM, and it still won't boot, follow the steps below)

    1. Download the bootloader-only Odin package: T800XXU1CPK2.tar.md5
    This has the latest Marshmallow bootloader (December 2016)
    https://www.androidfilehost.com/?fid=457095661767146298
    2. Download Odin 3.11
    You can skip this if you already have a working Odin
    https://www.androidfilehost.com/?fid=673368273298937183
    3. Shutdown your tablet and start it up by holding Power+Home+Volume Down to enter Download Mode. Volume Down is the one right next to the power button. Really shut it down and use this key combination, if you use Advanced Restart, or go into download mode via TWRP the bootloader won't change.
    4. Make sure the screen of your tablet has a green android symbol with a "Downloading..." text
    5. Open Odin3_v3.11.1.exe and follow the instructions in this image:
    http%3A%2F%2Fi.imgur.com%2F2LpBdo2.png


    If anything is missing, you WON'T flash bootloader successfully.
    6. Click Start. Your tablet will automatically reboot back into your ROM.
    7. To verify you have the new bootloader, you can run in terminal emulator "getprop ro.bootloader". It should say T800XXU1CPK2.

    Thanks @ZakooZ for the post!
    22
    Replacement charging port installed and we have a booting tablet again! Woo! Work can begin again, though I do have to learn my way around it again with exynos, it's different then Snapdragon.

    Really appreciate your patience and understanding with how I was busy throughout the year etc! Thanks a mill!