• XDA Forums have been migrated to XenForo. To discuss, report bugs and other issues, use this thread.

[ROM][7.1.x|SM-P900| Unofficial LineageOS 14.1 (v1awifi)

thompatry

Recognized Developer
Aug 28, 2012
409
1,428
0
Kansas
LineageOS is a free, community built, aftermarket firmware distribution of Android 7.1.* (Nougat), which is designed to increase performance and reliability over stock Android for your device.

Code:
#include <std_disclaimer.h>

/*
 * Your warranty is now void.
 *
 * We are not responsible for bricked devices, dead SD cards,
 * thermonuclear war, or you getting fired because the alarm app failed. Please
 * do some research if you have any concerns about features included in this ROM
 * before flashing it! YOU are choosing to make these modifications, and if
 * you point the finger at us for messing up your device, we will laugh at you.
 *
 */
LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (gapps). LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.


Important information:
This thread is for Unofficial LineageOS 14.1 (v1awifi) ROM for the Samsung Galaxy Note Pro 12.2. The following will not be supported here:
  • Custom kernels
  • Mods
  • Xposed

Do not ask for ETAs. If you do, I will ignore you and your post.

SEANDROID ERROR
  • If you see a message at boot about Recovery or Kernel is not SEANDROID Enforcing, you can ignore it. This is just telling you that you are not running Samsung stock software. It has no effect on recovery or the ROM itself nor related to either.

I don't support Xposed and any logcat which includes a Xposed module will be ignored.

You're kindly invited to not report bugs if you:
  • Flashed a custom kernel
  • Installed or did mods from untrusted sources
  • Modified system files

Bootloader Information
You need to make sure you have a Lollipop bootloader installed or else your device won't boot. Here you can go grab the latest bootloader and odin and flash it in download mode. Read all the steps before you do this.

Make sure you have a full backup because just in case you something fails.

Here are the steps to flash this via ODIN:
  1. Make sure you have a full backup because just in case you something fails. Here are the steps to flash this via ODIN.
  2. Reboot your tablet into download mode. Do this by first switching off the phone, then pressing and holding the volume down + home button together and then pressing the power button. Press volume up button to enter download mode.
  3. Open ODIN on your computer. You?ll see the ID:COM box turning yellow with a COM port number upon successful connection with the tablet.
  4. In ODIN click the BL button, select the bootloader firmware. It's a tar file.
  5. Make sure Auto Reboot & F. Reset Time options are selected in ODIN
  6. Click on the start button. When the process is completed your phone will reboot.

Installation
  1. Download the zip(s)
  2. Install a compatible Recovery (This will not work with the T900 recovery)
  3. --I have built a new version of TWRP with the MM kernel. MTP, Vibations, ADB now work and there are performance increases. Link
  4. Perform a nandroid backup of your current ROM (optional)
  5. Wipe data/factory reset
  6. Flash LineageOS
  7. Install the Google Apps addon package (Optional)
  8. Reboot

Root
The SU root binary is no longer installed with ROM by default. If you would like to install root, please go here and download the binary.

Issues?
Before posting in this thread, make sure of a few things:

  • You used the search function of the forums
  • If you are the only one having a problem. Boot into recovery, wipe data/factory reset, reflash the rom/gapps and nothing else. Boot up and see if the problem persists.
  • Make sure your post is relevant to this thread.
  • Logs or it didn't happen! You can use this: Syslog App


Downloads

Nightlies
Stable with latest features (Has the latest features from the Exynos5420 team.)
These builds are built weekly through the Exynos5420 Jenkins Server
Exynos5420 Device Builds

Stable and Signed Builds (May not have the latest and greatest features that are device specific.)
These builds are built weekly through the LineageOS Jenkins Server
Lineage Device Builds
-----------
Google Drive Device Builds (Old - Not maintained)

Google Apps
http://opengapps.org/ - Thanks to the OpenGapps team!
Use the 7.1 and Arm options when downloading.

LineageOS Changelog
LineageOS Changelog

Issues
  • MHL out to TV not working

The LineageOS team would like to thank everyone involved in helping with testing, coding, debugging, & documentation.

Source:
Kernel: Link
Device Tree: Link

Credits
@Valera1978 Initial device tree
@UpInTheAir for his kernel magic and misc fixes
@DGT79 for his testing efforts and helping me manage the thread.
@chhaggerty, @tbjr50 and @titidu3701 for their testing efforts.
Exynos5420 Dev Team ( @deadman96385 @thompatry @ZakooZ @Orion116 @mosimchah @joshndroid @Andmoreagain @thermskin, @javelinanddart, @tincho5588 )

XDA:DevDB Information
[ROM][7.1.x|SM-P900| Unofficial LineageOS 14.1 (v1awifi), ROM for the Samsung Galaxy Note Pro 12.2

Contributors
thompatry
ROM OS Version: 7.x Nougat
ROM Kernel: Linux 3.4.x
Based On: LineageOS

Version Information
Status: Stable

Created 2016-12-23
Last Updated 2017-09-27
 

bmwdroid

Active member
Mar 8, 2014
505
130
43
@thompatry server can't be reached any more.
Is this permanent or temporarily, do you know?
Thx again for your work, I'm updating your ROM once a month and it's still the best I've found/tested for P900.
 

thompatry

Recognized Developer
Aug 28, 2012
409
1,428
0
Kansas
I can second this. Hasn't been connecting for last few days. Attached is my screenshot. Tried from multiple devices, same results.

-K
@thompatry server can't be reached any more.
Is this permanent or temporarily, do you know?
Thx again for your work, I'm updating your ROM once a month and it's still the best I've found/tested for P900.
This is fixed. Thanks for letting me know.
 

kpino1991

New member
Apr 23, 2014
3
0
0
need help

i have installed lineageOS 17.1 p900 its work fine but i want to try lineage OS 14.1 but it turns on ERROR when i flash with custom recovery ... :( can you help me please ?
 

bmwdroid

Active member
Mar 8, 2014
505
130
43
i have installed lineageOS 17.1 p900 its work fine but i want to try lineage OS 14.1 but it turns on ERROR when i flash with custom recovery ... :( can you help me please ?
Hard to say if I can.
Please tell us, what you did for:
clean install,
which TWRP used,
if you tried several downloads,
checked md5 signature in TWRP,
and what ever may be relevant.
 

thools60

New member
Aug 14, 2013
611
290
0
Kristinehamn
im using Team win recovery 3.4.0.0
Your TWRP is too new. You need to downgrade to 3.2.1.0, at least was that the recovery i used last time I was on 14.1. But why not stay on 17.1 ? It's an up-to-date ROM that is going to be a great one as soon as the bugs are straightened out. It's already working as a daily driver.
 

kpino1991

New member
Apr 23, 2014
3
0
0
Your TWRP is too new. You need to downgrade to 3.2.1.0, at least was that the recovery i used last time I was on 14.1. But why not stay on 17.1 ? It's an up-to-date ROM that is going to be a great one as soon as the bugs are straightened out. It's already working as a daily driver.
i downgraded twrp and it works , i had an error on ext4 something like that but rom is working FINE , the newer version of the rom is more laggy than this rom ands work FINE without bugs , and the battery is better with this rom
thanks for helping me
 

mexigga

New member
May 9, 2007
1,320
172
0
Los Angeles
Silly question... its been a while since I've done this...
Can I dirty flash the latest nightly "lineage-14.1-20201009-UNOFFICIAL-v1awifi.zip (2020-10-09 01:34)"
over my current build: 14.1-20190622-unofficial-v1awifi ?

Thanks!
 

thools60

New member
Aug 14, 2013
611
290
0
Kristinehamn
Silly question... its been a while since I've done this...
Can I dirty flash the latest nightly "lineage-14.1-20201009-UNOFFICIAL-v1awifi.zip (2020-10-09 01:34)"
over my current build: 14.1-20190622-unofficial-v1awifi ?

Thanks!
In theory you could, but since so long time has passed between the builds, i would go for a clean install. I always wipe it totally clean once in a while when following a builds progress. I have Google backing up EVERYTHING in the cloud, so when I start fresh i get all the apps and even my personal settings back in a whiff.
 

bmwdroid

Active member
Mar 8, 2014
505
130
43
Silly question... its been a while since I've done this...
Can I dirty flash the latest nightly "lineage-14.1-20201009-UNOFFICIAL-v1awifi.zip (2020-10-09 01:34)"
over my current build: 14.1-20190622-unofficial-v1awifi ?
Thanks!
In theory you could, but since so long time has passed between the builds, i would go for a clean install. I always wipe it totally clean once in a while when following a builds progress. I have Google backing up EVERYTHING in the cloud, so when I start fresh i get all the apps and even my personal settings back in a whiff.
I do it a bit differently.
First backup Data, then do a full wipe plus "data format", then a clean install plus BiTGapps and Magisk, let it start once and then restore the backup of the older version.
Usually this is successful.
 

mexigga

New member
May 9, 2007
1,320
172
0
Los Angeles
In theory you could, but since so long time has passed between the builds, i would go for a clean install. I always wipe it totally clean once in a while when following a builds progress. I have Google backing up EVERYTHING in the cloud, so when I start fresh i get all the apps and even my personal settings back in a whiff.
Awesome....great point and reminder to start with a fresh install. I haven't used the cloud to do a restore, so I will have to try that instead of Titanium Backup (my go to).

Cheers!
 

bmwdroid

Active member
Mar 8, 2014
505
130
43
FYI
TWRP 3.4.0-0 gave me Error 7 when flashing lineage-14.1-20201020-NIGHTLY-v1awifi.
3.3.1-0 worked.
With lineage-14.1-20201027-NIGHTLY-v1awifi as well.
 
Last edited:

bmwdroid

Active member
Mar 8, 2014
505
130
43
TWRP 3.4 actually works fine if you remember to reboot to recovery after wiping the various partitions.
That's not true for me as 3.4.0 was installed already and backing up worked fine.
After that I tried to flash onto wiped system (Dalvik+cache as well of course) partitions.
Or do you mean first wiping and then reboot to recovery?
That would be peculiar as it's not necessary on any other device.
 

Smartie36

New member
Oct 4, 2011
206
24
0
Having done a quick search through this thread I see there's lots of posts about Google play store, I've read a few but not seen anyone mentioning the issue I'm having, which is the play store is asking me to pay for apps I've already purchased.

Have carried out the fixes I've found online etc, nothings working, anyone experiencing something similar with this rom?

Sent from my LYA-L09 using Tapatalk
 
Last edited:

bmwdroid

Active member
Mar 8, 2014
505
130
43
Having done a quick search through this thread I see there's lots of posts about Google play store, I've read a few but not seen anyone mentioning the issue I'm having, which is the play store is asking me to pay for apps I've already purchased.

Have carried out the fixes I've found online etc, nothings working, anyone experiencing something similar with this rom?
Afaik nothing to do with the ROM as it's working on mine.
Read something similar somewhere else.
That helped there: delete Playstore cache and data in app settings and let it rebuild its database.
Which "fixes..found.. online"? That as well?
 

Smartie36

New member
Oct 4, 2011
206
24
0
Feels like I cleared the data & cache of the play store app a million times, along with Google play services & anything else including removing my Google account from the device & adding it again but nothing fixed it so after all afternoon trying to sort this out I decided to download the Google play store apk, the exact same version that was already installed & installed that, after which I cleared data & cache of the app yet again, rebooted & thank god that fixed it!

Sent from my SHT-W09 using Tapatalk
 

thompatry

Recognized Developer
Aug 28, 2012
409
1,428
0
Kansas
Reserved

Deathly Adiutor App

Deathly Adiutor is an open-source, modified version of Kernel Adiutor made specifically for Exynos 5420 devices.

Features
Power Saving:
  • S-Pen Power Saving - Same as in Touchwiz, disables S-Pen detection if it's inserted in the slot
  • S-Pen Input Booster - Instantly increase CPU frequency when the S-Pen touches the screen
  • Touchscreen Input Booster - Instantly increase CPU frequency when you touch the screen
  • Touchkey Input Booster - Instantly increase CPU frequency when you touch the capacitive buttons
  • Touchscreen Glove Mode (Not all screens support this)

CPU Control:
  • CPU Settings reworked - Deathly adiutor back-end was cleaned up to work specifically with our CPU
  • CPU Thermal - Control all thermal throttling points for the CPU (make your device run colder... or even hotter)

GPU Control:
  • GPU Time in States - Same as CPU Time in States (Times in each frequency)
  • GPU Frequency Control (not yet supported on Nougat)
  • GPU Voltage Control (not yet supported on Nougat)
  • GPU Governor Control (not yet supported on Nougat)

Battery control:
  • Full power statistics - See current and maximum charging currents and current source of power
  • Unstable power source detection - Lowers current until the power source is stable
  • Customize charger current limits - Make your device charge faster (safe, if the charger can not supply enough current, the board will dynamically decrease the current)
  • Screen-On current limiter - Limit charging if screen is on (to avoid overheating)

Speakers:
  • Privacy mode - Disable main speaker if headphones are plugged in
  • Earpiece volume
  • Left/Right speaker volume
  • Speaker equalizer

Headphones:
  • Left/Right channel volume
  • Mono output mode
  • Headphone equalizer

App Themes:
  • Light theme - White and Red
  • Dark theme - Grey and Red

Credits
This post was written by @ZakooZ
This app is brought you by the exynos5420 developer team: @deadman96385 @thompatry @ZakooZ @Orion116 @mosimchah @joshndroid @Andmoreagain @thermskin, @javelinanddart, @tincho5588, @ShevT

Translators:
@ShevT - Russian

The following people deserve distinction for their major contribution:
@tincho5588, responsible for 80%+ of the code for the new features
@deadman96385, the main maintainer of the Deathly kernel and most of the remaining code

Downloads
The app can be found in the Play Store:

Helping the developers
You may have noticed there's 2 versions of this app, one ad-free for donators and one with ads.
You can help us by clicking ads you're interested in for the free version, or purchasing the donator version!
We will use the money generated by this app as common money for the developers of the team. It will be used to pay for our web-hosting (we own a gerrit server and a domain name, exynos5420.com). It will also be used to buy a new device if one of ours breaks.

Translating the App
You can also help us by translating the app to your language:
1. You can start by looking at the full english language file: Link
2. Then compare it to your unfinished language file. You can find it here, under values-xx/strings.xml, xx being your language abbreviation.
3. You can then fill-in the missing strings in your language file. Here's an example of what a proper update looks like.
4. Then you can submit your translation by using our gerrit. If you don't know how to use gerrit, just PM the translation to your favorite developer and he'll get it merged!
 

Drift3r

New member
Oct 9, 2016
17
4
0
Thank you for this wonderful Christmas present, for all your handwork and passion for this tablet and the community built around it at xdadevelopers!!

I'm so giddy right now. I'm gonna download it and start playing around with this rom ASAP !! :)
 

thompatry

Recognized Developer
Aug 28, 2012
409
1,428
0
Kansas
I would not recommend dirty flashing from CM-13.0 since this is a major OS change. Also something to take into account is that some apps are not ready for N yet.
 
Last edited:

DaveUK

New member
Feb 19, 2005
143
40
0
installed ok.... was an error flashed up in TWRP about E:log twice. Doesn't seem to have affected the install. App update running now. Thanks for your hard work ?

Sent from my SM-G935F using Tapatalk

---------- Post added at 11:48 PM ---------- Previous post was at 11:05 PM ----------

Found a small problem the MHL out to TV isn't working. Preferences menu button in Titanium Backup isn't there. Configured a hardware key to open menu. That way works.

Sent from my SM-P900 using Tapatalk
 

Drift3r

New member
Oct 9, 2016
17
4
0
Question. How would I go about providing myself root access? Is this built-in but disabled by default or do I need to download and use something like SuperSU?
 

DaveUK

New member
Feb 19, 2005
143
40
0
go to settings > about > tap on build number until tells you developer..... go back to main settings menu and go to dev options. It's in there

Sent from my SM-P900 using Tapatalk
 

Drift3r

New member
Oct 9, 2016
17
4
0
go to settings > about > tap on build number until tells you developer..... go back to main settings menu and go to dev options. It's in there

Sent from my SM-P900 using Tapatalk
Thank you. Worked like a charm.

Oh man. The split screen mode built into Nougat 7.1 is soooooo glorious! :D
 
Last edited:

thompatry

Recognized Developer
Aug 28, 2012
409
1,428
0
Kansas
installed ok.... was an error flashed up in TWRP about E:log twice. Doesn't seem to have affected the install. App update running now. Thanks for your hard work ?

Sent from my SM-G935F using Tapatalk

---------- Post added at 11:48 PM ---------- Previous post was at 11:05 PM ----------

Found a small problem the MHL out to TV isn't working. Preferences menu button in Titanium Backup isn't there. Configured a hardware key to open menu. That way works.

Sent from my SM-P900 using Tapatalk
I am working MHL out to TV. The error in TWRP can be ignored.

Up and running, clean install, unable to load LastPass. Anyone else?

Sent from my SM-P900 using Tapatalk
Something to take into account is that some apps are not ready for N yet.
 

shonkin

New member
Oct 15, 2012
1,448
579
0
Did a factory wipe, installed nougat, installed openapps, loaded up...

NO problem. I haven't done much in here yet... but hey, Chrome words. Words with Friends (my wife!) works. Haven't played with any of the whistles and bells yet.
 

shonkin

New member
Oct 15, 2012
1,448
579
0
Okay, odd result: when I restart the tablet plugged in, it cycles between showing me the battery charging icon and going dark. Won't start. If I unplug the tablet, I can start it. Just me? Anyone else?
 

DaveUK

New member
Feb 19, 2005
143
40
0
Okay, odd result: when I restart the tablet plugged in, it cycles between showing me the battery charging icon and going dark. Won't start. If I unplug the tablet, I can start it. Just me? Anyone else?
Mine does that sometimes..... I either hold the power button or just unplug the cable. It's always done it on all roms.

Sent from my SM-P900 using Tapatalk
 

thools60

New member
Aug 14, 2013
611
290
0
Kristinehamn
Thanks for this @thompatry An amazing Christmas present!!! So excited to try this out. Imagine that, a couple of months ago, I was thinking to myself, better sell this outdated tablet and go for a Nexus device or something that's not going to be abandoned by its manufacturer after one update. And today I'm watching the very latest Android OS booting on this great machine!!! Fantastic!!! And all thanks to you and other determined, clever people.
A very Merry Christmas to you Tom, and thanks again!
 

risant

New member
Aug 6, 2016
261
30
0
thomspatry you're a genuis ..thanks for the wonderful update to nougat for p900 ,,, anticipating for future cm upgrades... keep up the good work