• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM][8.0.0][AOSP][SUZU] Oreo Builds

Search This thread

Netzheimer

Member
Sep 3, 2014
36
5
Hi I would like to install this ROM on my xperia X 5121. I also want to install the Google camera.

I just found this thread with links for the BSG Google Camera v4 you have mentioned in this thread.

Is the v4 BSG Google Camera the right one? Is it also possible to use the v5 BSG camera?

I already read, that I have to remove the stock camera with root in order to install the google camera afterwards. Is it possible to remove the root permissions afterwards? I need this, because some of my apps do not run on rooted devices because of possible security lacks (online banking for example)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 24
    [ROM][8.0.0][AOSP][SUZU] Oreo Builds
    SUZU F5121 and F5122

    Just builded AOSP from source for test. Not develop, only for testing new futures, so now you can try Oreo AOSP

    i'm not responsible for any damage caused with your device after flashing this ROM. Flash only on your own risk.

    Download (GDrive repo)
    AOSP Drive
    Install:
    1) Copy to SD card and flash with recovery
    2) Download SW_binaries_for_Xperia_AOSP_O_MR0_4.4_v05_loire.img and flash it via fastboot with:
    Code:
    fastboot flash oem SW_binaries_for_Xperia_AOSP_O_MR0_4.4_v05_loire.img
    3) Flash SuperSU
    4) Reboot.


    Feature

    Working:

    - Wi-Fi
    - Bluetooth
    - Fingerprint (partially)
    - Gapps included
    - GPS
    - Sensors
    - Dual Sim (need testers)
    - Camera

    Not working for now:
    - You tell me

    Builded with
    Code:
    https://github.com/SonyAosp
    sources

    Screenshots:
    Screenshot_20171005-100126.pngScreenshot_20171005-100155.pngScreenshot_20171005-100309.jpg
    7
    today i have build new version AOSP 8.0.0 ROM with This repo
    and call speaker worked now. camera still not working.

    Screenshot_20171008-102559.pngScreenshot_20171008-102703.pngScreenshot_20171008-103534.jpg
    4
    yes got it i tried to make it by the way is your rom is having random restart i face this issue
    and is there any update near by

    i'm building new builds right now.
    4
    upload a new builds with working camera.
    for now we have only fingerprint problems and some times a random reboots

    for working video camera - install open camera and enable API v2.0 on settings.
    4
    updated build to 14.10.17 for single and later for dual (compiling now)