[ROM][8.1.0][A3F/H/FU/G/M/Y] LineageOS 15.1 Unofficial for Samsung Galaxy A3 (2015)

Search This thread

Miperpe80

Member
Aug 11, 2020
15
0
SIM card not detected LineageOS 17.01

Hi,
I've SM-A300FU and I flashed LineageOS 17.1 from LineageOS 16.0 with TWRP "recovery-twrp-v3.3.1-20191129-a3ulte-Bluemax.img"
I have had the following problems:
- no audio (ok I've read yours solutions)
- no SIM Card detected! (HELP please!)
I noticed that there was an unknown IMEI and I think about a EFS folder corruption so I flashed LOS 16. (that works well) from nandroid backup, I saved EFS folder with recovery, I flashed Los 17.1 and EFS folder but nothing... no SIM card
of course I did all the various wipes
otherwise the rom is nice and fast, very good
has anyone already had the same problem?
 

Miperpe80

Member
Aug 11, 2020
15
0
SIM card not detected LineageOS 17.01 Solved

Hi,
I've SM-A300FU and I flashed LineageOS 17.1 from LineageOS 16.0 with TWRP "recovery-twrp-v3.3.1-20191129-a3ulte-Bluemax.img"
I have had the following problems:
- no audio (ok I've read yours solutions)
- no SIM Card detected! (HELP please!)
I noticed that there was an unknown IMEI and I think about a EFS folder corruption so I flashed LOS 16. (that works well) from nandroid backup, I saved EFS folder with recovery, I flashed Los 17.1 and EFS folder but nothing... no SIM card
of course I did all the various wipes
otherwise the rom is nice and fast, very good
has anyone already had the same problem?

Thx I solved all the problems flashing LOS 17.1 with your TWRP: twrp_3.3.1-2_sm-a300_ashyx!!
THX ^^
 

Miperpe80

Member
Aug 11, 2020
15
0
Voice echo calls

Hi :)
I've SM-A300FU with "Twrp_3.3.1-2_sm-a300_ashyx" and "lineage-17.1-20200720-UNOFFICIAL-a3lte"
I've 2 problems:
1. (important) Voice echo calls: when a person calls me he hears the echo of his own voice; I tried to raise and lower the volume during the call, to desable hey google of voice match (web news) but nothing...
2. camera doesn't save photos in memory card
Could someone help me please? :(

Thx!
 

carlos974

Senior Member
May 18, 2016
813
1,039
Saint-Denis
Hi :)
I've SM-A300FU with "Twrp_3.3.1-2_sm-a300_ashyx" and "lineage-17.1-20200720-UNOFFICIAL-a3lte"
I've 2 problems:
1. (important) Voice echo calls: when a person calls me he hears the echo of his own voice; I tried to raise and lower the volume during the call, to desable hey google of voice match (web news) but nothing...
2. camera doesn't save photos in memory card
Could someone help me please? :(

Thx!

For photos or videos, on ext sdcard go to the directory /android/data/org.lineageos.snap/files
 

Miperpe80

Member
Aug 11, 2020
15
0
Camera memory

For photos or videos, on ext sdcard go to the directory /android/data/org.lineageos.snap/files

Wow Thx ^^ :good:
Ok the photos are there.
the problem is:
- then the problem is that, once the memory card is set, the camera takes the photo but if I click on the preview of the photo, just taken from the camera app, it does not open it ...
can the problem be solved?
Thx :)
 

carlos974

Senior Member
May 18, 2016
813
1,039
Saint-Denis
Hi :)
I've SM-A300FU with "Twrp_3.3.1-2_sm-a300_ashyx" and "lineage-17.1-20200720-UNOFFICIAL-a3lte"
1. (important) Voice echo calls: when a person calls me he hears the echo of his own voice; I tried to raise and lower the volume during the call, to desable hey google of voice match (web news) but nothing...

Thx!

The dev fixed this!
Thanks to @vl_w
https://github.com/vlw/android_device_samsung_a3lte/commit/ef4534829345aef67b4bf04ce3a0b0ed7a24f6a7
 
  • Like
Reactions: Beatz106

carlos974

Senior Member
May 18, 2016
813
1,039
Saint-Denis
Last edited:

Miperpe80

Member
Aug 11, 2020
15
0
Yes, try to do it!
https://github.com/vlw/android_devi...a24f6a7/configs/audio/audio_platform_info.xml
Right click on the "raw" button, then save link target as ...

To replace him!
The file is located in /system/vendor/etc
Also think of giving chmod 644 to the file
Reboot

Hi and first of all Thx very much for all
I downloaded the file "https://github.com/vlw/android_devic...tform_info.xm" and i overwrote it then I went to check that the file was the right one, that is the one downloaded, checking for the presence of the changes made and the replacement was successful ...
unfortunately no ringtone, notification sound and no voice in the calls! I didn't give chmod 644 to the file because I don't know how to do it ><
so I reinstalled the latest nanobackup...
Thanks a lot anyway! ;)

---------- Post added at 05:03 PM ---------- Previous post was at 04:34 PM ----------

On the internet I read that you could disable the "noise reduction" option but it seems to me there is no call settings for this rom right? Because it seems that it would be enough to disable the top microphone of the smartphone and it seems to me that the Galaxy A3 2015 has it :confused:
 
Last edited:

carlos974

Senior Member
May 18, 2016
813
1,039
Saint-Denis
Hi and first of all Thx very much for all
I downloaded the file "https://github.com/vlw/android_devic...tform_info.xm" and i overwrote it then I went to check that the file was the right one, that is the one downloaded, checking for the presence of the changes made and the replacement was successful ...
unfortunately no ringtone, notification sound and no voice in the calls! I didn't give chmod 644 to the file because I don't know how to do it ><
so I reinstalled the latest nanobackup...
Thanks a lot anyway! ;)

---------- Post added at 05:03 PM ---------- Previous post was at 04:34 PM ----------

On the internet I read that you could disable the "noise reduction" option but it seems to me there is no call settings for this rom right? Because it seems that it would be enough to disable the top microphone of the smartphone and it seems to me that the Galaxy A3 2015 has it :confused:

For chmod 644 do it in twrp.

Mount partition / system

after Advanced settings, use the file manager.

Go in:
/ system / system / vendor / etc
Select the file.

chmod button
Remove 0000 and put 644 and validate

Reboot
 

Attachments

  • Screenshot_2020-08-25-12-23-43.png
    Screenshot_2020-08-25-12-23-43.png
    33.6 KB · Views: 36

Miperpe80

Member
Aug 11, 2020
15
0
For chmod 644 do it in twrp.

Mount partition / system

after Advanced settings, use the file manager.

Go in:
/ system / system / vendor / etc
Select the file.

chmod button
Remove 0000 and put 644 and validate

Reboot

Thx very much! :)
with chmod 644 permissions you hear everything, sounds and call voice...
the echo is always there but lower :-/
As a layman I think the problem could be that the rom supports all A3 2015 models a33g-a3lte-a3ulte, maybe the mod file works perfectly on other A3 models, I don't know...
Anyway thanks a lot for the skill and patience and sorry for the constant disturbance! ^^
 

carlos974

Senior Member
May 18, 2016
813
1,039
Saint-Denis
Thx very much! :)
with chmod 644 permissions you hear everything, sounds and call voice...
the echo is always there but lower :-/
As a layman I think the problem could be that the rom supports all A3 2015 models a33g-a3lte-a3ulte, maybe the mod file works perfectly on other A3 models, I don't know...
Anyway thanks a lot for the skill and patience and sorry for the constant disturbance! ^^

The dev @vl_w might update next month! :fingers-crossed:
 
  • Like
Reactions: Beatz106

Top Liked Posts

  • There are no posts matching your filters.
  • 44
    Hi all!

    LineageOS 15.1 Unofficial for Samsung Galaxy A3 (2015)​

    Currently supported variants:
    * SM-A300F
    * SM-A300H
    * SM-A300M
    * SM-A300FU
    * SM-A300G
    * SM-A300Y
    * SM-A300YX

    DISCLAIMER
    Code:
    #include 
    /*
    * Your warranty is now void.
    * The ROM is under developement and have some bugs.
    * We are not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at us for messing up your device, we will laugh at you. By flashing this ROM, you accept this disclaimer.
    */


    BUGS:
    * FM works only on headphones
    * Unable to capture video in 1080p (only 720р works)
    * Incorrectly work with secondary sim (incall sound issues)
    * On FU and H doesn't adjusting flahlight brightness
    * On H incorrectly detecting battery temperature
    * Hardware keystore doesn't work (only software)
    * NFC sometimes doesn't work


    2a0e1xv.jpg


    LineageOS 15.1 for Galaxy A3 (2015)

    NOTE: THIS ROM IS MADE FOR GALAXY A3, OBVIOUSLY IT WILL NOT WORK ON ANY OTHER DEVICE.

    Uploading my files elsewhere is not appreciated, if you need to upload my files, just use the links provided here. Thanks.

    Download link to the latest build: (Developement and Updates provided by @vl_w)


    FOR A300F/M/G/Y -> DOWNLOAD
    FOR A300H -> DOWNLOAD
    FOR A300FU/YX -> DOWNLOAD


    Other useful links:
    * Google Apps (choose arm and for Android 8.1):
    * Root
    https://mirrorbits.lineageos.org/su/addonsu-15.1-arm-signed.zip
    After install this package u should enable root access in developer settings



    v3WMXKl.jpg

    * Steps for a Clean Install:
    1) Put the .zip file in Internal or External Storage.
    2) Reboot in Recovery Mode (Using TWRP/CWM Recovery)
    3) Wipe Data, Cache, Dalvik Cache and format /System
    4) Install the ROM.
    5) Flash the Google Apps.
    6) Reboot and Enjoy!



    Contributors:
    vl_w, @Jonny_Hood (Testing)


    Sources:


    Version Information:
    ROM Status: Beta
    ROM OS Version: 8.1.0 Oreo
    ROM Kernel: Linux 3.10.x
    ROM Firmware Required: Any Bootloader and Modem.
    Based On: LineageOS 15.1


    Created: 2018-05-21
    Last Updated: 2017-05-21
    11
    Screenshots

    Screenshots
    6
    Do you even know what LineageOS is for ??? search on google... LOS is the AOSP and it doesnt come with gapps or microG or whatsoever apps... do it your self.... and stop begging for extra apps

    We are here to test and report O-N-L-Y ROM related BUGS... IT'S BETA!!!!

    damn it, people don't wanna read and write only unrelated stuff. Use search! XDA has many threads for all stuff including MicroG, gapps, Magisk(read root), Xposed,....
    Just sad... :crying: :crying:

    And than you wanna bugs free LOS... ignorance is a bliss :D

    P.S. it was just a notice about MicroG link: https://forum.xda-developers.com/an...-gmscore-floss-play-services-t3217616/page465

    Hello drnightshadow,

    Thank you for your wise words on using the search function and other topics of this forum.
    I'm sorry for my mistake, that I referred to your edit about MicroG and my curiosity about it.
    asking for plans ≠ begging

    I hope your blood pressure isn't as high as it reads...

    Cheers
    6
    I confirm, none of vince-made images ever boots on my A300 FU, only bootloop.
    (just to add, full clean install, even internal storage was always formatted)

    The booting issue was due to a faulty camera repopick that was being picked during the daily lineage source sync but not in the RR sync, which is why RR builds were booting, but the lineage ones not.

    I understand some of you may have disdain for me because of this, but this was really out of my control; I really do try my best with what I have, and complaining won't make it better. You can take it how you will.

    The above but was supposed to be addressed in last week's weeklies, but a lot of them never ran because that's round about when someone got access to Jenkins and gerrit and messed with things on the server, so some builds may be missing from the dl server.

    All gprime/fortuna/a3 devices as far as I'm aware were affected by this bug in pre-20180803/04 builds.

    You can try last week's builds if they're up on the dl server, they should work fine.