[ROM][8.1.0][A3F/H/FU/G/M/Y] LineageOS 15.1 Unofficial for Samsung Galaxy A3 (2015)

Search This thread

Beatz106

Senior Member
Jul 25, 2018
184
42
Here is some of what I have experienced in the last update, there are bugs that I must describe in a new post for better clarity.

The new build slightly improved the use of RAM, even so, you have to put your hand to have a more decent result. It does not have zram or zswap (I do not see it critical, in fact such a function seems useless), I must resort to making a false Swap partition (swapfile) to improve multitasking due to the lack of free RAM.

Battery consumption is better than Oreo, still feels some fast discharge for some reason or place, I'm not sure where the origin is (discarding the applications, of course) despite having deleted content related to NFC (Not all the same, as a curious fact, the structure of the system is different from Oreo and you have to search in different areas). There are files that say something of a "neural network" something obviously useless, without neglecting the files of infrared, CDMA and virtual reality, content to be removed to see important changes.

Problems and bugs found at the moment:

There is a bug in the music player, this will be omitted in this post because I have to explain the problem in detail.

This ROM does not have the navigation bar on screen, that is a problem with games when accidentally swiping your finger over the multitasking button. In the "buttons" section of the system settings, there are not so much the navigation bar settings as the special settings for the hardware buttons, in Oreo it was possible to use the multitasking button as a menu button for certain applications such as Titanium Backup (it can be any other compatible application)

The file manager shows some files as screenshots with a weight of "0 bytes"

More coming soon...
 

Attachments

  • Screenshot_20200901-184856_Archivos.png
    Screenshot_20200901-184856_Archivos.png
    51.6 KB · Views: 66
  • Screenshot_20200903-004308_RAMEXPANDER.jpg
    Screenshot_20200903-004308_RAMEXPANDER.jpg
    89.6 KB · Views: 66

Beatz106

Senior Member
Jul 25, 2018
184
42
It is no longer possible to use Shazam's Pop Up function, as well as other applications that require the use of such a function. Any way to make bypass to it?
 

Attachments

  • Screenshot_20200907-095000_Ajustes.png
    Screenshot_20200907-095000_Ajustes.png
    21.1 KB · Views: 53

Beatz106

Senior Member
Jul 25, 2018
184
42
With almost a week of use, there are things in detail to take into account to repair.

Always on Display: There are times when locking the screen, the clock and the amount of available battery / battery charging appear, so good up to that point, except that the wallpaper appears. I don't know at what point the problem solves itself, but it finally shows the function without a wallpaper or anything like that, it usually happens after activating the music player.

Music player: I don't know if it will be design motive, but when changing the song or pausing the content, the mini player (from the notification shutter) appears, instead of a dedicated mini player like in Android Pie (it consists of something similar to Always on Display, but with Previous, Play/Pause and Next buttons). This build doesn't have any setup that allows removing both the animation bars and the song cover from the lock screen.

Design: I'm not sure whether or not it is a default customization for this version, But unlike the icons for Wi-Fi and the mobile signal, those for headphones, vibration or any other are very separate from each other, it makes no sense to use space for a single icon, if the issue was to have enough space for the icons of notifications or important tasks, even, we must not forget that this issue has to be involved with the notch that by the way, this build has a dedicated setting from the developer menu for a fake notch, such a setting should be removed in a stable release in the future for very obvious reasons.

File manager: When uploading a photo to applications such as a browser or Boost for Reddit (It can be any other application that requires going to the system file manager), when searching for a photo, I must currently do 2 things, search the content by date (if it is a very recent image) or from the gallery, as with Oreo, the main screen does not show the thumbnails of the photos that are in the phone, that forces me to resort to the above.

Sorry for the poor quality photos, but I only had an old phone on hand.

More reports (if I have) coming soon...
 

Attachments

  • 20140112_202349.jpg
    20140112_202349.jpg
    163 KB · Views: 47
  • 20140112_202543.jpg
    20140112_202543.jpg
    149.3 KB · Views: 47
  • 20140112_202705.jpg
    20140112_202705.jpg
    137.3 KB · Views: 43
  • 20140112_202726.jpg
    20140112_202726.jpg
    145.6 KB · Views: 40
  • 20140112_202729.jpg
    20140112_202729.jpg
    142.7 KB · Views: 43
  • 20140112_202919.jpg
    20140112_202919.jpg
    148.3 KB · Views: 44
  • IMG_20200908_223058.jpg
    IMG_20200908_223058.jpg
    5.6 KB · Views: 44
  • Screenshot_20200908-211224_Archivos.png
    Screenshot_20200908-211224_Archivos.png
    31.9 KB · Views: 46
  • Screenshot_20200908-233056_Ajustes.png
    Screenshot_20200908-233056_Ajustes.png
    62.6 KB · Views: 46

Beatz106

Senior Member
Jul 25, 2018
184
42
New details found:

The kernel needs some changes, in principle, when adjusting the profile "energy saving" in the battery settings of the system, it should not be used only from 800Mhz to 1094MHz of CPU, Battery usage is still notorious, in addition to wasting some frequency values ​​including 200MHz, At least from Kernel Adiutor, it is also impossible to observe a random activity, but it is always set at the same frequencies, therefore it will be possible to see that frequencies such as 200MHz arent used, in fact, the frequency is always set to the highest value.

I/O: The read-ahead value must not be anymore at numbers up to 128kB (Mandatory value). There is a huge improvement to multitasking, Even so, an investigation will continue whether or not it results in an improvement in RAM consumption.

Gallery: The timeline is not respected, the date or time the content appears is not taken into account, they appear randomly.

AS I DON'T KNOW HOW TO USE GITHUB, PLEASE THOSE WHO HAVE AN ACCOUNT THERE, SEND MY REPORTS IMMEDIATELY.
 

Attachments

  • Screenshot_20200920-163250_Kernel_Adiutor.png
    Screenshot_20200920-163250_Kernel_Adiutor.png
    53.9 KB · Views: 30
  • Screenshot_20200920-170345_Kernel_Adiutor.png
    Screenshot_20200920-170345_Kernel_Adiutor.png
    57.8 KB · Views: 33
  • PicsArt_1600645725718.jpg
    PicsArt_1600645725718.jpg
    92.6 KB · Views: 32

BirthdayDog11

Senior Member
Jul 13, 2012
236
17
Thank you for the rom.
I'm having this very odd issue that the menu button will open recent apps switcher, no matter what I set it to.
Is this a known issue? Any ideas?
 

Beatz106

Senior Member
Jul 25, 2018
184
42
I will go to the task of trying to revive the work for our devices, yes, it is mandatory to send your error reports and of course with the cleanest possible ROM. Priority: a33gxx

I don't give any guarantee of successful results or reports received due to my inexperience on GitHub, but I am not comfortable at all with a half-made ROM
 

Attachments

  • Screenshot_20201115-003231_Iceraven.png
    Screenshot_20201115-003231_Iceraven.png
    71.7 KB · Views: 50
Well..
ROM 17.1 has a biiig bug ... VPN isn't working, any firewall app will also fails... for testing you can use NETGUARD app (just run it and enable it without any restrictions/rules, actually you gonna get really simple basic VPN). And you'll lose internet/lan, etc.... no connection!
Total communication breakdown!
Can someone report this on github to vlv..
Security really sucks on latest ROM.
 
Last edited:

Beatz106

Senior Member
Jul 25, 2018
184
42
Well..
ROM 17.1 has a biiig bug ... VPN isn't working, any firewall app will also fails... for testing you can use NETGUARD app (just run it and enable it without any restrictions/rules, actually you gonna get really simple basic VPN). And you'll lose internet/lan, etc.... no connection!
Total communication breakdown!
Can someone report this on github to vlv..
Security really sucks on latest ROM.
Deleted
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 44
    Hi all!

    LineageOS 15.1 Unofficial for Samsung Galaxy A3 (2015)​

    Currently supported variants:
    * SM-A300F
    * SM-A300H
    * SM-A300M
    * SM-A300FU
    * SM-A300G
    * SM-A300Y
    * SM-A300YX

    DISCLAIMER
    Code:
    #include 
    /*
    * Your warranty is now void.
    * The ROM is under developement and have some bugs.
    * We are not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at us for messing up your device, we will laugh at you. By flashing this ROM, you accept this disclaimer.
    */


    BUGS:
    * FM works only on headphones
    * Unable to capture video in 1080p (only 720р works)
    * Incorrectly work with secondary sim (incall sound issues)
    * On FU and H doesn't adjusting flahlight brightness
    * On H incorrectly detecting battery temperature
    * Hardware keystore doesn't work (only software)
    * NFC sometimes doesn't work


    2a0e1xv.jpg


    LineageOS 15.1 for Galaxy A3 (2015)

    NOTE: THIS ROM IS MADE FOR GALAXY A3, OBVIOUSLY IT WILL NOT WORK ON ANY OTHER DEVICE.

    Uploading my files elsewhere is not appreciated, if you need to upload my files, just use the links provided here. Thanks.

    Download link to the latest build: (Developement and Updates provided by @vl_w)


    FOR A300F/M/G/Y -> DOWNLOAD
    FOR A300H -> DOWNLOAD
    FOR A300FU/YX -> DOWNLOAD


    Other useful links:
    * Google Apps (choose arm and for Android 8.1):
    * Root
    https://mirrorbits.lineageos.org/su/addonsu-15.1-arm-signed.zip
    After install this package u should enable root access in developer settings



    v3WMXKl.jpg

    * Steps for a Clean Install:
    1) Put the .zip file in Internal or External Storage.
    2) Reboot in Recovery Mode (Using TWRP/CWM Recovery)
    3) Wipe Data, Cache, Dalvik Cache and format /System
    4) Install the ROM.
    5) Flash the Google Apps.
    6) Reboot and Enjoy!



    Contributors:
    vl_w, @Jonny_Hood (Testing)


    Sources:


    Version Information:
    ROM Status: Beta
    ROM OS Version: 8.1.0 Oreo
    ROM Kernel: Linux 3.10.x
    ROM Firmware Required: Any Bootloader and Modem.
    Based On: LineageOS 15.1


    Created: 2018-05-21
    Last Updated: 2017-05-21
    11
    Screenshots

    Screenshots
    6
    Do you even know what LineageOS is for ??? search on google... LOS is the AOSP and it doesnt come with gapps or microG or whatsoever apps... do it your self.... and stop begging for extra apps

    We are here to test and report O-N-L-Y ROM related BUGS... IT'S BETA!!!!

    damn it, people don't wanna read and write only unrelated stuff. Use search! XDA has many threads for all stuff including MicroG, gapps, Magisk(read root), Xposed,....
    Just sad... :crying: :crying:

    And than you wanna bugs free LOS... ignorance is a bliss :D

    P.S. it was just a notice about MicroG link: https://forum.xda-developers.com/an...-gmscore-floss-play-services-t3217616/page465

    Hello drnightshadow,

    Thank you for your wise words on using the search function and other topics of this forum.
    I'm sorry for my mistake, that I referred to your edit about MicroG and my curiosity about it.
    asking for plans ≠ begging

    I hope your blood pressure isn't as high as it reads...

    Cheers
    6
    I confirm, none of vince-made images ever boots on my A300 FU, only bootloop.
    (just to add, full clean install, even internal storage was always formatted)

    The booting issue was due to a faulty camera repopick that was being picked during the daily lineage source sync but not in the RR sync, which is why RR builds were booting, but the lineage ones not.

    I understand some of you may have disdain for me because of this, but this was really out of my control; I really do try my best with what I have, and complaining won't make it better. You can take it how you will.

    The above but was supposed to be addressed in last week's weeklies, but a lot of them never ran because that's round about when someone got access to Jenkins and gerrit and messed with things on the server, so some builds may be missing from the dl server.

    All gprime/fortuna/a3 devices as far as I'm aware were affected by this bug in pre-20180803/04 builds.

    You can try last week's builds if they're up on the dl server, they should work fine.