[ROM][8.1.0][A3F/H/FU/G/M/Y] LineageOS 15.1 Unofficial for Samsung Galaxy A3 (2015)

Search This thread

Beatz106

Senior Member
Jul 25, 2018
184
42
Well..
ROM 17.1 has a biiig bug ... VPN isn't working, any firewall app will also fails... for testing you can use NETGUARD app (just run it and enable it without any restrictions/rules, actually you gonna get really simple basic VPN). And you'll lose internet/lan, etc.... no connection!
Total communication breakdown!
Can someone report this on github to vlv..
Security really sucks on latest ROM.
I have already tried both with that application and other VPNs, while, indeed, Netguard fails, other VPNs work as they should, the problem must be Netguard, in fact, when testing the application, many settings were disabled (grayed out), and the way of use is confusing, contrary to other options such as the classic AFWall. It took me some work to activate the Netguard VPN ... Does the firewall that comes with it have something to do with the inability to connect to the internet?

(The first screenshot was with Netguard, the others were with another app)
 

Attachments

  • Screenshot_20201115-194455_Iceraven.png
    Screenshot_20201115-194455_Iceraven.png
    71.9 KB · Views: 41
  • Screenshot_20201115-195131_Iceraven.png
    Screenshot_20201115-195131_Iceraven.png
    153.1 KB · Views: 42
  • Screenshot_20201115-195149_Iceraven.png
    Screenshot_20201115-195149_Iceraven.png
    105.7 KB · Views: 39
I have already tried both with that application and other VPNs, while, indeed, Netguard fails, other VPNs work as they should, the problem must be Netguard, in fact, when testing the application, many settings were disabled (grayed out), and the way of use is confusing, contrary to other options such as the classic AFWall. It took me some work to activate the Netguard VPN ... Does the firewall that comes with it have something to do with the inability to connect to the internet?

(The first screenshot was with Netguard, the others were with another app)
Yap, Netguard fails cause network isn't config the right way...The usage was just a simple basic VPN without any restrictions as an example , of course main goal is you can block apps to access to web or just some of them ( like Facebook or block trackers and loggers).. a real firewall, actually it's better than AFWall+ and it use a VPN for restriction rules... it's working on my others two devices, both running LOS 17.1, without any problems.
So there is something wrong in network framework, I guess.. try using Netguard in any other device and you'll see how it works... just perfect for privacy protection.
Good luck and stay safe.

P.s.: did you try to use orbot or any tor VPN ? Many of them fails like Netguard ?
 
Last edited:

Beatz106

Senior Member
Jul 25, 2018
184
42
Yap, Netguard fails cause network isn't config the right way...The usage was just a simple basic VPN without any restrictions as an example , of course main goal is you can block apps to access to web or just some of them ( like Facebook or block trackers and loggers).. a real firewall, actually it's better than AFWall+ and it use a VPN for restriction rules... it's working on my others two devices, both running LOS 17.1, without any problems.
So there is something wrong in network framework, I guess.. try using Netguard in any other device and you'll see how it works... just perfect for privacy protection.
Good luck and stay safe.

P.s.: did you try to use orbot or any tor VPN ? Many of them fails like Netguard ?
Tor (the browser) works in a somewhat different way than Orbot, even so I will go to take a look at the latter.
 

jbs_v4

New member
Nov 23, 2020
2
0
Hai
I have a sm-a300f.
Does the LOS 17 version support mine...
If yes can anyone help me by giving the download link???
 
Tor (the browser) works in a somewhat different way than Orbot, even so I will go to take a look at the latter.
Tor browser is just a browser like firefox, chrome, etc... you can try orbot, its actually VPN, and it will not work :crying:
I think the problem is in kernel, idk ... Kmmm I'll try adaway 5 with VPN option... will report..
Edit: funny adaway 5.1.0 in non root mode aka VPN mode is working... khmm im clueless. .
 
Last edited:

Beatz106

Senior Member
Jul 25, 2018
184
42
Tor browser is just a browser like firefox, chrome, etc... you can try orbot, its actually VPN, and it will not work :crying:
I think the problem is in kernel, idk ... Kmmm I'll try adaway 5 with VPN option... will report..
Edit: funny adaway 5.1.0 in non root mode aka VPN mode is working... khmm im clueless. .
You have to take into account that Orbot is becoming obsolete, I would not be surprised if there are bugs in Android 10, if I remember correctly in Oreo it gave me failures and that is why I stopped using that app.
 
You have to take into account that Orbot is becoming obsolete, I would not be surprised if there are bugs in Android 10, if I remember correctly in Oreo it gave me failures and that is why I stopped using that app.
Just read NetGuard FAQ and like I said VPN is broken.. pic attached from
https://github.com/M66B/NetGuard
and https://github.com/M66B/NetGuard/blob/master/FAQ.md#user-content-faq51
Edit: pff xda app failed to upload pic :eek:
Quoting from page
"Some LineageOS versions have a broken Android VPN implementation, causing all traffic to be blocked, please see this FAQ for more information."
 
Last edited:

jbs_v4

New member
Nov 23, 2020
2
0
Hai,
I recently flashed the lineageos 17 rom in my sm-a300f but found that some of the Indian language were not rendering. I tried copying droidsansfallback.ttf to the system/fonts directory using a root explorer ,but succeded in displaying only some. The language I really need(Malayalam) is still not displayed.

Can anyone help me fix this. Please...

Screenshot_20201208-181953_Settings.png

Screenshot_20201208-182023_Settings.png
 

Beatz106

Senior Member
Jul 25, 2018
184
42
Hai,
I recently flashed the lineageos 17 rom in my sm-a300f but found that some of the Indian language were not rendering. I tried copying droidsansfallback.ttf to the system/fonts directory using a root explorer ,but succeded in displaying only some. The language I really need(Malayalam) is still not displayed.

Can anyone help me fix this. Please...

View attachment 5152897

View attachment 5152899
I don't think we can, even this server, the only thing I would recommend is doing the report on GitHub. As I do not know the subject of the language (any of that country except English) I cannot report well
 
  • Like
Reactions: jbs_v4

Beatz106

Senior Member
Jul 25, 2018
184
42
I abandon the idea of continuing to contribute (what I can) to the development of ROMs due to the abandonment of its main developer, there was another applicant but due to memory space issues he could not do anything
 
  • Like
Reactions: Ud4ba

Ud4ba

Senior Member
Jul 17, 2019
134
51
I abandon the idea of continuing to contribute (what I can) to the development of ROMs due to the abandonment of its main developer, there was another applicant but due to memory space issues he could not do anything
It would be perfect if you can assist with any time you have :D the latest update is quite nice . many bugs solved , but needs some job done . Please make a try and help us :D
 

carlos974

Senior Member
May 18, 2016
813
1,039
Saint-Denis
FYI:
For more information, advice and updates the dev has opened a forum on telegram (y)
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 44
    Hi all!

    LineageOS 15.1 Unofficial for Samsung Galaxy A3 (2015)​

    Currently supported variants:
    * SM-A300F
    * SM-A300H
    * SM-A300M
    * SM-A300FU
    * SM-A300G
    * SM-A300Y
    * SM-A300YX

    DISCLAIMER
    Code:
    #include 
    /*
    * Your warranty is now void.
    * The ROM is under developement and have some bugs.
    * We are not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at us for messing up your device, we will laugh at you. By flashing this ROM, you accept this disclaimer.
    */


    BUGS:
    * FM works only on headphones
    * Unable to capture video in 1080p (only 720р works)
    * Incorrectly work with secondary sim (incall sound issues)
    * On FU and H doesn't adjusting flahlight brightness
    * On H incorrectly detecting battery temperature
    * Hardware keystore doesn't work (only software)
    * NFC sometimes doesn't work


    2a0e1xv.jpg


    LineageOS 15.1 for Galaxy A3 (2015)

    NOTE: THIS ROM IS MADE FOR GALAXY A3, OBVIOUSLY IT WILL NOT WORK ON ANY OTHER DEVICE.

    Uploading my files elsewhere is not appreciated, if you need to upload my files, just use the links provided here. Thanks.

    Download link to the latest build: (Developement and Updates provided by @vl_w)


    FOR A300F/M/G/Y -> DOWNLOAD
    FOR A300H -> DOWNLOAD
    FOR A300FU/YX -> DOWNLOAD


    Other useful links:
    * Google Apps (choose arm and for Android 8.1):
    * Root
    https://mirrorbits.lineageos.org/su/addonsu-15.1-arm-signed.zip
    After install this package u should enable root access in developer settings



    v3WMXKl.jpg

    * Steps for a Clean Install:
    1) Put the .zip file in Internal or External Storage.
    2) Reboot in Recovery Mode (Using TWRP/CWM Recovery)
    3) Wipe Data, Cache, Dalvik Cache and format /System
    4) Install the ROM.
    5) Flash the Google Apps.
    6) Reboot and Enjoy!



    Contributors:
    vl_w, @Jonny_Hood (Testing)


    Sources:


    Version Information:
    ROM Status: Beta
    ROM OS Version: 8.1.0 Oreo
    ROM Kernel: Linux 3.10.x
    ROM Firmware Required: Any Bootloader and Modem.
    Based On: LineageOS 15.1


    Created: 2018-05-21
    Last Updated: 2017-05-21
    11
    Screenshots

    Screenshots
    6
    Do you even know what LineageOS is for ??? search on google... LOS is the AOSP and it doesnt come with gapps or microG or whatsoever apps... do it your self.... and stop begging for extra apps

    We are here to test and report O-N-L-Y ROM related BUGS... IT'S BETA!!!!

    damn it, people don't wanna read and write only unrelated stuff. Use search! XDA has many threads for all stuff including MicroG, gapps, Magisk(read root), Xposed,....
    Just sad... :crying: :crying:

    And than you wanna bugs free LOS... ignorance is a bliss :D

    P.S. it was just a notice about MicroG link: https://forum.xda-developers.com/an...-gmscore-floss-play-services-t3217616/page465

    Hello drnightshadow,

    Thank you for your wise words on using the search function and other topics of this forum.
    I'm sorry for my mistake, that I referred to your edit about MicroG and my curiosity about it.
    asking for plans ≠ begging

    I hope your blood pressure isn't as high as it reads...

    Cheers
    6
    I confirm, none of vince-made images ever boots on my A300 FU, only bootloop.
    (just to add, full clean install, even internal storage was always formatted)

    The booting issue was due to a faulty camera repopick that was being picked during the daily lineage source sync but not in the RR sync, which is why RR builds were booting, but the lineage ones not.

    I understand some of you may have disdain for me because of this, but this was really out of my control; I really do try my best with what I have, and complaining won't make it better. You can take it how you will.

    The above but was supposed to be addressed in last week's weeklies, but a lot of them never ran because that's round about when someone got access to Jenkins and gerrit and messed with things on the server, so some builds may be missing from the dl server.

    All gprime/fortuna/a3 devices as far as I'm aware were affected by this bug in pre-20180803/04 builds.

    You can try last week's builds if they're up on the dl server, they should work fine.