[ROM][8.1.0][H850][UNOFFICIAL] LineageOS 15.1

Search This thread

xyy1566

Member
Feb 7, 2018
6
0
0
woo!!!!!8.1 is coming!!But the big bug makes me go crazy.i have to spend so many time to make phone to rec. i hope you can fix it soon.thanks u very much!!!Pleased!!!( '▿ ' )
 

KCKitsune

Senior Member
Mar 7, 2011
279
73
0
OK, I installed the 04/14 ROM and Nano OpenGAPPS, and when I connect via my Ford Focus's SYNC (the Bluetooth in-car phone system) the person on the other end of the line says that there is enough static that I was barely understandable.

Does anyone know how to correct this? I mean is there anything for noise cancellation?
 
Last edited:

SkippyDream

Member
Oct 3, 2016
43
78
0
Turin, Italy
OK, I installed the 04/14 ROM and Nano OpenGAPPS, and when I connect via my Ford Focus's SYNC (the Bluetooth in-car phone system) the person on the other end of the line says that there is enough static that I was barely understandable.

Does anyone know how to correct this? I mean is there anything for noise cancellation?

Does Ford Sync use a prorpietary MIC? Or your g5's one?
 

KCKitsune

Senior Member
Mar 7, 2011
279
73
0
Does Ford Sync use a prorpietary MIC? Or your g5's one?

I don't know if it's proprietary or not. I do know when I was running stock, that I did not have any audio issues, so the issue can not be with the Sync's microphone.

I'm not trying to be a jerk about this. I really am not. It's just that I need to be able to use the Bluetooth when making phone calls and any LOS ROM is just giving an unacceptable level of static.

OK, Skippy (and anyone else) what can I do to help? Is there any thing I can send you to help diagnose WHY this happening with LOS ROMs and not happening with stock?
 
  • Like
Reactions: nullsec

gerciolisz

Senior Member
Feb 22, 2013
933
343
83
Gdańsk
Just a small thing about Bluetooth. I am still running stock and use car audio some Sony xplod old unit with bluetooth. Everytime when it connects with bt first call is handled by phone speaker and I always need to change it manually to car (but it's still connected to Bluetooth). In the other hand I remember I had the problem in OPO when devs enabled some clearvoice or sth similar feature in rom , it was similar effect in distorted voice.
One last thing is maybe some mixer-paths are pointed to use wrong mic with bt. This device have 2 mic's am I right?
 
  • Like
Reactions: nullsec

drmilosh

Senior Member
Nov 25, 2011
397
122
73
Nis
Theres an app (i dont know the name) that i have seen in h830 oreo 8.1 thread, that enables charging. Is it lossible to use it with this rom? Thx
 

SkippyDream

Member
Oct 3, 2016
43
78
0
Turin, Italy
Theres an app (i dont know the name) that i have seen in h830 oreo 8.1 thread, that enables charging. Is it lossible to use it with this rom? Thx
Actually I didn't try the app because installing a chinese app (I can't speak chinese) and giving it root access to my kernel is kinda stupid imho, even if it might fix my bugs.
I'm pretty sure that this app works by implementing a proprietary "power manager" (our power manager is not working properly).
A developer has to fix problems, but fixing problem is not finding chinese workarounds. That means that we will fix our kernel and we will release a fixed kernel in the next builds, but till the day of the fix, please, don't f*** up your h850 with those bulls***s: we need testers :D
 

SkippyDream

Member
Oct 3, 2016
43
78
0
Turin, Italy
I don't know if it's proprietary or not. I do know when I was running stock, that I did not have any audio issues, so the issue can not be with the Sync's microphone.

I'm not trying to be a jerk about this. I really am not. It's just that I need to be able to use the Bluetooth when making phone calls and any LOS ROM is just giving an unacceptable level of static.

OK, Skippy (and anyone else) what can I do to help? Is there any thing I can send you to help diagnose WHY this happening with LOS ROMs and not happening with stock?

Everyday I use WhatsApp: I noticed a bad mic behaviour too (not BT only but MIC in general).
Thanks for reporting: now I know it's not me but the ROM: I will work on it

P.S.: No logcats needed, thanks :)
 
Last edited:
  • Like
Reactions: KCKitsune

vladosyar

Member
Apr 15, 2018
6
0
0
and why does the phone terribly lag when I expose ntfs sd-card. I'm not sure that this is a problem due to the firmware but with fat-32 everything works fine
 

_andreas_

Member
Jul 29, 2008
14
2
0
I also teste this Rom with Open GApps stock, because of problems in my last used Roms...
- The Wifi bug with MAC Adresse 00:00:00:00 is also present
+ no Problems when i charge my phone with a powerbank
 

KCKitsune

Senior Member
Mar 7, 2011
279
73
0
I also teste this Rom with Open GApps stock, because of problems in my last used Roms...
- The Wifi bug with MAC Adresse 00:00:00:00 is also present
+ no Problems when i charge my phone with a powerbank

I did not have any problems with WiFi. I am running the 04/14 version of the ROM.

I am able to charge with a USB power adapter (no computer attached) perfectly fine.

Everyday I use WhatsApp: I noticed a bad mic behaviour too (not BT only but MIC in general).
Thanks for reporting: now I know it's not me but the ROM: I will work on it

P.S.: No logcats needed, thanks :)

Thank you.

When you put a new version of the ROM, I'll clean flash it and retest to see if the noise problem goes away.
 
Last edited:

_andreas_

Member
Jul 29, 2008
14
2
0
I did not have any problems with WiFi. I am running the 04/14 version of the ROM.

I am able to charge with a USB power adapter (no computer attached) perfectly fine.



Thank you.

When you put a new version of the ROM, I'll clean flash it and retest to see if the noise problem goes away.

I also performed a complete wipe and clean flash...
Maybe it depends from the previously ROM (I used a Android 6 ROM, because of the Android 7 Roms had Battery and Camera Problems)
I Fixed the problem with modifiing the pisc partition and entering the correct MAC-Address.

I also had some crashes when i tried to restore my google profile, but setting up as a new device work fine - until now.
Another problem was, that i cant accept an incomming call, because there was no dialogue.
Charging with an original LG Power Supply with Quick-Charge was not possible, but as already wrote, charging with my powerbank works fine.
 
  • Like
Reactions: nullsec

Top Liked Posts

  • There are no posts matching your filters.
  • 19
    20170102T093800.jpg

    I won't keep up this project anymore as I passed to LG G7.

    Thanks to everyone who supported my ROM.
    Peace!

    Check x86cpu's new thread.


    Credits:
    • Lineage OS.
    • My 8GB RAM non-SSD laptop which compiles for us :victory:

    XDA:DevDB Information
    LineageOS 15.1, ROM for the LG G5

    Contributors
    SkippyDream
    ROM OS Version: 8.x Oreo
    ROM Kernel: Linux 3.x
    Based On: LineageOS

    Version Information
    Status: Abandoned

    Created 2018-04-16 (YYYY-MM-DD)
    Last Updated 2018-08-13 (YYYY-MM-DD)
    11
    Hey!
    A new build is up. Check it! ;)

    21/04 update:
    • Fixed charging while USB Debug is ON
    • Fixed "build number mismatch error" displaying on every boot
    • Fixed Camera

    9
    New build is up :cool:

    Download immediately

    Changes in 30/04 update:
    • ambient display: Fixed black screen bug
    • livedisplay: Fixed LiveDisplay, which is now working again.
    6
    Downloads:

    OpenGApps
    (AMD64 > 8.1):
    opengapps.org/



    lineage-15.1-20180610-UNOFFICIAL-h850.zip
    md5: b2ac3617476ff1aeffa58af197e2ceec
    androidfilehost.com/?fid=674106145207484546



    Magisk ROOT
    by @topjohnwu
    (tested and working):
    tiny.cc/latestmagisk


    divider.png



    Changes:

    30/04 update:
    -- ambient display: Fixed black screen bug
    -- livedisplay: Fixed LiveDisplay, which is now working again.

    21/04 update:
    -- Fixed charging while USB Debug is ON
    -- Fixed "build number mismatch error" displaying on every boot
    -- Fixed Camera

    14/04 update:
    -- Kernel update from GitHub @Rashed97 commits: still charging bug.
    -- Updated build to 14/04



    divider.png



    Todos list:

    -- Pre-root
    -- substratum: Add Substratum (theming) support with no reboots needed
    -- widecamera: Add wide camera support
    -- lowmic: Fix low mic volume



    divider.png



    Mini installation guide for noobs:
    1. Reboot into latest TWRP(Mirrors: US, EU).
    2. *Optional*: Nandroid backup your actual ROM
    3. Perform a full wipe (advanced wipe > data, cache, art cache, system)
    4. Install the ROM zip file
    5. Optional but recommended: Install GApps (you won't be able to do that after the first boot)
    6. Enjoy :) .
    5
    Any added custom features?
    Well, we have some priorities here: I think that achieving more stability before adding custom features is necessary to the project to be good.
    Anyway, updates are coming :)
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone