[ROM][8.1.0][UNOFFICIAL] LineageOS 15.1 for klte

Search This thread
Ahhh Thank You!! I did update my twrp but apparently only to 3.1.0 .... Well I'll try that and see what happens.... Thanks again!

Edit: I cannot update my twrp to 3.2.3 or anything above 3.1.0 because then my device gets stuck in download mode and won't boot. Says flashed successfully in the twrp app but when restarts just gets stuck.... Go back to 3.1.0 and it's fine... ? What the heck is going on here... I tried using Odin to flash 3.2.3klte.img.tar but Odin crashes... Weird I've never come across a problem like this...

Use Odin to flash in download mode the TWRP 3.2.3
 

TheFixItMan

Senior Member
  • Jul 8, 2012
    7,772
    3,977
    London
    Ahhh Thank You!! I did update my twrp but apparently only to 3.1.0 .... Well I'll try that and see what happens.... Thanks again!

    Edit: I cannot update my twrp to 3.2.3 or anything above 3.1.0 because then my device gets stuck in download mode and won't boot. Says flashed successfully in the twrp app but when restarts just gets stuck.... Go back to 3.1.0 and it's fine... ? What the heck is going on here... I tried using Odin to flash 3.2.3klte.img.tar but Odin crashes... Weird I've never come across a problem like this...

    If you're rooted use the official twrp app to flash it
    As long as you are flashing the correct twrp for your variant it should work

    You will need the file ending in .img & not .tar
     
    Last edited:

    SP33DY89

    Senior Member
    Jul 18, 2012
    58
    3
    If you're rooted use the official twrp app to flash it
    As long as you are flashing the correct twrp for your variant it should work

    You will need the file ending in .img & not .tar

    Nah it don't work guys. Okay so I double checked. I have kltedv and I am downloading klte version 3.2.3 when I tried flashing using the app I downloaded the .IMG and when I tried to flash with Odin in download mode I flashed the .tar....... I got the same result. Brick. It tries booting into recovery but says could not do normal boot or something like that and just gets stuck in download mode. I've been over everything twice it bricks itself if I go passed version 3.1.0 EVEN IF I get message flash successful it won't boot after..... I don't have heaps of time but I will later hopefully try again..
     
    Last edited:

    SP33DY89

    Senior Member
    Jul 18, 2012
    58
    3
    Bingo found the problem. Ran xposed uninstaller and then was successful in updating my twrp to 3.2.3 ;) see how next update of los will go for me. On a separate note I would like to change my kernel.... Something a little on the battery saver side of things ... Thanks !
     
    • Like
    Reactions: vv211

    vv211

    Member
    Feb 12, 2018
    23
    6
    Is anyone else noticing received MMS messages coming through in very low quality?
    Particularly, images are scaled down to a few KB in size, and videos are split/converted into a very low resolution .jpg and an audio file.
    I'm running the Verizon G900V variant; LineageOS 15.1-20180918; rooted with Magisk 17.1/MM 6.0.0
    I was having this issue on 14.1 as well, which was the major reason for upgrading to 15.1 to see if that would fix it. Neither a dirty flash to 15.1 nor a total wipe + clean flash to 15.1 fixed it.
    I am on Total Wireless, rather than Verizon itself. Perhaps that is the cause? Though I don't recall having this issue when running the stock Samsung ROM. I have tried changing APN settings as well to no avail.

    Reading up on this it sounds like it's probably the phone is sending an unrecognized MMS user agent (LineageOS) to the server, and so the server sends the lowest quality message it can to ensure compatibility and that the target device is able to display the message.
    From what I've read, changing the user agent in strings.xml inside framework-res.apk from LineageOS to something that phone carriers will recognize should fix this.

    I've tried updating framework-res.apk on my own, but then the phone always gets stuck at the boot animation and I need to revert to a backed-up original from LOS.

    This seems (to my unlearned-self) like it would be a trivially simple update to the image. But I am quite new to this so I wouldn't be surprised if I'm misunderstanding something and am wrong on that; is there any possibility of having it included in the next update release?
    Or if not, any help on the correct steps to editing and replacing framework-res.apk?
     

    phalkon30

    Senior Member
    Aug 23, 2009
    401
    176
    Does it happen when sending or receiving to your same carrier?

    I find that sending cross carrier (like from AT&T to project Fi) things get almost unusable, but when my wife's family sends within AT&T they're fine. This has been on my S5, 6P, and Pixel XL2

    Sent from my Pixel 2 XL using Tapatalk
     

    vv211

    Member
    Feb 12, 2018
    23
    6
    Does it happen when sending or receiving to your same carrier?

    I find that sending cross carrier (like from AT&T to project Fi) things get almost unusable, but when my wife's family sends within AT&T they're fine. This has been on my S5, 6P, and Pixel XL2

    I've been testing it using my Google voice number, and received pictures are poor but anything I send from my S5 looks fine. I've gotten a couple pictures from my brother, who is on the same total wireless plan as me, and they were very low quality. He's said pictures I'd sent to him looked fine

    ---------- Post added at 05:53 PM ---------- Previous post was at 05:43 PM ----------

    I've tried updating framework-res.apk on my own, but then the phone always gets stuck at the boot animation and I need to revert to a backed-up original from LOS.

    Also, the steps I take when updating framework-res is:
    copy it to a Linux box
    Use apktool to install and then decode
    Edit and save strings.xml
    Build
    Copy rebuilt framework-res to my windows box
    Use advanced apktools to sign and then zipalign
    copy back to phone and replace the original in TWRP with its file manager
     
    • Like
    Reactions: phalkon30

    andrew2432

    Senior Member
    Please shift your questions to the official thread of Lineage OS this thread was made before the rom became Official

    Official LineageOS thread : OFFICIAL LINEAGEOS-15.1 Thread

    I'm so sorry, I should know this I'm just extremely busy recently. I didn't even search :/

    Thumbs down for me but thanks for the direction. I was hoping a kind soul would direct me to the "fix" just being lazy, same place to look for the GPS signal not being found correctly or putting me 400 miles away from where I actually am? I may have posted that too somewhere...sorry for spamming your thread I just literally have time currently for nothing
     

    KazuDante

    Senior Member
    Sep 6, 2015
    1,383
    1,038
    Port-Au-Prince
    I'm so sorry, I should know this I'm just extremely busy recently. I didn't even search :/

    Thumbs down for me but thanks for the direction. I was hoping a kind soul would direct me to the "fix" just being lazy, same place to look for the GPS signal not being found correctly or putting me 400 miles away from where I actually am? I may have posted that too somewhere...sorry for spamming your thread I just literally have time currently for nothing

    you have better luck of getting an answer on the official thread but yes this rom does pass , pretty much all rom pass so I for sure can't say what went wrong during flashing that makes it fail the test.
     
    • Like
    Reactions: andrew2432

    CStadler

    Senior Member
    Apr 4, 2017
    696
    293
    I'm so sorry, I should know this I'm just extremely busy recently. I didn't even search :/

    Thumbs down for me but thanks for the direction. I was hoping a kind soul would direct me to the "fix" just being lazy, same place to look for the GPS signal not being found correctly or putting me 400 miles away from where I actually am? I may have posted that too somewhere...sorry for spamming your thread I just literally have time currently for nothing
    Try Universal SafetyNet Fix if you use magisk, its it the modules section if you search for it
     
    • Like
    Reactions: andrew2432

    strikeraj

    Member
    Feb 4, 2012
    27
    0
    Hi
    I just flashed from lineageos 14.1 to 15.1 in TWRP using file dated 20180925.
    I flashed addonsu_arm a couple times but when I open titanium backup, i still dont have su access.
    Did I do something wrong?
     

    TheFixItMan

    Senior Member
  • Jul 8, 2012
    7,772
    3,977
    London
    Hi
    I just flashed from lineageos 14.1 to 15.1 in TWRP using file dated 20180925.
    I flashed addonsu_arm a couple times but when I open titanium backup, i still dont have su access.
    Did I do something wrong?

    If you're using the lineageos su addon zip once flash you need to enable root from the dev options in settings

    If development options are not available click build number in about phone until it says you're a developer

    In developer options enable root for adb & apps

    Or you can just flash magisk

    Also this rom is now official & has an official thread - no need to post in unofficial thread now
     

    TheFixItMan

    Senior Member
  • Jul 8, 2012
    7,772
    3,977
    London
    How were you able to click ok on the Connection Request portion?

    I don't have any screen filter on and also tried to delete and reinstalling the app. Neither worked...

    Don't know what part you mean but as you can see from screenshots I can select any server and connect without issue
     

    Attachments

    • 2018_11_11_14.20.33.png
      2018_11_11_14.20.33.png
      127.5 KB · Views: 235
    • 2018_11_11_14.20.47.png
      2018_11_11_14.20.47.png
      200.5 KB · Views: 239

    Top Liked Posts

    • There are no posts matching your filters.
    • 162
      https%3A%2F%2Fi.imgur.com%2F2okPze5.png


      LineageOS is a free, community built, aftermarket firmware distribution of Android 8.0 (Oreo), which is designed to increase performance and reliability over stock Android for your device.

      LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

      All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

      Instructions :

      • Download the latest build
      • Reboot to recovery
      • Flash the latest build
      • Wipe data
      • Reboot

      Downloads :
      Review & Instruction video :
      https://youtu.be/Ie6UxhXdD64 thanks to @MikeTheTechSavvy

      Reporting Bugs :

      • DO NOT Report bugs if you installed Xposed
      • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
      • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
      • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log

      Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues.

      Sources :

      Thanks :
      haggertk
      lineageos team
      list will be updated, tell me if I missed you!
      66
      Changelog:

      [2017-12-24]
      - Fix wifi signal strength (thanks to haggertk)
      - Based on latest haggertk commits

      [2017-12-18]
      - Updated to android 8.1.0
      - Camera partially fixed
      - Flashlight works

      [2017-12-09]
      - Fix Audio
      - Fix Video
      - Fix RIL (thanks to haggertk & javelinanddart for oss-ril port & nx111 for data fix)
      - Fix Fingerprint
      - Small bug fixes

      [2017-10-06]
      - Fix Bluetooth
      - Fix NFC
      - Disable strict mode
      - Improve WIFI
      - Small bug fixes

      [2017-09-28]
      - initial build
      59
      @afaneh92 should have working mobile data next time he releases a build. There was a compat patch in his libril import (it wasn't in staging/lineage-15.1 ril-caf yet) -- I told him in PM that I pushed all the related patches to gerrit.
      45
      Merry Christmas ???⛄
      Santa bring you new LOS-15.1 build.

      Based on haggertk last commits and he fixed wifi signal too. Go give him some thanks.
      You can notice some improvments, didnt test every thing.
      Data not working yet.
      41
      New build is up

      Changelog :

      [2017-12-09]
      - Fix Audio
      - Fix Video
      - Fix RIL (thanks to haggertk & javelinanddart for oss-ril port & nx111 for data fix)
      - Fix Fingerprint
      - Small bug fixes

      Not Working :
      - Camera and Flash
      - GPS
      - Sound record
      - Some minor stuff

      PS: kltevzw users if SIM not working after reboot rename /system/vendor/lib/libsec-ril.usc.so to /system/vendor/lib/libsec-ril.vzw.so
      i think my changes didn't stick on build

      PS2: Will work on camera, GPS and sound recorder this week. any short useful log appreciated, and if you find a device specific bug (not lineage bug) plz report.

      PS3: Enjoy testing.
    Our Apps
    Get our official app!
    The best way to access XDA on your phone
    Nav Gestures
    Add swipe gestures to any Android
    One Handed Mode
    Eases uses one hand with your phone