[ROM][8.1][UNOFFICIAL] LineageOS 15.1 [TITAN]

RenanQueiroz

Senior Member
Mar 15, 2016
154
1,314
0


LineageOS is a free, community built, aftermarket firmware distribution of Android 8.1 (Oreo), which is designed to increase performance and reliability over stock Android for your device.

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

What's working :

  • Boots
  • RIL (Calls, SMS, Data)
  • Wifi
  • Bluetooth
  • Camera
  • Video recording
  • Video Playback
  • Audio ( Record and Playback )
  • Sensors
  • Flash
  • Led
  • Offline Charging

What's not working :
  • SELinux is permissive

Instructions :
  • Download the latest build and gapps
  • Reboot to recovery
  • Flash the latest build and gapps
  • Reboot
Downloads :
Reporting Bugs
  • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
  • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
  • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

Code:
What is your--
Phone model (XT1063/XT1064/XT1068/XT1069):
Lineage version:
Lineage Download url:
Gapps version:
 
Did you--
wipe:
 restore with titanium backup:
reboot after having the issue:
 
Are you using--
a task killer:
a non-stock kernel:
LineageSettings/Performance settings (other than stock):
Dual SIM:
other modifications:
 
Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
Credits :

Donations :
You don't have to but if you want so...

XDA:DevDB Information
LineageOS 15.1, ROM for the Moto G 2014

Contributors
RenanQueiroz
Source Code: https://github.com/LineageOS/

ROM OS Version: 8.x Oreo
ROM Kernel: Linux 3.4.x
Based On: LineageOS

Version Information
Status: Beta

Created 2018-05-06
Last Updated 2018-06-10
 

Arcline

Senior Member
Sep 11, 2016
79
18
0
Great! So its near official! What does that mean for Thea (MotoG2 LTE)? Does someone have to build it for thea specifically? Or as a whole develop it?
 
  • Like
Reactions: SGH-i200

Malethra

Member
Nov 16, 2015
39
29
0
Wow! Thanks a lot! Just some dumb questions, is it possible to update from the official 14.1 to this one now? I tried this multiple times with Luk's builds but couldn't get the ROM to boot appropriately going this way. Is it something related to the different signatures?
 
Last edited:

tejasrao1996

Senior Member
Mar 7, 2016
365
206
0
Mangalore
Wow! Thanks a lot! Just some dumb questions, is it possible to update from the official 14.1 to this one now? I tried this multiple times with Luk's builds but couldn't get the ROM to boot appropriately going this way. Is it something related to the different signatures?
Did you do a clean install? Wipe everything while moving from one android version to another.
 

Malethra

Member
Nov 16, 2015
39
29
0
Did you do a clean install? Wipe everything while moving from one android version to another.
Yes, of course I did. This way works perfectly but I don't have my DATA, more precisely, I don't have my banking app's data. Titanium Backup is useless in this case and if I were to restore only the /data partition, the same problem would happen again. I've been doing that dirty install for a long time and it hasn't been a problem for me, I just clean install when I do some unrecoverable sh*t, which in this case, I can make use of the restore function on TWRP. I clean install when I used to downgrade to another Android version too, but I don't do this anymore.

And now I remember, Google put some verifications on the Oreo's boot process, maybe it's the reason for all that.